[HACK] Grow your data partition


Inactive Recognized Developer
Sep 18, 2010
Los Angeles
>>> Please note that Vashiru reworked this guide for reliability and alternate values, so I recommend you check his various posts in this thread starting with this one. <<<

As many of us have noticed, it is fairly easy to get an "Out of space" message when installing apps on our phones because, for some weird reason, Oppo decided that the storage part of the device should linger in the dark ages, when /userdata and /sdcard were separate partitions and you only had 2GB of data storage, even if your phone was a 32GB model.

Now, imagine that you are running KitKat and would like to try ART. This may be a bad idea as, if your data partition is more than 30% full, you will find that while converting your apps to this new format, Android will run out of space.

At OppoForums, a few bright people started looking into the issue and, of course, there is a way to improve the situation.


If you follow the steps below correctly, you should not run in any trouble. If you do not, however, you may end up spending much more time fixing your phone.


  • Anders tinkered with his device’s partition table until he got to where he had grown the /userdata partition to something useable. Yes, it’s some people’s definition of “play” ;)
  • Jousa11 is the first person trying to put a guide together explaining the steps to reproduce Anders’ work. WARNING: I did no get to see said guide as Jousa quickly deleted it due to the risks involved. So, take that in account!
  • Rockman for providing the last resort rescue tools in case you brick your phone
  • Lucky for providing the WiFi fix
Please let me know if you are not on this list and I forgot to give you credit!


The hardware:

  • An Oppo Find5 phone(!)
  • A computer (Windows/Linux/Mac) with adb installed and working
  • A USB cable

On your computer:

  • adb
  • [Optional] fastboot

On your phone (SDCard):

  • parted + mke2fs + tune2fs
  • mmcblk0p21_persist_ext4.img
  • openrecovery-twrp-
  • [Optional] gdisk

You will use parted to work on your partition table; mke2fs and tune2fs to create ext4 filesystems on some of these partitions (parted does not know how to create ext4 partitions)

mmcblk0p21_persist_ext4.img is an image that you need to restore your /persist partition and avoid issues such as non-working WiFi.

openrecovery-twrp- is a patched recovery image. I know: you already have a recovery image if you are going through these steps. However, we are going to wipe it so you want to install this guy before rebooting. Note that if you forget, you can always flash it later using fastboot.

On your computer:

  • adb to access your phone recovery, push files to SDCard, reboot...
  • [Optional] fastboot. You will only need fastboot if you mess up your recovery partition.


You may “brick” your phone. Apparently it’s near impossible to hard brick your Find5, though. See below.

First, Anders recommends making a backup of your partition table. I didn’t because I felt that if I messed something up, it would be a partitions’ content rather than the partition table but that’s not the wisest approach.
Furthermore, if you are really worried about what stilly error your fat fingers will cause (I know I should be!) you can also backup your partitions.

Backing up your partition table:

On your phone:
gdisk -b /sdcard/gpt.bin /dev/block/mmcblk0
Backing up a single partition:

On your phone:
dd if=/dev/block/mmcblk0p<partition id> of=/sdcard/backup-<partition id>.bin
On your computer:
adb pull /sdcard/gpt.bin
adb pull /sdcard/backup-<partition id>.bin

OK. So, you've bricked your phone. Now what?
First, you will need Windows. So if you're on a Mac or Linux and have no access to a Windows machine/VM, er..don't brick your phone.

  1. - Download drivers and tools
  2. - Download and follow the instructions


>>>>>>>>>>>> First, Download The Files <<<<<<<<<<<<


On your computer:
UPDATE As dixxa pointed out, mke2fs and tune2fs may already be present on your device. It was not the case for me but you should check first; it seems like a good idea to use existing binaries.
adb reboot recovery
adb push parted /sbin
adb push mke2fs /sbin
adb push tune2fs /sbin
On your phone:
chmod 755 /sbin/parted /sbin/mke2fs /sbin/tune2fs

umount /cache
umount /sdcard
umount /emmc
umount /data

parted /dev/block/mmcblk0
You are now in the parted shell.
CAREFUL! Do not delete any partition below 20 or you will enter "Big Oops" territory. I recommend typing carefully and, yes, staying away from copy/paste operations that may swallow a character like, say, the '2' in '20'

Note that the size value I am using here is '4GB' for /userdata (rather than 2GB). I guess you could make /userdata bigger than 4GB, in which case you would have to recompute all the offsets in the commands below(!)

# rm sdcard
rm 29
# 28 thru 23 are reserved
rm 28
rm 27
rm 26
rm 25
# rm recovery
rm 24
# rm misc
rm 23
# rm cache
rm 22
# rm persist
rm 21
# rm data/emmc
rm 20

# now, re-create partitions but data is bigger
mkpart primary 1325 5421
name 20 userdata
mkpart primary 5421  5430
name 21 persist
mkpart primary 5430  5967
name 22 cache
mkpart primary 5967  5968
name 23 misc
mkpart primary 5968  5979
name 24 recovery
mkpart primary 5979  6012
name 25 reserve1
mkpart primary 6012  6019
name 26 reserve2
mkpart primary 6019 6028
name 27 reserve3
mkpart primary 6028 6062
name 28 reserve4
mkpart primary 6062MB  100%
name 29 sdcard
# exit parted shell
Let's create a file system on the partitions that require one. Note that I am formatting the SDCard using VFAT as, yes, EXT4 is a better FS, but it is also incompatible with Oppo's ROM and some apps may not require the proper permissions etc.

# Notes:
# -m 0: no reserved blocks
# -c 0: no max mount count
# -C -1: no mount count
# -i -1: max_int interval between checks
mke2fs -t ext4 -m 0 -L userdata /dev/block/mmcblk0p20
tune2fs -c 0 -i -1 -C -1 /dev/block/mmcblk0p20
mke2fs -t ext4 -m 0 -L persist /dev/block/mmcblk0p21
tune2fs -c 0 -i -1 -C -1 /dev/block/mmcblk0p21
mke2fs -t ext4 -m 0 -L cache /dev/block/mmcblk0p22
tune2fs -c 0 -i -1 -C -1 /dev/block/mmcblk0p22
# Hey look it’s an ext4 SDCard!
mke2fs -t ext4 -m 0 -L sdcard /dev/block/mmcblk0p29
tune2fs -c 0 -i -1 -C -1 /dev/block/mmcblk0p29
# Actually to avoid errors like unable to write to root of sdcard:
mkdosfs -n sdcard -F 32 /dev/block/mmcblk0p29
mount -t vfat /dev/block/mmcblk0p29 /sdcard
At this point, we have clobbered the /persist partition and this could cause issues as mentioned earlier. Let's restore it.

# Restore /persist partition
mount -t ext4 /dev/block/mmcblk0p29 /sdcard
# On computer
adb push mmcblk0p21_persist_ext4.img /sdcard/
# On phone
dd if=mmcblk0p21_persist_ext4.img of=/dev/block/mmcblk0p21
IMPORTANT! Flash your recovery partition now. If you wait until after rebooting, you will need to use fastboot instead.

# Recovery partition: on computer
adb push openrecovery-twrp- /sdcard/
# On phone
dd if=openrecovery-twrp- of=/dev/block/mmcblk0p24
Admire your work
parted /dev/block/mmcblk0 print
Reboot into your new recovery and install your favorite ROM


Q: Is this dangerous?
A: Yes. Yes, it is.

Q: Any tip?
A: Yes. Follow these instructions carefully and if something wrong happens, unless you know what you are doing, leave your device alone and come here to ask for help.

Q: Can I hold you responsible for any damage to my phone/etc?
A: As usual, the answer is 'No'

Q: I found an error in your write-up!
A: Please let me know immediately.

Last edited:


Senior Member
Jul 30, 2007
This thread is fine the only problem here is with those 2 binaries: mke2fs and tune2fs
You don't need to push them or chmod them since they are already in the recovery
Except that that thread is perfect.


Senior Member
Mar 23, 2011
Hi all, I am trying to do this mod and I am half way through it with a problem

I am stuck on the new file system, I cannot use mke2fs or tune2fs, i get

mke2fs: not found
like it doesn't even exist, but it does I can see it. I get the same error for tune2fs. but parted and gdisk work fine.

Yes I did push them and chmod 755 them.. and I have tried running it from the /sbin directory.



New member
Jan 13, 2010

I'm getting the same error over and over again creating /dev/block/mmcblk0p21 to /dev/block/mmcblk0p22:

tune2fs -c 0 -i -1 -C -1 /dev/block/mmcblk0p21

"Bad magic number in super-block while trying to open /dev/block/mmcblk0p21"
"Couldn't find valid filesystem superblock"

So i can't create a file system on the created partitions. I have been looking everywhere for an answer. Somebody have an idea?


Senior Member
Mar 4, 2009
U should just wait. Andrew dodd found a way to make find7a have unified partition and he claims he can make it work on find5 as well. Let's give him a bit to figure it out tho.

Scribed henceforth from thy G pad.
  • Like
Reactions: cajuda
Nov 26, 2013
Gdisk not working... :(

Ok guys sort of a noob here... Firstly, totally appreciate what you guys are doing here... I wants it bad, thass why i'm here. ;)

So far... I have i have done...

"adb reboot recovery"

"adb push gdisk /sbin"

I figured that's how you are supposed to install it ... hope i'm not wrong, but i guess it pushed through fine

But after rebooting to system in TWRP , i opened terminal emulator and when i use the command

"gdisk -b /sdcard/gpt.bin /dev/block/mmcblk0"

I get ...

"/system/bin/sh: gdisk: not found"

now i'm too scared to proceed without backing up the partition tables... so please help...

edit - FYI , i'm running the last build of Asylum Carbon... should i just go back to latest oopo stable stock rom and then root my device again and then try all this again... would that help... ???
Last edited:


Senior Member
Mar 4, 2009
Directly from Andrew Dodds g+ " IT HAS BEGUN.

The first phase of Find 7a/7s LVM testing is here.* See linked post for details.* (Sorry to disappoint, but the first phase is "make sure we don't break existing configurations")

Once this phase is complete, the remaining list is:
Fix up the remaining TWRP issues (make RECOVERY_SDCARD_ON_DATA runtime instead of compile-time)
Make user-friendly conversion processes

Once things are solid on Find 7, I'll work on Find 5 and N1."

Stay thirsty my friends. Good things ahead

Sent from my A0001 using Tapatalk


Jan 18, 2009
Can someone help please?

I'm trying to do this, but after enter in parted [parted /dev/block/mmcblk0] when i try to do "rm 29", i get "can't remove 29: no such file or directory

I'm doing the "on your phone" commands in TWRP command line., is that correct?

I'm running stable colorOS 1.0.9i