Hard- brick Help ASAP

Search This thread


New member
Jun 18, 2014
My epic 4g wont turn on anymore. I tried everything! IT wont turn on, the battery sign wont show up when charging, and it wont boot at all! I need help urgently!


Senior Member
Jul 31, 2011
You say your tried everything, if that's true and nothing worked then you probably can't do anything about it. But here's some things you should try.
Remove the battery and let it sit for some time. I'd say about 10-15 minutes should be a long. Then try to plug it into your computer while holding 1 (on the physical keyboard) and the powerbutton to boot into download mode.
Also try booting into download mode with no battery or memory card in the phone.
Try using different cables and a different computer if you're able to remove the chances of having a bad wire or something wrong with your computer.
That's all the things I would try. If none work, you probably have no hope getting it to run again. Your main focus is to get it into download mode and odin a stock .tar to start fresh. If you can't get into download mode, you probably can't get anywhere else. Good luck.

Sent from my SPH-D700 using xda app-developers app