• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Hard bricked solved(ROG 3 tencent strix ZS661KS)

Search This thread

CaptainX40

Member
Jun 16, 2021
7
0
ASUS ROG Phone 3
Hey bros i've finally fixed my hardbricked rog 3 and i'm super happy. My phone got hardbricked like this.
i unlocked the bootloader and usb debugging, turned on FTP, i was about to root the phone, the phone is on 80% charge. I pluged in the usb c original cable on my phone side port first and then pluged into the pc type c port. but unluckily my hands was on the buttons, i don't know maybe all the buttons were pressed at once and at that time i plugged in the cable.
As soon as i plugged in the phone got all black. No turning on, no USB, no nothing. Didn't even recognized as a bulk or QS USB device. But whenever i pushed the both VOL button the indicator light would flash. So i at least knew it was not dead dead. Many days passed by just to search up the solution. I tried EDL cable, different cables, all kinds of tutorials. But nothing worked, because there was no USB connection.

But today i plugged in my phone and it suddenly showed the bootloader is on and file integrity can not be assured and ........................ those lines . I though what how what happened. so i charged up my phone for a little bit and i long press the power button and amazing it turned on , no bootloader no flush , it just turned on. Maybe i just got lucky , or maybe because i didn't flush any rom in the first place so the main rom remained.......... anyway i got my rog 3 back, ima go play some Call Of Duty ,,,,,,