Has anyone been able to root on Android 12?

Search This thread


Senior Member
Jan 31, 2017
What do you mean it's not work? What error message do you get? Got a screenshot? Thanks (y)
Last edited:


Oct 6, 2021
When I flash patched AP.tar, I get "error verifying vbmeta: HASH MISMATCH" error. I followed the official instructions for installing magisk.

I also tried flashing patched boot.img, but I get another error saying that only official firmware is allowed to be installed.

I never installed magisk this way, so I don't know if this procedure worked on previous Android versions (or if I'm even doing it right considering it's Samsung...).
  • Sad
Reactions: lebigmac


Senior Member
umh..I made the mistake of connecting my M21 2021 Edition to internet and it updated something in the blink of an eye and then when I checked Developer Options the OEM Unlock button disappeared. I cant flash TWRP-ODIN-patch-file anymore , it shows Secure Download error in Download Mode also Custom Binary Blocked error. Without TWRP I cant flash anything. I'm dead!