Question Has anyone got 5G working on unlisted country (rooted module is welcome)????

Search This thread

Shipoftheline

Senior Member
Oct 6, 2015
857
346
Salford
Google Pixel 6 Pro
First, no reason to be hostile. 2nd, keep your comments respectful.
Well I agree him and it is Googles fault even if you don't like people saying it, TWO staff from the network I'm with have said it, TWO
 

Attachments

  • Smarty1.jpg
    Smarty1.jpg
    67.8 KB · Views: 230
  • smarty2.jpg
    smarty2.jpg
    67.2 KB · Views: 228

V0latyle

Forum Moderator
Staff member
if LTE+/5G/volte are features that are "still in development" in the year 2022 for google pixel devices, its no wonder theyre not popular devices.
I have to admit I'm not quite following. All Pixels from the 4a (5G) and newer support 5G, not to mention LTE+ (which I believe was supported as early as the Nexus 7). VoLTE is software, not a hardware capability.

There are different flavors, however - the US version of the Pixel 6 supports both C band and mmWave 5G; the ROW version does not, to my knowledge. Google does limit what versions are sold to what regions.

I have a Pixel 5 that I'm using on Verizon; I haven't tested UWB 5G since I'm rarely in the urban areas but the co-spectrum 5G works just fine.
Well I agree him and it is Googles fault even if you don't like people saying it, TWO staff from the network I'm with have said it, TWO
I mean...You can't really depend on customer service reps to know the technical ins and outs. There may be truth to what they're saying, there may not.
 
  • Like
Reactions: roirraW "edor" ehT

billybobjones

Senior Member
Jun 2, 2008
230
57
Yes, the phones support 5G and those features but google "geo locks" them to the countries it has a google store on. If you dont live in one of those countries then you dont get 5G/LTE+/VoLTE/VoWIFI etc..

Also have talked to technicians in the carrier in my country as others have done and it comes down to google intentionally doing this. This is why countries where google have recently opened up a store there suddenly got these features working.

Its quite sad not enough people are calling out google for essentially locking people from basic features in 2022.
 

reas0n

Senior Member
Dec 23, 2010
1,786
1,349
Google Pixel 6
Android 12 Beta 2 not L but the old one, has working 5g carrier configs, the only problem is that i cannot seem to get efs explore working with my phone or the ShannonDM as i think this phone(Pixel 6 Pro) need new tools for it, maybe they moved it somewhere i dont know where it is a folder now? anyway still investigating.
First place is /vendor/firmware/carrierconfig which vendor's build.prop mentions.
Second thing i found is some protobuf file but i have no idea what's the path of it. I know that GrapheneOS uses this https://github.com/daradib/carriersettings-extractor to convert it to AOSP-compatible XML

About that compatibility topic. I have Orange Poland (not officially supported). LTE+ works out of the box, VoLTE/VoWIFI needed Magisk module, 5G doesn't work in any way. My carrier uses EXACTLY THE SAME Sub-6 5G band as Magenta Austria (officially supported), I even contracted my carrier and they can't do anything. It's clearly fked up by Google.

Edit: there are some ims settings too *#*#0702#*#* (source: https://forum.xda-developers.com/t/no-root-sercrtcode-to-unlock-all-country-5g-and-volte.4355759/)
Edit2: the path for that proto file is /product/etc/CarrierSettings
 
Last edited:
  • Like
Reactions: alvarorojas4

clipdawg05

Senior Member
Nov 20, 2014
134
29
Last I checked, it's very difficult to even enable the modem and serial ports on this phone.

And when you do, Shannon DM and air screen still do not work when connected to the phone. Shannon in particular is too old to read 5g events when you try to feed a log file from this phone.

This phone is a black hole for those diag ports.

That being said, there was a new network signal guru release (4.0.4) yesterday that included an updated hiagent that may help us. I doubt it though. It does include crude band locking for the phone though, which is a surprising first step.
Where did you download 4.0.4. i am on 4.0.3 with no update available. I really want to try some band locking
 

LLStarks

Senior Member
Jun 1, 2012
1,868
1,047
Easiest way seems to be clearing the cache and restarting the app. It should prompt for the update when you launch. The apk is also in the Telegram channel.

Be careful. Locking will persist through reboots. 5G locking is not possible at the moment.

The crazy thing is that the changelog only mentions Exynos band locking. The Pixel is very similar and it somehow works.
 

tanipat

Senior Member
Nov 22, 2011
339
103
to be clear seems still we discuss the problem lies with google or carrier. here to say it again it all google fault, they just lazy to put all carrier support (or may be intended to) so unlisted countries will not support all that. to be clear it is not just happens it happens since pixel1 not the new problem at all. most cheap chinese phone bought from china even works more in other countries because they just put all carrier update that is all needed. i live in Thailand and buy alot of phone that not sell in Thailand and pixel always the most problem in terms of carrier support.

just root it and there should be the way i make vowifi and volte works just not 5g because diag is not work anymore on tensor. but there should be way and we trying together to find out sooner than later. but if not root no hope i can say as pixel1-5 still no support upto now since several years passed by
 

danw_oz

Senior Member
Jul 12, 2011
1,405
371
Brisbane
That is a lie from Google, try and flash the Android 12 beta 2(not 12L) firmware for ether Pixel 4a or the Pixel 5 5g and voila you got 5g in unsupported country and provider, cause they messed up and forgot to lock off the countries and providers they dont like or want to have 5g.

I am in the proccess of finding the files and getting 5g on my Pixel 6 Pro, Google really are bad people with this.
That doesn't prove anything about google, not saying they are angels or anything, but if your providers do provide their carrier settings how can google dream up how they might be setup? Really your think google knows every legal band range for every single carrier throughout the world to provide this???

Google create a phone that supports the world.

Then each countries legislation (govt) airwave regulators, probably the armed services decide what bands... are available in the countries... Google does not give a crap about any of this.

Your service providers have to decide if they are going to support the phone in that country and provide the details to support that device in the country NOT google.

Trust me google want their phone everywhere, to get sales not limit them, this is in their interest. But if they are not provided the supported files for your vendors, then they can't support your vendors.

Pixel 4a or 5, that is great that you can use the vendors provided files to use in your pixel 6 pro, but if you have issues with that phone with 5G you can't ask your telecommunitation provider to help or fix, and google wouldn't know how to fix.
 
  • Like
Reactions: roirraW "edor" ehT

amalras

Member
Jan 27, 2022
9
4
Those who participated in the Android Beta Program noticed that there was no such restrictions to limit the 5G & VOLTE to specific countries. So I was wondering if there's any way to flash the Pixel 6 device with Android 12 Beta ROM.
 

reas0n

Senior Member
Dec 23, 2010
1,786
1,349
Google Pixel 6
Those who participated in the Android Beta Program noticed that there was no such restrictions to limit the 5G & VOLTE to specific countries. So I was wondering if there's any way to flash the Pixel 6 device with Android 12 Beta ROM.
Possible 12L beta is our hope. Maybe then someone can extract required files and make a Magisk module
 

Utini

Senior Member
Dec 25, 2010
1,220
243
www.whymacsucks.com
www.whymacsucks.com
First place is /vendor/firmware/carrierconfig which vendor's build.prop mentions.
Second thing i found is some protobuf file but i have no idea what's the path of it. I know that GrapheneOS uses this https://github.com/daradib/carriersettings-extractor to convert it to AOSP-compatible XML

About that compatibility topic. I have Orange Poland (not officially supported). LTE+ works out of the box, VoLTE/VoWIFI needed Magisk module, 5G doesn't work in any way. My carrier uses EXACTLY THE SAME Sub-6 5G band as Magenta Austria (officially supported), I even contracted my carrier and they can't do anything. It's clearly fked up by Google.

Edit: there are some ims settings too *#*#0702#*#* (source: https://forum.xda-developers.com/t/no-root-sercrtcode-to-unlock-all-country-5g-and-volte.4355759/)
Edit2: the path for that proto file is /product/etc/CarrierSettings

It is a provider/carrier AND google issue. But more of a provider/carrier issue than google.

The google support claims it is the carrier which needs to unlock those features.
The carriers say its google who has to take care of it.

  • I am in Austria and I have 2 different carriers (Magenta & Drei).
  • Magenta doesn't support VoLTE while drei does.
  • Both do not seem to support VoWiFi.
  • I am never getting an LTE+ icon but I get 4G (which I believe stands for LTE+).
  • Magenta doesn't allow me to use 5G.
  • Drei does allow me to use 5G.
  • Some features are broken with Magenta which work with drei.
  • Also there are some bug with Magenta which do not exist with drei.
  • Both carriers say its google fault (even if stuff works with the other carrier)

Clearly it is not the devices fault.
Clearly it isn't even google's fault because stuff works with a different carrier in the same country.
Clearly some stuff doesn't work at all in my country which can probably be fixed by either google or the carrier.
 

amalras

Member
Jan 27, 2022
9
4
Actually according to this Android documentation https://source.android.com/devices/tech/config/carrier

The providers must create a signed application for themselves, which will set these settings as needed. Since Android 6 ...

And what changes by root is the replacement of the configs made by Google - the last iteration of the search for carrier settings.

Of course, there is a certain problem with this - there is only one Google, and there are hundreds (maybe thousands) of providers. Therefore, other manufacturers simply follow everything by default, instead of relying on these bad providers, which either have no programmers, or some other reason not to make such applications with settings (perhaps this is a problem with the digital signature of a physical sim and the need replace it periodically).

Who knows? The problem and the solution have been for so many years ... Perhaps you need to try to somehow influence the providers, Google? Or at least transfer this information to them?
 

gi.ier

Member
Feb 8, 2022
10
5
I can add my 2 cents.
I live in Italy and my area is covered by 5g signal.

My carrier is Fastweb. Fastweb can use 2 networks (some kind of roaming), one is TIM and the other is WIND3. The same sim card cannot use both of them, so if it's registered under Tim no way to have a 5g signal.If registered under WIND3, 5g signal should be available . BUT, and here's the point:


Pixel 6 is NOT listed among official authorized smartphones for 5g for FASTWEB.
the list of authorized smartphones is here:


It's the same for all the other Italian carriers
Tim, Wind3, Vodafone and Iliad all have different lists of authorized smartphones.
So it's possible that a device that is 5g, will work if the carrier is Vodafone but won't work if the carrier (sim) is Iliad.

Why? i don't know.

My opinion is that there could be some technical issues, but the most important thing is that each of these providers sell smartphones with their plans. So, if you want an Oppo, you'll have it at special price with a certain provider, if you want a samsung you'll better check another provider and so on. And obviously, they'll activate 5g on those brands they sell, not others.
 
Last edited:
  • Like
Reactions: roirraW "edor" ehT

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    why did they close the thread?? i also wanted to donate to this cause
    Check Telegram, Pixel5GBounty. XDA didn't like this, we have $230 already
  • 4
    Yes, the phones support 5G and those features but google "geo locks" them to the countries it has a google store on. If you dont live in one of those countries then you dont get 5G/LTE+/VoLTE/VoWIFI etc..

    Also have talked to technicians in the carrier in my country as others have done and it comes down to google intentionally doing this. This is why countries where google have recently opened up a store there suddenly got these features working.

    Its quite sad not enough people are calling out google for essentially locking people from basic features in 2022.
    4
    i think the problem lies elsewhere. i found all carriers in product/etc/carriersettings

    in the folder all in .pb files and each one of the supported carriers in listed countries have separate files even more separate profile for 5 g ( such as att_us.pb att5g_us.pb att5gsa_us.pb). while i only found my country in others.pb which contains a lot of unlisted countries but all in very short details not like the separate file. if someone with knowledge enough to create or modify these carrier files then i think it might be possible for 5g to work with the carrier
    3
    What do you mean with "unlisted country"? It's your carriers choice whether or not he activates VoLTE/5G and whether or not he supports your phone, so why not talk to your carrier why they don't support the new P6?
    3
    What do you mean with "unlisted country"? It's your carriers choice whether or not he activates VoLTE/5G and whether or not he supports your phone, so why not talk to your carrier why they don't support the new P6?
    No, google blocks 5G and volte in unsupported countries, i.e. countries where it is not officially sold, e.g. Czech Republic, Finland, Poland, Croatia etc.,
    3
    Maybe a phone country that has mmWave deployed may work for you.

    Tell me if I am wrong but I understand that the service providers send in their vendor, and radio images, google colates them and releases them with the builds. This is not up to google rather the service provider to do this, because contained within are APN and other settings specific to the service provider.

    Read this will give you a clear understanding that this is not google blocking countries... rather service providers supporting certain makes and models of phones. https://support.google.com/pixelphone/answer/10082009?hl=en
    That is a lie from Google, try and flash the Android 12 beta 2(not 12L) firmware for ether Pixel 4a or the Pixel 5 5g and voila you got 5g in unsupported country and provider, cause they messed up and forgot to lock off the countries and providers they dont like or want to have 5g.

    I am in the proccess of finding the files and getting 5g on my Pixel 6 Pro, Google really are bad people with this.