Have you installedMagisk v15.x on Samsung S7 G930F?

Search This thread

ssteward

Member
Jun 29, 2007
35
0
I soft bricked my G930FD when going from v14.0 to v15 using the in-app update but got it back by dirty flashing my stock ROM thanks to the help I got here.

Now I'd like to install the latest Magisk to get root back but despite reading a lot of threads where people solved similar issues going to v15 on Samsung devices and following their suggestions, I can't get Magisk to work and always get stuck on boot, either a boot loop, or more often, the pulsating Samsung logo.

If I try using the patched_boot.img.tar method with v15.3, which is technique I used originally to install v14.0, then I get stuck at the the pulsating Samsung logo. If I use TWRP to flash the v15.3 zip, I get a boot loop. At that point, flashing the stock boot.img allows me to boot or if I flash no-verity-opt-encrypt-6.0 then I get to the pulsating Samsung logo. I did select 'Preserve AVB 2.0/dm-verity' in Magisk Manager.

I also tried again with a clean stock ROM install and flashed the v15.3 zip and immediately flashed no-verity-opt-encrypt-6.0, as suggested by someone who'd successfully installed v15.3 on an S7, but again, stuck at the pulsating Samsung logo.

One clue perhaps, TWRP couldn't see the internal SD card data (iow /data). I wasn't able to check this option in the 'Mount' menu in TWRP either. I think this points to /data being encrypted. TWRP could see it before I dirty flashed the ROM, so perhaps I've inadvertently encrypted this. I was careful to uncheck 'Preserve force encryption' in Magisk Manager , which seemed to default on.

I'm at a bit of a loss so would really appreciate it if you can tell me how to get up and running with Magisk v15 on my Samsung Galaxy S7 if you've managed this yourself.
 
Last edited: