Havoc OS not loading

Search This thread

MayhemIam

Senior Member
Dec 16, 2014
51
1
Hi all,

I'm trying to install Havoc OS on my P20 lite (2018 model - ANE-LX1 8.0.0.0.135(C432)). My current version of EMUI is 8.0. So I need to install a A version of ARM and NOT AB.

The system image is
Havoc-OS-v3.1-20200202-ARM64A-GSI.img

I have TWRP 3.4.0 installed and working. PS, I have also tried this via fastboot (fastboot flash system Havoc-OS-v3.1-20200202-ARM64A-GSI.img.xz) with the same results :confused:

Before flashing the ROM and my GAPPS file (open_gapps-arm64-10.0-nano-20200808.zip). Via TWRP I wipe Dalvik/Cache/System/Data

Then I installed the ROM via TWRP install and selected .img install, there are no errors and the screen output says it is installed correctly.

Then I flashed the GAPPS mentioned above. After that I wipe Dalvik/Cache again.

And reboot....nothing happens. The phone boots back up and goes straight to TWRP again. It's like the ROM is not being initialized at all.

Any help would be appreciated.
 

-Alf-

Senior Member
Sep 28, 2017
1,986
627
Huawei P9 Lite
Huawei P10 Lite
Hi all,

I'm trying to install Havoc OS on my P20 lite (2018 model - ANE-LX1 8.0.0.0.135(C432)). My current version of EMUI is 8.0. So I need to install a A version of ARM and NOT AB.

The system image is
Havoc-OS-v3.1-20200202-ARM64A-GSI.img

I have TWRP 3.4.0 installed and working. PS, I have also tried this via fastboot (fastboot flash system Havoc-OS-v3.1-20200202-ARM64A-GSI.img.xz) with the same results :confused:

Before flashing the ROM and my GAPPS file (open_gapps-arm64-10.0-nano-20200808.zip). Via TWRP I wipe Dalvik/Cache/System/Data

Then I installed the ROM via TWRP install and selected .img install, there are no errors and the screen output says it is installed correctly.

Then I flashed the GAPPS mentioned above. After that I wipe Dalvik/Cache again.

And reboot....nothing happens. The phone boots back up and goes straight to TWRP again. It's like the ROM is not being initialized at all.

Any help would be appreciated.
Hi,
1. On Oreo use this TWRP
https://mega.nz/#!Fgd0xa4R!1o5ejzDnkLJLG2tAZG-STtlJ4nnNCHfwwZdOlmOkrVw
2. You have to extract system.img (cca 1,2GB) from .xz package (unpack it on PC), then transfer it to SD .
Reboot to the TWRP > Wipe > Format Data > go back > Wipe > Advanced > Dalvik/Cache/System/Data > go back > flash system.img
Go back > Reboot> Recovery and do factory reset from Stock recovery (se the note bellow!)

P.S.: it's recommended install TWRP over eRecovery:
Copy downloaded TWRP file to the SD card, and also copy to card Stock ramdisk_recovery , download here: (for EMUI 8 only! )
https://mega.nz/#!04dG0JBb!hEgTk6DMKVDffttHiXGqa_YR_zG5UYwTMEi41KTkZi8
Since A8 and above you can not install TWRP over eRecovery from fastboot, follow instructions:
- install TWRP from fastboot , reboot to TWRP, select install image, and flash TWRP over eRecovery, go back, find recovery_ramdisk330 and flash it over recovery. Reboot system. After the boot screen appears in the recovery with the inscription "Your device is booting now ..." press and hold Volume Up
for 3 sec, device will boot to TWRP.
 
Last edited:

MayhemIam

Senior Member
Dec 16, 2014
51
1
Hi,
1. On Oreo use this TWRP
https://mega.nz/#!Fgd0xa4R!1o5ejzDnkLJLG2tAZG-STtlJ4nnNCHfwwZdOlmOkrVw
2. You have to extract system.img (cca 1,2GB) from .xz package (unpack it on PC), then transfer it to SD .
Reboot to the TWRP > Wipe > Format Data > go back > Wipe > Advanced > Dalvik/Cache/System/Data > go back > flash system.img
Go back > Reboot> Recovery and do factory reset from Stock recovery (se the note bellow!)

P.S.: it's recommended install TWRP over eRecovery:
Copy downloaded TWRP file to the SD card, and also copy to card Stock ramdisk_recovery , download here: (for EMUI 8 only! )
https://mega.nz/#!04dG0JBb!hEgTk6DMKVDffttHiXGqa_YR_zG5UYwTMEi41KTkZi8
Since A8 and above you can not install TWRP over eRecovery from fastboot, follow instructions:
- install TWRP from fastboot , reboot to TWRP, select install image, and flash TWRP over eRecovery, go back, find recovery_ramdisk330 and flash it over recovery. Reboot system. After the boot screen appears in the recovery with the inscription "Your device is booting now ..." press and hold Volume Up
for 3 sec, device will boot to TWRP.

Hi Alf my man :)

So I am having a bit of trouble with your instructions. I am very sure it is my own fault! I just want to clarify the steps please. I have downloaded the 2 provided files you gave in the link.

1
Install TWRP via
"fastboot flash recovery_ramdisk TWRP-oreo-smart.img"

2
Boot into newly flashed TWRP and flash the 2 files again as specified
"....flash TWRP over eRecovery, go back, find recovery_ramdisk330 and flash it over recovery...."

3
Reboot after step 2 and go into TWRP again and perform the system.img install as per instructions via TWRP
"Reboot to the TWRP > Wipe > Format Data > go back > Wipe > Advanced > Dalvik/Cache/System/Data > go back > flash system.img
Go back > Reboot> Recovery and do factory reset from Stock recovery
"
I take it that I need to install my GAPPS package as well in this stage?

4
After factory reset from stock recovery the OS should boot and initiate...

Thanks again man for your help!
 

MayhemIam

Senior Member
Dec 16, 2014
51
1
Hi Alf my man :)

So I am having a bit of trouble with your instructions. I am very sure it is my own fault! I just want to clarify the steps please. I have downloaded the 2 provided files you gave in the link.

1
Install TWRP via
"fastboot flash recovery_ramdisk TWRP-oreo-smart.img"

2
Boot into newly flashed TWRP and flash the 2 files again as specified
"....flash TWRP over eRecovery, go back, find recovery_ramdisk330 and flash it over recovery...."

3
Reboot after step 2 and go into TWRP again and perform the system.img install as per instructions via TWRP
"Reboot to the TWRP > Wipe > Format Data > go back > Wipe > Advanced > Dalvik/Cache/System/Data > go back > flash system.img
Go back > Reboot> Recovery and do factory reset from Stock recovery
"
I take it that I need to install my GAPPS package as well in this stage?

4
After factory reset from stock recovery the OS should boot and initiate...

Thanks again man for your help!

I have done as instructed yet there is am issue at the last step. I can boot into stock recovery but when I try and do a Factory Reset via the menu the reset only goes to 9% and gives a large orange/red exclamation mark.....so it did not finish. When I try and reboot and load the OS it goes into a boot loop and that is it.
 

-Alf-

Senior Member
Sep 28, 2017
1,986
627
Huawei P9 Lite
Huawei P10 Lite
I have done as instructed yet there is am issue at the last step. I can boot into stock recovery but when I try and do a Factory Reset via the menu the reset only goes to 9% and gives a large orange/red exclamation mark.....so it did not finish. When I try and reboot and load the OS it goes into a boot loop and that is it.

Okay, reboot system. You can perform factory reset later (if needed).

---------- Post added at 19:17 ---------- Previous post was at 18:56 ----------

Please provide me the link where you downloaded Havoc OS
 

-Alf-

Senior Member
Sep 28, 2017
1,986
627
Huawei P9 Lite
Huawei P10 Lite
No it's stuck on a bootloop Alf :crying:
Don't panic! :) IMO it's time to clean your phone , download Service ROM
https://androidhost.ru/5NX
Unpack .zip package, find dload file and copy it to the SD card (without unpacking it!). Then turn off the phone and flash ROM using three button combo.
(instruction can be found in file ReleaseDoc).
Important: the process will erase all your data and will lock again the bootloader!
I will now try to install Havoc 3.1A and I will let you know, okay?
 

MayhemIam

Senior Member
Dec 16, 2014
51
1
Don't panic! :) IMO it's time to clean your phone , download Service ROM
https://androidhost.ru/5NX
Unpack .zip package, find dload file and copy it to the SD card (without unpacking it!). Then turn off the phone and flash ROM using three button combo.
(instruction can be found in file ReleaseDoc).
Important: the process will erase all your data and will lock again the bootloader!
I will now try to install Havoc 3.1A and I will let you know, okay?

Well I can still dload back to my old EMUI 8.0 OS! I just did it again and it works. I can get back into my OS no probs. I have done this about 6 times today, lol. I really do not want to lock my bootloader again as it took me a long time to get it unlocked!

Thnx for the reply!
 

MayhemIam

Senior Member
Dec 16, 2014
51
1
Well I can still dload back to my old EMUI 8.0 OS! I just did it again and it works. I can get back into my OS no probs. I have done this about 6 times today, lol. I really do not want to lock my bootloader again as it took me a long time to get it unlocked!

Thnx for the reply!

Also just for me to understand. I have EMUI 8.0 running then I can't upgrade to a Android 9 Custom ROM?
 

-Alf-

Senior Member
Sep 28, 2017
1,986
627
Huawei P9 Lite
Huawei P10 Lite
Also just for me to understand. I have EMUI 8.0 running then I can't upgrade to a Android 9 Custom ROM?


I'm not sure I fully understand your question, you cannot upgrade to A9 , you can flash Custom ROM based on A9 (which requires A8 OS).
Btw, I tried flash Havoc 3.1, 3.0, tried several TWRP, no luck. Flashed system.img from fastboot, nothing. It seems A-only version doesn't work on ANE. I have no idea what the problem is...
(hehe, R.I.P. English :))
 

MayhemIam

Senior Member
Dec 16, 2014
51
1
I'm not sure I fully understand your question, you cannot upgrade to A9 , you can flash Custom ROM based on A9 (which requires A8 OS).
Btw, I tried flash Havoc 3.1, 3.0, tried several TWRP, no luck. Flashed system.img from fastboot, nothing. It seems A-only version doesn't work on ANE. I have no idea what the problem is...
(hehe, R.I.P. English :))

OK I can't upgrade to EMUI 9 but I can upgrade to a custom ROM which has Android 9 (through AB partition)?

"...you can flash Custom ROM based on A9 (which requires A8 OS)." Which means I can upgrade to any custom ROM which has Android 9 / 10?

What is the difference then between the following?

ARM64A
ARM64AB
 
Last edited:

MayhemIam

Senior Member
Dec 16, 2014
51
1
Okay, reboot system. You can perform factory reset later (if needed).

---------- Post added at 19:17 ---------- Previous post was at 18:56 ----------

Please provide me the link where you downloaded Havoc OS

Oh snap man, I only saw the last part of your post now.

I tried the following ROMS.

Most of them was downloaded from SourceForge man.

Havoc-OS-v3.0-20191225-ARM64A-Unofficial.img.xz
Havoc-OS-v3.1-20200202-ARM64A-GSI.img

I have tried others as well but they were ARM64AB....
 

-Alf-

Senior Member
Sep 28, 2017
1,986
627
Huawei P9 Lite
Huawei P10 Lite
OK I can't upgrade to EMUI 9 but I can upgrade to a custom ROM which has Android 9 (through AB partition)?

"...you can flash Custom ROM based on A9 (which requires A8 OS)." Which means I can upgrade to any custom ROM which has Android 9 / 10?
For example:
Pixel Experience, ROM for the Huawei P20 Lite

Contributors
DarkJoker360
Source Code: https://github.com/DarkJoker360

ROM OS Version: 9.0 Pie
ROM Kernel: Linux 4.x
ROM Firmware Required: Emui 8 unlocked bootloader & twrp
 
Last edited:

MayhemIam

Senior Member
Dec 16, 2014
51
1
OK I can't upgrade to EMUI 9 but I can upgrade to a custom ROM which has Android 9 (through AB partition)?

"...you can flash Custom ROM based on A9 (which requires A8 OS)." Which means I can upgrade to any custom ROM which has Android 9 / 10?

What is the difference then between the following?

ARM64A
ARM64AB

What is the difference then between the following?

ARM64A
ARM64AB

OK so the answer is
Use ARM64xA - when your phone is using Android 8.0 (EMUI 8.0)
Use ARM64xAB - when your phone is using Android 9 (EMUI 9.1)
 

MayhemIam

Senior Member
Dec 16, 2014
51
1
For example:
Pixel Experience, ROM for the Huawei P20 Lite

Contributors
DarkJoker360
Source Code: https://github.com/DarkJoker360

ROM OS Version: 9.0 Pie
ROM Kernel: Linux 4.x
ROM Firmware Required: Emui 8 unlocked bootloader & twrp

Hi Alf,

I have abandoned ship to get HavocOS on my device :(

But I'm trying now the following AOSP Android 10 Q
https://www.getdroidtips.com/android-10-huawei-p20-lite/

I'm going to try and use this TWRP (twrp-3.4.0-0-anne.img)

Will let you know how it goes!
 

-Alf-

Senior Member
Sep 28, 2017
1,986
627
Huawei P9 Lite
Huawei P10 Lite
Hi Alf,

I have abandoned ship to get HavocOS on my device :(

But I'm trying now the following AOSP Android 10 Q
https://www.getdroidtips.com/android-10-huawei-p20-lite/

I'm going to try and use this TWRP (twrp-3.4.0-0-anne.img)

Will let you know how it goes!
Getdroidtips? Really reliable source :)
I finally installed Havoc 3.8ab (latest version), I'm disappointed :( . No Music player, no Sound recorder (=no call recording) , no email client, Calendar etc. etc....
I think you should upgrade to EMUI 9.1 and try AB versions , hm?
 

MayhemIam

Senior Member
Dec 16, 2014
51
1
Getdroidtips? Really reliable source :)
I finally installed Havoc 3.8ab (latest version), I'm disappointed :( . No Music player, no Sound recorder (=no call recording) , no email client, Calendar etc. etc....
I think you should upgrade to EMUI 9.1 and try AB versions , hm?

I would have really like to test an earlier version then which did not have all those missing features! It seemed to me that customization was very good on the ROM....

:rolleyes: facepalm on Get Droid Tips....because the only tip I got from them is more than 12 hrs of trying to implement their crappy advice!

Ok I will upgrade to EMUI 9 then Alf.

Thanks for all the advice man and flashing along side me :eek:;)
 
Last edited:

-Alf-

Senior Member
Sep 28, 2017
1,986
627
Huawei P9 Lite
Huawei P10 Lite
Try Havoc 2.9 for Oreo , the Rom is just perfect . (own experience, tested on 8.0.0.126 )
INSTALL ON CLEAN OS (if your current OS is Custom ROM, flash stock ROM).
Download and unpack on your PC Havoc 2.9 arm64a:
https://sourceforge.net/projects/ha...90914-phhgsi_arm64_a-Official.img.xz/download

Flash extracted Havoc.img from fastboot using command
fastboot flash system (file name).img
Before booting up the ROM, you will need to perform a factory reset in stock recovery!!!
Reboot system.

In the Phh-Treble Settings-Huawei features, select fast charge 4000mA and Enable blurry UI workaround

If you want to install GAPPs or Magic (Magic v20.3 works without problems) , use TWRP by "ascuccio" (own experience), download link:
https://mega.nz/#!EsdTgYqZ!2QX9wgAhA653Dp2MkDTLPHa3tmFdNqmC5CDDHB-7f5Y

Screenshots:
https://mega.nz/#!1tlnlSyS!3SdAkZwf9miFVMkEXiq5Ypy3PcTOhuuohywk1ta-eXI
 
Last edited:

Dego02

Member
May 7, 2020
13
3
Los Rios
Hi all,

I'm trying to install Havoc OS on my P20 lite (2018 model - ANE-LX1 8.0.0.0.135(C432)). My current version of EMUI is 8.0. So I need to install a A version of ARM and NOT AB.

The system image is
Havoc-OS-v3.1-20200202-ARM64A-GSI.img

I have TWRP 3.4.0 installed and working. PS, I have also tried this via fastboot (fastboot flash system Havoc-OS-v3.1-20200202-ARM64A-GSI.img.xz) with the same results :confused:

Before flashing the ROM and my GAPPS file (open_gapps-arm64-10.0-nano-20200808.zip). Via TWRP I wipe Dalvik/Cache/System/Data

Then I installed the ROM via TWRP install and selected .img install, there are no errors and the screen output says it is installed correctly.

Then I flashed the GAPPS mentioned above. After that I wipe Dalvik/Cache again.

And reboot....nothing happens. The phone boots back up and goes straight to TWRP again. It's like the ROM is not being initialized at all.

Any help would be appreciated.
You have tried to decrypt the data?

https://forum.xda-developers.com/honor-7x/development/mod-decrypt-data-emui-8-t3765403
 
Last edited: