Havoc OS not loading

Search This thread

MayhemIam

Senior Member
Dec 16, 2014
51
1
You can try Havoc 2.9 for Oreo , the Rom is just perfect . (own experience, tested on 8.0.0.126 )
INSTALL ON CLEAN OS (if your current OS is Custom ROM, flash stock ROM).
Download and unpack on your PC Havoc 2.9 arm64a:
https://sourceforge.net/projects/ha...90914-phhgsi_arm64_a-Official.img.xz/download

Flash extracted Havoc.img from fastboot using command
fastboot flash system (file name).img
Before booting up the ROM, you will need to perform a factory reset in stock recovery!
Reboot system.

In the Phh-Treble Settings-Huawei features, select fast charge 4000mA and Enable blurry UI workaround

If you want to install GAPPs or Magic (Magic v20.3 works without problems) , use TWRP by "ascuccio" (own experience), download link:
https://mega.nz/#!EsdTgYqZ!2QX9wgAhA653Dp2MkDTLPHa3tmFdNqmC5CDDHB-7f5Y

Screenshots:
https://mega.nz/#!1tlnlSyS!3SdAkZwf9miFVMkEXiq5Ypy3PcTOhuuohywk1ta-eXI

I followed your downgrade instructions Alf. Flashed a Service ROM, phone was locked, then I did downgrade through HiSuite to EMUI 8. All went good! Installed Havoc OS 2.9 as suggested! Thank you so very much for all you help dude!
 

MayhemIam

Senior Member
Dec 16, 2014
51
1
... specific to GSI :). Stock Camera is better.

Ok....where do I get a stock camera app then? I tried via F-Droid. The camera app that is installed with the OS does not work. It crashes to the home screen. I also tried a few through the PlayStore. No luck.

When you say GSI, that means all ROMs that are GSI based has this issue with Huawei phones?
 

-Alf-

Senior Member
Sep 28, 2017
1,973
625
Huawei P9 Lite
Huawei P10 Lite
Ok....where do I get a stock camera app then? I tried via F-Droid. The camera app that is installed with the OS does not work. It crashes to the home screen. I also tried a few through the PlayStore. No luck.

When you say GSI, that means all ROMs that are GSI based has this issue with Huawei phones?

If you want Hua Stock Camera, take OpenKirin LOS 16 (video recording issue) . Or, on Havoc 2.9 you can install Stock P9 Camera (but with the same video recording problem- not work) , link
https://mega.nz/#!dwEB0IZL!fd5hC4eMhRLdAcdkqInfvCXejcDcl4E3i4UDxYY1bHo
 

MayhemIam

Senior Member
Dec 16, 2014
51
1

MayhemIam

Senior Member
Dec 16, 2014
51
1
The question is, what are you expecting from the Custom ROM? IMO best Custom ROM = Stock ROM with root access :cool: .

I was not sure what I wanted :p from the custom ROM.

Well when I started down this path I learned a couple of things. It would seem you are indeed correct. But what I saw with a non-GAPSS phone compared to a manufacturer ROM is that even when not using the phone, the custom ROM uses about 1 gig less memory. That is also to do with GAPPS not running as well as maybe not many apps installed on a vanilla ROM.

That leads me to my next question. Is that the reason you branded that phone to the Chinese Nova ROM? To get away from GAPPS? Cause I would also like to go without GAPPS on a stock ROM. It would seem that is the best path forward. I did like the customization of custom ROMS and wow Havoc OS sure delivers on that front. But yeah, not being able to use the camera is a deal breaker.

PS...I tried that link and flashed it via TWRP. No dice, it just crashes to homescreen. I am trying another one

Should I flash it via Magisk or TWRP? I flashed the .zip file via TWRP yet it did not work? Must it be installed in a specific place on the system partition?

https://forum.xda-developers.com/apps/magisk/module-huawei-p20-camera-kirin659-t3798436
 
Last edited:

-Alf-

Senior Member
Sep 28, 2017
1,973
625
Huawei P9 Lite
Huawei P10 Lite
I was not sure what I wanted :p from the custom ROM.

Well when I started down this path I learned a couple of things. It would seem you are indeed correct. But what I saw with a non-GAPSS phone compared to a manufacturer ROM is that even when not using the phone, the custom ROM uses about 1 gig less memory. That is also to do with GAPPS not running as well as maybe not many apps installed on a vanilla ROM.

That leads me to my next question. Is that t he reason you branded that phone to the Chinese Nova ROM? To get away from GAPPS? Cause I would also like to go without GAPPS on a stock ROM. It would seem that is the best path forward. I did like the customization of custom ROMS and wow Havoc OS sure delivers on that front. But yeah, not being able to use the camera is a deal breaker.

PS...I tried that link and flashed it via TWRP. No dice, it just crashes to homescreen. I am trying another one

Should I flash it via Magisk or TWRP? I flashed the .zip file via TWRP yet it did not work? Must it be installed in a specific place on the system partition?

https://forum.xda-developers.com/apps/magisk/module-huawei-p20-camera-kirin659-t3798436

We talked about this a week ago:
"If you "hate" Google and Google's bloatware (like me ) only, you can simply rebrand your phone to chinese Nova 3e.
Or, choose Custom ROM based on Stock with KangVip settings , stable enough to be used as your daily driver." ( e.g. https://forum.xda-developers.com/hu...m-emui-8-0-kangvip-p20-lite-catuva21-t3813564
https://forum.xda-developers.com/hu...-emui-8-0-0-huawei-p20-lite-dual-sim-t3813604) . Using KangVip settings you can disable completely GAPPs .
Rebranding is a little more complicated .
My primary phone is at the moment Mate 10 lite rebranded to chinese Maimang 6 (to get away from GAPPS :)) . Among other things, better battery life, lower data consumption (using FUT) etc.
P.S.: I flashed this P9 HwCamera simply via TWRP, and it works. Maybe require SELinux permisive , idk (I have it ) .

---------- Post added at 22:32 ---------- Previous post was at 22:21 ----------

Should I flash it via Magisk or TWRP? I flashed the .zip file via TWRP yet it did not work? Must it be installed in a specific place on the system partition?

https://forum.xda-developers.com/apps/magisk/module-huawei-p20-camera-kirin659-t3798436

Afaik magisk module overwrite stock camera, it will not work with non-Huawei camera...
 

MayhemIam

Senior Member
Dec 16, 2014
51
1
We talked about this a week ago:
"If you "hate" Google and Google's bloatware (like me ) only, you can simply rebrand your phone to chinese Nova 3e.
Or, choose Custom ROM based on Stock with KangVip settings , stable enough to be used as your daily driver." ( e.g. https://forum.xda-developers.com/hu...m-emui-8-0-kangvip-p20-lite-catuva21-t3813564
https://forum.xda-developers.com/hu...-emui-8-0-0-huawei-p20-lite-dual-sim-t3813604) . Using KangVip settings you can disable completely GAPPs .
Rebranding is a little more complicated .
My primary phone is at the moment Mate 10 lite rebranded to chinese Maimang 6 (to get away from GAPPS :)) . Among other things, better battery life, lower data consumption (using FUT) etc.
P.S.: I flashed this P9 HwCamera simply via TWRP, and it works. Maybe require SELinux permisive , idk (I have it ) .

---------- Post added at 22:32 ---------- Previous post was at 22:21 ----------



Afaik magisk module overwrite stock camera, it will not work with non-Huawei camera...

I had so many posts I forgot what you said. But I did go back to your old ones, some of them to try and figure out how to flash back to A8 and install Havoc OS. Thank you for telling me again :victory:

Ok i will look at also getting SELinux permissive then. You were right about this ROM though. It is a awesome ROM thus far and so so many customization options. I have never seen anything like it. It;s just a bummer I can't ever use my phone's video recording ever with a custom ROM. But ok. Will see how I tolerate the ROM without that feature.

Thanks again man!
 

MayhemIam

Senior Member
Dec 16, 2014
51
1
from HavocOS to KangVIP

We talked about this a week ago:
"If you "hate" Google and Google's bloatware (like me ) only, you can simply rebrand your phone to chinese Nova 3e.
Or, choose Custom ROM based on Stock with KangVip settings , stable enough to be used as your daily driver." ( e.g. https://forum.xda-developers.com/hu...m-emui-8-0-kangvip-p20-lite-catuva21-t3813564
https://forum.xda-developers.com/hu...-emui-8-0-0-huawei-p20-lite-dual-sim-t3813604) . Using KangVip settings you can disable completely GAPPs .
Rebranding is a little more complicated .
My primary phone is at the moment Mate 10 lite rebranded to chinese Maimang 6 (to get away from GAPPS :)) . Among other things, better battery life, lower data consumption (using FUT) etc.
P.S.: I flashed this P9 HwCamera simply via TWRP, and it works. Maybe require SELinux permisive , idk (I have it ) .

---------- Post added at 22:32 ---------- Previous post was at 22:21 ----------


Afaik magisk module overwrite stock camera, it will not work with non-Huawei camera...
So hello there Alf man

I flashed KangVIP ROM and all went good until I couldn't phone or properly install Magisk. As per this xda thread
https://forum.xda-developers.com/hu...m-emui-8-0-kangvip-p20-lite-catuva21-t3813564

If I wanted Magisk instead of the SuperSU installed with the OS, then I need to flash the provided TWRP in that forum post. Ok I did that, and when I tried to use it it told me that my Magisk manager was outdated so I updated it and then I uninstalled SuperSU as instructed on the post. Magisjk was granting super user access to a couple of pre-installed apps. I tried doing a SafetyNET check in Magisk but nothing happens? Will Magisk work if it did not pass SafetyNET check?

To fix the phoneing issue this ZIP needs to be flashed via Magisk Manager. (Module-MorfuzKernel_P20LITE .zip). I did that and rebooted yet nothing happens......seeing as it needs to be flashed with Magisk is it a Magisk module I presume? Anyway the phoning was still not working after I flashed the zip.

Any help would be greatly appreciated. I have also looked through that forum post and no one mentions the issues I had.
 
Last edited:

-Alf-

Senior Member
Sep 28, 2017
1,973
625
Huawei P9 Lite
Huawei P10 Lite
So hello there Alf man

I flashed KangVIP ROM and all went good until I couldn't phone or properly install Magisk. As per this xda thread
https://forum.xda-developers.com/hu...m-emui-8-0-kangvip-p20-lite-catuva21-t3813564

If I wanted Magisk instead of the SuperSU installed with the OS, then I need to flash the provided TWRP in that forum post. Ok I did that, and when I tried to use it it told me that my Magisk manager was outdated so I updated it and then I uninstalled SuperSU as instructed on the post. Magisjk was granting super user access to a couple of pre-installed apps. I tried doing a SafetyNET check in Magisk but nothing happens? Will Magisk work if it did not pass SafetyNET check?

To fix the phoneing issue this ZIP needs to be flashed via Magisk Manager. (Module-MorfuzKernel_P20LITE .zip). I did that and rebooted yet nothing happens......seeing as it needs to be flashed with Magisk is it a Magisk module I presume? Anyway the phoning was still not working after I flashed the zip.

Any help would be greatly appreciated. I have also looked through that forum post and no one mentions the issues I had.

Hello,
sorry for answering you late,
i'm little busy atm.
Download and install Morfuz 4.5 version, no bugs, everything works like a charm, inc. VoLTE, call recording etc. (my own experience) . I thought I mentioned it in my post, sorry bro.
Download link:
http://catuva21.blogspot.com/2018/06/morfuzp20.html?m=1
Tested on 8.0.0.126 , but 4.5 should work on higher build numbers too.
 
Last edited:

MayhemIam

Senior Member
Dec 16, 2014
51
1
Hello,
sorry for answering you late,
i'm little busy atm.
Download and install Morfuz 4.5 version, no bugs, everything works like a charm, inc. VoLTE, call recording etc. (my own experience) . I thought I mentioned it in my post, sorry bro.
Download link:
http://catuva21.blogspot.com/2018/06/morfuzp20.html?m=1
Tested on 8.0.0.126 , but 4.5 should work on higher build numbers too.

Hi there Alf.

Well the good news is I got Magisk 21 running and working! I also installed the following
Module-MorfuzKernel_P20LITE .zip -- ([KERNEL][MORFUZ-5.6][EAS][OREO] For P20 Lite by Catuva21)

When I try and flash the phone fix through Magisk, it gives me the following output.

Copying zip to temp dir
Installation Module-MorfuzKernel_P20LITE.zip
******
Comliment Morfuz Kernel
******
******
Powered by Magisk
******
Extracting module files
Setting permissions
Done


Then it asks me to reboot, and I do and the phone issue is still present. I would really appreaciate any info please.

When I get this working I am staying on this ROM as I have been trying now for weeks to get the right one!

m
And as I see it then I need to install the phoning fix.
Kernel_Morfuz5.6_HI6250 .zip

My phoning still does not work. I tried asking on their Telegram account but they just responded and said they don't support it any more.
 

MayhemIam

Senior Member
Dec 16, 2014
51
1
Which ROM?
P.S.: Do you need a Morfuz kernel at all? You needn't it, IMHO.

So a kernel is just an app for a person to set hardware specific settings? I see that the OS has one built in. I installed the last ROM you suggested.

This one - ROM V4.5 - EMUI 8
http://catuva21.blogspot.com/2018/06/morfuzp20.html?m=1

So then I just need to flash the provided file for fixing the phone issue.

https://forum.xda-developers.com/huawei-p20-lite/development/kernel-p20-lite-catuva21-t3840969

It seems that Huawei modified the modem partition in the September-October patch and the MORFUZ kernel does not work incoming and outgoing calls.
-IMPORTANTonly install this module from the root Magisk options if incoming and outgoing calls do not work.
HONOR 7X----------link
HONOR 9L----------link
P8 LITE-----------link
P10 LITE----------link
P20 LITE----------link
MATE 10 LITE------link

That P20 link gives this download
Module-MorfuzKernel_P20LITE .zip

So I just have to flash it via Magisk? I tried that and the phone issue persists :crying:
 

-Alf-

Senior Member
Sep 28, 2017
1,973
625
Huawei P9 Lite
Huawei P10 Lite
So a kernel is just an app for a person to set hardware specific settings? I see that the OS has one built in. I installed the last ROM you suggested.

This one - ROM V4.5 - EMUI 8
http://catuva21.blogspot.com/2018/06/morfuzp20.html?m=1

So then I just need to flash the provided file for fixing the phone issue.

https://forum.xda-developers.com/huawei-p20-lite/development/kernel-p20-lite-catuva21-t3840969

It seems that Huawei modified the modem partition in the September-October patch and the MORFUZ kernel does not work incoming and outgoing calls.
-IMPORTANTonly install this module from the root Magisk options if incoming and outgoing calls do not work.
HONOR 7X----------link
HONOR 9L----------link
P8 LITE-----------link
P10 LITE----------link
P20 LITE----------link
MATE 10 LITE------link

That P20 link gives this download
Module-MorfuzKernel_P20LITE .zip

So I just have to flash it via Magisk? I tried that and the phone issue persists :crying:

Yes, Catuva21 mentioned problems with build numbers with security patch 09.2018 and higher, logically, in this case, you need to install Morfuz on FW with a lower build number (e.g. .126, .136 etc.,), if you don't want extra problems.( The same problem was on Mate 10 Lite running Morfuz ROM). The phone issue persists on FW with Google patch 09.2018+ , so if you want to definitely solve the problem with incoming / outcoming calls, downgrade build number to .126 or .136 via Service ROM, then simply install 4.5 version , without Morfuz kernel (if you want switch processor power and change governors, you can use Kernel adiutor apk)
 

MayhemIam

Senior Member
Dec 16, 2014
51
1
Yes, Catuva21 mentioned problems with build numbers with security patch 09.2018 and higher, logically, in this case, you need to install Morfuz on FW with a lower build number (e.g. .126, .136 etc.,), if you don't want extra problems.( The same problem was on Mate 10 Lite running Morfuz ROM). The phone issue persists on FW with Google patch 09.2018+ , so if you want to definitely solve the problem with incoming / outcoming calls, downgrade build number to .126 or .136 via Service ROM, then simply install 4.5 version , without Morfuz kernel (if you want switch processor power and change governors, you can use Kernel adiutor apk)

Thank you man! I was thinking the other day about my security patch maybe not being low enough.. I will downgrade to stock less than 09.2018. But I just wiped the phone again, and used his version of Magisk 17.1, installed the patch for the phone issue and it was resolved BUT when I upgrade Magisk to v20 it stops working. I couldn't use Magisk modules with v17.1. Ok I will downgrade and test again!

Thanks for your help again Alf!