• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Head units RockChip PX5 with MCU S32F0 (Android 8.0.0/Android9.0.0)

Search This thread

Stifler2000

Member
Jul 20, 2011
22
1
I carried out the update! The Erisin version only has bugs! back to ZQ_PX5C_UPDATE_C54_HA1_Xrc2-10-EN_2009141032.

Does anyone have a factory new version than this? The seller told me there are no more updates? even though the radio was bought in May!


Since then I have had the problem, when I unchecked the car, my radio turned on, when I put the key in the ignition, my radio was already operational. My problem is when I first put the key in. Now started always? so boots.
It worked before the update, the old version was updated again, not since then, do I have to go to the factory setting if necessary?




The one with the MTC / MCU, see example image, green marking, that is not displayed for me?
Screenshot-20201007-143854.png
 
Last edited:

Jarninho

Member
Jul 29, 2020
5
4
Further to my post #115 in the Malays ROM thread: Turns out I had more things wrong... I had severe battery drain issues last few weeks. This came to light because of the lock down and hardly driving anymore. There was a parasitic draw which I narrowed down to the head unit.

I have a BMW 125i and am using a ZLtoopai unit.

I had the yellow wire connected to my fuse box. But I'd never seen another yellow wire coming from my canbus iso connector. This is directly linked to the yellow wire from the fuse box. Now, BMW shuts off the canbus after 20 minutes. Upon further inspection the yellow wire going into the canbus had a quick disconnect. It was still connected... So I disconnected it and left it overnight.
Last few days I had charged the car a bit every day (up to 12.2V). When I came back in the morning it was always 11.9v or lower. This morning with the yellow wire not connected to canbus, it was still at 12.2v. Finally!

So basically what had happened was that when I connected my yellow wire, there was a constant 12v powering my car's canbus or wherever it went. This was draining the battery quite rapidly.

So far it seems all is working well. But I'm keeping my fingers crossed and hope no new issues will come to light...
 

fabiusx01

Member
Jul 23, 2014
20
3
Hi guys by mistake I deleted the zlink app, I tried to re-install via apk but I can't install, it gives me an error. Do you think it is necessary to restore the factory data?
 

royalhawk2002

Senior Member
Sep 21, 2008
899
140
Avezzano
for whom are interested to an alternative Radio App, here there is the Navradio+ ported by Kotix to our devices:
 

obioan

Senior Member
Feb 4, 2012
70
4
Bucharest
Does anyone had the problem of rear speakers not working?
They worked perfectly on stock firmware on first install in my car.
I don't know if its a setting thing because I cannot pinpoint the exact moment when my speakers stopped working. I am sure that they are not burned or something because they are new and have 150W.
 

koli84

Member
Jul 23, 2012
7
1
Hi, i have a problem installing this firmware. I copy everything to usb, the installation begins and then an error appears as in the attached photo. I also attach a photo with the version of my software. Anyone can help me?

IMG_20210521_173215.jpg
IMG_20210521_204135.jpg
 

royalhawk2002

Senior Member
Sep 21, 2008
899
140
Avezzano

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    It seems but, as already said, it is a very small update.... I don't understand
    when you look into meta info the small one seems to be update for real Android 10 and the big one is for Fake-Android 10
  • 2
    I posted here last month about my headunit, I'm pleased to say the performance has gotten much better over time. When I first got the unit, it was very slow and laggy even with 4GB of RAM. But now the performance is excellent, I can switch between apps on the fly and multitask without issue.

    The "Screen Mirror" app on my headunit was atrocious; it had no touch screen functionality, crashed constantly, and did not enlarge the display. I've since installed this Apple CarPlay adapter: Binize Wireless Carplay/Android Auto USB Dongle (https://www.amazon.com/gp/product/B084X4WY6C). This really changed the simplicity of the device for me. The scaling seems off in Android, and apps like Google Maps are very small and the Apple Music app is cutoff. With car play, the apps are scaled perfect and the controls are much more simplified for driving. But I still have the full Android operating system for watching videos, using the Torque App, browsing the internet, etc.

    Only real qualm I have left about my headunit is very flaky when it comes to connecting to the mobile hotspot. If I have the hotspot enabled before I start the car, it connects automatically about 65% of the time. If I forget or it fails, its an awful combination of turning off the headunit wifi and the hotspot until it connects.

    I use Google Maps as navigator, and I have Macrodroid installed on my phone to enable the hotspot when connects by Bluetooth with the car. It works like a charm. It always connects and I've driven long distances without a problem. Maybe the problem is on your phone, try with another phone. I use the app Free Notification Reader (https: //play.google.com/store/apps/details?id=com.pelix.notify&hl=en_US) too, this app allows you to listen and answer WhatsApp and other apps with your voice when in your car. It activates only when connected by Bluetooth and it works perfectly for me.

    Only have two problems, my physical buttons do not light. Maybe the ILL cable was disconnected, but I have to dismount half-car to check it. I've tried to activate the light in factory settings, changing the setting from head-light to power, but the lights still didn't work. The other problem is that I can't call with voice. I've tried MTCDialer without success.
    1
    Anyone has this radio , is it possible to update ?

    https://forum.xda-developers.com/picture.php?albumid=15993&pictureid=59835

    https://forum.xda-developers.com/picture.php?albumid=15993&pictureid=59837



    Have no idea why photos are not loading hence link to my album in XDA

    Take a look here : http://4pda.ru/forum/index.php?showtopic=973677
    I use Google translate, but I am not brave enough to flash any of the ROMs from there.
    I have the same unit I'm my Camry.
    1
    I have a Hizpo Android10 head unit with the same MCU version (I think, first letters are same: S32F0). Also interested in if there are updates available and how the h**l you can acivate recovery mode with button presses.

    Skickat från min BLA-L29 via Tapatalk
    1


    ---------- Post added at 08:21 AM ---------- Previous post was at 08:17 AM ----------

    Hoping as time passes more will get these HU's and eventually root and cook a ROM for them.

    Mine has a number of issues,
    1) The OEM reverse camera only works for 3 seconds when selecting reverse then it switches off
    2) The basic DSP works but the more advanced DSP doesn't
    3) GPS is very inaccurate
    4) No RDS
    5) Volume and radio channels change by themselves
    6) Car settings don't work
    7) Open doors indicator is switched around, left door open shows right door on HU.

    Are you sure you have the same unit?
    Because:
    1) My reverse camera works,
    2) DSP Works
    3) Gps never give me problem, error of 3 meters is normal
    4) RDS works perfectly
    5)Never happen to me
    6) car setting works, i changed SW and other settings
    7) I didnt have that functions (in my car) so i cannot test
    1
    It seems but, as already said, it is a very small update.... I don't understand
    when you look into meta info the small one seems to be update for real Android 10 and the big one is for Fake-Android 10