[HELP] A50 Magisk bootlooping

Search This thread

ben.marks

Senior Member
Jul 23, 2010
331
22
Hi all,
I've been trying to root my A505FN all day with the help of various guides but everytime Magisk starts up via Recovery method I get a bootloop. It starts up the startup wizard, then 10 seconds later reboots.

I have flashed a stock Android 10 firmware on it with BIT5 - A505FNXXS5BTLA - all working fine.
Took the AP file, and pushed it to the device, and stripped the .md5 off the end.
Installed Magisk.
Patched the AP file using Magisk App, and the log looked ok and said -patched recovery.img
Pulled the magisk_patched.tar file
Put the magisk_patched file into AP slot on ODIN, and added other .tar.md5 files as normal. Unchecked Auto-reboot
Flashed successfully, rebooted myself, and then held the recovery buttons to enter recovery to do factory reset
Rebooted again and held recovery buttons to the OEM unlock splash screen and then let go.
Boots up fine, but then 10 seconds later, reboot, can't even get past Wi-fi setup.

Any ideas? Thanks
 
Last edited:

ben.marks

Senior Member
Jul 23, 2010
331
22
Trying this again and flashing multidisabler, that could be the issue. If that still fails I'll be using OrangeFox and trying that method.
 

ben.marks

Senior Member
Jul 23, 2010
331
22
OrangeFox Recovery method worked with the following

- recovery sequence is Vol Up + Power button
- to get to download, from a powered off state, press Vol Up + Vol Down and plug in cable
- to get back to rooted/Magisk state, I have found the following works better
- power on device, you will see Samsung startup A50 'Secured by Knox screen'
- you then need to press power button to continue booting
- you then see Samsung startup 'secured by knox' screen again.
- once you see JUST the Samsung logo with black screen, now press Vol Up + Power
- seems to boot to rooted state with no issue