• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Help each other: firehose and eng bootloader publicly available

Search This thread


Senior Member
May 31, 2021
How can you not understand, octoplus/medusa work the same way as qfil, nothing depends on the program, this file (firehose) is from ZTE, anyone with Heh editor will understand this. Not the program decides, but the phone, the phone checks the divice id and the public hash of the file.

This firehose will only work on refurbished phones where memory or processor was changed. This file will never work with the original LG. Why do you believe blindly? You can read the information and find out for yourself. The guys were definitely deceived and slipped them the wrong file. LOL
benefit of doubt

Oswald Boelcke

Senior Moderator / Moderator Committee
Staff member
Moderator Announcement

With references to rule no. 13 of the XDA Forum Rules thread has been cleaned from references to paid services. Even if you don't benefit from such services please refrain from sharing such information that is not in line with the spirit of XDA. Thanks for your cooperation.

Oswald Boelcke
Senior Moderator
  • Like
Reactions: inuyasha1999


Senior Member
Feb 2, 2017
Samsung Galaxy Note 4
LG V30
I would really appreciate that it's monitored and closed would likely be the best course of action.
For the time being, no release (please see the original post that was edited earlier). However, I'm hoping that the community can pull things together and begin their research. Definitely not a troll post - which leads me to the next quote here

We'd love to have you. I'm not going to be as active as I usually am for a while, but it's nice for more people to come in, and I'd love for you to see the progress everyone's making.

Apologies, too, by the way - didn't get a notification here from your message.
Hey can I get an invite to the server? Invite expired

ebowen 747

Senior Member
Jun 3, 2014
LG V30
Google Pixel 4 XL
{Mod edit: Quoted post has been deleted}

I bought a Medusa box and want to learn how to use it. Is this something I can do myself, or are the files not available to me.
Last edited by a moderator:


Senior Member
Apr 17, 2009
Ft. Lauderdale
I mange to flash on boot _a but phone is messed up. I was trying to go to go a12gsi I think I'm little skindsh... there is no backup,,,,, twrp,. now says BL unlock.
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 10
    Thank you to everyone for patiently waiting - I know these forums have been dark and getting darker. I really hope that this will help bring some life back into the LG Forums; you guys deserve it.

    Sorry about this, guys.

    Not long ago, @ps3hacker3 and I got our hands on a firehose programmer for the Kona, and the engineering bootloader for the V60.

    I created the post as I was under the assumption that we had a working method to provide the ability to unlock the device and root it. Over time as I looked more and more into it, a prevalent issue arose: Sahara refuses to communicate with us when trying to open the partition manager from QFIL.
    The original process used on ps3hacker3's LMV600AM model utilized Medusa Pro, but as far as I can tell, I can't help but feel like I'm still missing a piece of this puzzle. Perhaps it's as simple as a setting configuration, and perhaps it's as complex as an entire other part of this process that I'm missing.
    Nonetheless, I can leave you with two things.
    A) The firehose, one way or another, despite what anybody says or doubts about it, worked on ps3hacker3's phone. Screenshots as proof are available deeper into the thread.
    B) The engineering bootloader worked just as well.

    I apologize for thinking that I'd gotten you halfway there, and for prematurely creating a thread that posed answers without being able to follow through on the process. In acknowledgement of the time and amount of workload and stress this project and the Stylo 6 projects have taken up in my life, I don't feel that I have the capacity to continue leading any of these projects anymore.

    I would still take everything that anyone in this thread, seemingly right or wrong, said with a grain of salt and do your own research and ask people your own questions before concluding anything. It's nothing personal to do with anybody, it's just the best advice that I can give you based off of the situation. I didn't learn anything by taking everybody's word for it. Even if you're wrong at first, or the first hundred times, just keep doubting and testing theories. Keep wondering. Nobody knows everything and even well-established concepts may not be fully fleshed out, especially in the world of consumers and developers attempting to use software and files from OEMs and other manufacturers that is meant to remain unbeknownst to us. There's a lot I don't know, and a lot everyone doesn't know.

    Thank you for being here with me on this journey.
    I hope that the files can still make themselves useful - I have full confidence that they do.
    Regardless, someone I would feel more comfortable not naming due to a recently closed thread was using them to unlock phones for high prices for people. Skipping over the drama, I just wanted to make them available for everybody. I suppose I've done my part, so please take this into your hands and give it all you've got.
    The original post contents are in a dropdown below. I advise you to not blindly follow through with all of it.

    It's up to you guys now - do your best.
    Stay hopeful, and question everything. All the time.

    Apparently, I overlooked a detail as I didn't think it was necessary. QPST was not used here, but rather a patched Medusa that can be found here.
    The way this worked was complicated and I overlooked the fact we do not have a patched Medusa.
    QPST is apparently unsuccessful at the moment.
    I am working on a fix for this.
    If anyone has any success with a specific QFIL or QPST version then please be sure to let us know so that I can update the post.
    We have the files - hardest part is over. Now we just have to be able to use them.

    Apologies to everybody who ran into troubles.
    I am testing on the T-Mobile variant as soon as we're able to.

    It's over.

    Enter 9008:
    • Qualcomm USB 9008 drivers should be installed prior to this operation. These can be retrieved below, inside the archive along with the necessary files.
    • Your phone must be plugged into the computer prior to the rest of the process.
    • With your phone on, hold volume down and power. After about ten seconds, continue to hold power and volume down, while also spamming volume up. This works much better if your device is powered on and your screen is on, as a bar will show up on the bottom and you can initiate the volume up spamming as soon as the bar drains to empty.
    • As soon as the screen turns black, let go of all of the buttons. The device should appear in 9008 mode in the Device Manager.

    I'm going to be honest, guys - I've been working on the Stylo 6 since January and the V60 from some random point a few months ago. From here my memory's foggy, I'm tired, and you guys are smart, so if someone needs help, then help each other, okay?

    Generally speaking you can use QPST or another piece of software that can interact with Qualcomm devices in 9008 mode the patched Medusa from the link at the top of the post to flash the engineering bootloader. You will use the firehose attached below along with the eng boot for this.
    I don't know why it is that Medusa is required. It is unfortunate.

    The previous V40 thread is practically identical and has a lot of prior support and questions answered that, the vast majority of the time, can be adapted to the current model and files. They also cover many potential problems that I did not, and it is strongly recommended that you review that thread.

    Be kind. Be patient. Be courteous. Share.

    And enjoy.

    Special thanks to @ps3hacker3 for participating in my Discord server and working with me last second on managing to obtain the files.
    Donate to him and his partner here: PayPal.me
    For devices that have replaced the CPU, the firehose signature is not verified. You can view it through *#546368#*model#-SVC Menu-MID Info-IMPL
    Thank you very much for your reminder, my website is no longer operating.
    This further solidifies my theory, luckily enough. It doesn't pass attestation, but it does function correctly.
    So... that's it.
    Working on getting the firehose to work tonight. I do know that it does indeed function because we have someone who has an unlocked bootloader because of it. 😉
    It may not officially support the V60 due to it being designed for ZTE, but it does functionally support it. Perhaps it's because this is the Kona processor, which is the prototype version of the processor. Either way, it functionally supports it, and the obstacle of getting around attestation is much less daunting to me than not having the files we need or knowing how to unlock the device.
    This is the firehose file of ZTE phone,not support LG phones.
    CN = QCT Attestation CA O = QUALCOMM OU = General ztemt attestation L = San Diego S = CA C = USView attachment 5347163
    Except that it did.
    So... say what you will. I genuinely witnessed this file get used. Speculate about the details with someone else. I'm not here to debate. I'm here to provide.

    Next time consider asking some questions instead of pointing a finger and implying that I'm wrong because of some information you have without actually elaborating.
    I wouldn't be here if it didn't actually work.


    Hey, also, your port 8888 is open, and thus so is your site login.
    Also, your site is really broken.
    Best of luck :)
    I'm not sure. I have the TMO and I'll be trying I'm a little while. I'll update the post to let everyone know so be sure to keep an eye on it
    Thanks for all the hard work!
    It's my understanding people are having trouble with QPST.
    We used a patched Medusa and it seems unfortunately that it was necessary. I'll be updating the post shortly. :)