• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[Help][Guide][Philippines]SM-N9860 HK/TW/CH Snapdragon Users|5G Reception Fix

Search This thread

ching2-o

Member
Jun 30, 2016
6
0
Hello guys, I know by default we have trouble enabling VoLTE of DITO SIM on TGY/BRI/CN. But I figured it out but we need to root G9860. If your interested please send me PM.. Don't worry its free. This thread is a big help to me I am sharing this also. In case i will post this or create other Thread.
 

tribalfs

Senior Member
Mar 28, 2014
1,030
707
Hello guys, I know by default we have trouble enabling VoLTE of DITO SIM on TGY/BRI/CN. But I figured it out but we need to root G9860. If your interested please send me PM.. Don't worry its free. This thread is a big help to me I am sharing this also. In case i will post this or create other Thread.
Hi! I think it's best to share it here instead so everyone can see. :)
 

ching2-o

Member
Jun 30, 2016
6
0
The thread starts with N9860, but I am using G9860 and work it out..
* Disclaimer: Its your phone, if you want to take the risk try it.
1. Need to root your device with Magisk or any root process you can use for your phone
2. Install Root Explorer and navigate look for the customer.xml. By default, depending on your CSC, the volte settings was set to the operators of the said country
3. You might also save imsservice.apk and backup both original file in case you can revert back.
4. Edit customer.xml, you can right click open the file and use xml editor available online. You can see operator settings, at the end check for Operator setting with VoLTE enabled. Take note of that and for the whole XML file, edit that operator settings fully on that xml.
Note: MNC-MCC
DITO 51566
DITO APN: internet.dito.ph

Save your edited customer.xml base on your operator preferred volte to enable
5. Replace customer.xml using root explorer, with changing permission to Execute
6. Actually, backup your files on phone, because you need to Wipe (thru recovery mode) the phone after and setup as new settings. Before you proceed with Wipe, check OEM Unlock is enabled on your Developer Option
7. After reboot you can see Enable/Disable VoLTE options on Mobile Network Settings and see VoLTE on signal bar

Please do take this at your own risk and don't blame me if has errors. Mine worked already enabled 4 G9860

It might be the hard way to enable VoLTE for DITO but if there still way here you can share. No problem

Smart and Globe VoLTE has no issues on VoLTE by the way it will work as is.. Just for DITO

For me i use BRI - Taiwan Firmware so I Edited TW Mobile operator
For TGY - Hongkong, you can edit 3 Macau settings to DITO
 
Last edited:

tynlc

New member
Jun 23, 2013
2
0
I'm using S20 FE 5G HK Variant. After doing this "Try this. On UE Settings>Protocol>GCF>Remove NR Whitelisting. Then reboot. That's the first step I did." I can detect 5g signal but everytime I turn on data it goes back to 4g+. Tried doing speedtest or youtube but still doesn't go to 5g. =(

PS: I'm using Smart Prepaid
 

Andromeduh

Senior Member
I'm using S20 FE 5G HK Variant. After doing this "Try this. On UE Settings>Protocol>GCF>Remove NR Whitelisting. Then reboot. That's the first step I did." I can detect 5g signal but everytime I turn on data it goes back to 4g+. Tried doing speedtest or youtube but still doesn't go to 5g. =(

PS: I'm using Smart Prepaid
Maybe the bands assigned for 5G in your area isn't compatible? IIRC the 5G band it connects to here in my house is B5, so I'm not sure if you have that band. If ny memory serves me right, only B1 and B5 gets enabled for 5G under Smart.
 

tribalfs

Senior Member
Mar 28, 2014
1,030
707
The thread starts with N9860, but I am using G9860 and work it out..
* Disclaimer: Its your phone, if you want to take the risk try it.
1. Need to root your device with Magisk or any root process you can use for your phone
2. Install Root Explorer and navigate look for the customer.xml. By default, depending on your CSC, the volte settings was set to the operators of the said country
3. You might also save imsservice.apk and backup both original file in case you can revert back.
4. Edit customer.xml, you can right click open the file and use xml editor available online. You can see operator settings, at the end check for Operator setting with VoLTE enabled. Take note of that and for the whole XML file, edit that operator settings fully on that xml.
Note: MNC-MCC
DITO 51566
DITO APN: internet.dito.ph

Save your edited customer.xml base on your operator preferred volte to enable
5. Replace customer.xml using root explorer, with changing permission to Execute
6. Actually, backup your files on phone, because you need to Wipe (thru recovery mode) the phone after and setup as new settings. Before you proceed with Wipe, check OEM Unlock is enabled on your Developer Option
7. After reboot you can see Enable/Disable VoLTE options on Mobile Network Settings and see VoLTE on signal bar

Please do take this at your own risk and don't blame me if has errors. Mine worked already enabled 4 G9860

It might be the hard way to enable VoLTE for DITO but if there still way here you can share. No problem

Smart and Globe VoLTE has no issues on VoLTE by the way it will work as is.. Just for DITO

For me i use BRI - Taiwan Firmware so I Edited TW Mobile operator
For TGY - Hongkong, you can edit 3 Macau settings to DITO
Thank you for sharing.

I understand this process is basically adding DITO's APN in order to use DITO's data and VoLTE, right? Is manually adding this APN in Settings > Mobile networks doesn't work?
 

tribalfs

Senior Member
Mar 28, 2014
1,030
707
Maybe the bands assigned for 5G in your area isn't compatible? IIRC the 5G band it connects to here in my house is B5, so I'm not sure if you have that band. If ny memory serves me right, only B1 and B5 gets enabled for 5G under Smart.
What device do you have? 5G band 5 is missing in SM-N9860.
 

ching2-o

Member
Jun 30, 2016
6
0
@tribalfs
No it not just a basic adding an APN

Even you add manually APN, yes Mobile Data will work but VoLTE will not be present and no VoLTE switch and cannot make a call because DITO is purely VoLTE technology on Calls and no more fallback to 3G or GSM for Calls. DITO is not defined on imsservice.apk and customer. xml.
I am not sharing enable and define manually an APN but to Enable VoLTE and VoWiFi of the phone with DITO Network

You cannot add an uneditable ims settings on the APN to work DITO VoLTE. Even you add manually VoLTE will still not work.

Maybe updates will fix the issue especially Android 11 but initially since by default Android 10 or stock, VoLTE will not work.
 

Attachments

  • Screenshot_20210615-204350_Settings.jpg
    Screenshot_20210615-204350_Settings.jpg
    64 KB · Views: 27
Last edited:

ching2-o

Member
Jun 30, 2016
6
0
And another thing, for the case of this Service Mode:
UE SETINGS>Protocol>GCF>Remove NR Whitelisting.

No Problem with Philippine Globe and Smart NSA 5Gs
For Phillippine DITO Network, 5G will still not work even if if N41 and N78 is within the N9860/G9860 even removed whitelist or SA/NSA Enable. That what's im trying to figure it out if someone could share fix for it.
 

tribalfs

Senior Member
Mar 28, 2014
1,030
707
@tribalfs
No it not just a basic adding an APN

Even you add manually APN, yes Mobile Data will work but VoLTE will not be present and no VoLTE switch and cannot make a call because DITO is purely VoLTE technology on Calls and no more fallback to 3G or GSM for Calls. DITO is not defined on imsservice.apk and customer. xml.
I am not sharing enable and define manually an APN but to Enable VoLTE and VoWiFi of the phone with DITO Network

You cannot add an uneditable ims settings on the APN to work DITO VoLTE. Even you add manually VoLTE will still not work.

Maybe updates will fix the issue especially Android 11 but initially since by default Android 10 or stock, VoLTE will not work.
So this process adds both APN and VoLTE profile. Thanks for clearing.
 
Last edited:

tribalfs

Senior Member
Mar 28, 2014
1,030
707
And another thing, for the case of this Service Mode:
UE SETINGS>Protocol>GCF>Remove NR Whitelisting.

No Problem with Philippine Globe and Smart NSA 5Gs
For Phillippine DITO Network, 5G will still not work even if if N41 and N78 is within the N9860/G9860 even removed whitelist or SA/NSA Enable. That what's im trying to figure it out if someone could share fix for it.
Maybe no 5G coverage. There's no DITO 5G site yet according to this DITO's website.
 

syber shaman

Member
Apr 25, 2014
25
5
Just updated a couple of days ago, and surprisingly, no changes were made. Everything is as I left them. Wish it's always like this. No more modifying after each update.
 

ching2-o

Member
Jun 30, 2016
6
0
Maybe no 5G coverage. There's no DITO 5G site yet according to this DITO's website.
I am a telecom engineer, we have the database and we can pinpoint where and check status of on-air 5G sites which the DITO websites still didn't published. There are on-air 5G DITO sites in Mindanao especially in Davao and we tested the phone, didn't received 5G even if we tested together with a 5G CPE. IT should received N41/N78 Band but failed.
 

omniviper

Member
Dec 8, 2007
15
1
Glad I found this. Tested and got 5g working on a Korean variant a90. Didn't have all the menus but it did have the whitelist which I fiddled with and got 5g to work
 

omniviper

Member
Dec 8, 2007
15
1
Guess I rejoiced too soon.
Indicator shows 5g
However network info app shows 4g LTE
Fast speed shows LTE speed
My non 5g data is being consumed despite it being unli 5g.

What am I doing wrong

Did the whitelist clearance
 

Android_fan_12_13

New member
May 15, 2017
4
0
The following are the mobile 5G bands being used in the Philippines from foi.gov.ph:
- Smart 5GNR bands: 1, 3, 5, 8, 40, 41 and 78
- Globe 5GNR bands: 1, 3, 8, 28, 40, 41
Update: According to Globe's website, they are using NR41 and NR78
View attachment 5327677

The 5GNR bands missing is in N9860 are 5, 8 and 40. Theoretically, our device should work in 5G sites utilizing 5GNR bands 1*, 3*, 28**, 41* and 78*** which our device is capable of. Otherwise, 5G will not work.


*Globe/Smart
**Globe Only
***Smart Only
I did some digging and i found the list if the 5GNR frequency use in the Philippines

Dito 5GNR Band that they use is 1, 28, 34, 41, 78
 

Attachments

  • 20210715_110604.png
    20210715_110604.png
    334.2 KB · Views: 10

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    Try this. On UE Settings>Protocol>GCF>Remove NR Whitelisting. Then reboot. That's the first step I did.
    4
    xUtsumi and kent800129.....Greetings form the UK

    Huge thank you to your both. :)(y):D:p:p:cool:

    I had almost givem up with this dam phone. Although it is my wife's , no 5g had stopped me importing one for myself.

    In the UK this phone got 5g on networks Vodafone and Three but not on god dam EE which is the biggest UK network.

    I am going to link your post in the other thread!

    Thankyou Thankyou Thankyou
    It was a consolidated effort. :) Also the only necessary part on enabling 5G is the first part. I just included the next 2 parts to increase signal strength and diversity stuff. Although I don't understand what they do fully, I've researched a little and enabling them will not hurt battery life while increasing the strength of signal. Correct me if I'm wrong on this. :D
    3
    Hope this solution helps others on this thread. :) Thanks @kent800129 for the idea. We can finally enjoy 5G. Hahaha.
    xUtsumi and kent800129.....Greetings form the UK

    Huge thank you to you both. :)(y):D:p:p:cool:

    I had almost given up with this dam phone. Although it is my wife's , no 5g had stopped me importing one for myself.

    In the UK this phone got 5g on networks Vodafone and Three but not on god dam EE, which is the biggest UK network.

    I am going to link your post in the other thread!

    Thankyou Thankyou Thankyou
    2
    Hi! I created this thread for SM-N9860 HK/TW/CH variant users from Philippines.

    The GOAL is to make our units work with our local carriers':
    • 4G Carrier Aggregation (4G CA) (i.e. 4G+/LTE-A).
    • 5G network
    and resolve any carrier related issues that you want to address.



    First, I will share my personal experience with my unit using my Globe 5G enabled postpaid sim. My N20U 5G unit is from Hongkong with TGY (Hongkong) CSC.
    While on TGY, 4G CA and 5G on my unit were NOT working. I am only getting max 20mbps with 4G and not getting the 4G+ signal.
    Note: To check the existing CSC, go to settings > about phone > software info >service provider SW ver. You should see something like TGY/TGY,TGY/TGY.

    However, I was able to change my CSC from TGY to BRI (Taiwan's CSC) using the procedures in this thread.
    I am now on BRI and I am glad that 4G CA is now working. I am already getting 70-125mbps on speedtest with it. Check this post on how to check 4G CA.

    However, I have not tested the 5G signal yet as I am far from a 5G enabled location.
    It's noteworthy though that Taiwan telcos use 5G bands n78, n257 and LTE DSS which include that n78 5G band being used by telcos in the Philippines (source: List of 5G NR networks
    )
    I am hoping for fellows to hit this thread try this change and test if this will work on his/her network, hopefully on 5G network too.



    UPDATES/SOLUTIONS

    How to access ServiceMode menu on pre-OneUI 3.0
    1. Install Google Phone app from Play Store and set it as default dialer.
    2. Open Google Phone app and key in *#*#27663368378#*#*


    How to access ServiceMode menu on OneUI 3.0/3.1
    I just saw a method for opening the menu again for Android 11. I saw this on the US thread. :)


    Just check the code on my N9810 BRI
    This method only works on Qualcomm versions
    I use *#*#276633683782#*#* on Google phone dialer
    and it brings up a service mode screen.

    Press [5] RF Test and choose [2] PREF MODE SET
    (or other options also works )
    It will show Please use *#2263# for mode set
    Then just tap three dots on right top menu and choose back
    It will bring you back to the main menu.

    by kent800129

    I can finally go to UE settings with this.


    Enabling 5G Stand Alone mode
    Go to UE SETTING&INFO -> SETTING -> PROTOCOL -> NR5G -> NR5G SA/NSA Mode Control > SA/NSA ENABLE Exit


    Solution to make 5G work in PH (also works in some countries with compatible 5G bands)
    Try this. On UE Settings>Protocol>GCF>Remove NR Whitelisting. Then reboot. That's the first step I did.

    Unhide/Enable 5GNR bands 3 and 28
    Hi there,
    Please go to [2] UE Settings >> [2]System
    On the last page choose [1] SET LTE BAND CONFIG
    Then click on [1] SET DEFAULT LTE BAND
    Reboot your phone and check again the available NR bands.


    How to check what 5G bands are enabled
    4. Go to UE SETTING&INFO -> SETTING -> PROTOCOL -> NAS -> NETWORK CONTROL -> BAND SELECTION -> BAND SELECTION SIM * -> NR5G Band Preference -> (enabled ones are marked with asterisks)

    If not yet enabled, select each then -> GO MAIN -> APPLY BAND CONFIGURATION. Exit then reboot

    Better 4G Carrier Aggregation (4G+)
    UE Settings>System>Diversity Control Menu>LTE Diversity Control>LTE 4RX ALL Enable.

    Note: You may need to redo the above procedures after software updates.



    5G Bands Supported by the device
    Bands 1, 3, 28, 41, 78 and 79


    5G Bands in PH
    The following are the mobile 5G bands being used in the Philippines from foi.gov.ph:
    - Smart: 1, 3, 5, 8, 40, 41 and 78
    - Globe: 1, 3, 8, 28, 40, 41

    Update: According to Globe's website, they are using NR41 and NR78
    View attachment 5327677

    -DITO: 1, 28, 34, 41, 78

    The 5GNR bands missing is in N9860 are 5, 8, 34 and 40. Theoretically, our device should work in 5G sites utilizing 5GNR bands 1, 3, 28, 41 and 78 which our device is capable of. Otherwise, 5G will not work.


    Enable call and text on DITO sim (root required)
    The thread starts with N9860, but I am using G9860 and work it out..
    * Disclaimer: Its your phone, if you want to take the risk try it.
    1. Need to root your device with Magisk or any root process you can use for your phone
    2. Install Root Explorer and navigate look for the customer.xml. By default, depending on your CSC, the volte settings was set to the operators of the said country
    3. You might also save imsservice.apk and backup both original file in case you can revert back.
    4. Edit customer.xml, you can right click open the file and use xml editor available online. You can see operator settings, at the end check for Operator setting with VoLTE enabled. Take note of that and for the whole XML file, edit that operator settings fully on that xml.
    Note: MNC-MCC
    DITO 51566
    DITO APN: internet.dito.ph

    Save your edited customer.xml base on your operator preferred volte to enable
    5. Replace customer.xml using root explorer, with changing permission to Execute
    6. Actually, backup your files on phone, because you need to Wipe (thru recovery mode) the phone after and setup as new settings. Before you proceed with Wipe, check OEM Unlock is enabled on your Developer Option
    7. After reboot you can see Enable/Disable VoLTE options on Mobile Network Settings and see VoLTE on signal bar

    Please do take this at your own risk and don't blame me if has errors. Mine worked already enabled 4 G9860

    It might be the hard way to enable VoLTE for DITO but if there still way here you can share. No problem

    Smart and Globe VoLTE has no issues on VoLTE by the way it will work as is.. Just for DITO

    For me i use BRI - Taiwan Firmware so I Edited TW Mobile operator
    For TGY - Hongkong, you can edit 3 Macau settings to DITO

    Video Guide:

    2
    Hope this solution helps others on this thread. :) Thanks @kent800129 for the idea. We can finally enjoy 5G. Hahaha.