Help!! I bought a Google LLC "lost" device on eBay

Search This thread

2blackbar

Member
Oct 21, 2011
23
4
I had this issue with my pixel, i still have it but it just installed Lineage 18.1 and pounced this ****ty google policy to the moon, i can use my phone again and it works even better than stock.I recommend it, i was planning to use this phone just for gaming offline cause whenever i was connecting to wifi, google was snatching the phone with its ****ty information that its gonna wipe the phone in 1 hourt, this is literally a scam to buy new phone.IM glad it can be solved by using non googledised rom.You can sideload gapps and it still works fine on lineage.
 

quera

Senior Member
Dec 10, 2011
230
29
Enable debug mode.
Do a fresh start cleaning all.
Restart phone but remove sim card.
Before connect on wifi, plug the phone on USB and type this lines of code via fastboot mode:

adb devices
adb shell
pm list packages | grep ‘google’
pm list packages | grep ‘work’
pm uninstall -k --user 0 com.google.android.apps.work.oobconfig


Give me a reply if it works for you!
Hey @rodrigo82, you're awesome man!

It worked perfectly for android 11.
For some reason it does not work for android 12.
 

helpimdumb

New member
Mar 29, 2022
2
0
@rodrigo82 What do you mean by "fresh start clearing all"? How do I type commands in fastboot mode?

I have a large batch of Pixel 1's on Android 10 and here's what I'm doing:

Skip through initial setup, skip SIM and WiFi, get to home screen, then enable debug mode and USB debug, and I'm putting in the codes you suggested. It says "success" when uninstalling the oobconfig file. So I factory reset device and set up as normal. About half the time, it works perfectly and I can sign in. The other half the time, the same message about the phone being in an organization pops up despite successful file deletion.
 

pgda

New member
Mar 28, 2022
4
4
Enable debug mode.
Do a fresh start cleaning all.
Restart phone but remove sim card.
Before connect on wifi, plug the phone on USB and type this lines of code via fastboot mode:

adb devices
adb shell
pm list packages | grep ‘google’
pm list packages | grep ‘work’
pm uninstall -k --user 0 com.google.android.apps.work.oobconfig


Give me a reply if it works for you!

Thanks!
These cmds didn't help, but looks like this one helps (found it with logcat):

pm uninstall -k --user 0 com.google.android.gms

However, if do uninstall "com.google.android.gms", then no google play anymore (and other problems with login to google account).

So the problem inside Google Play (inside com.google.android.gms) that it does some checking if phone connected to the Google LLC or other business account (e.g. saying "This device is managed", "Your device at work", "Your device will automatically reset in 1 hour 40 minutes").

Someone told me the solution (that actually works and simple setup):
1. Do factory reset (could be from general settings menu or from fastboot menu that is recovery/factory-reset).
2. Setup phone without access to internet and without SIM card (like press "do it offline", "will add network connection later").
3. Go to settings / applications
4. Find Google Play services, open it
5. Find list of permissions, click on it (that non obvious that can click it)
6. Find "Phone" in the list of permissions for the Google Play services and disable it (so now "Google Play services" has no access to "Phone").
7. That's all. Connect to Wifi, insert SIM, login to google account. Use your phone. Everything works and no more of this struggling message (with auto reset every 2 hours).

I used it for Google Pixel 3 locked phone (attached to Google LLC), so I don't know if it works for other cases.
 

helpimdumb

New member
Mar 29, 2022
2
0
@pgda Holy crap, thank you!!! This completely solved my issue. For anyone else having a similar problem on Android 9/10, here's what I did that worked perfectly:

  1. Factory reset phone.
  2. Skip adding SIM or WiFi to get to home screen.
  3. Disable "Phone" permission in settings for Google Play Services.
  4. Follow the steps in this thread from @rodrigo82's original post (uninstalling the google work oobconfig file), but just entering the commands in cmd on your computer while the phone is on the home screen. No need to fastboot or anything like that.
  5. Now connect phone to WiFi and add your Google account through the phone settings.
  6. Ensure you have the latest phone update, security update, and Play Store update.
  7. Update all stock apps.
  8. Finally, re-enable phone permission to complete setup.
I can't guarantee it's a permanent fix, but I've had my phone up and running now for over two hours with the above fix and haven't seen a single notification about "admins" or whatever, and no issues accessing my account or downloading anything. Also, I'm not sure how much of the updating is being overly cautious, but this is what I did and it finally worked for me. Good luck!
 
Last edited:

rodrigo82

Senior Member
Nov 5, 2011
146
25
39
São Paulo
twitter.com
Thanks!
These cmds didn't help, but looks like this one helps (found it with logcat):

pm uninstall -k --user 0 com.google.android.gms

However, if do uninstall "com.google.android.gms", then no google play anymore (and other problems with login to google account).

So the problem inside Google Play (inside com.google.android.gms) that it does some checking if phone connected to the Google LLC or other business account (e.g. saying "This device is managed", "Your device at work", "Your device will automatically reset in 1 hour 40 minutes").

Someone told me the solution (that actually works and simple setup):
1. Do factory reset (could be from general settings menu or from fastboot menu that is recovery/factory-reset).
2. Setup phone without access to internet and without SIM card (like press "do it offline", "will add network connection later").
3. Go to settings / applications
4. Find Google Play services, open it
5. Find list of permissions, click on it (that non obvious that can click it)
6. Find "Phone" in the list of permissions for the Google Play services and disable it (so now "Google Play services" has no access to "Phone").
7. That's all. Connect to Wifi, insert SIM, login to google account. Use your phone. Everything works and no more of this struggling message (with auto reset every 2 hours).

I used it for Google Pixel 3 locked phone (attached to Google LLC), so I don't know if it works for other cases.
Works even with Android 12?
 

pgda

New member
Mar 28, 2022
4
4
Works even with Android 12?

Yes. It worked for me with Android 12 (Android version "12", model "pixel 3", Android security update "October 5, 2021").

I already used this phone a little bit after and everything Ok: can install apps with google play services (or from .apk) and everything fine (receive calls, make calls, etc).
 

pgda

New member
Mar 28, 2022
4
4
@pgda Holy crap, thank you!!! This completely solved my issue. For anyone else having a similar problem on Android 9/10, here's what I did that worked perfectly:

  1. Factory reset phone.
  2. Skip adding SIM or WiFi to get to home screen.
  3. Disable "Phone" permission in settings for Google Play Services.
  4. Follow the steps in this thread from @rodrigo82's original post (uninstalling the google work oobconfig file), but just entering the commands in cmd on your computer while the phone is on the home screen. No need to fastboot or anything like that.
  5. Now connect phone to WiFi and add your Google account through the phone settings.
  6. Ensure you have the latest phone update, security update, and Play Store update.
  7. Update all stock apps.
  8. Finally, re-enable phone permission to complete setup.
I can't guarantee it's a permanent fix, but I've had my phone up and running now for over two hours with the above fix and haven't seen a single notification about "admins" or whatever, and no issues accessing my account or downloading anything. Also, I'm not sure how much of the updating is being overly cautious, but this is what I did and it finally worked for me. Good luck!

Note that for Android 12 the described step 4 fails (means no need of original command "pm uninstall -k --user 0 com.google.android.apps.work.oobconfig" and cannot re-enable phone permission regarding "Phone" permission being disabled of the "Google Play services").

Also sometimes during first startup of telephone it can non-showing "offline setup" (that is second screen after "skip SIM setup" where "connect to WiFi" happens). I don't know what it depends on (maybe if no cached prev connections, then it allows offline setup, and other case not). Sometimes without reboot just "back"/"back"/"SIM skip" helps and then can see "off line setup" (even didn't see during previous attempt). Sometimes reset to factory helps (means starting again from step 1). Sometimes play with enable/disable internet connection during these two initial screens setup helps. However if it ever starts downloading something from WiFi, then even if you can press "cancel, off line setup", it still already "infected" with linked to business account, but anyway then can restart again to factory and would see "off line setup".

So for "pixel 3" and "android 12" the instruction is same as it was:

1. Do factory reset (could be from general settings menu or from fastboot menu that is recovery/factory-reset).
2. Setup phone without access to internet and without SIM card (like press "do it offline", "will add network connection later").
3. Do not run any applications. Do not connect to internet. Go to settings / applications
4. Find Google Play services, open it
5. Find list of permissions, click on it (that non obvious that can click it)
6. Find "Phone" in the list of permissions for the Google Play services and disable it (so now "Google Play services" has no access to "Phone").
7. That's all. Connect to Wifi, insert SIM, login to google account. Use your phone. Everything works and no more of this struggling message (with auto reset every 2 hours).
8. (and do not enable "Phone" for "Google Play services" anymore).
 
  • Like
Reactions: dcarvil

rodrigo82

Senior Member
Nov 5, 2011
146
25
39
São Paulo
twitter.com
For me it doesn't work. Weird.
Worked on A11 but after update to A12 not anymore.
After re enable phone permission on Google Play Services, the message appears again.

@pgda I can not re-enable phone permission for Google Play Services? Its always shows error message asking to re-enable.
 
Last edited:

pgda

New member
Mar 28, 2022
4
4
For me it doesn't work. Weird.
Worked on A11 but after update to A12 not anymore.
After re enable phone permission on Google Play Services, the message appears again.

@pgda I can not re-enable phone permission for Google Play Services? Its always shows error message asking to re-enable.

Why do you need to re-enable phone permission for Google Play Services? If it asks to enable it, just ignore it. Keep it disabled. Then everything works fine: you can call, you can install Google Play applications, etc. You may install something to remove this kind of notification messages just to forget about it (or just to blacklist it). I understand that it may doesn't make feel well with telephone when you cannot enable back default settings, but in some cases it can give some benefits: ex. if someone try to reset phone to factory settings, the phone stops working until finding this workaround.
 
  • Like
Reactions: rodrigo82

Chiefpriest20

New member
Jan 18, 2020
1
0
Note that for Android 12 the described step 4 fails (means no need of original command "pm uninstall -k --user 0 com.google.android.apps.work.oobconfig" and cannot re-enable phone permission regarding "Phone" permission being disabled of the "Google Play services").

Also sometimes during first startup of telephone it can non-showing "offline setup" (that is second screen after "skip SIM setup" where "connect to WiFi" happens). I don't know what it depends on (maybe if no cached prev connections, then it allows offline setup, and other case not). Sometimes without reboot just "back"/"back"/"SIM skip" helps and then can see "off line setup" (even didn't see during previous attempt). Sometimes reset to factory helps (means starting again from step 1). Sometimes play with enable/disable internet connection during these two initial screens setup helps. However if it ever starts downloading something from WiFi, then even if you can press "cancel, off line setup", it still already "infected" with linked to business account, but anyway then can restart again to factory and would see "off line setup".

So for "pixel 3" and "android 12" the instruction is same as it was:

1. Do factory reset (could be from general settings menu or from fastboot menu that is recovery/factory-reset).
2. Setup phone without access to internet and without SIM card (like press "do it offline", "will add network connection later").
3. Do not run any applications. Do not connect to internet. Go to settings / applications
4. Find Google Play services, open it
5. Find list of permissions, click on it (that non obvious that can click it)
6. Find "Phone" in the list of permissions for the Google Play services and disable it (so now "Google Play services" has no access to "Phone").
7. That's all. Connect to Wifi, insert SIM, login to google account. Use your phone. Everything works and no more of this struggling message (with auto reset every 2 hours).
8. (and do not enable "Phone" for "Google Play services" anymore).
@pgda After doing this, can I continue installing monthly security update without the device resetting every two hours?
 

Chipiga07

New member
May 29, 2022
1
0
Why do you need to re-enable phone permission for Google Play Services? If it asks to enable it, just ignore it. Keep it disabled. Then everything works fine: you can call, you can install Google Play applications, etc. You may install something to remove this kind of notification messages just to forget about it (or just to blacklist it). I understand that it may doesn't make feel well with telephone when you cannot enable back default settings, but in some cases it can give some benefits: ex. if someone try to reset phone to factory settings, the phone stops working until finding this workaround.
google pay not working if phone is disabled
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Enable debug mode.
    Do a fresh start cleaning all.
    Restart phone but remove sim card.
    Before connect on wifi, plug the phone on USB and type this lines of code via fastboot mode:

    adb devices
    adb shell
    pm list packages | grep ‘google’
    pm list packages | grep ‘work’
    pm uninstall -k --user 0 com.google.android.apps.work.oobconfig


    Give me a reply if it works for you!
    2
    Enable debug mode.
    Do a fresh start cleaning all.
    Restart phone but remove sim card.
    Before connect on wifi, plug the phone on USB and type this lines of code via fastboot mode:

    adb devices
    adb shell
    pm list packages | grep ‘google’
    pm list packages | grep ‘work’
    pm uninstall -k --user 0 com.google.android.apps.work.oobconfig


    Give me a reply if it works for you!

    Thanks!
    These cmds didn't help, but looks like this one helps (found it with logcat):

    pm uninstall -k --user 0 com.google.android.gms

    However, if do uninstall "com.google.android.gms", then no google play anymore (and other problems with login to google account).

    So the problem inside Google Play (inside com.google.android.gms) that it does some checking if phone connected to the Google LLC or other business account (e.g. saying "This device is managed", "Your device at work", "Your device will automatically reset in 1 hour 40 minutes").

    Someone told me the solution (that actually works and simple setup):
    1. Do factory reset (could be from general settings menu or from fastboot menu that is recovery/factory-reset).
    2. Setup phone without access to internet and without SIM card (like press "do it offline", "will add network connection later").
    3. Go to settings / applications
    4. Find Google Play services, open it
    5. Find list of permissions, click on it (that non obvious that can click it)
    6. Find "Phone" in the list of permissions for the Google Play services and disable it (so now "Google Play services" has no access to "Phone").
    7. That's all. Connect to Wifi, insert SIM, login to google account. Use your phone. Everything works and no more of this struggling message (with auto reset every 2 hours).

    I used it for Google Pixel 3 locked phone (attached to Google LLC), so I don't know if it works for other cases.
    1
    Interesting problem! Can you bypass wifi setup and get into settings? If so can you enable developer options and enable oem unlock. And flash a factory image. Or can you get into recovery and sideload the ota? I'm guessing not but worth a try.

    OEM Unlocking is grayed out. I think it is a vzw pixel from what the IMEI shows.
    1
    @pgda Holy crap, thank you!!! This completely solved my issue. For anyone else having a similar problem on Android 9/10, here's what I did that worked perfectly:

    1. Factory reset phone.
    2. Skip adding SIM or WiFi to get to home screen.
    3. Disable "Phone" permission in settings for Google Play Services.
    4. Follow the steps in this thread from @rodrigo82's original post (uninstalling the google work oobconfig file), but just entering the commands in cmd on your computer while the phone is on the home screen. No need to fastboot or anything like that.
    5. Now connect phone to WiFi and add your Google account through the phone settings.
    6. Ensure you have the latest phone update, security update, and Play Store update.
    7. Update all stock apps.
    8. Finally, re-enable phone permission to complete setup.
    I can't guarantee it's a permanent fix, but I've had my phone up and running now for over two hours with the above fix and haven't seen a single notification about "admins" or whatever, and no issues accessing my account or downloading anything. Also, I'm not sure how much of the updating is being overly cautious, but this is what I did and it finally worked for me. Good luck!

    Note that for Android 12 the described step 4 fails (means no need of original command "pm uninstall -k --user 0 com.google.android.apps.work.oobconfig" and cannot re-enable phone permission regarding "Phone" permission being disabled of the "Google Play services").

    Also sometimes during first startup of telephone it can non-showing "offline setup" (that is second screen after "skip SIM setup" where "connect to WiFi" happens). I don't know what it depends on (maybe if no cached prev connections, then it allows offline setup, and other case not). Sometimes without reboot just "back"/"back"/"SIM skip" helps and then can see "off line setup" (even didn't see during previous attempt). Sometimes reset to factory helps (means starting again from step 1). Sometimes play with enable/disable internet connection during these two initial screens setup helps. However if it ever starts downloading something from WiFi, then even if you can press "cancel, off line setup", it still already "infected" with linked to business account, but anyway then can restart again to factory and would see "off line setup".

    So for "pixel 3" and "android 12" the instruction is same as it was:

    1. Do factory reset (could be from general settings menu or from fastboot menu that is recovery/factory-reset).
    2. Setup phone without access to internet and without SIM card (like press "do it offline", "will add network connection later").
    3. Do not run any applications. Do not connect to internet. Go to settings / applications
    4. Find Google Play services, open it
    5. Find list of permissions, click on it (that non obvious that can click it)
    6. Find "Phone" in the list of permissions for the Google Play services and disable it (so now "Google Play services" has no access to "Phone").
    7. That's all. Connect to Wifi, insert SIM, login to google account. Use your phone. Everything works and no more of this struggling message (with auto reset every 2 hours).
    8. (and do not enable "Phone" for "Google Play services" anymore).
    1
    For me it doesn't work. Weird.
    Worked on A11 but after update to A12 not anymore.
    After re enable phone permission on Google Play Services, the message appears again.

    @pgda I can not re-enable phone permission for Google Play Services? Its always shows error message asking to re-enable.

    Why do you need to re-enable phone permission for Google Play Services? If it asks to enable it, just ignore it. Keep it disabled. Then everything works fine: you can call, you can install Google Play applications, etc. You may install something to remove this kind of notification messages just to forget about it (or just to blacklist it). I understand that it may doesn't make feel well with telephone when you cannot enable back default settings, but in some cases it can give some benefits: ex. if someone try to reset phone to factory settings, the phone stops working until finding this workaround.