Help identifying head unit for fixes and/or upgrades - PX6 RK3399 in a BMW E38

Search This thread

m5james

Senior Member
Aug 27, 2010
599
17
LONG story short I bought this used MCMW head unit, tried getting my money back but PayPal sided with the seller even though it's missing pieces and constantly crashes after about a week of use. Performance has been under par (compared to AVINUSA.com or Joying unit's I've got running in other BMW's) and the manufacturer hasn't been helpful when I keep asking for firmware to reflash the unit to see if that'll help. It'll run decently for about a week, then suddenly Waze, the DVR app, etc will continually crash leaving me to only use the unit for Bluetooth and that's about it...unless I reset it back to factory, reinstall apps and then buy myself another week. The touchscreen is oddly either unresponsive or too sensitive as I'm scrolling around, it's just getting frustrating for daily use. I just wanna see if anyone has any advice on how to improve it's performance so it's usable and doesn't need weekly resetting. Even pointing me to the correct forums would be helpful but direct links to actual flashable firmwares, updates, etc would be awesome.

 

marchnz

Senior Member
Nov 26, 2012
4,908
1,005
NZ
Unfortunately, the forum crystal ball doesnt know what you unit is and from the hundreds of made up models and brands, the seller could be selling units of different types, from different factories, despite branding with the same model name.

Post screenshots from Android system information, including the MCU version when posting questions.

Doing this will at least help others help you, or you might find the information has already been posted or discussed here, yourself.
 
  • Like
Reactions: m5james

m5james

Senior Member
Aug 27, 2010
599
17
Damn it, man...just squint harder and you'll see it!! ;-)

My bad....I'm at work, meant to post these and then got caught up. Hopefully these suffice.

20220805_174857_HDR.jpg

20220805_174926_HDR.jpg

20220805_174908_HDR.jpg
 

Attachments

  • 20220805_174908_HDR.jpg
    20220805_174908_HDR.jpg
    1.7 MB · Views: 11
  • 20220805_174926_HDR.jpg
    20220805_174926_HDR.jpg
    1.8 MB · Views: 12
Last edited:

Pavel-71

Senior Member
Jul 9, 2020
274
151
Hello, your unit is MCU: MTCH, the app crashes problem is doing the last updates of android webview and chrome. Maybe that's your problem too. Just uninstall and disable their updates, reboot the unit. Ignore any requests to update them. A firmware update won't help, this is the only working solution on Android 10 so far.
 
  • Like
Reactions: m5james

m5james

Senior Member
Aug 27, 2010
599
17
Ok, I'll try that since I did update Android Webview and Chrome during my lunch, yet Waze and my dashcam app crashed consistently on my drive home. I'll try uninstalling both and see if that helps me avoid having to completely reset the unit again.
 

marchnz

Senior Member
Nov 26, 2012
4,908
1,005
NZ
Requested moderator moves to MTCD section.


Op read through MTCD section, the issue has been discussed already.
 
  • Like
Reactions: m5james

m5james

Senior Member
Aug 27, 2010
599
17
Hello, your unit is MCU: MTCH, the app crashes problem is doing the last updates of android webview and chrome. Maybe that's your problem too. Just uninstall and disable their updates, reboot the unit. Ignore any requests to update them. A firmware update won't help, this is the only working solution on Android 10 so far.
Disabled, cleared their storage and now Waze works again. Unit's still slow to respond (dragging apps for split screen took like 8 tries) vs it's stats but at least it works now. Thanks for the help.
 

Jeremy.flaugh

New member
Jul 14, 2022
2
1
I bought the same unit for my E38 but I bought it from Xtrons directly thru xtrons-usa on ebay I almost purchased it from MCMW until I figured out he is reselling an Xtrons unit even though he says he is not and says that Xtrons is rubbish. I can tell you it is the biggest POS I've spent $400 on so MCMW is right it is rubbish. I think it runs better after updating webview seams to be more fluid but I just updated it after reading this thread lastnight so time will tell, you understand.


I did resolve the noise issues by dumping the factory amp since I posted this.
 
Last edited:
  • Like
Reactions: m5james

m5james

Senior Member
Aug 27, 2010
599
17
Ooh I'm sure they're the ones exact same units, I guess the only saving grace of keeping this used unit is that it included all the iBus converter and another module I'm forgetting about but I can read everything from the OBC on the iBus app and it adds features like triple blinkers.

My current frustration with the unit (which happened to bring me back to these forums today) is that I wanted to see if there's a way to adjust screen sensitivity/accuracy. As I mentioned above it takes multiple times to move apps around in the app drawer, trying to run dual apps and even general use.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Unfortunately, the forum crystal ball doesnt know what you unit is and from the hundreds of made up models and brands, the seller could be selling units of different types, from different factories, despite branding with the same model name.

    Post screenshots from Android system information, including the MCU version when posting questions.

    Doing this will at least help others help you, or you might find the information has already been posted or discussed here, yourself.
    1
    Hello, your unit is MCU: MTCH, the app crashes problem is doing the last updates of android webview and chrome. Maybe that's your problem too. Just uninstall and disable their updates, reboot the unit. Ignore any requests to update them. A firmware update won't help, this is the only working solution on Android 10 so far.
    1
    Requested moderator moves to MTCD section.


    Op read through MTCD section, the issue has been discussed already.
    1
    I bought the same unit for my E38 but I bought it from Xtrons directly thru xtrons-usa on ebay I almost purchased it from MCMW until I figured out he is reselling an Xtrons unit even though he says he is not and says that Xtrons is rubbish. I can tell you it is the biggest POS I've spent $400 on so MCMW is right it is rubbish. I think it runs better after updating webview seams to be more fluid but I just updated it after reading this thread lastnight so time will tell, you understand.


    I did resolve the noise issues by dumping the factory amp since I posted this.