• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
Search This thread


New member
Jun 19, 2021
I am new to linux (as expected) and tried installing Kali NetHunter on my android device [One Plus 6]. I was successful in installing with Android 8 but my phone keeps bricking when attempted with Android 9/10. I referred to these instructions and followed these steps:

I am looking for help and also any explanations for my understanding of the process is also appreciated very much!

1) Start developer mode, enable oem unlocking and usb debugging, and restart in fastboot mode > then from Powershell: fastboot oem unlock

Phone gets wiped so again start developer mode, usb debugging.

2) Now I download the twrp .img and zip files, also the Magisk.apk from github then rename the apk to .zip (as instructed in their documentation). Finally move these files to the internal storage of the phone.

3) Restart phone in Fastboot mode > from Powershell: fastboot boot twrp-3.x.x-x-enchilada.img (version according to android 8 or 10 respectively)

4) Now that I am temporary booted into twrp I install the twrp .zip file from here and reboot into recovery mode (TWRP that was installed).
Now I flash install the Magisk.zip and reboot the OS > Install the magisk.apk that shows up.

Following the kali nethunter documentation linked above no extra steps are needed for android 8. So I just install the Nethunter zip from Magisk app (click the modules [puzzle piece] icon and select nethunter zip). This works perfectly!!! Ps: if i flash nethunter from TWRP it says successful but bricks the phone and doesn't reboot. Don't know why but if you do please let me know or hint what i should look into to understand better.

****[NEED HELP HERE]****
: The Kali documentation says for disabling encryption we need to first flash Universal DM-Verity, ForceEncrypt Disabler. So I download the zip and move it to internal storage, from what I understand for my requirement I do not need to change anything in file naming. If I flash this zip using Magisk or TWRP the result is just a bricked phone that gets stuck on "The bootloader is unlocked" warning message.

If I skip this step then it bricks if I flash nethunter through TWRP and if I flash as a module using Magisk then it works fine.
According to nethunter documentation without the Universal DM-Verity, SSH capabilites should not work but on my phone it works just fine if I open the NetHunter app > Kali services > SSH (don't know an extensive way to test this or if any other functionality has been compromised without the ForceEncrypt Disabler). Am I understanding this part wrong? or in my case I do not need to flash Universal DM-Verity, ForceEncrypt Disabler? This step is what confuses me and I have tried countless times via different ways over the past summer.

The Kernel is shows is 4.9.179-perf+ with Android 10.
The reason i wanted to update to Android 10 from 8 is because I am having compatibility issues with RTL8814AU and none of the drivers I find seem to work (Android 8 kernel is 4.9.65-perf+).

Thank you for your time to read and respond!