Help mytouch 4g not turning on

Search This thread

jeff7790

Senior Member
Aug 24, 2008
156
11
New York City
Hello there today my phone stop working all i did was remove the battery and remove the sim card to put a new one in. When i put it back on and turn on the phone, the phone vibrates for three times and the charging led starts blinking ,also the screen is black. I cant even get into bootloader mode anyone knows a fix. I was running Ossymod MIUI and have an engineer boot loader.

Did i mention that this happened because i pull the battery out while phone was on this could be what f*ck it up.

Problem
Phones off --> Hit the on button---> Three Vibrates with black Screen ----> Orange LED Blinking.

Things i tried
Try to get into Fast boot but i only get a black screen with a Green Led while connected to the pc, Device manager detects my mytouch as a "Qualcomm CDMA Technologies MSM".
 
Last edited:

jeff7790

Senior Member
Aug 24, 2008
156
11
New York City
battery had 50 percent im trying to get it on fastboot by holding the power and volume down while connected to the pc but all i get is a black screen and in my pc it shows "Qualcomm CDMA Technologies MSM" could this have been cause ,by pulling the battery while the phone was on.
 
Last edited:

cmdmilitia13

Senior Member
Jan 20, 2011
574
127
camden,nj
battery had 50 percent im trying to get it on fastboot by holding the power and volume down while connected to the pc but all i get is a black screen and im my pc it shows "Qualcomm CDMA Technologies MSM" could this have been cause ,by pulling the battery while the phone was on.

I dnt believe that pullin the battery while the phone is on would cause that issue,ive dropped my phone numerous times while it was on,while playin a game or by just gettin out my car while listenin to music & not once had that issue...

Mytouch 4g-white
Permrooted s-off
Root Method-gfree
CWR-3.0.2.4
Rom-Royalginger v2.1
Kernel-Ckisgen~smartass~v1.2
 

G8351427

Senior Member
Dec 20, 2010
90
19
I cannot figure out how you got to this point, but I think you have a bad radio.

That Qualcomm MSM device is something that I think happens only with the engineering bootloader installed. I believe it could provide a way to access the radio directly, but I have never seen any info on how to do that.

I mistakenly flashed the wrong data to the radio partition while I was trying to reset to factory and since I had the engineering bootloader, I got the same results as you. As a result, mine was effectively bricked and I had to return it to T-mobile like that. This was a couple of months ago and I have not heard anything about it.
 

jeff7790

Senior Member
Aug 24, 2008
156
11
New York City
I cannot figure out how you got to this point, but I think you have a bad radio.

That Qualcomm MSM device is something that I think happens only with the engineering bootloader installed. I believe it could provide a way to access the radio directly, but I have never seen any info on how to do that.

I mistakenly flashed the wrong data to the radio partition while I was trying to reset to factory and since I had the engineering bootloader, I got the same results as you. As a result, mine was effectively bricked and I had to return it to T-mobile like that. This was a couple of months ago and I have not heard anything about it.

Ever since I've had this phone i never try to flash radios or beta test radios i always kept it stock . The only thing i flash were Roms and yes i have a engineering bootloader.
 

G8351427

Senior Member
Dec 20, 2010
90
19
I am not saying you did any of those things, I am only telling you how I got to that point and that once there, I had zero luck in recovering.
 

TmobileDash12

Senior Member
May 31, 2009
456
64
Illinois
This happened to me before. I had a full charge and turned off the phone, pulled out the battery, and put it back in. Tried turning it on, it wouldn't. Plugged it in the charger, had the blinking light. I simply googled "amber blinking led mytouch 4g" or something like that. It happens when the phone thinks the battery is really low. So just leave it off, plug in your charger and wait.
 

G8351427

Senior Member
Dec 20, 2010
90
19
I am pretty sure that if the radio is bad it will not charge. So if you can charge, then you do not have a bad radio.

I found this thread for the same issue on an HD2. They say a JTAG is required to fix a bad flash on an HD2; may be the same on a Glacier, I don't know.

I am fairly certain that this Qualcomm MSM is the radio itself and if you had the right drivers you could send it commands, though flashing the emmc may not be possible from there.
 

jeff7790

Senior Member
Aug 24, 2008
156
11
New York City
the device does charge no blinking at all so it might not be a radio ,funny thing this happened without me flashing anything.

Edit: i though it was charging but then 5 minutes later i see a green LED on ,i think the phone turn on while it was charging not sure.

Edit2: Yeah its not charging i plug the phone then it just turns on to a black screen

Thanks for the Help
 
Last edited:
B

bretjrodgers

Guest
Can we remove this thread or post it where it is supposed to be? Thanks!

Sent from my HTC Glacier using XDA App
 

cmdmilitia13

Senior Member
Jan 20, 2011
574
127
camden,nj
Have u tried takin out the battery,sim card & sd card,leave it out for about 10 min or so & then put everythin bck on & try of it starts that way,a friend of mine called me earlier & sd his phone just shut dwn & wouldnt start & thats what he did & it wrked... He sd he thinks the phone was thinkin the battery was dead & thats what fixed it? Just a thought : )

Mytouch 4g-white
Permrooted s-off
Root Method-gfree
CWR-3.0.2.4
Rom-Royalginger v2.1
Kernel-Ckisgen~smartass~v1.2
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hey I've got the same issue. When I boot it up like normal, it goes to the white screen with "T-Mobile MyTouch" written on it, does a short vibrate, then stays like that.
    I CAN get to the ClockworkMod Recovery screen but I'm not tech-genius like most of you guys and I'd REALLY appreciate any help I can get.

    Thanks,
    Casey

    Edit: I tried to leave it sitting with the sd card, sim card and battery pulled out and I also tried to just let it sit and charge. Nothing from either.

    If you have a saved back up of your ROM, you can reload it from the clock work mod recovery screen. Just use the menu to navigate to backup / restore. Then restore. Then choose your saved ROM and go.

    Should boot back up properly in about 4-5 minutes.

    You don't have to be a tech genius, I promise. As long as you are literate, you should be fine.