• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

(HELP NEEDED) Onn 8" gen 2, 100011885 no boot

Search This thread

Ankylo'sburner

New member
Mar 13, 2021
4
0
So I didn't happen to back up my scatter or boot.img files when I used fastboot to try and flash the TWRP for the onn 10 inch, I was assuming it would work, but now I'm stuck with no recovery, no fastboot, no system, won't boot up when you hold the power button.

The only method of recovery I have is through MTK preloader and spflash, but I don't have the correct factory images or scatter file required to reflash stock. I've been looking everywhere online and can't find the right recovery files or any guides on how to recover from this.

Any help/files/advice would be greatly appreciated!!
 

LaikaXv1

Member
Jan 25, 2020
8
0
Two things, I got access to my old account after a password reset
and, I got my tab back up and running, as well as root & xposed + gravitybox

I'm working on a guide as we speak.
 

LaikaXv1

Member
Jan 25, 2020
8
0
Also, I will be dumping my firmware and adding the 10001885 to the list of stock image dumps on the main onn thread.
 

bbcdt22

Member
Jan 27, 2020
5
1
Hope this helps if still needing it, scatter file for the 100011885 mt8168 , good luck not responsible for anything lol i still cant get mine to work, anklosburner
So I didn't happen to back up my scatter or boot.img files when I used fastboot to try and flash the TWRP for the onn 10 inch, I was assuming it would work, but now I'm stuck with no recovery, no fastboot, no system, won't boot up when you hold the power button.

The only method of recovery I have is through MTK preloader and spflash, but I don't have the correct factory images or scatter file required to reflash stock. I've been looking everywhere online and can't find the right recovery files or any guides on how to recover from this.

Any help/files/advice would be greatly appreciated!!
hope this helps if you still need it for 100011885 mt8168 scatter file, but not responsible for any damages, because i still cant get mine to work, i had it to where it would come on, or i could see back light but thats it, which im impatient too, maybe it takes a min, but i did a readback on every downloadable item and flashed it but idk, let me know if you or how you get yours to work if you do
 

Attachments

  • MT8168_Android_scatter.txt
    14.8 KB · Views: 208

bbcdt22

Member
Jan 27, 2020
5
1
Hope this helps if still needing it, scatter file for the 100011885 mt8168 , good luck not responsible for anything lol i still cant get mine to work, anklosburner

hope this helps if you still need it for 100011885 mt8168 scatter file, but not responsible for any damages, because i still cant get mine to work, i had it to where it would come on, or i could see back light but thats it, which im impatient too, maybe it takes a min, but i did a readback on every downloadable item and flashed it but idk, let me know if you or how you get yours to work if you do
 

Attachments

  • boot.img
    32 MB · Views: 95
  • recovery.img
    32 MB · Views: 85

KMerrimanJr

Member
Jul 1, 2016
6
1
Hey, i've had that same issue but have since fixed it by flashing the rom to the 100011886. I used some of the posts here to flash both vbmeta.img and boot.img to gain root, with success https://drive.google.com/drive/folders/17LtLtjKg4JJU9EJdIXPsyNjen0H-ilMX?usp=sharing . i eventually went too far and currupted my rom and had a hard time finding the stock ROM. I found the stock ROM to the 100011886 and flashed that to fix the problem, now i run that as my system and it boots up just fine. https://www.mediafire.com/file/107jp6gwbiwq87q/MT8168_ONN_Gen2_100011886.zip/file

fastboot erase super
fastboot flash super super.img
 

Attachments

  • screen.png
    screen.png
    91.9 KB · Views: 81
  • Screenshot_20210620-184521.png
    Screenshot_20210620-184521.png
    84.5 KB · Views: 81
Last edited:

onn.

Member
Nov 29, 2021
16
2
Would you happen to have the preloader bin file for the MT8168? After digging around, you have helped me get closer to bringing my hard brick back to life.

Edit: @bbcdt22
 
Last edited:

KMerrimanJr

Member
Jul 1, 2016
6
1
Would you happen to have the preloader bin file for the MT8168? After digging around, you have helped me get closer to bringing my hard brick back to life.

Edit: @bbcdt22
I don't, but this thread may help:
Any rom you come across has to be extracted in order to get any necessary files from it. The thread mentions using 7zip but I've personally had better results extracting using ZArchiver. Also, a workaround I've found very useful when dealing with extraction issues, is removing the extension from the file. If all else fails, you may need to erase the super partition and reflash THAT
 

onn.

Member
Nov 29, 2021
16
2
I don't, but this thread may help:
Any rom you come across has to be extracted in order to get any necessary files from it. The thread mentions using 7zip but I've personally had better results extracting using ZArchiver. Also, a workaround I've found very useful when dealing with extraction issues, is removing the extension from the file. If all else fails, you may need to erase the super partition and reflash THAT
Thanks for the response. I'm at the end of that thread currently trying to see what I can find to fix my issue. Aside from buying another one from Walmart and trying to see if I can pull everything from a vanilla tablet, I'm not sure if I'll ever find the exact files.
 

KMerrimanJr

Member
Jul 1, 2016
6
1
Thanks for the response. I'm at the end of that thread currently trying to see what I can find to fix my issue. Aside from buying another one from Walmart and trying to see if I can pull everything from a vanilla tablet, I'm not sure if I'll ever find the exact files.
Thanks for the response. I'm at the end of that thread currently trying to see what I can find to fix my issue. Aside from buying another one from Walmart and trying to see if I can pull everything from a vanilla tablet, I'm not sure if I'll ever find the exact files.
When my tab crashed on me, flashing the super image solved my issue but it was a different rom. My tab's model number ended in 885 but the super file I flashed came from an 886, it still worked though
 

onn.

Member
Nov 29, 2021
16
2
When my tab crashed on me, flashing the super image solved my issue but it was a different rom. My tab's model number ended in 885 but the super file I flashed came from an 886, it still worked though
I wish I would have waited until I read this today instead of further messing with it yesterday. It looks like everything you have is what I need, but now I am battling trying to get the COM port to stay active when the device is plugged in. I'll tinker with it and see if I can get back to the state I had it in yesterday where it was staying connected.
 

onn.

Member
Nov 29, 2021
16
2
When my tab crashed on me, flashing the super image solved my issue but it was a different rom. My tab's model number ended in 885 but the super file I flashed came from an 886, it still worked though
Would you happen to know/remember all the settings you checked in SP Flash Tool (I assume you used that) when you flashed things to get it working? It seems that my PC is able to communicate with the device again, but I'm unsure of how to proceed next.
 
Last edited:

KMerrimanJr

Member
Jul 1, 2016
6
1
Have you installed all of the adb & mtk drivers? If so, you should be able to use adb to reboot into the boot loader then use fast boot to flash the super file
 

onn.

Member
Nov 29, 2021
16
2
Have you installed all of the adb & mtk drivers? If so, you should be able to use adb to reboot into the boot loader then use fast boot to flash the super file
It's hard bricked at the moment unfortunately, so there's no appearance of life to it. Attached picture is the error I get. https://www.gizmoadvices.com/list-sp-flash-tool-error-codes-solution-fix/ appears show info about the error, but it's not something I know how to fix yet.

The only way I can get the tablet to make moves in device manager (which I assume is a sign that the PC can at least partially recognize/see the device) is to click on Download in SPFT, connect tablet to PC via USB cord, and then hold down power button, which led to the error. Errors in SPFT I've received so far are 0xC0060001 and 0xC0060003.

When the tablet is active in the device manager, I assume that the device is in a powered state. However, when the device is grayed out, I assume it's in a powered off state (see other pic). I've yet to find away to actually flash anything to it.
 

Attachments

  • 1638481401702.png
    1638481401702.png
    139.3 KB · Views: 18
  • 1638482103451.png
    1638482103451.png
    16.9 KB · Views: 18