[Help Thread][Amazon Fire] 7" - 5th Gen 2015 ONLY! Ask Any Question, Noob Friendly

Search This thread

regulusirius

Member
Oct 18, 2012
23
1
Hello, I have a peculiar question. In the past years I experimented a bit and I think I messed up something: years ago I installed a custom ROM on my ford device (5th gen) by rooting and using flashfire. After that the exploit for unlocking the bootloader came out and I tried a Lineage ROM without Google services. It is then that I realized my device lost its Winevide drms, so I cannot use any video app. I tried searching for info on the matter but I couldn't find anyone that run in that issue, so I dropped the question (and the tablet).

A few days ago I had an idea: what if I were able to restore the fire to full stock? That should integrate the missing drms, right? Is it possible to recover rom, recovery, bootloader and kernel to full stock?

EDIT: Btw, if any of you has some idea on why I miss those DRMs and how I can solve the issue without going back to stock you are very welcome!!
 
Last edited:

LapisLyle

New member
Feb 21, 2021
1
0
Hello i was trying to root my kindle fire 5th gen and it said the bootloader was locked when trying to fastboot a img so idk if you can unlock it but i need help thx
 

sd_shadow

Recognized Contributor / XDA Welcome Team
Sep 21, 2011
18,650
2
9,291
South Dakota
goo.gl
Motorola Droid X
Amazon Fire
Hello i was trying to root my kindle fire 5th gen and it said the bootloader was locked when trying to fastboot a img so idk if you can unlock it but i need help thx
See
 

Echoecho33

Member
Jan 9, 2017
29
1
I have a 2015 5th Generation Kindle Fire that was rooted (way back when using that SuperTool) and then I think the Fire OS was corrupted. I put another on it (I forgot what I did), but I can't get that one to work right either. Also this device is missing the actual Amazon Kindle e-reader app that makes it a Kindle and even though I have forced other "Kindle" apks onto it and also tried downloading the Kindle app from Google Play on it, it has all been to no avail.

So the part that is driving me crazy is the first screen always says "Setup"
I could deal with that if I could get the Kindle (e-reader) app (or missing original apks) to work. Something strange happened when the original Fire OS got corrupted and I don't even know which "Kindle" (e-reader) apks are missing. The app I downloaded from the Play Store just blink crashes

I am willing to revert back to the Fire OS in an attempt to start over is that is possible.

I would appreciate any help and advice

 
Last edited:

Echoecho33

Member
Jan 9, 2017
29
1
The part that is frustrating me
I have a 2015 5th Generation Kindle Fire that was rooted (way back when using that SuperTool) and then I think the Fire OS was corrupted. I put another on it (I forgot what I did), but I can't get that one to work right either. Also this device is missing the actual Amazon Kindle e-reader app that makes it a Kindle and even though I have forced other "Kindle" apks onto it and also tried downloading the Kindle app from Google Play on it, it has all been to no avail.

So the part that is driving me crazy is the first screen always says "Set-Up"
I could deal with that if I could get the Kindle app (or missing original apks) to work. The one I downloaded from the Play Store just blink crashes

Proof it's still rooted

 

timelina

New member
Mar 13, 2021
1
0
My 7" 5th Gen Fire is running OS 5.6.8.0. Is there a program to root this version?

The memory was so packed when I got this tablet that I can hardly put anything at all on it. I keep running out of memory. I just want to get rid of a bunch of bloatware so I can free up some more space.
 

sd_shadow

Recognized Contributor / XDA Welcome Team
Sep 21, 2011
18,650
2
9,291
South Dakota
goo.gl
Motorola Droid X
Amazon Fire
My 7" 5th Gen Fire is running OS 5.6.8.0. Is there a program to root this version?

The memory was so packed when I got this tablet that I can hardly put anything at all on it. I keep running out of memory. I just want to get rid of a bunch of bloatware so I can free up some more space.
see
 

zeldhaking

Senior Member
Mar 14, 2008
76
6
Troyes
Hi, i have an Amazon Fire 7" 5th Gen with a modified ROM (see attachement).
I would install a newer ROM like Lineage 12.1 but i am a bit lost.

What is OK:
- Fire is rooted
- access ADB
- boot into Fastboot (vol+ and power or adb)

What is NOK:
- boot into recovery (vol- and power or via adb) -> stay under AMAZON logo
- flashfire v0.53 crash after message "checking for pro"
- in developper options "OEM unlocking" is missing
- flashing via adb is impossible -> message "flashing is not allowed for critical partitions"
- "fastboot flashing unlock_critical" doesn't work
- "fastboot flashing unlock" doesn't work

Can you give me some help?
 

Attachments

  • 20211224_134316.jpg
    20211224_134316.jpg
    4 MB · Views: 18

i.REN

Member
Jan 13, 2022
32
11
Hello.

So I have a 2015 Kindle Fire 7 that's already running a custom rom (lp-fire-nexus-rom 20171217 @ggow is the build number) but I'm not sure how I got it on there as it was at least five years ago that I did this. The rom is Android 5.1.1. My question is how can I flash a new custom rom in order to run a newer version of Android, preferably something 6 or above?

Device purchased August 2016. It's unlikely I ever updated the FireOS so whatever it came with at the time is most likely what it had when I first made any modifications.
 
Last edited:

Swooosh

New member
Jan 13, 2009
1
0
I have 5th gen fire 7 running 5.6.8.0 - hoping to get lineage on there but struggling with downgrading, I've followed the guide posted on the other thread but getting stuck, anyone help a total n00b to get this working?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 12
    [Help Thread][Amazon Fire] 7" - 5th Gen 2015 ONLY! Ask Any Question, Noob Friendly

    [SIZE=+2]This thread has been created
    for
    Questions & Answers/Troubleshooting
    [/SIZE]​
    [SIZE=+2]Specific to[/SIZE]

    Amazon Fire (7')
    5th Gen | 2015


    Please feel free to share issues, questions and offer help. Noob questions are welcomed.

    It is always best to use the Thanks button , in lieu of simply posting "Thank you".

    attachment.php

    Please keep discussion focused, on questions pertaining to this Device
    attachment.php
    List of supporters

    @sd_shadow
    @shimp208
    ...
    ...​
    To those seeking help: Please don't bombard the supporters with PMs asking for help. Instead, ask your question here in the thread so others can benefit from the solution to your problem as well. If you want to be sure someone particular gets notified of your question, put his / her username directly after an @.
    If you have ROM related questions, post in the relevant ROM Q&A thread (if there is one) or directly in the ROM development thread. If you are not eligible of posting there, you may post here. Thank you!

    Supporters: If you want to be put on or off the list, just make a request here in the thread!
    Before posting anything, I strongly advise you to read
    Please look for a similar thread when visiting another device forum.
    If you would like to create a [Help Thread] please Click Here.
    5
    [SIZE=+3]Frequently Asked Questions[/SIZE]
    [SIZE=+2]Amazon fire[/SIZE]

    [SIZE=+1]This a short list of frequently asked questions in this device forum and the answers often given as a response. It should serve as a starting point for gathering knowledge and finding solutions to many common problems. [/SIZE]

    [SIZE=+1]Q1: Which Amazon (Kindle) Fire Do I have?[/SIZE]
    [SIZE=+1]Q2: Can the Amazon Fire 5th Gen be rooted?[/SIZE]

    Fire OS 5.3.1.0 was the last rootable version for all Fires,
    except the 7th Gen HD 10.
    Do not attempt to downgrade. - 7th Oct 2018

    Yes, System version 5.3.1 can be rooted but not downgraded, trying will brick it. - 28 Nov 2016
    system versions 5.1.4, 5.1.3, & 5.1.2.1 cannot be rooted, but can be downgraded to 5.1.2, see Q14
    Yes, system versions 5.1.2, 5.1.1, & 5.0.X can be rooted with Kingoroot
    Kingroot thread KingRoot thread or RootJunky SuperTool
    then see rootjunky's supersume video
    https://www.youtube.com/watch?v=3O3DcpeS_Ic
    or manually install supersu with a terminal emulator
    http://www.w0lfdroid.com/2015/05/How-to-Remove-Replace-KingUser-KingRoot-with-SuperSU.html
    Yes, system versions 5.0.0-5.1.1 can be rooted see Device Tools, Root/Un-root/Un-brick methods

    [SIZE=+1]Q3: Can The bootloader be Unlocked?[/SIZE]
    No the Bootloader cannot be Unlocked. - 06 Oct 2015​

    [SIZE=+1]Q4: Can Custom Roms be Installed?[/SIZE]
    Yes, see Custom Roms

    [SIZE=+1]Q5: Can Custom recovery be Installed?[/SIZE]
    No, currently Custom Recoveries can only be booted temporally using Fastboot.exe see Device Tools, Root/Un-root/Un-brick methods -22 Nov 2015​

    [SIZE=+1]Q6: Can Google apps be Installed?[/SIZE]
    [SIZE=+1]Q7: How can I block updates and Replace the Fire (Stock) Launcher?[/SIZE]
    [SIZE=+1]Q8: How do I Unroot?[/SIZE]
    Unrooting is can be done from the supersu app that is installed in the rooting process, but unrooting is different than returning to full stock.​

    [SIZE=+1]Q9: How do I Restore Stock Firmware?[/SIZE]
    To restore full stock see Device Tools, Root/Un-root/Un-brick methods

    [SIZE=+1]Q10: How do I use adb/fastboot?[/SIZE]
    [SIZE=+1]Q11: Play Store app is showing up as "Play Store | Work"?[/SIZE]
    I think every one with that issue, has a grandfathered free Google Apps Account
    If that is the case, there is no fix, but should work fine
    http://forum.xda-developers.com/showpost.php?p=63833958&postcount=27

    [SIZE=+1]Q12: Is there a way to set up all your downloads to go to your micro SD card and not your internal storage?[/SIZE]
    install ES File Explorer>open ES>settings>Directory settings>Download path/backup arrow (on popup)> /storage/sdcard1>OK
    when downloading select ES Download manager (you will get a popup)
    Note: requires root and sd card read/write access
    ES is no longer a good app, use a different download manager - 10 Sept 2017​

    [SIZE=+1]Q13: Why can't I change files on the SD Card?[/SIZE]
    The External SD Card is Write protected by default in stock rom. To change to Read/Write try Enable R/W for SD Card SDFix: KitKat Writable MicroSD App (Requires Root)​

    [SIZE=+1]Q14: Cannot boot to stock recovery using button combination[/SIZE]
    Use Fastboot.exe command
    Code:
    fastboot.exe oem reboot-recovery
    See Fire Index: Which Amazon (Kindle) Fire Do I have? for setting up Fastboot.exe
    or use Super tools reboot recovery option

    [SIZE=+1]Q15: Can Firmware be Downgraded?[/SIZE]
    Yes, in some cases
    Downgrading Options
    • System version 5.1.4, 5.1.3 & 5.1.2.1 can be downgraded to 5.1.2 - 6 June 2015
    • System version 5.1.4, 5.1.3, 5.1.2.1, and 5.1.2 cannot be downgraded to 5.1.1 or lower, trying will brick the Fire
    • System Version 5.1.X cannot be downgraded to 5.0.X. trying will brick the Fire
      see Device Tools, Root/Un-root/Un-brick methods


    [SIZE=+1]Q16: Are there any Android 6+ (CM13) custom roms? [/SIZE]
    No, the locked bootloader prevents newer android versions from booting. - 20 Aug 2016


    [SIZE=+1]Q17: Will stock rom be updated to Android 6+?[/SIZE]
    Probably yes, but still unknown, if it is I likely will be late 2016 or later


    [SIZE=+1]Q18: Is there a scatter file for the 2015 Fire?[/SIZE]

    [SIZE=+1]Q18: Error: Service Installation Section in this INF is invalid in Windows(MTP,USB storage driver)
    [/SIZE]

    *​
    A special thanks to everyone who contributed to the production of this FAQ
    4
    Warning: for those who may have missed other warnings
    5.1.4, 5.1.3, 5.1.2.1, 5.1.2 cannot be downgraded to 5.1.1 or lower.
    trying to downgrade lower than 5.1.2 will brick the Fire (2015 7in, HD8 and HD10)
    5.1.1 cannot be downgraded, trying will brick the Fire (2015 7in, HD8 and HD10)
    3
    http://forum.xda-developers.com/showthread.php?t=2588979

    [TOOL] [WINDOWS] ADB, Fastboot and Drivers - 15 seconds ADB Installer v1.4.2

    Sent from my KFFOWI using Tapatalk

    Thank you for your help. I already had tried that before my post, and that didn't work either.
    The only thing that did work for me was

    1. Downloading this: https://app.box.com/s/dy9mz30t6ejf0j03xunfxdnel1oeuqoi
    2. Device Manager,
    Right Click On Amazon Fire,
    Properties,
    Update Driver,
    "Browse My Computer For Driver Software",
    "Let Me Pick from a List of Device Drivers on my Computer
    Have Disk
    Browse to extracted files from the downloaded zip from step 1.
    Next
    and now ADB should find the Amazon Fire Tablet.


    Any other method I tried did not work. I really hope this helps out anyone else trying to do this in the future.
    3
    How To Sideload Google Play

    I don't know if this is the right place to post this, so if it's not, please move it and let me know.

    1) Download ES File Explorer from the Amazon Marketplace. It's free.
    2) Enable Developer mode and ADB -- Amazon Fire (2015) Tips and Tricks
    3) Find the four APKs needed to install Google Play. Versions I used are listed:
    1. Google Play (v5.9.12)
    2. Google Play Services (v8.1.15 2250156-230)*
    3. Gmail (v5.6.103338659.release)
    4. Google Account Manager (v4.4.4-1227136)
    * I used -010 and it worked, but complained until I could download -230 from Google Play. Which means -030 should work as well.
    APK's 1-3 can be found on apkmirror.com, but the last one can't. If you're like me, you don't trust random mediafire links, so eventually I figured out how to create and transfer the APK from my Galaxy S4 (using App Backup & Restore) which did the trick. If someone wants to host this somewhere official, I can send it to them, but it doesn't look like I can just attach a file, because I'm noob level here. :)

    4) Once the APKs are installed, Services is unable to contact Google. Using this guide, allow Services the access it needs with adb.
    5) Restart the Amazon Fire and open Google Play to confirm it's working.

    I did this purely for a cheap device my children can play Ingress on. Despite what I've read online, Google Play works without any issues at all. I'll still be testing it during the week (as well as sideloading their Fire's), so if I have updates to this, I'll be sure to post it. Since the Fire isn't rooted, everything in the Amazon Marketplace works, even Underground.

    Enjoy :)