Search This thread

immortalneo

Senior Member
Jan 25, 2011
4,409
1,955
Malappuram, Kerala
There are a lot of people joining XDA on a daily basis, and there are a lot of repetitive questions being asked
which clutter up the Development and 'Q & A' threads. Point them here. Feel free to ask or answer questions.

The idea of this thread is to get users to help other users with their problems/questions. People are usually
ridiculed for asking questions that other people deem stupid even though it may be a legitimate question. This
leads to new users being afraid to ask questions!

Only provide well mannered help towards users in this thread. Please do not spoon feed, but rather point in
the direction where that user can find an answer
and educate himself. If you don't want to answer, at least
point out where to find the answer.



Before posting anything, I strongly advise you to read THIS thread.

Then, have a quick look at the names of threads in Post No. 2, you might find what you need right away.

Third. Even if you do get your question answered, please do come back and read threads in Post No. 2
(coming later as soon as we start getting the guides) to educate yourself. You'll be surprised how much time
and frustration it will save you in the future!



No abuse towards noobs tolerated here! That means:
NO TROLLING
NO NAME CALLING
NO RIDICULING
NO FLAMING


ASK ANY QUESTION HERE! No question is stupid or irrelevant in this thread. You will either get an answer or will get pointed in the right direction.


*A Special Thanks to mark manning for his help in creating this thread*


HALL OF FAME

People who contributed most to this thread and helped countless number of people with their
problems/questions. In no particular order.

Bruce Wayne
post-mortem
SilentStrider
Ghostfreak NB
mayank9856
sgs22012
Zatta
ADDICT.ANK



These people also have the right to use the banner below:
Newbie%20Thread%20Sign.gif


Just add this code to your signature:
HTML:
[URL="http://forum.xda-developers.com/showthread.php?t=2257421"][IMG]https://dl.dropboxusercontent.com/u/41066660/Newbie%20Thread%20Sign.gif[/IMG][/URL]
 
Last edited:

solidspider

New member
Sep 23, 2010
4
0
Hi, I have a Samsung s21 Ultra Device and I am Running Oblivion on Exagear Emulator (T+Z 6.0 Build) and The Game Runs GREAT! But I Can't Open THE CONSOLE to Input Codes for Stuff Like on my PC. I even have the //Input Bridge// Touch Screen Overlay working with Customizable Controls, and I added a "~" Button to Open the Console but it doesn't work. So I Installed Oblivion Script Extender (OBSE) to Install some Mods which I got to Load up, but the Game Crashes Upon Startup. If I could get the Console to work, I wouldn't have bothered with OBSE. Any Suggestions?
 
Last edited:

mirku78

New member
Dec 2, 2010
3
0
Hi. If I buy Vivo x80 pro in Chinese soft, will I be able to upload European software if there is a global version? Is it possible?



Cześć. Jeśli kupię Vivo x80 pro w chińskim soft, czy będę mógł wgrać europejskie oprogramowanie, jeśli pojawi się wersja globalna? Czy to możliwe?
 
Last edited by a moderator:

Afeef_H_S

Member
Mar 14, 2022
5
0
Got an issue with MIUI 12. When my phone receives notifications, it shows on the lockscreen, but when I unlock the phone and then lock it again, the notifications don't show on the lockscreen anymore (keep in mind I don't clear the notifications from the notifications shade). I assume I'm not the only one who faced this issue, but is there a fix to this?
Device: Redmi 8
ROM: MIUI 12 (EU)
 

syelan34

Member
Apr 23, 2022
9
2
Did you use an actual apk editing tool to remove the signature on the apk file then decompile the apk then make your changes or are you still only editing the app using the same tool that were using before? If you are still trying to do it with the tool you used before, stop using that method and do like I said, use APKtool or similar application on a PC to modify the app, don't use apps on your device to do this.
I tried using apktool but it gave me an error, here is the output:
I: Using Apktool 2.6.1 on framework-res.apk

I: Loading resource table...

Exception in thread "main" brut.androlib.AndrolibException: Invalid chunk type: expected=0x00000200, got=0x00000206

at brut.androlib.res.decoder.ARSCDecoder.checkChunkType(ARSCDecoder.java:549)

at brut.androlib.res.decoder.ARSCDecoder.readTablePackage(ARSCDecoder.java:90)

at brut.androlib.res.decoder.ARSCDecoder.readTableHeader(ARSCDecoder.java:84)

at brut.androlib.res.decoder.ARSCDecoder.decode(ARSCDecoder.java:50)

at brut.androlib.res.AndrolibResources.getResPackagesFromApk(AndrolibResources.java:783)

at brut.androlib.res.AndrolibResources.loadMainPkg(AndrolibResources.java:64)

at brut.androlib.res.AndrolibResources.getResTable(AndrolibResources.java:56)

at brut.androlib.Androlib.getResTable(Androlib.java:70)

at brut.androlib.ApkDecoder.getResTable(ApkDecoder.java:247)

at brut.androlib.ApkDecoder.decode(ApkDecoder.java:109)

at brut.apktool.Main.cmdDecode(Main.java:175)

at brut.apktool.Main.main(Main.java:79)

I don't know what this error is, but I can try and reinstall the OS to get another copy.
And how do I re-sign it so that the system doesn't reject it and cause a boot loop again?
 

Droidriven

Senior Member
Jan 27, 2014
15,411
9
5,357
NC
Verizon Samsung Galaxy S III
HTC Thunderbolt
I tried using apktool but it gave me an error, here is the output:
I: Using Apktool 2.6.1 on framework-res.apk

I: Loading resource table...

Exception in thread "main" brut.androlib.AndrolibException: Invalid chunk type: expected=0x00000200, got=0x00000206

at brut.androlib.res.decoder.ARSCDecoder.checkChunkType(ARSCDecoder.java:549)

at brut.androlib.res.decoder.ARSCDecoder.readTablePackage(ARSCDecoder.java:90)

at brut.androlib.res.decoder.ARSCDecoder.readTableHeader(ARSCDecoder.java:84)

at brut.androlib.res.decoder.ARSCDecoder.decode(ARSCDecoder.java:50)

at brut.androlib.res.AndrolibResources.getResPackagesFromApk(AndrolibResources.java:783)

at brut.androlib.res.AndrolibResources.loadMainPkg(AndrolibResources.java:64)

at brut.androlib.res.AndrolibResources.getResTable(AndrolibResources.java:56)

at brut.androlib.Androlib.getResTable(Androlib.java:70)

at brut.androlib.ApkDecoder.getResTable(ApkDecoder.java:247)

at brut.androlib.ApkDecoder.decode(ApkDecoder.java:109)

at brut.apktool.Main.cmdDecode(Main.java:175)

at brut.apktool.Main.main(Main.java:79)

I don't know what this error is, but I can try and reinstall the OS to get another copy.
And how do I re-sign it so that the system doesn't reject it and cause a boot loop again?
You should see an option to sign the apk in APKtool. Try finding a guide for how to use APKtool and find instructions for signing apk files.
 
Last edited:

rsngfrce

Senior Member
May 13, 2012
825
539
NorCal
Apps & Games
This isn't the kind of question I would normally ask on XDA, but I am attempting to assist a developmentally disabled friend and this is stumping me.

My friend has an Android phone and tablet. For the purpose of this question, I don't think the models or Android version particularly matters.

He normally uses Chrome on both devices. He searches Google for an image he likes and saves it to Google Favorite Images (I am completely unfamiliar with this). When he clicks on the link or bookmark to his favorite images, a page opens showing a lot of GENERIC THUMBNAILS and a few actual thumbnails. According to him, it previously displayed correct (non-generic) thumbnails for all the photos (since he is developmentally disabled, I can't say for certain this is true, but it is what I am going on).

These images ARE images that I would expect to be filtered out by safesearch being turned on, but I cannot find anywhere that it is. Also, when the generic thumbnails are clicked, the image displays. The links appear to be links to the Google search result page rather than directly to the page with the image, but that is true of the thumbnails that display correctly as well, so it doesn't seem relevant.

The same thing occurs on both devices and doesn't relate directly to the browser, because I installed Firefox and get the same result. To display the link, I have to log in to his Google account though, which leads me to the conclusion that IF THIS ISN'T NORMAL that it is being controlled by his Google Acct somehow.

I have checked all settings I can find and don't find anything I think would cause this. I cleared the cache externally and internally in Chrome, no help.

I think there must be a simple answer that I am missing and hope someone else can provide some direction to me before I pull my hair out.
 

Jellypop

New member
May 6, 2022
2
0
Thanks for creating this thread!

I just managed to flash my S10 with a stock rom using the advice on this forum (thanks all!). The thing is, I thought that flashing the CSC file (and not the HOME_CSC file) would effectively wipe my phone.

I didn't get any errors and Odin gives me a Pass at the end, but when I reboot my phone, all my apps are still there. I've tried this several times, even trying the HOME_CSC once in case the files somehow were mislabeled.

Is it possible that things didn't get wiped because the rom version I was flashing was the same version that is already on the phone?
 

Droidriven

Senior Member
Jan 27, 2014
15,411
9
5,357
NC
Verizon Samsung Galaxy S III
HTC Thunderbolt
Thanks for creating this thread!

I just managed to flash my S10 with a stock rom using the advice on this forum (thanks all!). The thing is, I thought that flashing the CSC file (and not the HOME_CSC file) would effectively wipe my phone.

I didn't get any errors and Odin gives me a Pass at the end, but when I reboot my phone, all my apps are still there. I've tried this several times, even trying the HOME_CSC once in case the files somehow were mislabeled.

Is it possible that things didn't get wiped because the rom version I was flashing was the same version that is already on the phone?
Yes, probably because you are flashing the same firmware as what you already had or maybe something to do with Factory Reset Protection or Mobile Device Manager preventing the wipe in order to prevent FRP lock when you reboot the device. If you want the device wiped after flashing, first, remove the Google account from the device then boot into recovery and factory reset the device from within recovery then reboot.
 

Jellypop

New member
May 6, 2022
2
0
Yes, probably because you are flashing the same firmware as what you already had or maybe something to do with Factory Reset Protection or Mobile Device Manager preventing the wipe in order to prevent FRP lock when you reboot the device. If you want the device wiped after flashing, first, remove the Google account from the device then boot into recovery and factory reset the device from within recovery then reboot.
Thank you!

I was worried that the flash didn't succeed. A security minded friend recommended I flash a stock rom after I told him I purchased the phone used. So I guess as long as that's what I'm on, the reset itself isn't so important. The phone actually came factory reset and I reset it again just to be sure.

Weird thing is, since my original post, I had read about repartitioning and how that should also result in a wiped device. So I tried flashing with that option using the pit file from the CSC file, but I still got the same result.

Thanks again. I know the rules say I should hit the thanks button, but I can't actually find one. Maybe cause I'm on mobile? I'll check again when I get home.
 

Droidriven

Senior Member
Jan 27, 2014
15,411
9
5,357
NC
Verizon Samsung Galaxy S III
HTC Thunderbolt
This isn't the kind of question I would normally ask on XDA, but I am attempting to assist a developmentally disabled friend and this is stumping me.

My friend has an Android phone and tablet. For the purpose of this question, I don't think the models or Android version particularly matters.

He normally uses Chrome on both devices. He searches Google for an image he likes and saves it to Google Favorite Images (I am completely unfamiliar with this). When he clicks on the link or bookmark to his favorite images, a page opens showing a lot of GENERIC THUMBNAILS and a few actual thumbnails. According to him, it previously displayed correct (non-generic) thumbnails for all the photos (since he is developmentally disabled, I can't say for certain this is true, but it is what I am going on).

These images ARE images that I would expect to be filtered out by safesearch being turned on, but I cannot find anywhere that it is. Also, when the generic thumbnails are clicked, the image displays. The links appear to be links to the Google search result page rather than directly to the page with the image, but that is true of the thumbnails that display correctly as well, so it doesn't seem relevant.

The same thing occurs on both devices and doesn't relate directly to the browser, because I installed Firefox and get the same result. To display the link, I have to log in to his Google account though, which leads me to the conclusion that IF THIS ISN'T NORMAL that it is being controlled by his Google Acct somehow.

I have checked all settings I can find and don't find anything I think would cause this. I cleared the cache externally and internally in Chrome, no help.

I think there must be a simple answer that I am missing and hope someone else can provide some direction to me before I pull my hair out.
Seems to me to be something to do with Google itself, not the Google account or the device. When you used Firefox, was Firefox using Google for it's search engine? If so, that may be why Firefox was getting the same results/behavior.
 
  • Like
Reactions: rsngfrce

rsngfrce

Senior Member
May 13, 2012
825
539
NorCal
Apps & Games
Seems to me to be something to do with Google itself, not the Google account or the device. When you used Firefox, was Firefox using Google for it's search engine? If so, that may be why Firefox was getting the same results/behavior.
Thanks for your response. In order to view "Google Favorite Images", you have to log in to your Google account. Therefore, when I used Firefox, I had to log in to his Google account, with the same result. As you say, this seems to be a Google or Google account issue, not a browser issue. Safesearch is not enabled and Google displays adult content anyways. I don't know that this is related to a "Safesearch" type of setting or not, he just happens to have saved a lot of adult content in this manner.
 

Droidriven

Senior Member
Jan 27, 2014
15,411
9
5,357
NC
Verizon Samsung Galaxy S III
HTC Thunderbolt
Thanks for your response. In order to view "Google Favorite Images", you have to log in to your Google account. Therefore, when I used Firefox, I had to log in to his Google account, with the same result. As you say, this seems to be a Google or Google account issue, not a browser issue. Safesearch is not enabled and Google displays adult content anyways. I don't know that this is related to a "Safesearch" type of setting or not, he just happens to have saved a lot of adult content in this manner.
Go to system settings>Accounts>select their Google Account, on the next page select "Google Account". On the next page you should see their Google account info and avatar with a header just below it with tabs from left to right that say Home, Personal Info, Data&Privacy, Security, etc.. Select the "Security" tab, then scroll down until you see "Enhanced Safe Browsing for your account" and disable it.
 
  • Like
Reactions: rsngfrce

rsngfrce

Senior Member
May 13, 2012
825
539
NorCal
Apps & Games
Go to system settings>Accounts>select their Google Account, on the next page select "Google Account". On the next page you should see their Google account info and avatar with a header just below it with tabs from left to right that say Home, Personal Info, Data&Privacy, Security, etc.. Select the "Security" tab, then scroll down until you see "Enhanced Safe Browsing for your account" and disable it.
Thanks, sounded like a good suggestion, but it was already disabled. It doesn't seem to be safesearch related to me, but is somehow related to the Google account, I think, but since you have to log in to Google to view the Favorite Images anyway, it could be a Favorite Images issue instead.
 

rsngfrce

Senior Member
May 13, 2012
825
539
NorCal
Apps & Games
Go to system settings>Accounts>select their Google Account, on the next page select "Google Account". On the next page you should see their Google account info and avatar with a header just below it with tabs from left to right that say Home, Personal Info, Data&Privacy, Security, etc.. Select the "Security" tab, then scroll down until you see "Enhanced Safe Browsing for your account" and disable it.
I was able to get more details from my friend. In Chrome, when he sees a photo he likes, he selects "Add to..." and then selects "Favorite Images". The page that is displaying MOSTLY generic thumbnails is the Google Favorite Images page. The generic thumbnails lead to valid images as far as I can tell.

Here is a poor quality example of the icon in the browser. I can't even find anything like it in a reverse image search. Maybe I should try contacting Google about this, I am unsure how responsive they are.

20220507_144117_2.jpg
 

Droidriven

Senior Member
Jan 27, 2014
15,411
9
5,357
NC
Verizon Samsung Galaxy S III
HTC Thunderbolt
I was able to get more details from my friend. In Chrome, when he sees a photo he likes, he selects "Add to..." and then selects "Favorite Images". The page that is displaying MOSTLY generic thumbnails is the Google Favorite Images page. The generic thumbnails lead to valid images as far as I can tell.

Here is a poor quality example of the icon in the browser. I can't even find anything like it in a reverse image search. Maybe I should try contacting Google about this, I am unsure how responsive they are.

View attachment 5608951
Or maybe the thumbnail file type isn't compatible with the viewer being used.
 
  • Like
Reactions: rsngfrce

suntie

New member
Dec 2, 2021
2
0
I wanna transplant smartisan 8.5.0 for xperia 5 ii,I made a sgsi ,but it will be power off in a second.I got the log like this,how to fix that,pls
 

Concept48

Senior Member
Dec 26, 2021
209
98
Sony Xperia M
There are a lot of people joining XDA on a daily basis, and there are a lot of repetitive questions being asked
which clutter up the Development and 'Q & A' threads. Point them here. Feel free to ask or answer questions.

The idea of this thread is to get users to help other users with their problems/questions. People are usually
ridiculed for asking questions that other people deem stupid even though it may be a legitimate question. This
leads to new users being afraid to ask questions!

Only provide well mannered help towards users in this thread. Please do not spoon feed, but rather point in
the direction where that user can find an answer
and educate himself. If you don't want to answer, at least
point out where to find the answer.



Before posting anything, I strongly advise you to read THIS thread.

Then, have a quick look at the names of threads in Post No. 2, you might find what you need right away.

Third. Even if you do get your question answered, please do come back and read threads in Post No. 2
(coming later as soon as we start getting the guides) to educate yourself. You'll be surprised how much time
and frustration it will save you in the future!



No abuse towards noobs tolerated here! That means:
NO TROLLING

NO NAME CALLING

NO RIDICULING

NO FLAMING


ASK ANY QUESTION HERE! No question is stupid or irrelevant in this thread. You will either get an answer or will get pointed in the right direction.

*A Special Thanks to mark manning for his help in creating this thread*


HALL OF FAME

People who contributed most to this thread and helped countless number of people with their
problems/questions. In no particular order.

Bruce Wayne
post-mortem
SilentStrider
Ghostfreak NB
mayank9856
sgs22012
Zatta
ADDICT.ANK



These people also have the right to use the banner below:
Newbie%20Thread%20Sign.gif


Just add this code to your signature:
HTML:
[URL="http://forum.xda-developers.com/showthread.php?t=2257421"][IMG]https://dl.dropboxusercontent.com/u/41066660/Newbie%20Thread%20Sign.gif[/IMG][/URL]
Nice , ok here is my question , How can I install Android 13 Arm64 AB GSI on the Samsung Galaxy S9 - he who knows the answer will be the first in the world ! Good luck. I hope this question will not be seen as not relevant , Best regards Puck
 

alanjoseph11

New member
May 8, 2022
3
0
Custom ROM Development

Which Programming language should I learn to start making custom rom's. I have no prerequisite knowledge in Programming.
 

Top Liked Posts

  • 1
    go back to stock

    A bit more specific?
    1
    Thx, anyway I tried everythiing, from flashing a chinese stock in fastboot to install from scratch a weekly in festboot, format data, all..... still stuck in TWRP.
    WTH is going on?
    Hiya Matey, I've sent a link that "maybe" of use, in your thread, keeps this thread tidy. Before taking any actions, I would highly recommend reading the whole thread, to gage what may work, and what has failed, ☕😊
    1
    Thx, anyway I tried everythiing, from flashing a chinese stock in fastboot to install from scratch a weekly in festboot, format data, all..... still stuck in TWRP.
    WTH is going on?
    After to flash the stock ROM, reboot to the stock recovery, don't flash TWRP yet, and perform a factory data, try to boot.
    If not, if you backed up dtbo and persist partitions, depending on what caused the issue, it may be helpful, restore them.
    And once I solved this, by flashing the super image through TWRP, some build number trigger the FBE while others not.
    This issue comes from decryption.
    1
    This just tells me everything I've already read a hundred times and I have more specific questions that I don't want to go and make an entire thread about as that wouldn't really help me much either that's why I came here asking if somebody could message me so I could talk with them about this entire thing as all that information is practically useless to me that's just like the rest of this stuff I've been reading it just keeps leaving me with more questions than actual answers I mean really if I was confident in my ability based off of the information I got from all of the form posts here I've read I wouldn't be sitting here asking for someone to message me so I could talk to them about all this shenanigans

    Now I don't want to seem rude but this is just tiring no one else reply to me giving me form posts or "generic" written instructions I need someone knowledgeable to please message me so I can talk with you as that is the type of help I need that I can't get anywhere else certainly not from the form posts I've already read too many times
    I don't think someone is interested enough to sit in front of you, to give you all the answers to your questions, this site is keep alive for Android lovers, volunteer and enthusiast to help others for free, all here we have our lives, we are not here because we have nothing to do, but we reserve a time for others, but not to spoon-feed on you, most of us, started from zero, just reading and reading, and also bricking some device, from time to time, I never thought to ask anyone to give me a complete guide to make the whole process, XDA is not intended to do so, you have to search here, and read there, this way, you could complete and satisfy your curiosity. I understand, in some way, your frustration, but you'll never find what you are searching for, the learning curve is a process that never ends, no matter you can do it now, to your A20, later, the things can change (and totally) for the next device, so better, try to learn why you have to do this or that, and very important, the order how they have to be done.

    Furthermore, I could, because some guides are more or less, generic, for devices that share some specs, but I had the A20, it didn't take me more than 10 minutes for the whole process though.
    1
    Okay I'll make someone interested then cuz I'm over here trying to root my phone with nothing but my ****ing tablet so I have questions like do I need Odin or can I just push the file through console commands and crap like that or how I found so many conflicting answers about needing a customer recovery or which one to even use that's why all these form posts aren't bloody helping me cuz I'm in no man's land with no one to talk to that's why I came here pretty much out of options seeking assistance I don't need my hand held through the entire process as I've rooted Android devices before but that was like freaking nougat and lollipop absolutely forever ago and the weird questions I have I can't find a written answer for that's why I was trying to find somebody that would message me so I could actually talk to them and clear some of these confusions up it's taking me forever to get as far as I have and I'm surprised I have but I need somebody to talk to that knows more about this than I do who's experience isn't like 7 years out of date so for the love of God can somebody actually help me cuz you do not understand how frustrating it is to be sitting here with no one to talk to with relevant experience leaving you stumbling through the dark with only half an idea of what the hell you need to do and no idea of how you're supposed to do it hell I'm probably the first draft idiot who's ever tried to do this and just like everything else in my life I don't have the correct tools to do it the way everyone else says to so I have to try and find weird workarounds and jury rig a solution
    No, you are wrong, it's not a workaround, a maybe yes, maybe not, what I pointed out is the straight way forward to what you need.

    You firstly said you need to root it, because you need to install LineageOS, and I clearly stated that you don't need to root it, in order to install LineageOS.

    If you still want to root it, this can be done in the half of the process, without interfere with the most important for you, that I suppose, is to install LineageOS. In my opinion, your issue is not about technical insides, because this is absolutely normal for everyone, before to start any way, in the whole life, but all about anxiety and methodology.

    Why methodology, well, I'll copy/paste my previous steps for you, and instead of only this symbol "-" I'll put numbers, that I understand we both, think that they mean the same, basically, an order, no?.

    1- Enable USB debugging, and OEM unlock.
    2- Install the Samsung drivers.
    3- Power off your device, and while pressing the both volume buttons, connect device to your PC, this will lead you to a menu, to unlock bootloader, follow the on instructions.
    4- Install TWRP using Odin, and search for a vbmeta patched file (in case you can't boot, you need to flash it too), you will find it in the A20 forum, https://forum.xda-developers.com/t/twrp-official-recovery-for-a20-and-a20e.4267815/#post-86192489, untick the option to reboot automatically in Odin, when the process ends, disconnect device.
    5- Reboot manually to TWRP by pressing PWR + volume up buttons.
    6- First in TWRP screen, swipe to allow modifications, and recommendable, format data, take a backup of (personally I do from) EFS, dtbo, persist.
    7- Flash the custom ROM of your preference.

    Ok, then now, you may question, what does the first step mean? I didn't put a specific link, even less, I can't put here the whole process to do so, because this is a generic guide for all the Android devices, that you'll find a lot of guides out there, it's already written, the same for the second step, the third step doesn't need more explanation, the fourth step is clearly stated, that you have to use Odin, OK, maybe here you don't know how to use Odin, then just search How to use Odin? It's already written, the fifth step, again, same for the sixth step, they don't need more insights, and for the seventh step, you have to read in the specific forum where you find the ROM of your preference. I encourage starting your way, following these steps, and if in some part of the process, you are stuck, feel free to ask again.

    PD: Usually, I don't provide private assistance, so better keep it here. Anyway a lot of post you did, and never mentioned that you want to do all of this using a second phone, I don't want to be rude, but you see what the anxiety makes, do you expect to receive a lot of answers trying to figure out what you really want to do?.

    OK, to the point, personally I don't like to use a second Android device over a PC, if the things go wrong, it is very, very hard to fix it.

    Simple things can be done easily, read this https://android.gadgethacks.com/how...mands-from-one-android-phone-another-0384181/ but in the case of Samsung devices, as they don't have fastboot enabled (by normal means), you can't use fastboot commands, that is what you need in order to have more of the steps done.
    What I think you can search for is, trying to install in your Tab, a Linux image, and get it to run, you should need to have Vine working, to have Odin, honestly, I never tried, but at least you have a clue, how this can be achieved or at least, from where you can look for.
  • 3
    A stupid question...why every support to roms, etc is on TELEGRAM? There are indeed FOSS alternatives like xmpp, wjhy stixcko to something cklosed and non free?
    2
    Hi guys, I have a question. I have a LG M320TV with power button broken, I tried to install a Custom Rom but I can't even enter in fastboot mode via adb to unlock the bootloader. The phone just restart normally without entering fastboot mode. I have no idea what's is happening or if the power button it has to do with this problem.
    Try with:
    - adb reboot bootloader or adb reboot fastboot, either, as one of these commands, probably you didn't try it, let the device without pressing a button, but for the other command, press the other button except the PWR button, the same try rebooting through menu, pressing the other button except PWR button.
    - Program your device to power off/on, at a certain time, and keep pressing the other button except PWR button, when the time comes.
    - Go to recovery through command adb reboot recovery, and from there you may find an option to go to fastboot mode.
    - Open the back cover and just pin the PWR button.
    - Connect to a PWR supply charger, and at the exact same time, press the other button to enter either to recovery (if it helps, remember the menu options), or to fastboot.
    - If nothing helps, probably you may take it to a repair center, most likely you will need this button to fix the troubleshooting you'll find tweaking with your device.
    2
    Hi, I am very new to rooting and xda. Could you please explain what you mean by that.
    Thanks
    There is search bar at the top of the page.Members are supposed to use that / Google before posting a question.
    e.g. you can simply use keywords "Root+Nokia 8.1+Android 11" into the seach box or navigate through "Forums > Nokia > Nokia 8.1".
    Anyway, here you go : https://forum.xda-developers.com/f/nokia-8-1-guides-news-discussion.8433/.
    Hope this helps!
    2
    I was wondering if XDA had a forum for game emulation? Either PC or Android? Emulators Like PSCX2, Dolphin, Project 64, etc. I want to learn more about them.
    A simple Google search for:

    "XDA game emulators"

    Yields this as the #1 search result, sometimes, you just can't beat a simple Google search for the thing that you are looking for.

    1
    As far as I know Google's AOSP is referred to as "Vanilla". Vanilla just means unflavored android with no extras such as the skin/UI/bloatware apps that device manufacturers and carriers add on top of Google's AOSP.
    Yes, this is in the main concept from Google, vanilla here, in this context refer to a ROM that comes without Gapps, usually developers make a custom ROM, then, if they don't have Gapps integrated, they, often call it, vanilla.
    As the user wanted a custom ROM (PixelPlusUI), I recommended searching a custom ROM without Gapps, as I don't think they find a PixelPlusUI without Gapps.
    I didn't want to make a technical input, but just followed what is the most current use to the general acknowledge. This is an example of.
    vanilla-concept.png
  • 391
    There are a lot of people joining XDA on a daily basis, and there are a lot of repetitive questions being asked
    which clutter up the Development and 'Q & A' threads. Point them here. Feel free to ask or answer questions.

    The idea of this thread is to get users to help other users with their problems/questions. People are usually
    ridiculed for asking questions that other people deem stupid even though it may be a legitimate question. This
    leads to new users being afraid to ask questions!

    Only provide well mannered help towards users in this thread. Please do not spoon feed, but rather point in
    the direction where that user can find an answer
    and educate himself. If you don't want to answer, at least
    point out where to find the answer.



    Before posting anything, I strongly advise you to read THIS thread.

    Then, have a quick look at the names of threads in Post No. 2, you might find what you need right away.

    Third. Even if you do get your question answered, please do come back and read threads in Post No. 2
    (coming later as soon as we start getting the guides) to educate yourself. You'll be surprised how much time
    and frustration it will save you in the future!



    No abuse towards noobs tolerated here! That means:
    NO TROLLING
    NO NAME CALLING
    NO RIDICULING
    NO FLAMING


    ASK ANY QUESTION HERE! No question is stupid or irrelevant in this thread. You will either get an answer or will get pointed in the right direction.


    *A Special Thanks to mark manning for his help in creating this thread*


    HALL OF FAME

    People who contributed most to this thread and helped countless number of people with their
    problems/questions. In no particular order.

    Bruce Wayne
    post-mortem
    SilentStrider
    Ghostfreak NB
    mayank9856
    sgs22012
    Zatta
    ADDICT.ANK



    These people also have the right to use the banner below:
    Newbie%20Thread%20Sign.gif


    Just add this code to your signature:
    HTML:
    [URL="http://forum.xda-developers.com/showthread.php?t=2257421"][IMG]https://dl.dropboxusercontent.com/u/41066660/Newbie%20Thread%20Sign.gif[/IMG][/URL]
    113
    Reserved

    Just a few words of advice on keeping this thread clean of unnecessary clutter:

    1. Before posting a question, it is highly recommended to read this thread.

    2. Click the Thanks button on the posts that helped you, instead of posting "Thanks". This helps other members in finding out the best replies that get buried in the thread.

    3. Do not use this thread to increase your post count! The Off-Topic forum is the place for that.

    4. Do a simple search of this thread before asking to see if your question has been asked previously.

    5. If your question has not received an answer after a few hours, please be patient. Someone will answer you shortly. If you do not get an answer in 24 hours, you may BUMP your post. If you still have no answer after a week, do mention me in your post.

    Thank you for your cooperation!
    27
    Good job mate, hopefully lots of members will find this thread very helpful :cool::good:
    12
    ZTE V970 Brick?

    Hi,

    I've been trying to install Bruno's ROM for this phone (cam with all chinese apps). http://forum.xda-developers.com/showthread.php?t=1856578

    but have a big problem. I tried my best to follow the instructions but, really couldn't work out if I was doing things in the right order.. is there an actual step- by step for this procedure? I know I'm a noob and read this read that I am an idiot etc. etc. but I thought if I used to ROM on that page and the software recommended it would be easy.

    Here's what I did:

    Downloaded all the files as told.

    Tried to 'flash a custom recovery' as here http://bm-smartphone-reviews.blogspot.co.uk/2012/05/mt6575-flashing-tutorial.html

    but it did not mention how to use the ZTE custom recovery file http://d-h.st/Vgt

    I'm also not sure at all that the 'MediaTek drivers' were installed properly. The phone never appeared in the Device manager.

    I opened SP flash tool and followed this: http://bm-smartphone-reviews.blogspot.co.uk/2012/05/mt6575-flashing-tutorial.html

    and selected the 'scatter file' from the unzipped Bruno ROM (took a while to realise had to unzip it to get the file!!!)

    I noticed most of the boxes on the scatter file were unchecked but carried on and ignored a warning message about the phone may not be able to boot (the tutorial said to ignore it).

    I had to click 'download' then plug the phone in and eventually I got the red loading bar. This finished... then nothing else.. no purple bar.. nothing.

    So after waiting a few minutes I unplugged the phone.

    It now appears to be a total brick. What did I do wrong? Why no purple bar? Were the scatter items supposed to be unchecked? What was the 'custom recovery' file for? Because the SP flash prog never asked for it.

    Is there any point in trying it again or is the phone dead?

    Thanks for any help..

    Theo