[Help Thread][Atoto A6 Pro] Ask Any Question, Noob Friendly

Search This thread

Colonel-Panic

New member
May 9, 2022
1
0
Here's one question of the thousand or so I have:

I have an ATOTO A6 PF (model A6G2A7PF). I'm trying to use Road Recorder 4.3.2 to record my rear view camera but it doesn't seem to write the video files. Below is an example of what's being written:

Code:
-rwxrwxrwx  1 colonel  staff     0B May  9 15:21 video_15-21.mp4
-rwxrwxrwx  1 colonel  staff    11K May  9 15:23 video_15-21.srt
-rwxrwxrwx  1 colonel  staff    17K May  9 15:23 video_15-21.xml
-rwxrwxrwx  1 colonel  staff     0B May  9 15:23 video_15-23.mp4
-rwxrwxrwx  1 colonel  staff     0B May  9 15:24 video_15-23.srt
[email protected] 1 colonel  staff    13K May  9 15:24 video_15-23.xml

You can see that it's writing XML and SRT files fine but the video files are 0 bytes. To the best of my knowledge, Road Recorder has full privileges. What should I be looking at to fix this issue?
 

Tech_Setup.exe

New member
May 12, 2022
1
0
Hello guys, I have 1 major issue with this unit (Atoto A6 Pro). I use spotify on my phone, but in the car, i prefer to have it directly installed on the unit, and not streaming in it by the bt on the phone. With the "free" spotify from the play store i have just no problems, the app installs fine and works just fine. But i can't get to work any of the "mod free apk" i find on the web i even verified the system architecture with the various app. But every single time i try to install one of that mod apk i always have the same result, app not installed and i can't get to know why. I have just removed and cleared the cache of the apps but nothing seems to work. Does anyone have some ideas? Thanks
 

RHCPayne

New member
May 27, 2022
1
0
I just got an ATOTO A6 Performance last week. I updated it to the most recent version of Android. That being said...

I bought this basically ONLY to watch Amazon Prime Video, HBOmax, Hulu, Disney+, and YouTubeTV. Amazon Prime Video works fine. Disney+ and Hulu both say that the app is not compatible with the Android version. YouTubeTV will load the app, show the selection screens and line-ups, but when you click play it never completes loading. This same thing happened when I used the web browser to login to Hulu and Disney+. It just spins the wait wheel endlessly. HBOmax will show the subtitles as the show or movie plays, but no video or sound. I tried casting with an iPad and an error saying something about the video being unplayable kept popping up. I contacted CS, and they told me to live with it like this or send it back. Is there a fix for any of this? I don't really know much about Android operating systems, do they use Codecs?

I've attached pics of the About device screen.
 

Attachments

  • ATOTO A6 PF Info 1.jpg
    ATOTO A6 PF Info 1.jpg
    3.5 MB · Views: 78
  • ATOTO A6 PF Info 2.jpg
    ATOTO A6 PF Info 2.jpg
    2.5 MB · Views: 77

WildWest66

Member
Jun 1, 2022
6
0
I just got an ATOTO A6 Performance last week. I updated it to the most recent version of Android. That being said...

I bought this basically ONLY to watch Amazon Prime Video, HBOmax, Hulu, Disney+, and YouTubeTV. Amazon Prime Video works fine. Disney+ and Hulu both say that the app is not compatible with the Android version. YouTubeTV will load the app, show the selection screens and line-ups, but when you click play it never completes loading. This same thing happened when I used the web browser to login to Hulu and Disney+. It just spins the wait wheel endlessly. HBOmax will show the subtitles as the show or movie plays, but no video or sound. I tried casting with an iPad and an error saying something about the video being unplayable kept popping up. I contacted CS, and they told me to live with it like this or send it back. Is there a fix for any of this? I don't really know much about Android operating systems, do they use Codecs?

I've attached pics of the About device screen.
I would recommend requesting Atoto support send you the factory OS that it was shipped with. Try reverting back to it and see if it fixes your issue.
 

WildWest66

Member
Jun 1, 2022
6
0
Does anybody know what the Atoto A6 PF model A6G2A7PF exact screen size in MM is by length and width? I purchased a screen protector from Boxwave that is a little to long (width fits perfectly). I want to give them the exact measurements so they can update their design.

BTW, since Atoto discontinued their screen protectors Boxwave has them for several models now.
https://www.boxwave.com/atoto-accessories/bwefmd/fvtf/
 

lordkramuk

Member
Mar 5, 2015
15
0
Just got an A6 the other day great unit, but I have a really weird issue, pressing the volume up button (+) on the actual head unit, makes the google assistant come up, I have not set any special instructions to do this, as I tried factory reset as well, also tried uninstalling assistant app and same thing happens, anyone know why?
 

Remy70

New member
Jun 17, 2022
2
0
Can someone please tell me how to turn on omri on my android 10 head unit on dab z please? Can’t find it anywhere and have looked in settings and still can’t find? Thanx
 

IINamelessII

New member
Jul 11, 2022
1
0
Hi, how to set a setting to be enabled by default (on launching the car)? For example, how to set subuffer to be enabled by default and don't go to settings - sound - subuffer on any launch?

subwoofer* XD
 

Quiche2192

New member
Jul 21, 2022
2
0
I have a 6PF and I've noticed that the button backlights do not illuminate automatically when cycling power on the unit. I have to keep going into the settings and toggle the panel illumination setting every time. Any solutions to this? I have a video showing the issue:

 
Mar 29, 2022
41
19
In your video I don't see any cycling power on the video using vehicle ignition.

By default the back panel lights will illuminate only when the car lights(Parking/Headlight) turned ON provided of you have connected the "Illumination" cable correctly. Hope helps!
 

Quiche2192

New member
Jul 21, 2022
2
0
In your video I don't see any cycling power on the video using vehicle ignition.

By default the back panel lights will illuminate only when the car lights(Parking/Headlight) turned ON provided of you have connected the "Illumination" cable correctly. Hope helps!
Yeah I just used the power button. I do not have the illumination cable connected. I expected that if the panel illumination setting is set to on in the settings menu as seen in the video, it will stay on regardless of the illumination cable or vehicle ignition state. But I'll connect it and see what happens. Thanks
 

jrubins

New member
Jan 28, 2013
3
0
Hi all, I have two issues with my new Atoto head unit (A6 performance, but AFAICT it's the same as the "Pro" in these issues)
issue 1:
What I'd like to do is run an app called Harry's Lap Timer https://play.google.com/store/apps/details?id=com.harrys.laptimerpro&hl=en_US&gl=US
This app enables an android device to use the camera to record video, and it overlays data from OBD2, as well as GPS, and internal sensors. It's a very powerful tool for track driving. I've What it can't do on the Atoto head unit is connect to the camera to record.

I have tried connecting the front (usb camera): no video
I've tried connecting the rear (backup camera): no video
i've tried connecting the backup camera to the "front camera" video input: nothing
I've tried connecting the backup camera to the "aux video" input and nothing.
I've also tried Trackaddict which is a different app with similar functionality

So my question is: is there a way to enable Harry's Lap timer to access the camera devices so it can record video? If I need to remove the USB camera and use a video camera like the backup camera, that's no problem. Ideally, I'd like it to record using that HD USB camera and the 128gb card in that camera.


Issue 2:
I'd like to have the crossover frequency in the eq settings go from 20hz-20khz for both the low pass and high pass filters so I can properly crossover electronically from woofers to tweeters. I'm using the rear channels to drive my tweeters and the front channels to drive my woofers. The current range of adjustment isn't as much as I'd like for the low pass or high pass filters. Is there some hidden settings to get more full control of the DSP?

Thanks,
jrubins
 
Mar 29, 2022
41
19
About Q1: let's talk about the type of camera and port you are connecting to.

Is that camera is a USB plug and play type or analog signaled RCA connector type?

Second, are you trying to connect that camera to back up camera connector (RCA reverse camera port) or to a auxiliary (External Input RCA) connector?
 

jrubins

New member
Jan 28, 2013
3
0
About Q1: let's talk about the type of camera and port you are connecting to.

Is that camera is a USB plug and play type or analog signaled RCA connector type?

Second, are you trying to connect that camera to back up camera connector (RCA reverse camera port) or to a auxiliary (External Input RCA) connector?
I'm using this USB camera https://www.amazon.com/gp/product/B0822KMK48/r which has a built-in micro SD card. this works fine with the native hd-dvr app, but not with Harry's Lap timer

And this backup camera which uses RCA ATOTO AC-HD01LR (from this package https://www.amazon.com/gp/product/B09PDL2JM2 )
Since the backup camera is RCA type, I can connect it to the backup camera input, works with native app, not with Harry's Lap Timer (HLT) or trackaddict.
I've tried plugging the backup camera into the front camera rca input, which also works with the native "fcam" app but not with HLT
And I've tried plugging into the auxiliary video input, which also works with the native video input app, but not visible in HLT.

So the cameras all work just fine, it's definitely some kind of software thing.
Thanks!
 
Has anyone tried rooting the A6 PF (A6G2A7PF) yet? I've been trying to source some stuff but I have to wait on a new USB A - USB A cable to come in from Amazon before I can try anything. I've been looking at the various threads on here regarding the S8 and the S8 Ultra, keeping notes here and there. Just wanted to see if anyone else had taken the initiative.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hi everyone,

    Just installed the A62721PB-G and I had a few questions:

    - is there a patched or rooted firmware out there for this model? I found some threads, but with all the different models, I wasn't sure.
    - anyone else experience the default music app just randomly opening? I can't even disable it, and it just takes over without action or warning.
    - any way to hide the notifications in the status bar, at least when it's collapsed?
    - is there a 9.7 version of the firmware, or is 9.6 the latest?
    - there's a lot of bloatware I've never heard of on it. Anything I should hesitate to remove?
    - anyone else experience wifi not automatically connecting? I feel like even with a network in range, i have to go in a toggle it or select connect.
    - any way to just get it to run a little smoother? I know the hardware is what it is, but maybe there's a way to disable some background resource hog.

    Any help or other tips would be appreciated. Thank you.
    Late reply but there is a 9.7 version for A6Y2721PB. I've installed it and it works well. Click on "Download Software" at the top right. I can post here if anyone is unable to get it.

    1
    I tried to access the link, but got a 404. If you could post it, it would be greatly appreciated. Thank you
  • 12
    This thread has been created
    for
    Questions & Answers/Troubleshooting
    Specific to

    Atoto A6 Pro



    Please feel free to share issues, questions and offer help. Noob questions are welcomed.


    It is always best to use the Thanks button , in lieu of simply posting "Thank you".

    attachment.php

    Please keep the discussion focused, on questions pertaining to this Device
    attachment.php
    List of supporters
    ...​
    ...​
    ...​
    ...​

    To those seeking help: Please don't bombard the supporters with PMs asking for help. Instead, ask your question here in the thread so others can benefit from the solution to your problem as well. If you want to be sure someone particular gets notified of your question, put his / her username directly after an @.​
    If you have ROM-related questions, post in the relevant ROM Q&A thread (if there is one) or directly in the ROM development thread. Thank you!​
    Supporters: If you want to be put on or off the list, just make a request here in the thread!​
    Before posting anything, I strongly advise you to read

    Please look for a similar thread when visiting another device forum.
    If you would like to create a [Help Thread] please Click Here.

    6
    Models
    A6Y2721P Premium 2G+32G-P
    A6YTY721P Premium 2G+32G-P for Select Toyota/Subaru
    A6Y2721PB Premium 2G+32G-PB
    A6Y2721PRB Pro 2G+32G-PRB (No Gesture sensor)
    A6Y2721PRB-G Pro 2G+32G-PRB-G
    A6Y2710S Standard 1G+16G-S
    A6YTY710S Standard 1G+16G-S(Toyota)
    A6Y2710SB Standard 1G+16G-SB




    [Video] ATOTO A6 AICE OS 9.4 firmware update


    Two hidden menu reachable. This two is named "OEM Settings". One is for mic adjustment, and one for other things.

    Just go to "Setting" -> "About device" . In there tap some times the "Model Number", I think, or an other. I can't remember, what exatly. This pickup the "OEM Settings" where You can input a password.

    The two password is 1238 for MIC settings, and 1617 for other hidden settings.
    No other hidden setting menu, just this two.
    3
    Official Site
    http://www.myatoto.com

    Amazon link

    Links for updates and support
    http://support.myatoto.com Official - 07 Jan 2019

    9.7 version for A6Y2721PB

    ATOTO AICE OS 9.6 for A6 Series is now available for download - 2019-11-07

    9.5.1 Firmware mirrors - 19 Jan 2019

    Firmware 9.4 Info - 27 June 2019

    Firmware Update AICE 9.3 Info - Released
    3
    Thank you for answering i install emil head unit reloaded but when i connect with usb cable or with wifi i have a blackscreen....after few seconds return to home screen...i suppose is a dpi resolution issue? Have you same problem?

    Hi maurizyo, it happened to me as well when I was trying emil's hur. What seems to work for me is close everything (clear recent open apps) and do the speed-up feature of atoto (swipe down from notification). Also, looks like I had an issue with usb cable at that time. I was using some cheap usb cable from amazon, but when I tried the usb which came from my samsung, everything is smooth.

    With wifi, you need to setup your phone as hotspot and connect atoto a6. This works for me but preferred the cable as it opens up as soon as I connect the phone.

    ---------- Post added at 05:46 PM ---------- Previous post was at 05:43 PM ----------

    Guys, for quick charge, have you tried opening the quick charge app installed by default in atoto? You may need to select standard vs quick charge to make the quick charge work.
    3
    Hello guys, i have a big problem with bluetooth dialer, when i say "ok google" voice command, work only for maps and apps but don't call, don't write messages...
    I look for an apk that interface google and native dialer and i found tmc dialer...so this apk don't work on this atoto chipset version.
    Have you fixed that? Calling someone with hands free is primary.
    Thank you in advance

    Hi maurizyo85, I suggest you install headunit reloaded (Android Auto Emulator) by Emil for hands free voice calling. I have google assistant installed on Atoto A6 too but all it does is voice command to open apps or search/navigate. I even have the Atoto steering wheel control installed but it has simple functionality:
    - media next/prev (does not even have a play/pause),
    - end and answer button (but will no way to at least a function to re-dial previous call)
    - volume up/down
    - voice command button (I have it assigned triggers google assistant but no beep sound to determine that assistant is activated). Again, i have it useful for opening app like "play my private on <spotify>" or navigate to nearest gas station. I have it to work as well on my smart devices at home like "Turn on my living room lights". Again no voice command or hands free calls. Edit: Hands-free/Remote Mic Button call works as long as Atoto is not connected to internet, so either you give up internet on Atoto to gain voice call or access internet without it.

    So I end up using Emil's Headunit reloaded to run Android Auto and it works fine with voice command:
    - Call someone like "Ok google, call home"
    - Smart device "Ok google turn on dining room"
    - navigate "ok google navigate to nearest gas station"

    So far that 3 above are the most frequently used for me so I end up with Android Auto.

    Hope this helps.