[Help Thread][Atoto A6 Pro] Ask Any Question, Noob Friendly

Search This thread
I posted a guide here if you want to try getting root. The root process worked. I just messed up installing a magisk module.
Ended up fixing the issue! Read here if you want to see how.

Basically the unit knows to read the firmware at boot if provided. You can trigger a restart via the reset button if it doesn't work right away. If you are dumb like me and you flashed a not-so-good recovery.img, you can signal a crash to the kernel by holding 'ALT+PRINTSCREEN' and repeatedly tapping 'C' on a USB keyboard you can hook up to the "External Storage" USB, which will force it into the buggy fastboot mode where you can flash the original recovery.img. Then, unplug your USB Keyboard, plug in your flash drive with your modded stuff on it, boot to the bootloader via fastboot reboot bootloader and, if your USB stick is inserted, the system should recognize it and immediately start the firmware install. WOO!
 

silverhawk79

New member
Oct 2, 2022
3
0
In your video I don't see any cycling power on the video using vehicle ignition.

By default the back panel lights will illuminate only when the car lights(Parking/Headlight) turned ON provided of you have connected the "Illumination" cable correctly. Hope helps!
I am having a similar issue but my Illumination cable is connected properly...it's on a 2008 VW Jetta; is there some kind of extra connection I need to make? Alternatively, is there a way to just force the lights to be on permanently?
 
Mar 29, 2022
41
19
If you are connected the Illumination wire correctly then as I said the panel lights will illuminate only when the you turn the Head/Step Lights ON. Alternatively you force the panel lights to permanently keep illuminating then you can go to Settings>Factory settings> here_enter_the_password_8888, click OK

Now go to "KeyLightSettings" and the system will popup "please open the debug button lamp lights!!" dialogue with only OK option. Click OK.

Now scroll down and you will see "Open Light" check box.
Tik that check box then click back button.
Now system will ask you to save the settings.
Click OK.

That's all now the lights will illuminate permanently on your system .
Screenshot_20221003-171050.png
 

zman519

Senior Member
Oct 27, 2010
2,237
254
the Land of Beer & Cheese
Is there any way to fully shut down the A6 Pro on demand? I tried to install an app that shows the power menu and I managed to power it off but then after few seconds it boots itself back again. I need to do that because I'm using the car only once a week nowadays for a short drive, which isn't enough to charge the battery much and because of that, the 7 days of inactivity never come, so the A6 Pro never goes into deep sleep and keeps chopping the voltage slowly. Any idea?
I just got a car that has a Atoto A6 installed. Been looking over this thread.

Over all first thoughts are AWESOME display, nice sound QH! Butt... SLOW SLOW SLOW! come on ATOTO Like an S3 was faster.

Any how have you thought about a timer switch https://www.amazon.com/12-volt-timer-switch/s?k=12+volt+timer+switch
 

zman519

Senior Member
Oct 27, 2010
2,237
254
the Land of Beer & Cheese
I have a ATOTO A6Y2710SB and i plugged in a (it came from a server's hot spare) enterprise grade SanDisk 512GB SSD into the back USB port via a Startech USB 3 to SATA adapter. (I have tired many SSDs and it always seems the same) Now this particular USB 3 to Sata is old and has been kinda funky at times. I have another Startech thats always worked flawlessly and i have a band new one setting next to me that will get swapped in, next time i pull the headunit out of the dash.

Any one have issues or advice with a SSD SATA over USB on an A6 ?

I used both Startech USB 3 to SATA adapters when i first pulled it out of the dash and was testing different SSD. So i don't really feel it's the adapter.

  1. Sometimes OsmAnd+ says it cant find it's data. That can be resolved by killing the app and reopening it. (very annoying, but have a work around)
  2. The only media audio player that can find the music on the USB SSD is the crappy default app. I have over 50GB 7000 plus tracks and any time i open it it's always searching for update (says something like that.)
    1. Things i have tried
      1. Ext4 formatted =NoGo (maybe ive been using CynagenMod and LOS for so long but i thought all androids R/W to Ext4 partitions )
      2. NTFS =NoGo
      3. Format to Fat32 via Linux = NoGo
      4. Tried a 1.92TB intel server SSD = supper supper dupper slow!
      5. FatEX =NoGo
My first thought was root it and use symlinks. Well they don't work on FAT 32 and the dumb thing dose not R/W or read Ext4.


I have thought about buying a 128 or 256 SD card, but at this point i feel like that might be a waist of money.
 
Last edited:

Lodi07

New member
Nov 4, 2022
1
0
J'ai un problème avec mon atoto S8 gen 2
Les contacts de mon téléphone sont bien installés dans Atoto. Lorsque je réalise un appel aucun problème le nom de mon contact s'affiche. A l'inverse lorsque je reçois un appel systématiquement le nom du contact apparaît unknown ( inconnu).
d'où cela peut-il provenir?
j'ai déjà réenitialisé le bluetooth sans succès
 

fredmens1960

New member
Nov 27, 2022
1
0
Hello all. So nice to find a forum about the atoto 6PF. I bought a new Atoto 6 PF and connected it to my car via the ISO plugs. I drive a Saab 95 2004. The car had an old after market radio that played well,..., but did not have extra functions. After a while i bought a new radio that had some extra functions. i connected the Iso plugs and it played ok. After i saw the Atoto i instantly wanted to have that one. I connected it, found the carplay, internet bluetooth, everything worked instantly exept THE SOUND. no sound what soever, no beeps, no radio, nothing via bluetooth. The speakers seem to be dead. To be very sure i did not damage anything i reconnected the "old radio". played fine. I had some nice contact with the support of Atoto, but they don't seem to have the golden tip how i can connect the radio to make some sound. No extra amps or anything are fitted in the car, just a standard Iso plug. Are there any golden tips here what to do ?? i would hate to send the unit back,.... at the moment it feels like a DOA. Thanx in advance

Fred
 

effebi77

Member
Jul 28, 2020
5
1
Hi there! I've an Atoto A6 A6YVW710PB and I was wondering if there is a way to delete the contacts from the HU. On my phone I tried to switch to an account with no contacts saved , then connected the phone to the HU and, at last, reload contacts on HU (swiping downward on the contacts app of HU), but nothing happened. All the contacts already saved, stayed still there.
Any advice?

Thanks
 
Last edited:

plemen

Senior Member
Hi everyone,

Just installed the A62721PB-G and I had a few questions:

- is there a patched or rooted firmware out there for this model? I found some threads, but with all the different models, I wasn't sure.
- anyone else experience the default music app just randomly opening? I can't even disable it, and it just takes over without action or warning.
- any way to hide the notifications in the status bar, at least when it's collapsed?
- is there a 9.7 version of the firmware, or is 9.6 the latest?
- there's a lot of bloatware I've never heard of on it. Anything I should hesitate to remove?
- anyone else experience wifi not automatically connecting? I feel like even with a network in range, i have to go in a toggle it or select connect.
- any way to just get it to run a little smoother? I know the hardware is what it is, but maybe there's a way to disable some background resource hog.

Any help or other tips would be appreciated. Thank you.
Late reply but there is a 9.7 version for A6Y2721PB. I've installed it and it works well. Click on "Download Software" at the top right. I can post here if anyone is unable to get it.

 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hi everyone,

    Just installed the A62721PB-G and I had a few questions:

    - is there a patched or rooted firmware out there for this model? I found some threads, but with all the different models, I wasn't sure.
    - anyone else experience the default music app just randomly opening? I can't even disable it, and it just takes over without action or warning.
    - any way to hide the notifications in the status bar, at least when it's collapsed?
    - is there a 9.7 version of the firmware, or is 9.6 the latest?
    - there's a lot of bloatware I've never heard of on it. Anything I should hesitate to remove?
    - anyone else experience wifi not automatically connecting? I feel like even with a network in range, i have to go in a toggle it or select connect.
    - any way to just get it to run a little smoother? I know the hardware is what it is, but maybe there's a way to disable some background resource hog.

    Any help or other tips would be appreciated. Thank you.
    Late reply but there is a 9.7 version for A6Y2721PB. I've installed it and it works well. Click on "Download Software" at the top right. I can post here if anyone is unable to get it.

    1
    I tried to access the link, but got a 404. If you could post it, it would be greatly appreciated. Thank you
  • 12
    This thread has been created
    for
    Questions & Answers/Troubleshooting
    Specific to

    Atoto A6 Pro



    Please feel free to share issues, questions and offer help. Noob questions are welcomed.


    It is always best to use the Thanks button , in lieu of simply posting "Thank you".

    attachment.php

    Please keep the discussion focused, on questions pertaining to this Device
    attachment.php
    List of supporters
    ...​
    ...​
    ...​
    ...​

    To those seeking help: Please don't bombard the supporters with PMs asking for help. Instead, ask your question here in the thread so others can benefit from the solution to your problem as well. If you want to be sure someone particular gets notified of your question, put his / her username directly after an @.​
    If you have ROM-related questions, post in the relevant ROM Q&A thread (if there is one) or directly in the ROM development thread. Thank you!​
    Supporters: If you want to be put on or off the list, just make a request here in the thread!​
    Before posting anything, I strongly advise you to read

    Please look for a similar thread when visiting another device forum.
    If you would like to create a [Help Thread] please Click Here.

    6
    Models
    A6Y2721P Premium 2G+32G-P
    A6YTY721P Premium 2G+32G-P for Select Toyota/Subaru
    A6Y2721PB Premium 2G+32G-PB
    A6Y2721PRB Pro 2G+32G-PRB (No Gesture sensor)
    A6Y2721PRB-G Pro 2G+32G-PRB-G
    A6Y2710S Standard 1G+16G-S
    A6YTY710S Standard 1G+16G-S(Toyota)
    A6Y2710SB Standard 1G+16G-SB




    [Video] ATOTO A6 AICE OS 9.4 firmware update


    Two hidden menu reachable. This two is named "OEM Settings". One is for mic adjustment, and one for other things.

    Just go to "Setting" -> "About device" . In there tap some times the "Model Number", I think, or an other. I can't remember, what exatly. This pickup the "OEM Settings" where You can input a password.

    The two password is 1238 for MIC settings, and 1617 for other hidden settings.
    No other hidden setting menu, just this two.
    3
    Official Site
    http://www.myatoto.com

    Amazon link

    Links for updates and support
    http://support.myatoto.com Official - 07 Jan 2019

    9.7 version for A6Y2721PB

    ATOTO AICE OS 9.6 for A6 Series is now available for download - 2019-11-07

    9.5.1 Firmware mirrors - 19 Jan 2019

    Firmware 9.4 Info - 27 June 2019

    Firmware Update AICE 9.3 Info - Released
    3
    Thank you for answering i install emil head unit reloaded but when i connect with usb cable or with wifi i have a blackscreen....after few seconds return to home screen...i suppose is a dpi resolution issue? Have you same problem?

    Hi maurizyo, it happened to me as well when I was trying emil's hur. What seems to work for me is close everything (clear recent open apps) and do the speed-up feature of atoto (swipe down from notification). Also, looks like I had an issue with usb cable at that time. I was using some cheap usb cable from amazon, but when I tried the usb which came from my samsung, everything is smooth.

    With wifi, you need to setup your phone as hotspot and connect atoto a6. This works for me but preferred the cable as it opens up as soon as I connect the phone.

    ---------- Post added at 05:46 PM ---------- Previous post was at 05:43 PM ----------

    Guys, for quick charge, have you tried opening the quick charge app installed by default in atoto? You may need to select standard vs quick charge to make the quick charge work.
    3
    Hello guys, i have a big problem with bluetooth dialer, when i say "ok google" voice command, work only for maps and apps but don't call, don't write messages...
    I look for an apk that interface google and native dialer and i found tmc dialer...so this apk don't work on this atoto chipset version.
    Have you fixed that? Calling someone with hands free is primary.
    Thank you in advance

    Hi maurizyo85, I suggest you install headunit reloaded (Android Auto Emulator) by Emil for hands free voice calling. I have google assistant installed on Atoto A6 too but all it does is voice command to open apps or search/navigate. I even have the Atoto steering wheel control installed but it has simple functionality:
    - media next/prev (does not even have a play/pause),
    - end and answer button (but will no way to at least a function to re-dial previous call)
    - volume up/down
    - voice command button (I have it assigned triggers google assistant but no beep sound to determine that assistant is activated). Again, i have it useful for opening app like "play my private on <spotify>" or navigate to nearest gas station. I have it to work as well on my smart devices at home like "Turn on my living room lights". Again no voice command or hands free calls. Edit: Hands-free/Remote Mic Button call works as long as Atoto is not connected to internet, so either you give up internet on Atoto to gain voice call or access internet without it.

    So I end up using Emil's Headunit reloaded to run Android Auto and it works fine with voice command:
    - Call someone like "Ok google, call home"
    - Smart device "Ok google turn on dining room"
    - navigate "ok google navigate to nearest gas station"

    So far that 3 above are the most frequently used for me so I end up with Android Auto.

    Hope this helps.