[Help Thread][Google Pixel 3 XL](2018) Ask Any Question, Noob Friendly

note-script

New member
Nov 16, 2020
4
0
0
FAILED (remote: 'Not allowed to flash (modem_a)')

Just installed the latest platform-tools
Still receiving FAILED (remote: not allowed to flash (modem_a))

Edit: I was able to sideload and took care of the issue. Thanks
I encountered the same mistake as you. How did you solve it? Look forward to your reply.
 

Risingsunn

Member
Jul 26, 2009
22
4
23
Good afternoon all,
I acquired my Pixel 3 XL second hand and already running Android 11. Everything on the phone works great, EXCEPT that the Bluetooth range is under 2 feet. I have spent hours pouring through the forums to find an answer (so yes, I have done my due dilligence;)). I have tried factory resetting the phone, resetting the play store, clearing the cache, tweaking Bluetooth settings in Dev Options, but nothing seems to work. I know my headset is not the issue as it has great range on my older Galaxy S6. I know I may have missed something though, but I have all but given up hope of getting it corrected. I am thinking about possibly going to a custom ROM to see if that would work.
My question is would a custom ROM have the same Bluetooth issues? Obviously, if it is hardware, then a new ROM will not make any difference, I just want to get as much info as possible before I jump into flashing it.
Any help would be appreciated. Thank you in advance.

Josh D

EDIT: So I flashed to latest Lineage 18, and no luck. The Bluetooth range is still 2-3 ft before it starts stuttering. For grins and giggles, and since I read that people started having the issue after the first android 10 updates, I flashed all the way back to the second Android 9 stock ROM available, still no luck. So my issue seems like a hardware problem. Really bums me out, I was loving it too. First used phone I have had that I did not feel the need to install a custom ROM on. ¯\_(ツ)_/¯ C'est la vie.
 
Last edited:

digitalmatrixio

Senior Member
May 20, 2008
68
0
26
CT
Any suggestions on how to successfully 'fastboot flashing unlock'? I can issue the command and select the option on the phone to unlock but then the screen blanks for 10 minutes before sending me back to the bootloader with the phone still locked.

Back story:
After this month's patch my 3 XL started rebooting daily. I Went through and cleared out a ton of apps to no avail. Completed a factory reset and did NOT allow Google to restore the phone and with no additional apps installed only automatically updating the ones on the base install with it still rebooting daily. Once I realized this was potentially going to be an issue with something in the image I selected the option to allow unlocking in dev settings.

More details about the issue:
When getting into the bootloader and issuing the 'fastboot flashing unlock' the device appears to operate normally - I press a vol key to select to unlock and press power then the screen goes blank. I immediately lose USB access from the computer (device disconnect but no device reconnect sound) but the screen stays blank for about 10 minutes before it goes back to the bootloader and indicates that the device is still locked but displays no error. If I just boot the device at that point it is clear that the wipe of user data step of the unlock was successful as it needs to be set back up again. This is a device I received new from Google this past August via RMA and it has never been unlocked but I am very familiar with the process as I had all of the Nexus phones and was very into using custom ROMs back in those days.

Thank you in advance for any assistance.