[Help Thread][Oneplus 7] Ask Any Question, Noob Friendly

Search This thread

strongst

Senior Moderator - Developer Committee
Staff member
Sep 18, 2007
13,433
17,022
thank's
HTC Desire
Smart Watches
to be honest i cant recall which guide i used because i did the change from h20 to oxygen then updated from 10 to 11 and lost root and i think it was the fastboot flash that got me past that issue and the magisk_patched_rccmg is what i had saved on computer. and the tool_all_in_one_2.0.1.4 along with twrp 3.4.0-11-enchilada but i lost twrp when i updated so i think i updated on the phone with a stock android 11 img from one plus 7's web site.
maybe you can try again using this guide?
 

GuruDude

Member
Apr 27, 2014
16
0
Folks, I have Android 10 (Oxygen) on guacamoleb, rooted with magisk, twrp.
Two Qs:
1. What's the best way to upgrade to Android 11?
2. Should I wait for Android 12 instead? How long then (estimate)?

Thanks!
 

strongst

Senior Moderator - Developer Committee
Staff member
Sep 18, 2007
13,433
17,022
thank's
HTC Desire
Smart Watches
Folks, I have Android 10 (Oxygen) on guacamoleb, rooted with magisk, twrp.
Two Qs:
1. What's the best way to upgrade to Android 11?
2. Should I wait for Android 12 instead? How long then (estimate)?

Thanks!
For updating you can start here, a Android 11 TWRP can be found here.
I did not test the Updating from 10 to 11 with TWRP cause there was no TWRP available at the time hence the guide is as shown:)
 

shemeer2ki

Member
Dec 21, 2014
15
1
I have a issue after rooting my OnePlus 7 the sensors are not working not one all of them are not working .I did flashing the stock rom and did flash a custom rom nothing works.i saw this problem on Mi phone they have a solution on that phone like persist.img flashing.if one plus have solution like that please provide.please
 
I have a issue after rooting my OnePlus 7 the sensors are not working not one all of them are not working .I did flashing the stock rom and did flash a custom rom nothing works.i saw this problem on Mi phone they have a solution on that phone like persist.img flashing.if one plus have solution like that please provide.please

Read in OP > specific threads & guides for oneplus7 , try flashing the stock rom to reset your device etc..

https://forum.xda-developers.com/t/...ck-twrp-factory-image-stock-recovery.3930861/

https://forum.xda-developers.com/t/...l-to-restore-your-device-to-oxygenos.3954325/

https://forum.xda-developers.com/t/oneplus-7-rom-ota-oxygen-os-repo-of-oxygen-os-builds.3937152/
 
May 12, 2022
5
3
My notification slider does not work now, sliding doesn’t make a response, is it something about the persist partition?
Hey! I'd love to know if you have an answer for that, I'm facing a very similar issue. However, my GYROSCOPE/Rotation sensor is absent as well.

I've read on the fixes related to persist.img but I'm wondering about the specificities since I have a T-Mobile OnePlus 7 Pro that was converted to International firmware (Android 11), so I'm unsure which version of the persist to flash.

There's also the question of L1... will flashing persist.img block us at Widevine L3?

I'll let you know if I find anything, can you do the same? Good luck!
 

Prinçe çharming ap

Senior Member
Dec 30, 2018
226
54
India
OnePlus 7
Hey! I'd love to know if you have an answer for that, I'm facing a very similar issue. However, my GYROSCOPE/Rotation sensor is absent as well.

I've read on the fixes related to persist.img but I'm wondering about the specificities since I have a T-Mobile OnePlus 7 Pro that was converted to International firmware (Android 11), so I'm unsure which version of the persist to flash.

There's also the question of L1... will flashing persist.img block us at Widevine L3?

I'll let you know if I find anything, can you do the same? Good luck

Hey! I'd love to know if you have an answer for that, I'm facing a very similar issue. However, my GYROSCOPE/Rotation sensor is absent as well.

I've read on the fixes related to persist.img but I'm wondering about the specificities since I have a T-Mobile OnePlus 7 Pro that was converted to International firmware (Android 11), so I'm unsure which version of the persist to flash.

There's also the question of L1... will flashing persist.img block us at Widevine L3?

I'll let you know if I find anything, can you do the same? Good luck!
Look you can just write the persist partition in twrp shell by this command

dd if=/sdcard/persist.img of=/dev/block/platform/soc/1d84000.ufshc/by-name/persist

And now if the reboot
Your sensors will work fine

Just make sure to copy persist.img partition in your OnePlus device root folder.

You can get your persist.img from your own device ota zip by decrypting it using payload dumper

And about that widevine L1 it will get fixed by ota.
 
  • Like
Reactions: Dashrendar2507
May 12, 2022
5
3
Look you can just write the persist partition in twrp shell by this command

dd if=/sdcard/persist.img of=/dev/block/platform/soc/1d84000.ufshc/by-name/persist

And now if the reboot
Your sensors will work fine

Just make sure to copy persist.img partition in your OnePlus device root folder.

You can get your persist.img from your own device ota zip by decrypting it using payload dumper

And about that widevine L1 it will get fixed by ota.

Thank you so much, Charming, I had already tried that without success. I'll try again.

However, I downloaded the full OTA.zip from oneplus, extracted it, but there's no persist file. See image below:

1658419742562.png


The file is used is this one: https://www.oneplus.com/ca_en/support/softwareupgrade/details?code=PM1574156267635.

Is there something I'm not understanding? Your help is really appreciated.

Thank you!

EDIT: I should also mentioned that I tried the same process with the OTA from my device (downloaded using Oxygen Updater), and the persist file is still not there.
 
Last edited:

Prinçe çharming ap

Senior Member
Dec 30, 2018
226
54
India
OnePlus 7
Thank you so much, Charming, I had already tried that without success. I'll try again.

However, I downloaded the full OTA.zip from oneplus, extracted it, but there's no persist file. See image below:

View attachment 5665493

The file is used is this one: https://www.oneplus.com/ca_en/support/softwareupgrade/details?code=PM1574156267635.

Is there something I'm not understanding? Your help is really appreciated.

Thank you!

EDIT: I should also mentioned that I tried the same process with the OTA from my device (downloaded using Oxygen Updater), and the persist file is still not there.
Don't worry i will upload OnePlus 7 device persist partition soon when i will be home
 

Prinçe çharming ap

Senior Member
Dec 30, 2018
226
54
India
OnePlus 7
Thank you so much, you are a life saver!

Is the persist for the OnePlus 7 and the OnePlus 7 Pro the same? I have the OnePlus 7 PRO.

Thanks again so much for your help, it's really appreciated!
Indeed for OnePlus 7 pro it will be different and since i don't have pro version so i think i won't be able to find this partition.ask someone who have OnePlus 7 pro and ask him to pull that partition and that will work on your device 😶
 

fr_arnob

Member
Jul 13, 2022
13
6
I was trying to flash Pixel Experience 12 on my oneplus 7 when I faced a weird issue that i never faced before...when i put my phone in fastboot mode..PC recognizes my phone in 'fastboot devices' command..but returns empty when in ' adb devices'..which means it detects the fastboot but not adb..as a result im unable to sideload through adb....
 

fr_arnob

Member
Jul 13, 2022
13
6
I was trying to flash Pixel Experience 12 on my oneplus 7 when I faced a weird issue that i never faced before...when i put my phone in fastboot mode..PC recognizes my phone in 'fastboot devices' command..but returns empty when in ' adb devices'..which means it detects the fastboot but not adb..as a result im unable to sideload through adb....
Its to be noted that...
1. Usb debugging was enabled.
2.I have installed Oneplus USB drivers..device manager shows it as "Oneplus Android Bootloader Interface"
 
Its to be noted that...
1. Usb debugging was enabled.
2.I have installed Oneplus USB drivers..device manager shows it as "Oneplus Android Bootloader Interface"



Try to "disable driver signature" (permanently / enforcing) ..
https://www.howtogeek.com/167723/ho...8.1-so-that-you-can-install-unsigned-drivers/
_ Set up system-wide adb & fastboot : https://technastic.com/system-wide-adb-fastboot-windows-10/
[not needed android SDK, minimal adb & fastboot is enough, 0.98mb]
https://forum.xda-developers.com/t/tool-minimal-adb-and-fastboot-2-9-18.2317790/
* (or Install "platform-tools" from Google : https://developer.android.com/studio/releases/platform-tools )
_ https://wiki.lineageos.org/adb_fastboot_guide
* Or this tool: https://forum.xda-developers.com/t/...vers-15-seconds-adb-installer-v1-4-3.2588979/
_ Qualcomm HS-usb Qdloader 9008 driver ( qualcomm Qdloader driver helps in detecting the device when it is connected to pc in EDL mode or download Mode - x32/64bit)
https://gsmusbdrivers.com/download/qualcomm-hs-usb-qdloader-9008-driver-64-bit-windows/
_ Also,try a different usb port (sometimes 2.0 works "correctly" than 3.0), maybe & different USB cable , check the device manager (for any device & update if needed) etc ...
[ for your convenience you can use this useful very small and easy tool, and it will do all the work for you. Just follow the instructions. It will disable signing, install google drivers, and qualcomm drivers & works on any device,not only in Xiaomi]
https://www.mediafire.com/file/c1fflk7xvpkcr8d/xdi_1.0.3.exe/file
... after installing drivers,reboot your pc !
__ * From #297 : "PC recognizes my phone in 'fastboot devices' command etc " ...
Fastboot does not require usb debugging to be enabled on the device (not absolutely), the problem is your drivers and installing them correctly , that's why there is the problem with adb ...

sry for english (y)
 
Last edited:

fr_arnob

Member
Jul 13, 2022
13
6
Try to "disable driver signature" (permanently / enforcing) ..
https://www.howtogeek.com/167723/ho...8.1-so-that-you-can-install-unsigned-drivers/
_ Set up system-wide adb & fastboot : https://technastic.com/system-wide-adb-fastboot-windows-10/
[not needed android SDK, minimal adb & fastboot is enough, 0.98mb]
https://forum.xda-developers.com/t/tool-minimal-adb-and-fastboot-2-9-18.2317790/
* (or Install "platform-tools" from Google : https://developer.android.com/studio/releases/platform-tools )
_ https://wiki.lineageos.org/adb_fastboot_guide
* Or this tool: https://forum.xda-developers.com/t/...vers-15-seconds-adb-installer-v1-4-3.2588979/
_ Qualcomm HS-usb Qdloader 9008 driver ( qualcomm Qdloader driver helps in detecting the device when it is connected to pc in EDL mode or download Mode - x32/64bit)
https://gsmusbdrivers.com/download/qualcomm-hs-usb-qdloader-9008-driver-64-bit-windows/
_ Also,try a different usb port (sometimes 2.0 works "correctly" than 3.0), maybe & different USB cable , check the device manager (for any device & update if needed) etc ...
[ for your convenience you can use this useful very small and easy tool, and it will do all the work for you. Just follow the instructions. It will disable signing, install google drivers, and qualcomm drivers & works on any device,not only in Xiaomi]
https://www.mediafire.com/file/c1fflk7xvpkcr8d/xdi_1.0.3.exe/file
... after installing drivers,reboot your pc !
__ * From #297 : "PC recognizes my phone in 'fastboot devices' command etc " ...
Fastboot does not require usb debugging to be enabled on the device (not absolutely), the problem is your drivers and installing them correctly , that's why there is the problem with adb ...

sry for english (y)
I have installed roms before and this was not an issue...i just had my SSD replaced and windows reinstalled..I have installed the drivers, disabled driver signing enforcement, installed Qualcomm usb drivers etc.... fastboot recognizes but adb doesn't...quite the opposite of what most people face..also msm tool works..only ADB doesn not...
Also..adb works when the phone is booted..adb doesn't work only in fastboot
 

Attachments

  • received_428991395985106.jpeg
    received_428991395985106.jpeg
    44.4 KB · Views: 6

Top Liked Posts