[HELP] Unable to unlock bootloader on POCO F1? Stuck at 99%!

Search This thread

Fireblaze15

Senior Member
Apr 18, 2014
91
57
www.youtube.com
I wanted to try out LOS16 so I have to unlock my bootloader first. I am running MIUI10 Global Beta 8.11.15
I already have unlock rights from Xiaomi. Enabled USB Debugging, OEM Unlocking, added device to account for unlocking, Find my device is ON, and synced.
When I try to unlock it using the MiUnlock tool, it gets stuck at 99% without any error. I have waited over 15mins but it does not proceed. I have also tried signing out of Mi account and relogging in. It did not help either. I read a lot of forum articles and threads, read somewhere that this might be the issue of this particular beta version. So I tried going back to Global Stable using updater, but it won't allow me to do so and asks me to unlock bootloader and flash via fastboot. So I'm kinda stuck here.

Screenshot attached - https://imgur.com/a/G6mb9kG
Any help would be appreciated.
Thank you.
J0LmbtQ.jpg
 
Last edited:

Kishorehiran

New member
May 24, 2022
1
0
Iam also having this problem what should I do now I factory reseted and changed mi account it's not working stuck on 99% miui global