• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Help with fastboot mode.

Search This thread

darkstay

Member
May 8, 2009
29
9
Hello, I have Xperia neo - Vodafone and im having some troubles with fastboot mode.
I cannot put my phone on this mode:
I tried in windows, with some various drivers, none worked, i never got the blue light, always green.
I tried in linux, same result.
Is not a driver problem, i think, i can get fastboot working with htc desire pretty easy.
I have read some post and some people say some xperia neo cant put fastboot mode:
http://unlockbootloader.sonyericsson.com/which-phones
So i could flash with other ROMs my phone with some flash utily, my doubt is: If this program can flash with other rom my phone, how it works? this program uses a self terminal and run this commands??? how it does???

Any idea how to unblock my fastboot???
Thanks alot.
 

renes2

Senior Member
Oct 16, 2011
71
7
DU
Ehhm, you know that you have to hold the LEFT! hardware button?
1. Battry out
2. Press the left button and hold it
3. Battery in
4. Plug USB Kabel in
5. Blue light turns on
 

darkstay

Member
May 8, 2009
29
9
you are asking if i am pressing menu button(which is the RIGHT one of the 3 buttons) to enable fast boot????
-Yes, i am pressing the menu button while connecting the phone to the computer, also tryed your steps with the battery.
 
Last edited:

renes2

Senior Member
Oct 16, 2011
71
7
DU
Yeah, you must press the LEFT Button, not the RIGHT one!

Right Button = Recovery Menu
Home Button = nothing
Left Button = Fastboot Mode
 

taaviu

Senior Member
Jan 11, 2010
2,123
755
Tallinn
OnePlus 9 Pro
LEFT button for flashtool (green LED)
RIGHT buttor for fastboot or ADB. (blue LED)

IF dont work try reinstall drivers, safemode PC, another Pc.


Regards!
Taavi

Sent from my MT15i using Tapatalk
 

darkstay

Member
May 8, 2009
29
9
LEFT button for flashtool (green LED)
RIGHT buttor for fastboot or ADB. (blue LED)

IF dont work try reinstall drivers, safemode PC, another Pc.


Regards!
Taavi

Sent from my MT15i using Tapatalk

Tryied with some OS in the same pc, tryied with other mobile(htc desire) and worked , so i think inst a drivers problem. I think its more likely the fastboot its disabled or something.
 

taaviu

Senior Member
Jan 11, 2010
2,123
755
Tallinn
OnePlus 9 Pro
Tryied with some OS in the same pc, tryied with other mobile(htc desire) and worked , so i think inst a drivers problem. I think its more likely the fastboot its disabled or something.

For HTC and for SE you need DIFFERENT drivers i think ;)
I had to desire and already working adb....but this dont work with SE.
After i installed drivers for SE all was right.


Regards!
Taavi

Sent from my MT15i using Tapatalk
 
  • Like
Reactions: renes2

hmonteiro

Member
Oct 16, 2011
9
1
Fastboot won't work here either

I'm not being able to fastboot either.

I successfully unlocked the bootloader and rooted my Xperia Neo, as described in

http://forum.xda-developers.com/showthread.php?t=1194823

It had 2.3.3 when i ran that process. After that i already upgraded OTA and right now it has 2.3.4. The phone is still rooted.

Right now, no matter what i try i cannot boot into fastboot mode. I have tried several drivers, i have tried on windows and i have tried on linux. I even tried using Xperia Reboot app but the result was the same. It either boots regularly or it boots into "charging mode" and all i get is the green light.

Please advise.

Thank you in advance.
 

darkstay

Member
May 8, 2009
29
9
hmonteiro, just the problem i have.
I also have 2.3.4 rooted.
I think it comes blocked by default and we need to unblock the fastboot mode, dont know how....
 

hmonteiro

Member
Oct 16, 2011
9
1
After reading a few scattered posts, i'm starting to believe the reason it's not working is because my phone is network locked.

Does anyone know if it's possible to unlock the bootloader of a network locked Neo, after removing the network lock?
 

hmonteiro

Member
Oct 16, 2011
9
1
In order to get fastboot working you need to remove the SIM lock first. I was able to do it with the service provided by Alejandrissimo
Although a but tricky to maintain the tespoint connected, it went smoothly and Alejandrissimo was there all the way.
I have not yet installed anything but i can confirm that the fastboot program now sees the device and i do get the blue light right after plugging the phone to the computer.
Hope it turns out ok for you too! :)
 
Last edited:
  • Like
Reactions: Alejandrissimo
T

testadeferro

Guest
Try to use omnius, google it. Then you have both ready, sim unlock and bootloader.
For sure and for 15 euros.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Tryied with some OS in the same pc, tryied with other mobile(htc desire) and worked , so i think inst a drivers problem. I think its more likely the fastboot its disabled or something.

    For HTC and for SE you need DIFFERENT drivers i think ;)
    I had to desire and already working adb....but this dont work with SE.
    After i installed drivers for SE all was right.


    Regards!
    Taavi

    Sent from my MT15i using Tapatalk
    1
    In order to get fastboot working you need to remove the SIM lock first. I was able to do it with the service provided by Alejandrissimo
    Although a but tricky to maintain the tespoint connected, it went smoothly and Alejandrissimo was there all the way.
    I have not yet installed anything but i can confirm that the fastboot program now sees the device and i do get the blue light right after plugging the phone to the computer.
    Hope it turns out ok for you too! :)