[HELP!] Wrong kernel ruined my IMEI & fastboot getvars!!! How can I restore?

Search This thread

qsmyle

Senior Member
Jun 21, 2010
392
48
matedon.com
Dear Fellows!

I have taken a very lame mistake.
I have looked arround the entire web for a HTC Sensation kernel which supports OTG with JellyBam ROM. I found a forum with a working, good kernel but I havent noticed that it is not HTC. It was a @&# kernel for SGS II. There was nothing wrong with the new kernel but I have noticed I can not to register my SIM card. ... Some time later I checked the fastboot getvar entries and I found a very very very big problem. Mi IMEI is modified!

Here is my current fastboot getvar stuff:
Code:
Microsoft Windows [verziószám: 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Minden jog fenntartva.

c:\android-sdk-windows\tools>fastboot.exe getvar all
(bootloader) version: 0.5
(bootloader) version-bootloader: 1.27.1100
(bootloader) version-baseband: 11.24A.3504.31_M
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 3.33.401.106
(bootloader) serialno: SH16GV815084
(bootloader) imei: 355195000000010
(bootloader) product: pyramid
(bootloader) platform: HBOOT-8260
(bootloader) modelid: PG5813000
(bootloader) cidnum: 11111111
(bootloader) battery-status: good
(bootloader) battery-voltage: 3784mV
(bootloader) partition-layout: Generic
(bootloader) security: off
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: 617f0a98
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0
all: Done!
finished. total time: 0.491s

c:\android-sdk-windows\tools>

But I have a previous state (from the first fastboot action when I have S-OFFed my Sensation):
Code:
c:\fastboot>fastboot.exe getvar all
< waiting for device >
INFOversion: 0.5
INFOversion-bootloader: 1.27.1111
INFOversion-baseband: 11.24A.3504.31_M
INFOversion-cpld: None
INFOversion-microp: None
INFOversion-main: 1.24.401.1
INFOserialno: SH16GV815084
INFOimei: 3564xxxxxxx05
INFOproduct: pyramid
INFOplatform: HBOOT-8260
INFOmodelid: PG5813000
INFOcidnum: HTC__032
INFObattery-status: good
INFObattery-voltage: 3934mV
INFOpartition-layout: Generic
INFOsecurity: off
INFObuild-mode: SHIP
INFOboot-mode: FASTBOOT
INFOcommitno-bootloader: 617f0a98
INFOhbootpreupdate: 11
INFOgencheckpt: 0
all: Done!

I have tried many things without success. I tried to reflash the firmware with KGS Utility 8.0, rewrite the cidnum with it, without success. How the hell could I get the factory variables? Anybody has an idea?

Thank you!

A very desperate guy.
 

qsmyle

Senior Member
Jun 21, 2010
392
48
matedon.com
Finally I got the solution. Very very very big thanks for ganesh!
dhanyavad ganesh
Restoring RUU doesn't solve the IMEI problem.
The solution is much more complex than I could write it down.
Be aware of installing uncompatible stuff for your device.
 

moj2911

Member
Apr 27, 2014
27
3
same situation.. help!!

Hi guys,

I'm in the same situation :( I have a HTC sensation and flashed a rom but for some reason my IMEI has changed to a generic one and I can't use my SIM card, all other functions are working though. My phone is S-OFF but the bootloader is locked.

For those of you who found the fix, can you please let me know too? PM is fine.

Thanks in advance!!
 

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone