[Hisense A5] Root & Gapps Customizer R05 - 06.10.04.00

Search This thread

Bassiehetkoekje

New member
Jan 9, 2022
2
0
I've tried multiple times to follow the steps outlined in the OP, as well as following https://www.chinahandys.net/hisense-a5-playstore-guide-english/ (based on this thread). I get into bootloop after flashing with Magisk every time (I can see that the flashing doesn't succeed to the end). I think it has to do with the Magisk update...

Is it still possible to get Gapps? Anyone having the same problem as me? I'm kind of a noob at this.
Never mind, it just worked on the 3rd try!!!
Things I did differently:
- kept WiFi on all the time
- updated only companion app for Magisk, and the pressed 'install' as well after reboot (for good measure)
 

artelse

Member
Jan 11, 2022
10
2
Trying to root my A5 but after entering the edl step with device found, get stuck on the QFIL step showing No Port. I tried reinstalling the Qualcomm drivers and such, but nothing opens the port.
Anyone has an idea how to get this resolved? Thanks much for any hints!
 

wishindo

Member
Feb 20, 2018
7
1
In case anyone needs it, I put at drive.google.com/open?id=1JBzsFrtGtIXLYTPTMA2cc9spp_dxF_WX the firmware I used to unbrick the phone.

Sorry for the badly formatted link, but I am a new user and as such cannot post links yet.

---------- Post added at 07:42 AM ---------- Previous post was at 07:41 AM ----------

Does anyone know how I could fix the permissions problem for GSF though? I would really like to get Android Auto to work...

OneDrive mirror for Google Drive link above: https://1drv.ms/u/s!AjVHFMyZ7cn7irNj9za-z89B7aCKRw?e=q5aFqb
 

nebulosiz

New member
May 4, 2022
1
0
hoping someone can help out / clarify somethings for a newb--let me know also if it's better to make a new thread

I successfully followed the instructions at chinahandys (I also ran into the updating imagemagisk, bootlooping, but was able to solve by reflashing from TF and only updating imagemagisk once, to v22 I think?), but I've been trying to remove the bloatware with TitaniumBackup, which is reporting that it doesn't have root access. rootchecker says the same.

AFAIK, the kit should've given root--am I misunderstanding something? Any way to get root access? I mostly want it to remove probably spyware/bloatware. Other ways to get both gapps and cleanout bloatware would also be appreciated.
 

Thang2022

New member
May 23, 2022
2
0
I have an international Firmware and copied the latest chinese Firmware 6.09. to the microSD, but I am not able to enter the TF-Mode, tried it many times with the guide here.
https://forum.xda-developers.com/showpost.php?p=82575517&postcount=21
Ther's just the Hisense Logo and "powered by Android". Anybody an idea what I can try to force the flashing?
Hello everyone.

I have the same problem.

I bought a Hisense A5 in AliExpress.
Firstly, it worked properly.

After some weeks, when I turned it on, it just displayed the Hisense logo (the black text) in the white screen.

I tried to turn the Hisense A5 off and on many times, but it was still the same problem.

I have never installed any firmware to any Android smartphones by myself.

This is the first time in my life that I have faced this problem.

Is there any advice for me ???

Thank you very much.
 

Thang2022

New member
May 23, 2022
2
0
HLTE202N (Hisense A5) official TF mode packages are here:
https://fans.hisense.com/thread-171079-1-1.html

Seems you need to create an account to get the files.

However, as long as you can boot under TF mode, the phone will automatically flash this package. It's worth trying, but that means that in theory, you can unbrick your phone or return back to stock with this file, as long as you have TF mode.

@gowin132 managed to unbrick his phone after Magisk upgrade on his phone that put it under bootloop.

For flashing instructions, here is what I found on Internet:
Upgrade method:
Use T card to upgrade.
(1) Upgrade notes:
1. The upgrade operation will clear all the non-factory preset user information in the mobile phone. Please save important information in advance.
2. Make sure that the battery power is sufficient. It is recommended that the battery has at least 50% power to avoid interruption of the power during the upgrade process and cause the upgrade to fail.
(2) Preparations before T card upgrade:
1. Prepare a TF card, first format the TF card into FAT format;
2. Unzip the downloaded product software version (usually a compressed package and divided into multiple compressed sub-packages), and copy the resulting folder named "HLTE202N_TF" to the root directory of the TF card;
3. Insert the TF card into the mobile phone and put the battery into the mobile phone. Confirm that the battery charge is greater than 50%, if the battery charge is low, please charge first;
(3) T card upgrade process
1. Hold down the two side keys "Volume +" and "Volume-" at the same time, then press the power button, the phone will automatically enter the T card upgrade mode for upgrade, if the phone does not enter the T card upgrade mode, please shut down Then repeat the operation.
2. Wait for about 5 minutes for the upgrade to complete, and a prompt for successful upgrade will be displayed.
3. Restart according to the prompt after the upgrade is successful. If there is no such prompt, press and hold the power button for more than 20 seconds to restart. The first boot after the upgrade will take a long time, which is several times the normal boot time.

@joygram Are you able to confirm if this is correct what I am saying? Thanks


Edit: Oooops, similar post than @zizicici . At least it has flashing steps. I'll keep it.
Hi everyone.

I successfully followed the steps here.

I just want to add that :

Instead of :

(3) T card upgrade process
1. Hold down the two side keys "Volume +" and "Volume-" at the same time, then press the power button,

You will need to :

Hold down the two side keys "Volume +" and "Volume-" as well as the power button simultaneously.

It means that you will need to hold down 3 buttons at the same time : Volume + , Volume -, Power button.


However, after I successfully installed the firmware (as mentioned above), I find that it doesn't have Google Play Store.



Can anyone here who can share the firmware for Hisense A5 with Google Play Store and multi-language support?????

I will be deeply grateful for it.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 18
    R05 support 06.10.04.00
    - unfortunately, if you already root with previous version.
    - you need rollback to original firmware.
    - you can rollback with TF package 6.09.06
    - update ota to 06.10.04.00
    - flash QFIL R5 customizer

    - if you have 06.10.04.00 original firmware
    - you can flash QFIL R5

    A5 customizer R5
    https://1drv.ms/u/s!AhwV6fFJV9sZrjAFyRawK-_ON9AK?e=jq7M44



    ** include original boot / recovery **
    if you want recover (when bricked in edl)

    you can recover with original flashing package and hisens's TF package(SD card updater)
    original_6.09.06

    A5-customizer-R04.7z
    https://onedrive.live.com/redir?resid=19DB5749F1E9151C!5934&authkey=!AD9UE8XlDjST_zQ&e=YhfVvD

    ** How to root Hisense A5 **

    prerequisite
    * QPIL installed PC
    install qualcomm driver
    install QPST 2.7.474

    A5 firmware version 6.09.06.00

    should be `6.09.06` or bricked. (only unbrick method is tear down phone and edl jump)


    flush root image with QFIL
    * enter edl mode

    open developer mode
    search settings `kernel version' and go
    tab 7 or more : developer options enabled

    * enable usb debugging
    change USB computer connection to Transfer files(MTP)
    use adb command
    adb reboot edl

    * flush ROOT files with QFIL : QFIL_6.09.06
    Select Build Type : Flat Build
    Select Programmer : select
    prog_emmc_firehose_8937_ddr_000bf0e1.mbn
    LoadXML:
    rawprogram_000bf0e1_joygram
    Download
    when complete please reboot the device.


    * install magisk manager
    MagiskManager-v7.5.1.apk

    * install and run then manager lead you.


    after Root success you can install magisk module with magisk manager.
    then you can use gapps :)

    here is minimal gapps module

    [A5] Gapps minimal R07 (Magisk Module)
    https://onedrive.live.com/redir?resid=19DB5749F1E9151C!5907&authkey=!AHVpUKf9sHCcClE&e=clBYPX


    happy reading :)
    5
    Experiences rooting HiSense A5 with GApps

    I thought I'd share my experiences with rooting the HiSense A5, changing the launcher, installing GApps, and cleaning up a bit of the crap that is installed on the phone.

    Following the guide posted at the top of this discussion takes a couple of minutes, and really works. If you botch it for whatever reason, don't worry, just reflash the original firmware from a micro-SD, and you will be ready for the next round in about five minutes :)

    At the end of the rooting process, via Magisk you do get honest to God working Google Play. I have to admit I almost teared up a bit when I saw it working. GMail, GMaps, calendar, everything does what it's supposed to do. I also put Slack, MS Teams, Meets, and used them extensively to full satisfaction. This phone is now the best I have ever had.

    Spotify works, and it also casts correctly to Chromecast. No idea if Google Home was required, but I did install it anyway.

    I dislike the standard launcher, so I went with Microsoft Launcher (ok, I admit it: I like it. There, I said it!). It works perfectly, and the phone feels .

    Keep in mind that I bricked the phone multiple times by attempting to uninstall the preinstalled apps. I simply gave up, and decided rather to disable them. Much more success, and they are all prevented from running at the moment, so the phone is clean and those awful things are not sending any data, nor burning any battery, but they kinda just "loom" there.

    Only minus point is that I cannot get Android Auto to work. Both Android Auto and Google Contacts complain that GSF (Google Services Framework) is missing some permissions, and I cannot grant them via adb. I am insufficiently versed in this, so if anyone is more expert, I would be willing to offer myself as a guinea pig to see if we can grant all the permissions GSF needs in order to stop complaining and to get Android Auto to work fully. If we can get to that, I cannot see anything that we cannot do with our lovely A5's.

    In any case, it was absolutely worth it to put this bit of work in this phone. It is by far and large my best phone ever, and even if I own other, conventionally nicer stuff (a new iPhone from work, for example), I enjoy the relaxing screen of the A5 beyond what I could have imagined. Thanks to all those who made this possible.
    4
    In case anyone needs it, I put at drive.google.com/open?id=1JBzsFrtGtIXLYTPTMA2cc9spp_dxF_WX the firmware I used to unbrick the phone.

    Sorry for the badly formatted link, but I am a new user and as such cannot post links yet.

    ---------- Post added at 07:42 AM ---------- Previous post was at 07:41 AM ----------

    Does anyone know how I could fix the permissions problem for GSF though? I would really like to get Android Auto to work...
    2
    Exactly, we need more details to open the device without damaging,.... I sent joygram a pm already and we need to wait.
    If the hard edl works then we need also the edl Firmware.
    Maybe someone who speaks chinese can organize the Firmware from a chinese forum maybe from here https://www.yunyaokz.com/

    While doing my initial researches, I found those tutorials about edl more flashing.

    Tutorial to backup the entire firmware using edl mode
    Tutorial to flash a single partition (hence, your stock recovery) under edl mode

    This should help, and no need for the full edl mode flashable package, you can make your own.

    In principle, those tutorials can be successfully followed by using the file "prog_emmc_firehose_8937_ddr_000bf0e1.mbn" available in @joygram 's root package and this solves the brick potential.

    Side note, after some discussion with other users, partitions signatures are checked at boot, and signatures are stored in the partition vbmeta. Recovery is one of the partition for which vbmeta checks the signatures if I understood well.

    Which means that if you modify the recovery partition, it may not boot anymore because of this wrong signature.

    There is a way to repack vbmeta using AVBTOOL. But I don't know if this would be enough (vbmeta must be regenerated with boot, recovery, vendor, dtbo images to the parameters), I never used this tool. this is pure theory.
    2
    I am using an older international Rom International Rom L1657 6.03.02.00 / Kernel 4.9.112 / Security-Updates 2019/09 (incl. Gapps by Default) which is quite near to stock and lean compared to the Chinese Rom.


    Maybe this is useful for others:
    The attached apps I could freeze in Titanium Backup without any issues.
    With Net Monitor you can check the outgoing traffic and block IPs with the attached AfWall script.
    You can check the domains ie with www.whoisip.org/ip-locator (Peking, Akamai Tech, China Telecom, Google)


    P.S.: Remove ".txt" from block_hisense.sh.txt