how to auto override force dark mode in android Q

Search This thread

[email protected]

Senior Member
Sep 26, 2016
137
45
Do you think that I can delete this line "debug.hwui.force_dark=1" and put it back in the build.prop again after reboot please ?
Because it's the first time that I've modified this system file so I'm not used to manipulating it...

Thank you in advance for your answer.
Take a copy in pc. Modify and replace. In case any problem restore old one. Use twrp or smthing similer.
 

MobAndro

Senior Member
Dec 23, 2016
55
4
Take a copy in pc. Modify and replace. In case any problem restore old one. Use twrp or smthing similer.

Hello,

After deleting this line "debug.hwui.force_dark=1" and put it back in the build.prop again, the override force dark is random because it doesn't always work.

The override force-dark disables itself. When I turn it on, it immediately turns off itself without even restarting. ALWAYS
I still don't understand what's going on...

I'm giving up and thank you for your replies.
 

MobAndro

Senior Member
Dec 23, 2016
55
4
Hello [email protected],

Sorry for the inconvenience, but I just want to know if this problem is still present in the recent versions of Android 10 and 11 please ?
If it's the case, this solution still works please ?
Because my stock ROM current is from April 2020 and I'm thinking of upgrading to Android 11.

Thank you in advance.
 

Nukutza1976

New member
Aug 27, 2019
3
1
In AOSP based android Q roms, there is a force dark option in developer settings whoich makes almost all apps to be appreaded in dark mode.
This option gets unselected after reboot.
One has to enable it after every reboot.
However it's possible to enable it by default after reboot.
For rooted phone.
Just add the following line in your build.prop file

debug.hwui.force_dark=true

Thats all.
It's working in my phone. Tested.

For unrooted Phone
execute the following line after reboot

setprop debug.hwui.force_dark true

To make it auto after reboot use tasker or script manager app or smthing similer.

Check the space after setprop and dark.

Hit a thanks to me if you are benifited.
Its working,good job
 
  • Like
Reactions: orb_selektor

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    In AOSP based android Q roms, there is a force dark option in developer settings whoich makes almost all apps to be appreaded in dark mode.
    This option gets unselected after reboot.
    One has to enable it after every reboot.
    However it's possible to enable it by default after reboot.
    For rooted phone.
    Just add the following line in your build.prop file

    debug.hwui.force_dark=true

    Thats all.
    It's working in my phone. Tested.

    For unrooted Phone
    execute the following line after reboot

    setprop debug.hwui.force_dark true

    To make it auto after reboot use tasker or script manager app or smthing similer.

    Check the space after setprop and dark.

    Hit a thanks to me if you are benifited.
    1
    In Samsung phone setprop command is diff i guess... Google it for command.

    First thanks for the answer :) , but...
    I dont think its different. The getprop command (getprop debug.hwui.force_dark) works fine, gives me true if its turned on.
    If i do the setprop command over adb (adb shell setprop debug.hwui.force_dark true) it also works fine.
    The only thing not working is the setprop command executed directly on my device. Which lets me conclude that i probably need root?
    1
    In AOSP based android Q roms, there is a force dark option in developer settings whoich makes almost all apps to be appreaded in dark mode.
    This option gets unselected after reboot.
    One has to enable it after every reboot.
    However it's possible to enable it by default after reboot.
    For rooted phone.
    Just add the following line in your build.prop file

    debug.hwui.force_dark=true

    Thats all.
    It's working in my phone. Tested.

    For unrooted Phone
    execute the following line after reboot

    setprop debug.hwui.force_dark true

    To make it auto after reboot use tasker or script manager app or smthing similer.

    Check the space after setprop and dark.

    Hit a thanks to me if you are benifited.
    Its working,good job