[How-To] Better battery life, reduce Time Without Signal.

Search This thread

abcdfv

Senior Member
Dec 13, 2009
1,242
2
Wilmington, NC
Alright, I don't remember who it was, but first off, I would like to thank the person that figured out how to check the radio mode.

UPDATE: You need to do this with the current IRC FroYo build as well.


First things first, I have personally tested this with DamageControl 1.0, with Flipz's .03 radio, and found it increased my battery life by 30-40%. I am using the stock 1500mAh battery. Please note that the option to change the preferred network type is not available in 1.5 ROMs, as 1.5 is GSM only. (HTC hacked in CDMA support)

NOTE: when you first open the testing menu, it will show it as CDMA auto (prl). This is a visual glitch, in reality, it is set to GSM auto (prl). If your TWS is around 50%, it means it's GSM auto (prl)

First things first, go into Settings> About Phone> Battery> Battery Use> Cell Standby. Assuming your phone has been on, or off the charger for ~10 minutes, it should show Time Without Signal at around 50%.

Next thing, press HOME, and bring up the dialer. Dial *#*#4636#*#* (Do not press "Call"). After a second, it should bring up the "Testing" menu.

Go into Phone Information, press MENU, and tap "select radio band." You should experience a Force Close, don't panic, this was supposed to happen. Scrolling down shows that the preferred network type is GSM auto (prl).

What this means is that even though you are connected to a CDMA network, your phone is trying to find a GSM network, preventing the radio from sleeping, and causing excessive battery drain.

Remedy this by tapping GSM auto (prl), and changing it to CDMA auto (prl).


Now your done, your TWS should drop dramatically, and you should experience much better battery life!

Note: You need to do this every time you reboot.
 
Last edited:
  • Like
Reactions: altimuh

KBizzle

Senior Member
Oct 30, 2008
4,200
4,410
Knoxville
Confirmed. I did this a week ago. Even after a couple reboots, the setting sticks. I didnt see a huge increase but that is probably me.
 

Coldheat1906

Senior Member
Jun 30, 2008
980
86
Fort Worth
Just followed your instructions but mine was already set to CDMA auto (PRL).

Thanks for the info though, I'll make sure to remind my friends to check theirs.
 

abcdfv

Senior Member
Dec 13, 2009
1,242
2
Wilmington, NC
Confirmed. I did this a week ago. Even after a couple reboots, the setting sticks. I didnt see a huge increase but that is probably me.

It doesn't actually stick. It's a visual glitch, the setting itself is still GSM auto (prl), but it displays CDMA auto (prl). First post updated to be more specific.
 
Last edited:

watzone69

Senior Member
Oct 29, 2008
1,058
52
Austin, Texas
Thanks for this! I had tried the airplane mode toggle method before but it didn't work. Looks like this fix is holding.

Now, if only there was a way to make this survive (or at least start up after) a reboot.
 

5tr4t4

Senior Member
Nov 8, 2009
122
1
As has been noted elsewhere, the application "Network" from the market also provides quick access to this setting.
 

srb7215

Senior Member
Nov 29, 2009
337
21
Columbia, Mo
OnePlus 9
I go in and make the change then I hit the home button and then go back into the Testing menu and check to see if the change stuck. After the force close it shows the GSM is still on. Is this a glitch or do I need to do something else to make it stick.
 

rjj1976

Senior Member
Nov 9, 2009
206
6
Las Vegas
I was the one that started the other thread about better battery life. Doing these steps does not help me at all. I have to go in and turn on airplane mode and then turn it off before I see my "time without a signal: start to go down.
 

abcdfv

Senior Member
Dec 13, 2009
1,242
2
Wilmington, NC
Should I assume I don't have this problem if I have no TWS showing in the battery usage?

If you're not having a problem, TWS should be 0%.

I go in and make the change then I hit the home button and then go back into the Testing menu and check to see if the change stuck. After the force close it shows the GSM is still on. Is this a glitch or do I need to do something else to make it stick.

When you Force Close, it resets back to the default.

Then don't use Spare Parts. :D

Spare what now?

hmmm, wonder if the "Time without Signal" is a visual glitch, and the "better battery life" is the placebo effect...

nah..

I would agree with you, but after about a week of testing I've come to the conclusion that the amount of increased battery life I've seen is too big of a difference to be a placebo effect.

Any established dev want to back me up on this?
 
Last edited:

crash447

Senior Member
Feb 27, 2010
140
1
#1) This is the second time I have went in to change the network and it has never showed GSM (PRL). It is always CDMA (PRL). (Otherwise the first time I ever went in it already showed CDMA.)

#2) Even though it says CDMA if I try and change it and change it back I do not get a force close.

#3) I do have TWS issues as it creeps up throughout the day, the airplane trick does seem to help some.

#4) At my work my signal strength is very low and I normally have no bars or one bar. My battery seems to drain like crazy at work.

Did not know if anyone could help me make sense out of all of this.
 

abcdfv

Senior Member
Dec 13, 2009
1,242
2
Wilmington, NC
#1) This is the second time I have went in to change the network and it has never showed GSM (PRL). It is always CDMA (PRL). (Otherwise the first time I ever went in it already showed CDMA.)

#2) Even though it says CDMA if I try and change it and change it back I do not get a force close.

#3) I do have TWS issues as it creeps up throughout the day, the airplane trick does seem to help some.

#4) At my work my signal strength is very low and I normally have no bars or one bar. My battery seems to drain like crazy at work.

Did not know if anyone could help me make sense out of all of this.
This menu button.

2l8ksas.jpg
 

crash447

Senior Member
Feb 27, 2010
140
1
Thank you, I needed that diagram since I guess I refused to read instructions two different times. I really, really appreciate it.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Alright, I don't remember who it was, but first off, I would like to thank the person that figured out how to check the radio mode.

    UPDATE: You need to do this with the current IRC FroYo build as well.


    First things first, I have personally tested this with DamageControl 1.0, with Flipz's .03 radio, and found it increased my battery life by 30-40%. I am using the stock 1500mAh battery. Please note that the option to change the preferred network type is not available in 1.5 ROMs, as 1.5 is GSM only. (HTC hacked in CDMA support)

    NOTE: when you first open the testing menu, it will show it as CDMA auto (prl). This is a visual glitch, in reality, it is set to GSM auto (prl). If your TWS is around 50%, it means it's GSM auto (prl)

    First things first, go into Settings> About Phone> Battery> Battery Use> Cell Standby. Assuming your phone has been on, or off the charger for ~10 minutes, it should show Time Without Signal at around 50%.

    Next thing, press HOME, and bring up the dialer. Dial *#*#4636#*#* (Do not press "Call"). After a second, it should bring up the "Testing" menu.

    Go into Phone Information, press MENU, and tap "select radio band." You should experience a Force Close, don't panic, this was supposed to happen. Scrolling down shows that the preferred network type is GSM auto (prl).

    What this means is that even though you are connected to a CDMA network, your phone is trying to find a GSM network, preventing the radio from sleeping, and causing excessive battery drain.

    Remedy this by tapping GSM auto (prl), and changing it to CDMA auto (prl).


    Now your done, your TWS should drop dramatically, and you should experience much better battery life!

    Note: You need to do this every time you reboot.
    1
    Which app exactly is this? I searched the Market and there are several Network apps.

    This one -> LINK

    I'm not too sure that this is a problem anymore though..
    1
    does anyone now who is the developer beacause i cant find the app in the market. nothiing under just network. also i cant get the phone code to work. any help

    have you tried this one. one post above yours?


    This one -> http://www.appbrain.com/app/network/de.mangelow.network

    I'm not too sure that this is a problem anymore though..

    Sent from my PC36100 using XDA App