• XDA Forums have been migrated to XenForo. We are aware of several issues including missing threads, logins not working, and more. To discuss, use this thread.
  • If you are experiencing issues logging in, we migrated and software and made it more secure. We recommend trying to reset your password.

How to Build new recovery modded for Zopo zp999 or 3X mtk 6595M

bluefirebird

New member
Mar 23, 2013
1,027
5,023
0
carliv.eu
The main problem for not mounting internal sdcard in cwm is that I don't know the right voldmanged number for it. Since I don't have the phone, some of you have to check in /dev/block/vold and to tell me what is the number for internal sdcard. Or make some screenshots with that folder contents and I'll try to figure out. Thanks!
 
Last edited:
  • Like
Reactions: yuweng

split52

Senior Member
Mar 24, 2012
227
117
43
Barcelona
marsapa, carliv is right, the problem is in the update-script, after some changes made by me,(a litle script) i can install in system/app, framework and priv-app perfect, without error
 

marsapa

New member
Jul 9, 2012
94
37
0
verona
marsapa, carliv is right, the problem is in the update-script, after some changes made by me,(a litle script) i can install in system/app, framework and priv-app perfect, without error
I also noticed that I installed the little things, but I can also install all the rom without errors but then did not have anything installed. however post what you have changed so as to compare
 

split52

Senior Member
Mar 24, 2012
227
117
43
Barcelona
run_program("/sbin/busybox", "mount", "/system");
package_extract_dir("system", "/system");
set_progress(0.4);
ui_print(" Setting correct permissions...");
set_perm(0, 0, 0755, "/system");
set_progress(0.6);

this not delete system, only copy you want, i will make a rom and make a best script and test it later
 

AP756

New member
Oct 4, 2007
95
31
0
Test 9: no scdard0
Test 10: scdcard0 shows as sdcard, I can move around with Aroma file manager (even if Aromafm.zip is missing on my ZP999)
Test 11: no sdcard0, cannot write to /sdcard/clockworkmod/.reovery_version on power off
Test TWRP 2: does not see anything, cannot mount External SDcard in menu Mount.

PS: My battery runs out, too much flashing ;)
 
Last edited:

bluefirebird

New member
Mar 23, 2013
1,027
5,023
0
carliv.eu
Test 9: no scdard0
Test 10: scdcard0 shows as sdcard, I can move around with Aroma file manager (even if Aromafm.zip is missing on my ZP999)
Test 11: no sdcard0, cannot write to /sdcard/clockworkmod/.reovery_version on power off
Test TWRP 2: does not see anything, cannot mount External SDcard in menu Mount.

PS: My battery runs out, too much flashing ;)
So let's recap:
CWM test 10 works (if it show sdcard0 as sdcard). - that menu from aroma file manager is internal cwm file explorer (zip chooser), a very simple file manager. It is used for find zip files, and I integrated there to be able to find aroma zip even if it's not at its place.
And twrp boots but doesn't mount external sdcard. - btw, this twrp has mtp support, doesn't appear a "Disable MTP" button?
 
Last edited:
  • Like
Reactions: codelover

AP756

New member
Oct 4, 2007
95
31
0
To confirm: Test 10 runs fine. Internal and external sdcard works. Forget about the name, doesn't matter...

For TWRP: Yes, boots (shows two nice grey arrows), but doesn't see any memory (no internal, no external). If you go into "Mount" you cannot set the cross in front of external sdcard. Using "Install" neither card is available.
Didn't see any MTP button (at least can't remember, you know I'm getting old :)). Let me know if I have to install TWRP again, just now I'm running Test 10 to search for hickups.

Will attach the last logfile from Test 10. Please rename from .zip to .log (file is not packed, just renamed)
 
Last edited:

bluefirebird

New member
Mar 23, 2013
1,027
5,023
0
carliv.eu
To confirm: Test 10 runs fine. Internal and external sdcard works. Forget about the name, doesn't matter...

For TWRP: Yes, boots (shows two nice grey arrows), but doesn't see any memory (no internal, no external). If you go into "Mount" you cannot set the cross in front of external sdcard. Using "Install" neither card is available.
Didn't see any MTP button (at least can't remember, you know I'm getting old :)). Let me know if I have to install TWRP again, just now I'm running Test 10 to search for hickups.

Will attach the last logfile from Test 10. Please rename from .zip to .log (file is not packed, just renamed)
Well, thank you very much. I'm building now a new test for cwm and one carliv touch, and I found the problem for twrp. I'll build a new test for twrp too.
I don't know how will look mounts menu in twrp with data/media internal sdcard, but for me with fat internal sdcard looks like this:
 

Attachments

AP756

New member
Oct 4, 2007
95
31
0
Well, thank you very much. I'm building now a new test for cwm and one carliv touch, and I found the problem for twrp. I'll build a new test for twrp too.
I don't know how will look mounts menu in twrp with data/media internal sdcard, but for me with fat internal sdcard looks like this:
Yes, looked identical. Except internal sdcard was missing.

PS: I like Carliv touch best. Looks cool ;)
 

bluefirebird

New member
Mar 23, 2013
1,027
5,023
0
carliv.eu
New tests (hopefully latest):

CWM test 12
CTR test 1
TWRP test 3
In short time I will post here the new links.
Here they are:
CWM test 13
CTR test 2
TWRP test 4

and the latest ones:
CWM test 14
CWM test 15
CTR test 3
CTR test 4

.
 
Last edited:
  • Like
Reactions: ghost45 and split52

AP756

New member
Oct 4, 2007
95
31
0
Test 12: trying to install a file from sdcard shows a menu containing directories -0, -legacy, -obb and -otaLogs.
-0 is identified as internal sdcard (you can see all files from internal sdcard), -legacy is empty, obb one dir named com.antutu... (empty) and -otaLogs is empty. Couldn't find a rcovery.log

CTR Test 1 boots as expected, same symptoms as with test 12: No direct access to sdcard (first you have to enter directory -0). There is an information in screen. I: Can't partition non mmcblk device: /devices/platform/mtk.msdc.1/mmc_host/mmc1. Tried to install SuperSU from the root of sdcard, works.

Additional note: I use "Dual File Manager" which shows me following directories:
/storage/emulated -> subdirectories -0 and legacy
/storage/sdcard0
/storage/sdcard1
/storage/usbotg
In addition to that I see
/sdcard
/mnt/sdcard (internal sdcard)
/mnt/sdcard2 (external sdcard)
Maybe that helps. Personally I use /storage/sdcard0 and /storage/sdcard1 to identify my cards.
 
Last edited:
  • Like
Reactions: ghost45

bigrammy

Senior Member
Apr 8, 2011
2,881
2,509
113
huddersfield
Hi @marsapa
I am not sure if you know about or have tried this powerful tool ArchiKitchen Here to help you build your flashable ROM.zip's ;)
Just run your system.img through the kitchen and it will produce an updated updater_script and binary based on the links and permissions contained within the system.img and make you a flashable ROM .zip. :good:
It will save you loads of time :laugh:
I am trying without much success to figure out a way to modify the code so it supports mtk boot.img's but I seem to break the rest of the code when I try :laugh:
PS: It's a Linux Only Tool :eek:
 

AP756

New member
Oct 4, 2007
95
31
0
TWRP Test 3

Don't ask me what happened with the file dates... August is gone for a while... And I didn't change the date active...

Pic 3 shows in the header /sdcard which is wrong. This is my external sdcard (sdcard1)

Pic 4 shows the root with directories external sdcard (empty) and sdcard (which is external sdcard). Can't find internal sdcard anywhere ;).
 
Last edited:
  • Like
Reactions: ghost45

bluefirebird

New member
Mar 23, 2013
1,027
5,023
0
carliv.eu
TWRP Test 3

Don't ask me what happened with the file dates... August is gone for a while... And I didn't change the date active...

Pic 3 shows in the header /sdcard which is wrong. This is my external sdcard (sdcard1)

Pic 4 shows the root with directories external sdcard (empty) and sdcard (which is external sdcard). Can't find internal sdcard anywhere ;).
Thank you very much for your thoroughly tests. You helped me a lot. I have one more (twrp) and I finish all builds again. For twrp I forgot a flag on boardconfig to initiate data/media.
For cwm and ctr I finally understood that my previous settings were good and my only mistake was to define internal sdcard on fstabs: for cwm, if it is emulated, it must not be defined and will work. I experimented many things during this day and I understood a lot about this kind of phone.
And in twrp the sdcards are named as in old cwm: external is "sdcard" and internal is "emmc".
 
Last edited:

AP756

New member
Oct 4, 2007
95
31
0
Thank you very much for your thoroughly tests. You helped me a lot. I have one more (twrp) and I finish all builds again. For twrp I forgot a flag on boardconfig to initiate data/media.
For cwm and ctr I finally understood that my previous settings were good and my only mistake was to define internal sdcard on fstabs: for cwm, if it is emulated, it must not be defined and will work. I experimented many things during this day and I understood a lot about this kind of phone.
And in twrp the sdcards are named as in old cwm: external is "sdcard" and internal is "emmc".
You are welcome! You do a lot of work for us, so it's absolutely fine to do some work for you. Anyway I'm a bit tired now and I'll have a bit of sleep ;). Will be back in a couple of hours (after recharging all batteries. Thanks for your efforts.
 

ghost45

New member
Nov 10, 2012
1,481
1,147
0
[email protected]
new tests (hopefully latest):

in short time i will post here the new links.
Here they are:
cwm test 13
Show version 6 of the 3/1/2015 , see the sd card0,
Seems to run all the stepsof Backup in
storage0
but after when i return in android i do not see any backup in sdcard0 but found the folder clockworkmod but only these two files,
View attachment 3095367
View attachment 3095368
View attachment 3095369
these two previous files are renamed *.txt to attach here.
i enter again in recovery mode and i see that the backup there is but is in one section of the memory that i don't know where is...look
20150103_08380911.jpg
install correctly ALLmy zip files and zip files build for zp999,
these are the log files that i found in /cache /recovery:
View attachment last_log.txt
View attachment last_log_1.txt


ctr test 2
Show version 3 of the 3/1/2015 (Marvellous i never see jet this version without the butterfly! according me is better without it. ) ,
install correctly ALLmy zip files and zip files build for zp999,
(i have some problem to see correctly in the root the file that have the name more long because do not enter in the box label and give me name +points "..... ")
Make correctly the backup but the same to the before cmw strange position of the backup folder.
I try to investigate with my root browser and i found the real path where the backup was written here:
20150103_08380911.jpg
Screenshot_2014-01-01-01-32-58.jpg
path :/mtn/shell/emulated/






I'm seeing that we are a good point to this project thanks to everybody!
battery discharged
 
Last edited: