• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

How to disable/adjust the background task limit?

Search This thread

geeksquad2

Senior Member
Jul 16, 2011
58
37
Nunavut
My background with android is long and rocky.
A long time ago in a galaxy far away, I had a Samsung Galaxy S, then a S2.
I can remember a Google Nexus phone in there somewhere.
Then at some point I switched over to Windows Mobile for many years.
A couple of hears ago I came back to android with a Samsung Galaxy S8+ and I hated it.

Recently I upgraded to a OnePlus 6T McLaren and here I am.
I had been expecting to see android happily use up 7, 8 or even 9GB of ram before the background task manager would begin to kill tasks.
Except that I seldom saw android use much more than 5GB of ram.
And worse, background tasks were being killed on a regular basis.
Widgets would stop working overnight, or even in just a few hours.
Spotify would close while a playing a playlist.

A quick search on XDA reveals that many users believe that Android will just use up as much ram as your phone has.
However, that is simply not true.
And so, I began my quest to have Android use as much ram as the phone could provide.
In my case, 10GB.

- I understand that there is an inherent trade-off between keeping background apps running and battery usage. I can live with extra battery usage in exchange for keeping my widgets running or Spotify running for an entire playlist.
- I realized very quickly that in order to achieve the results that I was looking for that the phone would have to be rooted. So rooting was one of the first things that I did.

Step 1.
I started with the basic stuff that a quick google search would provide;
- Settings -> Battery -> Battery Saver (off)
- Settings -> Battery -> Adaptive Battery (off)
- Settings -> Battery -> Battery Optimization -> widget app (don’t optimize)
- Settings -> Battery -> Battery Optimization -> Spotify (don’t optimize)
- Settings -> Battery -> Battery Optimization -> Advanced Optimization -> Deep Optimization (off)
- Settings -> Battery -> Battery Optimization -> Advanced Optimization -> Sleep standby optimization (off)
- Settings -> Apps -> Widget app -> Battery -> Background Restriction (app can use battery in background)
- Settings -> Apps -> Spotify -> Battery -> Background Restriction (app can use battery in background)
This helped but not enough to make the widgets or Spotify usable.

Step 2.
I supposed that my specific background tasks that I wanted to keep running were being killed because of the many other apps that were running in the background.
I searched for and found Tomatot DeBloater scripts for the Oneplus 6.
Excellent! Just what I was looking for.
I chose the Tomatot-Debloater-OOS-Light-2.3.zip and installed it.
This helped some more but not enough to make the widgets or Spotify usable.

Step 3.
I realised that there were still some apps running in the background that I didn’t use or want.
So I used Titanium Backup to freeze the following apps;
- Calendar
- Calendar Storage 9
- Contacts (O+)(I replaced with google contacts)
- Dashboard
- Drive
- Face Unlock
- Gboard
- Gmail
- Google
- Google partner setup 9
- Google play music 8
- McLaren AR
- Messaging (O+)(replaced with google messaging)
- OK google enrollment 9
- Oneplus system 1
- Youtube
Perfect! These apps were no longer competing for phone resources with the apps that I wanted to run.
This helped some more but not enough to make the widgets or Spotify usable.
This did make the phone feel faster and smoother.
The phone is much more responsive and fluid to my input.
This made me realize that the apps were being closed not due to a lack of phone resources, but a background task manager being aggressive.
Presumably for battery saving purposes.
I changed my focus to adjusting that background task manager.

Step 4.
Enable the recent screen ‘LOCK’ on the widget app and Spotify.
This didn’t do anything for me.
Everything that I’ve read on it says that it just stops the task from being killed when you click on kill all tasks.
The lock doesn’t lock the task from being killed by the background task manager.

Step 5.
Further google searching led me to believe that the OEM kernel was limiting background tasks.
I choose ElementalX-OP-3.09 and the EX Kernel Manager.
I had to read a lot of google university material to make any sense of the settings in here.
I’m not sure that I fully understand even now.
Eventually, I ended up with the following settings;
Memory
- Adaptive Low Memory Killer (disabled)
- dirty ratio (20)
- dirty background ratio (5)
- min free kbytes (12398)
- vfs cache pressure (100)
Memory -> Low Memory Killer
- apply on boot
- Foreground app (72mb)
- Visible apps (90mb)
- Secondary server (108mb)
- Hidden apps (200mb)
- Content Providers (587mb)
- Empty apps (783mb)
This helped a lot.
This almost made the phone usable to the state that I wanted.
But the widget and Spotify would still stop running overnight and by morning the apps would have to be reopened to get them to run again.
At least the apps would run most of the day without being killed.
Still not the behaviour that I expected from a phone with 10GB of ram.
Ram usage was still not going much over 5.5Gb even if I opened up many apps at once.
Can I ever get ram usage up to the 10Gb that I have?

Step 6.
The last thing that I tried yesterday afternoon was to increase the background task limit in the build.prop.
ro.vendor.qti.sys.fw.bservice_limit=5 (changed it to 60)
ro.vendor.qti.sys.fw.bservice_age=5000 (changed it to 10000)
Yes, I know that I am on PIE and there isn’t supposed to be any effect.
No, I don’t know yet if this had any effect.
I am hopeful.
The widget app didn’t close last night, but Spotify did.
I am getting closer!


This is the best that I could do on my own without asking for help.
So here I am posting my question and asking for help.
How do I get the apps that I want to run to not be killed by the background task manager?
OR
How do I get the phone to use the 10GB of ram?

I feel that I am missing something.
With any luck, one of you smarter persons will be able to point it out to me.

As an aside from all of these changes the phone feels very smooth and fluid.
Except for apps closing that I don’t want to, this phone is a great experience and a pleasure to use.
Apps that I want to run are staying open much longer then before I started.
It’s now just an overnight issue.
And getting the phone to use over 6Gb of ram.
I would suggest that I am 90% happy with it now.

KERNAL: ElementalX-OP6-3.10
ROM: STOCK OOS 9.0.11
PHONE MODEL: 6013 O+6T McLaren
 

culiacanazo

Senior Member
Wow dude, interesting read, i will sign up for notifications from this thread hoping you get your answer because i have the exact same problem but with my work app, throwing it all out of whack and making me a target to big fines (in the $1,000's) and potentially reducing my marketability!
The attached screenies are from before i realized that the app getting killed in the background is what causes the problem (I've left it in the foreground HOURS a few times and it works perfectly!)
 

Attachments

  • Screenshot_20190109-223444__01.jpg
    Screenshot_20190109-223444__01.jpg
    233.9 KB · Views: 1,038
  • Screenshot_20190109-223456__01.jpg
    Screenshot_20190109-223456__01.jpg
    208.3 KB · Views: 1,046
  • Screenshot_20190109-223427__01.jpg
    Screenshot_20190109-223427__01.jpg
    188.4 KB · Views: 1,030
  • Like
Reactions: Bintang Krisna

geeksquad2

Senior Member
Jul 16, 2011
58
37
Nunavut
UPDATE:
Good news!

I seem to have solved my issue.
Time will tell for sure though.
But this morning and all day today, Spotify and the widget app have been running without closing.
AND I have seen memory usage up to 6.8GB used.

Here are the further steps that I took;
- ro.vendor.qti.sys.fw.bservice_enable=true (changed it to false)
I didn't really notice much of a change.
But then I noticed that perhaps the limit of 60 tasks was not high enough.
I seem to have that many apps open and limiting to just 60 may be an issue.


- ro.vendor.qti.sys.fw.bservice_limit=60 (changed it to 120)
THIS!
This seemed to have worked for me.
All apps seem to be open and be staying open.
Today I got a message/warning from android telling me that the widget app is consuming the battery in excess but I ignored the warning and android did not close the app or stop the widget from running.

I will keep an eye on the phone for the next few days to confirm that this actually solved my issues.

My next step will be to see what effect if any this has had on my battery usage.
I am curious to see if it's all that bad...
 

Attachments

  • Screenshot_20190105-095920.jpg
    Screenshot_20190105-095920.jpg
    193.4 KB · Views: 776
  • Screenshot_20190109-172848.jpg
    Screenshot_20190109-172848.jpg
    215.6 KB · Views: 767
  • Like
Reactions: arvindgr

kantjer

Inactive Recognized Contributor
Dec 11, 2010
12,393
29,848
www.androidfilehost.com
UPDATE:
Good news!

I seem to have solved my issue.
Time will tell for sure though.
But this morning and all day today, Spotify and the widget app have been running without closing.
AND I have seen memory usage up to 6.8GB used.

Here are the further steps that I took;
- ro.vendor.qti.sys.fw.bservice_enable=true (changed it to false)
I didn't really notice much of a change.
But then I noticed that perhaps the limit of 60 tasks was not high enough.
I seem to have that many apps open and limiting to just 60 may be an issue.


- ro.vendor.qti.sys.fw.bservice_limit=60 (changed it to 120)
THIS!
This seemed to have worked for me.
All apps seem to be open and be staying open.
Today I got a message/warning from android telling me that the widget app is consuming the battery in excess but I ignored the warning and android did not close the app or stop the widget from running.

I will keep an eye on the phone for the next few days to confirm that this actually solved my issues.

My next step will be to see what effect if any this has had on my battery usage.
I am curious to see if it's all that bad...

Nice find, I checked my build.prop and found this. No wonder my apps are killed
Code:
#ifdef VENDOR_EDIT
#[email protected] modify for app memory
ro.vendor.qti.sys.fw.bservice_enable=true
ro.vendor.qti.sys.fw.bservice_limit=5
ro.vendor.qti.sys.fw.bservice_age=5000
#endif/*VENDOR_EDIT*/

EDIT: I see a lot of custom ROM's have "ro.vendor.qti.sys.fw.bg_apps_limit=60" to the build prop, I wonder if that going to make a difference
 
Last edited:
  • Like
Reactions: Bintang Krisna

geeksquad2

Senior Member
Jul 16, 2011
58
37
Nunavut
UPDATE:

I am a silly goose.

I broke a cardinal rule while troubleshooting.
I may have had a few too many wobbly pops and made two changes at a time, thus when change was affected, I was unable to determine properly which change caused the affect.
The rule is, "only make one change at a time when testing".

Yes, all of my apps stay open all the time.
I am getting the behaviour that I was looking for.
However it wasn't necessarily changing the build.prop bgservice_limit from 60 to 120 that did it.

Let me back up a bit.
Earlier I had suggested that locking an app to the recent screen didn't do anything for me, and that in my reading it only locks the app from being killed by you when you try to close it manually.
However in reading up on the oneplus framework-res.apk I found a reference to an oneplus whitelist of apps that will never be killed, and a reference to the recent screen app lock that suggests that oneplus will add a locked app to the whitelist and not kill it.

In the course of a single day, I had inadvertently edited the build.prop and locked the widget app to the recent screen thus breaking the one change at a time rule.
So the next morning and the following days when all apps were staying open I attributed it to changing the build.prop not realizing that it could also have been the app lock.

Last night I realized my mistake.
I unlocked the widget app from the recent screen and went to bed.
When I woke up this morning the widget app was not running for the first time in days.
Also the notifications that I was receiving about the widget app consuming excessive battery have stopped.

It would appear that I was wrong in my earlier observations regarding the app lock mechanism.
It appears to be very useful for keeping apps running all the time.

Did changing the build.prop have any affect on keeping apps open?
Maybe?
I have noticed that my battery life has gone for a complete ****.
I can barely get 24 hours out of the phone.
Worse is that it doesn't matter if the screen is on or not, battery usage remains the same.
i.e. with the screen off and the phone put down, battery life appears to be used at the same rate as when the phone is in use.
I had expected the battery life to be not as good, but I didn't expect it to go to for a **** that badly.

There must be a balance between aggressive app management and acceptable battery life.
The phone didn't display this behaviour until I changed ro.vendor.qti.sys.fw.bservice_enable=true to false.
I think that today I will change ro.vendor.qti.sys.fw.bservice_enable= back to true and observe the battery tomorrow.
 

Attachments

  • Screenshot_20181227-005239.jpg
    Screenshot_20181227-005239.jpg
    211.6 KB · Views: 528
  • Screenshot_20190114-182439.jpg
    Screenshot_20190114-182439.jpg
    204.4 KB · Views: 528

geeksquad2

Senior Member
Jul 16, 2011
58
37
Nunavut
Nice find, I checked my build.prop and found this. No wonder my apps are killed
Code:
#ifdef VENDOR_EDIT
#[email protected] modify for app memory
ro.vendor.qti.sys.fw.bservice_enable=true
ro.vendor.qti.sys.fw.bservice_limit=5
ro.vendor.qti.sys.fw.bservice_age=5000
#endif/*VENDOR_EDIT*/

EDIT: I see a lot of custom ROM's have "ro.vendor.qti.sys.fw.bg_apps_limit=60" to the build prop, I wonder if that going to make a difference

I think that ro.vendor.qti.sys.fw.bservice_limit= and ro.vendor.qti.sys.fw.bg_apps_limit= are essentially the same thing, except for android versions.
ro.vendor.qti.sys.fw.bg_apps_limit= is for Android 7: Nougat and below.
ro.vendor.qti.sys.fw.bservice_limit= is for Android 8: Oreo and above.

Someone more knowledgeable than me should chime in here though.
 

cannothas

Senior Member
Jan 22, 2011
273
33
Durango
Do you think any of this could have to do with the way the phone keeps disabling push in Gmail? (Every other day I need to set my O365 exchange in Gmail back to push because it automatically changes to the default of checking every 30 mins.)
 

archraziel

Senior Member
Feb 23, 2012
268
30
SP
What did you find in the end?

How did you set this ?

ro.vendor.qti.sys.fw.bservice_enable=true
ro.vendor.qti.sys.fw.bservice_limit=5
ro.vendor.qti.sys.fw.bservice_age=5000
 

replica9000

Senior Member
May 31, 2009
2,168
561
So what's the verdict on the buildprop edits? Do they make a difference?

I notice that sometimes my on-going weather notification doesn't update, or gets killed off. I also have an app that controls rotation per app, and that also seems to stop doing it's thing after a while.
 

jonahmt21

Senior Member
Sep 17, 2012
212
40
Just want to share. If you are rooted with Magisk, try appsystemizer module. System apps don't get killed by oneplus as aggressively. Tried it with accubattery and it works.
 

scloss84

Senior Member
Jun 7, 2013
66
5
I am so glad I stumble across this, I just want to say, changing
ro.vendor.qti.sys.fw.bservice_limit=5 to 120
ro.vendor.qti.sys.fw.bservice_age=5000 to 10000
Keep apps in ram for much longer then original! For me the battery life is unaffected, might even be better.
 

popy2006

Senior Member
Mar 22, 2007
1,383
223
I am so glad I stumble across this, I just want to say, changing
ro.vendor.qti.sys.fw.bservice_limit=5 to 120
ro.vendor.qti.sys.fw.bservice_age=5000 to 10000
Keep apps in ram for much longer then original! For me the battery life is unaffected, might even be better.

Also want to solve this issue.
On which OOS Version you are? (i am on 10.3.1)

Does this really work in newer OOS Versions?
I have read elsewhere that those settings dont work on newer versions, sadly, cant find the thread/source.

thx
pOpY
 

scloss84

Senior Member
Jun 7, 2013
66
5
Also want to solve this issue.
On which OOS Version you are? (i am on 10.3.1)

Does this really work in newer OOS Versions?
I have read elsewhere that those settings dont work on newer versions, sadly, cant find the thread/source.

thx
pOpY
I'm actually Oneplus 6, OOS 9.0.9.

I also read that it doesn't work on Android 10 because magisk doesn't mount /system in Android 10, but there is a magisk module workaround that you can use. And hopefully magisk will update in the near future to fix that. Just google "Android 10 can't edit build.prop" and you'll find heaps of info.
 

Darnrain1

Senior Member
Jan 2, 2018
54
14
This is what I have in my build.prop file and it seems to help. I have Oreo it works great on my phone I don't know about later versions of Oreo.

ro.vendor.qti.sys.fw.bservice_enable=true
ro.vendor.qti.sys.fw.bservice_age=5000
ro.vendor.qti.sys.fw.bservice_limit=5
ro.sys.fw.bg_apps_limit=64
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    My background with android is long and rocky.
    A long time ago in a galaxy far away, I had a Samsung Galaxy S, then a S2.
    I can remember a Google Nexus phone in there somewhere.
    Then at some point I switched over to Windows Mobile for many years.
    A couple of hears ago I came back to android with a Samsung Galaxy S8+ and I hated it.

    Recently I upgraded to a OnePlus 6T McLaren and here I am.
    I had been expecting to see android happily use up 7, 8 or even 9GB of ram before the background task manager would begin to kill tasks.
    Except that I seldom saw android use much more than 5GB of ram.
    And worse, background tasks were being killed on a regular basis.
    Widgets would stop working overnight, or even in just a few hours.
    Spotify would close while a playing a playlist.

    A quick search on XDA reveals that many users believe that Android will just use up as much ram as your phone has.
    However, that is simply not true.
    And so, I began my quest to have Android use as much ram as the phone could provide.
    In my case, 10GB.

    - I understand that there is an inherent trade-off between keeping background apps running and battery usage. I can live with extra battery usage in exchange for keeping my widgets running or Spotify running for an entire playlist.
    - I realized very quickly that in order to achieve the results that I was looking for that the phone would have to be rooted. So rooting was one of the first things that I did.

    Step 1.
    I started with the basic stuff that a quick google search would provide;
    - Settings -> Battery -> Battery Saver (off)
    - Settings -> Battery -> Adaptive Battery (off)
    - Settings -> Battery -> Battery Optimization -> widget app (don’t optimize)
    - Settings -> Battery -> Battery Optimization -> Spotify (don’t optimize)
    - Settings -> Battery -> Battery Optimization -> Advanced Optimization -> Deep Optimization (off)
    - Settings -> Battery -> Battery Optimization -> Advanced Optimization -> Sleep standby optimization (off)
    - Settings -> Apps -> Widget app -> Battery -> Background Restriction (app can use battery in background)
    - Settings -> Apps -> Spotify -> Battery -> Background Restriction (app can use battery in background)
    This helped but not enough to make the widgets or Spotify usable.

    Step 2.
    I supposed that my specific background tasks that I wanted to keep running were being killed because of the many other apps that were running in the background.
    I searched for and found Tomatot DeBloater scripts for the Oneplus 6.
    Excellent! Just what I was looking for.
    I chose the Tomatot-Debloater-OOS-Light-2.3.zip and installed it.
    This helped some more but not enough to make the widgets or Spotify usable.

    Step 3.
    I realised that there were still some apps running in the background that I didn’t use or want.
    So I used Titanium Backup to freeze the following apps;
    - Calendar
    - Calendar Storage 9
    - Contacts (O+)(I replaced with google contacts)
    - Dashboard
    - Drive
    - Face Unlock
    - Gboard
    - Gmail
    - Google
    - Google partner setup 9
    - Google play music 8
    - McLaren AR
    - Messaging (O+)(replaced with google messaging)
    - OK google enrollment 9
    - Oneplus system 1
    - Youtube
    Perfect! These apps were no longer competing for phone resources with the apps that I wanted to run.
    This helped some more but not enough to make the widgets or Spotify usable.
    This did make the phone feel faster and smoother.
    The phone is much more responsive and fluid to my input.
    This made me realize that the apps were being closed not due to a lack of phone resources, but a background task manager being aggressive.
    Presumably for battery saving purposes.
    I changed my focus to adjusting that background task manager.

    Step 4.
    Enable the recent screen ‘LOCK’ on the widget app and Spotify.
    This didn’t do anything for me.
    Everything that I’ve read on it says that it just stops the task from being killed when you click on kill all tasks.
    The lock doesn’t lock the task from being killed by the background task manager.

    Step 5.
    Further google searching led me to believe that the OEM kernel was limiting background tasks.
    I choose ElementalX-OP-3.09 and the EX Kernel Manager.
    I had to read a lot of google university material to make any sense of the settings in here.
    I’m not sure that I fully understand even now.
    Eventually, I ended up with the following settings;
    Memory
    - Adaptive Low Memory Killer (disabled)
    - dirty ratio (20)
    - dirty background ratio (5)
    - min free kbytes (12398)
    - vfs cache pressure (100)
    Memory -> Low Memory Killer
    - apply on boot
    - Foreground app (72mb)
    - Visible apps (90mb)
    - Secondary server (108mb)
    - Hidden apps (200mb)
    - Content Providers (587mb)
    - Empty apps (783mb)
    This helped a lot.
    This almost made the phone usable to the state that I wanted.
    But the widget and Spotify would still stop running overnight and by morning the apps would have to be reopened to get them to run again.
    At least the apps would run most of the day without being killed.
    Still not the behaviour that I expected from a phone with 10GB of ram.
    Ram usage was still not going much over 5.5Gb even if I opened up many apps at once.
    Can I ever get ram usage up to the 10Gb that I have?

    Step 6.
    The last thing that I tried yesterday afternoon was to increase the background task limit in the build.prop.
    ro.vendor.qti.sys.fw.bservice_limit=5 (changed it to 60)
    ro.vendor.qti.sys.fw.bservice_age=5000 (changed it to 10000)
    Yes, I know that I am on PIE and there isn’t supposed to be any effect.
    No, I don’t know yet if this had any effect.
    I am hopeful.
    The widget app didn’t close last night, but Spotify did.
    I am getting closer!


    This is the best that I could do on my own without asking for help.
    So here I am posting my question and asking for help.
    How do I get the apps that I want to run to not be killed by the background task manager?
    OR
    How do I get the phone to use the 10GB of ram?

    I feel that I am missing something.
    With any luck, one of you smarter persons will be able to point it out to me.

    As an aside from all of these changes the phone feels very smooth and fluid.
    Except for apps closing that I don’t want to, this phone is a great experience and a pleasure to use.
    Apps that I want to run are staying open much longer then before I started.
    It’s now just an overnight issue.
    And getting the phone to use over 6Gb of ram.
    I would suggest that I am 90% happy with it now.

    KERNAL: ElementalX-OP6-3.10
    ROM: STOCK OOS 9.0.11
    PHONE MODEL: 6013 O+6T McLaren
    3
    UPDATE:

    I am a silly goose.

    I broke a cardinal rule while troubleshooting.
    I may have had a few too many wobbly pops and made two changes at a time, thus when change was affected, I was unable to determine properly which change caused the affect.
    The rule is, "only make one change at a time when testing".

    Yes, all of my apps stay open all the time.
    I am getting the behaviour that I was looking for.
    However it wasn't necessarily changing the build.prop bgservice_limit from 60 to 120 that did it.

    Let me back up a bit.
    Earlier I had suggested that locking an app to the recent screen didn't do anything for me, and that in my reading it only locks the app from being killed by you when you try to close it manually.
    However in reading up on the oneplus framework-res.apk I found a reference to an oneplus whitelist of apps that will never be killed, and a reference to the recent screen app lock that suggests that oneplus will add a locked app to the whitelist and not kill it.

    In the course of a single day, I had inadvertently edited the build.prop and locked the widget app to the recent screen thus breaking the one change at a time rule.
    So the next morning and the following days when all apps were staying open I attributed it to changing the build.prop not realizing that it could also have been the app lock.

    Last night I realized my mistake.
    I unlocked the widget app from the recent screen and went to bed.
    When I woke up this morning the widget app was not running for the first time in days.
    Also the notifications that I was receiving about the widget app consuming excessive battery have stopped.

    It would appear that I was wrong in my earlier observations regarding the app lock mechanism.
    It appears to be very useful for keeping apps running all the time.

    Did changing the build.prop have any affect on keeping apps open?
    Maybe?
    I have noticed that my battery life has gone for a complete ****.
    I can barely get 24 hours out of the phone.
    Worse is that it doesn't matter if the screen is on or not, battery usage remains the same.
    i.e. with the screen off and the phone put down, battery life appears to be used at the same rate as when the phone is in use.
    I had expected the battery life to be not as good, but I didn't expect it to go to for a **** that badly.

    There must be a balance between aggressive app management and acceptable battery life.
    The phone didn't display this behaviour until I changed ro.vendor.qti.sys.fw.bservice_enable=true to false.
    I think that today I will change ro.vendor.qti.sys.fw.bservice_enable= back to true and observe the battery tomorrow.
    2
    Tomorrow I may try making this change to the build.prop file;
    ro.vendor.qti.sys.fw.bservice_enable=true to false

    Don't know if it will help or not.
    2
    Nice find, I checked my build.prop and found this. No wonder my apps are killed
    Code:
    #ifdef VENDOR_EDIT
    #[email protected] modify for app memory
    ro.vendor.qti.sys.fw.bservice_enable=true
    ro.vendor.qti.sys.fw.bservice_limit=5
    ro.vendor.qti.sys.fw.bservice_age=5000
    #endif/*VENDOR_EDIT*/

    EDIT: I see a lot of custom ROM's have "ro.vendor.qti.sys.fw.bg_apps_limit=60" to the build prop, I wonder if that going to make a difference

    I think that ro.vendor.qti.sys.fw.bservice_limit= and ro.vendor.qti.sys.fw.bg_apps_limit= are essentially the same thing, except for android versions.
    ro.vendor.qti.sys.fw.bg_apps_limit= is for Android 7: Nougat and below.
    ro.vendor.qti.sys.fw.bservice_limit= is for Android 8: Oreo and above.

    Someone more knowledgeable than me should chime in here though.
    1
    Wow dude, interesting read, i will sign up for notifications from this thread hoping you get your answer because i have the exact same problem but with my work app, throwing it all out of whack and making me a target to big fines (in the $1,000's) and potentially reducing my marketability!
    The attached screenies are from before i realized that the app getting killed in the background is what causes the problem (I've left it in the foreground HOURS a few times and it works perfectly!)