How to disable OTA lollipop without wakelock

Search This thread

swallowingled

Senior Member
Dec 23, 2013
205
94
IN
I had trouble getting this to work as the "com.google.android.gms.update.SystemUpdateService$ ActiveReceiver" kept re-enabling itself after a reboot and I kept getting the System Update notification. I had to go into TWRP and wipe the cache and then this finally worked, in case anyone else is having the same issue. That system update notification was very annoying, so thank you for this solution.
 

slickvicster

New member
Nov 23, 2010
2
1
Ok this worked for me: Disable Lollipop OTA

Dowloadeded Manage Autostarts for Android from Play store. Next opened app and went to After Startup and disabled this:
com.google.android.gms.update.SystemUpdateService$ Receiver.
Next, went to Connectivity Change and disabled: com.google.android.gms.update.SystemUpdateService$ ActiveReceiver
Lastly, went to Secret Code and disabled:
com.google.android.gms.update.SystemUpdateService$ SecretCodeReceiver.
This worked like a charm for me, hit me back if it works for you, Cheers.
Viva LeAndroid .:cool:
 
  • Like
Reactions: eak1080

spaniard

Member
Apr 10, 2004
47
9
Madrid
www.nevasport.com
Disabling these 3 receivers in all those sections you mention, solves the wakelock issue?
Have you tested this throughout a full day?

Last time I tried this, I didn't disable all of them in all of those section.
My phone was awake 100% of the day...

Thanks Vlad_z and spaniard. These have to be disabled in both Play Services and Framework when they appear in each?



Tested one week without any wakelock issue.
They have been disabled just in Play services, same as Vlad.

Anyway I've finally sideloaded the OTA update and I'm very happy with it, just around a 20% less battery life.
 
Last edited:

augoza

Senior Member
Feb 4, 2010
535
42
If you decided to stick a bit longer with KK and lollipop OTA notification is bothering you - this is how you can disable it without wakelocking your phone.

Get something which disable service receivers/listeners (not just service like Disable Service app does). If you disable SystemUpdate service - this will wakelock your phone - thanks to Google wonderful design, which become "better and better".

But instead you disable 3 receivers for that service:

com.google.android.gms.update.SystemUpdateService$Receiver - this will run on boot completed.

com.google.android.gms.update.SystemUpdateService$ActiveReceiver - this will check for OTA on connectivity change.

com.google.android.gms.update.SystemUpdateService$SecretCodeReceiver - this will check for OTA when your phone "handles" the secret code.

So, by doing this, SystemUpdateService will never have a chance to get OTA and you phone will still sleep like a baby.

Now, what apps will allow to disable receivers? Well, I compiled my own Autostarts. It's old but still job can be done.

You can find something in play store or I can upload my autostarts if you want me to.

Anyway, in summary do not disable GooglePlayServices.SystemUpdate service just its 3 receivers.

EDIT: Here, this is autostarts I've compiled long time ago but still can be run on KK and of cause ads free. Well, you have to "hunt down" those 3 receivers. Just open up one by one and read if this is one of those 3 and then disable it.

I installed Manage Android Autostart. I went to disable those 3 receivers . They were already disabled with about 15 more.... So the app was useless, because they are already disabled. Unless its because i installed your app first. Then i uninstalled it and installed Manage Android Autostart. Did it carry your settings from your app to the Manage app?
 

Vlad_z

Senior Member
Mar 25, 2011
506
178
Autostart makes changes in OS configuration files, so you would need disable those receivers only once...
Though, sometimes, some updates might re-enable them again.
 
  • Like
Reactions: eak1080

hakkalugi

Senior Member
Sep 28, 2013
60
27
I must still be missing something...

1) First off thanks Vlad_z for starting all this!
2) I've disabled the 3 SystemUpdateService receivers in their respective events: After Startup, Connectivity Changed, and Secret Code Entered. -- Rebooted and re-validated receivers were still disabled. Even Cleared the cache (via Recovery) and re-validated receivers were still disabled.

Yet my battery life is half of normal. -- Normally I can squeak ~4days out of a single charge, but now I'm barely getting 36hours (with you guessed it "Screen" taking the percentage of Battery)! Bummer eh?

Lastly if I re-enable the 3 Receivers, my battery life goes back to normal.

Question:
What else could I possibly be missing?

Any thoughts are greatly appreciated!
Oh and yes, indeed, with the 3 Receivers disabled the annoying LP Update notification disappears.

FOLLOW-UP EDIT:
Similar to @swallowingled post #21 after clearing the cache, I just needed 2 more reboots and some patience! (The later being the most difficult.) -- Anyway for anyone reading my magic was to disable the receivers, wipe the cache (via Recovery), reboot and wait for everything to settle.
 
Last edited:

eqagunn

Member
Jan 13, 2015
48
18
Finally a proper way to do it!
"Disable Service" app recommended by other threads is totally unnecessary.
Just those three "SystemUpdateService" broadcast receivers in "Google Play Services".
Used "Auto Start Manager" from "ROM Toolbox" to deal with it.
Also, cleared cache based on comments of other users, just to be sure.
I VOTE STICKY ON THIS!
 
Last edited:

fiiish

Member
Nov 2, 2010
16
2
If you decided to stick a bit longer with KK and lollipop OTA notification is bothering you - this is how you can disable it without wakelocking your phone.

Get something which disable service receivers/listeners (not just service like Disable Service app does). If you disable SystemUpdate service - this will wakelock your phone - thanks to Google wonderful design, which become "better and better".

But instead you disable 3 receivers for that service:

com.google.android.gms.update.SystemUpdateService$Receiver - this will run on boot completed.

com.google.android.gms.update.SystemUpdateService$ActiveReceiver - this will check for OTA on connectivity change.

com.google.android.gms.update.SystemUpdateService$SecretCodeReceiver - this will check for OTA when your phone "handles" the secret code.

So, by doing this, SystemUpdateService will never have a chance to get OTA and you phone will still sleep like a baby.

Now, what apps will allow to disable receivers? Well, I compiled my own Autostarts. It's old but still job can be done.

You can find something in play store or I can upload my autostarts if you want me to.

Anyway, in summary do not disable GooglePlayServices.SystemUpdate service just its 3 receivers.

EDIT: Here, this is autostarts I've compiled long time ago but still can be run on KK and of cause ads free. Well, you have to "hunt down" those 3 receivers. Just open up one by one and read if this is one of those 3 and then disable it.

I'm flummoxed (i.e, seriously confused). I have reverted to KitKat, rooted and am now trying to turn off the Lollipop nag. I've used a variety of service disabler apps including ToolBox Pro v6.n.n and can't locate the services you've mentioned. Also can't locate: "After Startup", "Connectivity Changed", "Secret Code Entered" which are described as the receivers folders(?).

Please advise and thanks.

f
 

Vlad_z

Senior Member
Mar 25, 2011
506
178
I cannot talk for ToolBox Pro but if you use my Autostarts, click on "Google Play services", expand it and you can see lot's of receivers... find those three and disable them.
 

fiiish

Member
Nov 2, 2010
16
2
I cannot talk for ToolBox Pro but if you use my Autostarts, click on "Google Play services", expand it and you can see lot's of receivers... find those three and disable them.

I have installed your Autostarts, selected "Group by Events" and dont see "Google Play Services". 1st item is "During Startup", 2nd is After Startup", many etc.'s after. Hope it's me so I can fix it.

f
 

fiiish

Member
Nov 2, 2010
16
2
Found my way to a similar but different solution. I am using NotifyClean an Xposed Module. All it does is block the update notification which has been mocking me.

I am happy.

Thanks for your help.

f
 
Last edited:
  • Like
Reactions: ssssst

MrH.uk

Member
Aug 24, 2013
28
1
Thank you for this, I flashed back to Kit Kat yesterday due to Lollipop wifi issues and this OTA message was driving me nuts.
 

Soxbrother

New member
Feb 7, 2015
1
0
I guess all the methods in this thread require the phone to be rooted ?

My Samsung Galaxy S5 isn't rooted,
is there a way for me to get rid of the OTA lollipop 5.0 update notification without being rooted ?
Every time I start my phone I get a screen asking me to install the update.
I then bypass it with the "back" button.

Thanks in advance.

I just saw that this in fact a thread for "Google Nexus 5",
my apologies for posting in the wrong thread.
 
Last edited:

_MetalHead_

Senior Member
Jun 30, 2010
6,763
2,747
Portland
how I figure this out with rom toolbox? thank you

Use the auto start manager. I think all the systemupdateservice receivers are under Google play services. Just disable them.


I6PjPUU.jpg
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 28
    If you decided to stick a bit longer with KK and lollipop OTA notification is bothering you - this is how you can disable it without wakelocking your phone.

    Get something which disable service receivers/listeners (not just service like Disable Service app does). If you disable SystemUpdate service - this will wakelock your phone - thanks to Google wonderful design, which become "better and better".

    But instead you disable 3 receivers for that service:

    com.google.android.gms.update.SystemUpdateService$Receiver - this will run on boot completed.

    com.google.android.gms.update.SystemUpdateService$ActiveReceiver - this will check for OTA on connectivity change.

    com.google.android.gms.update.SystemUpdateService$SecretCodeReceiver - this will check for OTA when your phone "handles" the secret code.

    So, by doing this, SystemUpdateService will never have a chance to get OTA and you phone will still sleep like a baby.

    Now, what apps will allow to disable receivers? Well, I compiled my own Autostarts. It's old but still job can be done.

    You can find something in play store or I can upload my autostarts if you want me to.

    Anyway, in summary do not disable GooglePlayServices.SystemUpdate service just its 3 receivers.

    EDIT: Here, this is autostarts I've compiled long time ago but still can be run on KK and of cause ads free. Well, you have to "hunt down" those 3 receivers. Just open up one by one and read if this is one of those 3 and then disable it.
    3
    For those who need my autostarts.apk, I just added it to the first post.
    2
    how I figure this out with rom toolbox? thank you

    Use the auto start manager. I think all the systemupdateservice receivers are under Google play services. Just disable them.


    I6PjPUU.jpg
    2
    Thanks Vlad_z and spaniard. These have to be disabled in both Play Services and Framework when they appear in each?

    Just in Play Services.
    2
    com.google.android.gms.update.SystemUpdateService$Receiver - this will run on boot completed.

    com.google.android.gms.update.SystemUpdateService$ActiveReceiver - this will check for OTA on connectivity change.

    com.google.android.gms.update.SystemUpdateService$SecretCodeReceiver - this will check for OTA when your phone "handles" the secret code.

    Hi, if it can help, I've "hunted" these receivers in:
    After startup
    Connectivity changed
    Secret code entered
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone