How to enable usb debugging mode when phone is bricked

Search This thread

Shahid Niazi

Member
Jun 10, 2014
9
2
Hi! hello every one.......I'm new to XDA .... and may be I'm posting my problem in wrong discussion ...... any how I having a problem with my mt6589 Clone S4......
Yesterday I was using my phone and it's working fine but when I restart my phone I gets stuck on adroid logo..... I tried wiping cache / factory rest....but no luck...
I'm googling my problem for last 14 to 15 hours but I don't find any help full information......
I tried Installing custom rom by going to recovery mode .....but it gets unknown error....
I tried spflash tool ..... but it asks for enabling usb debugging mode but my stucks on android logo..... now basically my question is that how to turn debugging mode on when my phone get stucks on android logo.....
I also can't install cwm recovery because it's also ask for enabling a debugging mode.......
 

kashmir305

New member
Aug 8, 2016
1
0
kashmir

can anyone help me please i bricked my AQT80 tablet from sprint i rooted it with kingroot next thing later i go to sleep i get a black screen and den i tried to get back on it kept freezing and would not turn on would stay frozen on sprint icon i really hope there is a fix so i restored it on recovery and now it won't go back to the screen i can't get into USB debugging enabled is there any other way to fix this ?
 

xjackgimleyx

Member
Oct 29, 2016
9
0
samsung note 5 sprint model sm-n920p bricked

my note 5 sm-n920p phone is rooted and it is stuck in the frp boot loop odin mode download speed :fast custom binary system status is custom secure download is enabled knox warrenty is 1 rp swrev b:2 k:0 s:0 that's what im seeing while in odin download mode on my phone

my main problem is ive done this before and restored my phone but flashing stock firmware to my phone and it worked fixed my phone well the otherday I forgot when I was on my phone I was trying to do something while it was on I turned off oem unlock so now it is disabled well my phone died and I didn't turn it back on now im stuck in frp bootloop when I plug my phone into my computer I get a error message the last usb device you connected to this computer is malfunctioned and windows does not recognize it. this usb port works properly and works fine ive went to device manager and ive made sure all my usb ports were upgraded I cannot get the computer to recognize my device at all therefore odin cannot pick my phone up and recognize it for me to flash stock firmware back onto my phone anyone please help me solve this I really need someone who can tell me how to get odin to successfully add my phone so I can flash the stock firmware back to my phone and unbrick it please leave any tips or ideas.
 

Abinandan2004

New member
Jan 26, 2017
1
0
same problem in my lenovo s920 ican't go to the bootloader it stucks in "lenovo powered by android" if i press vol down and power it shows "you have been in meta mode long press power button to normal boot" but if i do it the same problen it stops at the lenovo logo. please help me.
 

Sheik mohamed

New member
Jan 26, 2017
1
0
m phone is yureka plus 5510A......its bricked.......when i try to on my phone YU logo comes then it goes black then again it shows YU logo.....................i tried to flash using YGDP Tool and the problem is ADB driver cannot detect my device........what shoud i do?????????????????
 

czarleenreyn07

New member
Feb 9, 2017
1
0
please help me. .how to enable usb debugging my cellphone stock in samsung logo,and advice on screen that "RECOVERY IS NOT SEADROID ENCORFING &BINARY BLOCK BY FRP LOCK". please help.my phone is samsung galaxy j700h.
 

Itstud1963

New member
Feb 25, 2017
1
0
Hi I have gigaset qv830 tablet factory reset put tablet into permeant erase
No recovery just erase

Upon unplugging battery an plugging back on power light won't light up an screen acts like booting bit all I get is screen lights up won't do anything unless plugged in wall won't charge

Can I use Odin to flash new OS onto tablet

USB debugging not on
 

Droidriven

Senior Member
Jan 27, 2014
15,429
9
5,360
NC
Verizon Samsung Galaxy S III
HTC Thunderbolt
Odin doesn't recognize a device that has usb debugging off. I've dealt with that enough to know. There are special cases where it can be flashed with USB debugging off depending on what got corrupted before flashing but in general Odin doesn't work without usb debugging being turned on.

The same is true for adb and other PC flashing softwares, it won't work without USB debugging turned on. Without it the PC can't connect to flash.

Sent from my SM-S903VL using Tapatalk
 

Kobro

Senior Member
Nov 21, 2013
579
94
Odin doesn't recognize a device that has usb debugging off. I've dealt with that enough to know. There are special cases where it can be flashed with USB debugging off depending on what got corrupted before flashing but in general Odin doesn't work without usb debugging being turned on.

The same is true for adb and other PC flashing softwares, it won't work without USB debugging turned on. Without it the PC can't connect to flash.

Sent from my SM-S903VL using Tapatalk

The amount of times I've wiped /system or other critical things and restored by flashing stock roms in odin seems to imply that either usb debugging has somehow always been on in every device of mine, regardless of state of device, or that it does not need to be turned on for flashing..
 

Droidriven

Senior Member
Jan 27, 2014
15,429
9
5,360
NC
Verizon Samsung Galaxy S III
HTC Thunderbolt
The amount of times I've wiped /system or other critical things and restored by flashing stock roms in odin seems to imply that either usb debugging has somehow always been on in every device of mine, regardless of state of device, or that it does not need to be turned on for flashing..
I stand corrected, in reading about it I see its not "supposed" be needed but I've seen many cases where the device couldn't be flashed due to USB debugging not being on. Strange, I guess it's just one of those things about android that makes you ask "how is that possible".

Sent from my SM-S903VL using Tapatalk
 

Kobro

Senior Member
Nov 21, 2013
579
94
I stand corrected, in reading about it I see its not "supposed" be needed but I've seen many cases where the device couldn't be flashed due to USB debugging not being on. Strange, I guess it's just one of those things about android that makes you ask "how is that possible".

Sent from my SM-S903VL using Tapatalk

It's the black magic man, the black magic gets to everything.
 

Droidriven

Senior Member
Jan 27, 2014
15,429
9
5,360
NC
Verizon Samsung Galaxy S III
HTC Thunderbolt
Hi,please help me.when i open developer options always force close.how to fix it thx☺Sorry for my bad english
My device:SHV-E330S

Have you modified something on your device recently? If so, what did you modify?

If you have TWRP, boot into TWRP then wipe cache and wipe dalvik cache.

If you have stock recovery, boot to recovery and wipe only the cache partition.
 

Praxxer1

Member
Mar 21, 2018
26
2
Can you wipe the cache and davik from the system partition manually? I have a kindle hdx (3rd gen) used an unlock script at the wrong step and now device won't turn on, but I can see all the individual files in the 7 partitions. ADB and Fastboot commands are non-responsive.
 

Droidriven

Senior Member
Jan 27, 2014
15,429
9
5,360
NC
Verizon Samsung Galaxy S III
HTC Thunderbolt
Can you wipe the cache and davik from the system partition manually? I have a kindle hdx (3rd gen) used an unlock script at the wrong step and now device won't turn on, but I can see all the individual files in the 7 partitions. ADB and Fastboot commands are non-responsive.

Your options are:

Recovery
adb
fastboot



A USB or MTP connection only allows you to view files, you can only access and modify the user space, not system.



Sent from my LGL84VL using Tapatalk
 

Praxxer1

Member
Mar 21, 2018
26
2
Your options are:

Recovery
adb
fastboot



A USB or MTP connection only allows you to view files, you can only access and modify the user space, not system.



Sent from my LGL84VL using Tapatalk

I'm okay with any option as long as I can get my device back lol. I'm trying to communicate with the device using ADB and Fastboot commands, but no luck yet. I've downloaded Motorola Device Manager and attempted to use their drives, still nothing. I even tried using composite drives from both fire device and Motorola, nothing. If I uninstall the device, unplug it from my computer and plug it back in, PC refers to it as "QHSUSB_BULK." So it's still communicating something with my PC, but I can't find the right driver to receive a response.

If I plug the device into Linux, all of the files in the partitions are visible. Would I have better luck communicating with the device via Linux or does it not matter?

Any suggestions? I've through a few forums already on QHSUSB_BULK, but all of the solutions relate to other devices or older firmware. One OP mentioned flashing the device with something like QDLoader? But he commented the fix would not work if I was using 4.5.5.3.

Any help would be appreciated.
 

Droidriven

Senior Member
Jan 27, 2014
15,429
9
5,360
NC
Verizon Samsung Galaxy S III
HTC Thunderbolt
I'm okay with any option as long as I can get my device back lol. I'm trying to communicate with the device using ADB and Fastboot commands, but no luck yet. I've downloaded Motorola Device Manager and attempted to use their drives, still nothing. I even tried using composite drives from both fire device and Motorola, nothing. If I uninstall the device, unplug it from my computer and plug it back in, PC refers to it as "QHSUSB_BULK." So it's still communicating something with my PC, but I can't find the right driver to receive a response.

If I plug the device into Linux, all of the files in the partitions are visible. Would I have better luck communicating with the device via Linux or does it not matter?

Any suggestions? I've through a few forums already on QHSUSB_BULK, but all of the solutions relate to other devices or older firmware. One OP mentioned flashing the device with something like QDLoader? But he commented the fix would not work if I was using 4.5.5.3.

Any help would be appreciated.
Have you seen this thread?

https://forum.xda-developers.com/showthread.php?t=2795602

Sent from my LGL84VL using Tapatalk
 

Praxxer1

Member
Mar 21, 2018
26
2
Have you seen this thread?

https://forum.xda-developers.com/showthread.php?t=2795602

Sent from my LGL84VL using Tapatalk

I just read through it, it was ALOT to take in. Pretty incredible, high level stuff - above my head. From what a garnered, they were unable to unbrick. But someone had suggested using a Qualcomm utility of some sort to flash the appropriate ADB driver on their device, but I wasn't able to comprehend exactly what they were suggesting. Any ideas about Qualcomm HS-USB QDLoader 9008 driver or where I can learn more about it?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hi! hello every one.......I'm new to XDA .... and may be I'm posting my problem in wrong discussion ...... any how I having a problem with my mt6589 Clone S4......
    Yesterday I was using my phone and it's working fine but when I restart my phone I gets stuck on adroid logo..... I tried wiping cache / factory rest....but no luck...
    I'm googling my problem for last 14 to 15 hours but I don't find any help full information......
    I tried Installing custom rom by going to recovery mode .....but it gets unknown error....
    I tried spflash tool ..... but it asks for enabling usb debugging mode but my stucks on android logo..... now basically my question is that how to turn debugging mode on when my phone get stucks on android logo.....
    I also can't install cwm recovery because it's also ask for enabling a debugging mode.......

    So, you flashed a ROM via cwm.
    A few lines later you mention that you can't install cwm... is there something I miss????
    Whatever;
    Can you enter Fastboot/Flash mode manually/via PC and flash a new ROM from there using Flash Tool?
    Have you unlocked your bootloader?

    Have you tried following these steps?

    That's pretty much everything I can think of.
    I hope it's just a software brick... :fingers-crossed:
    2
    plz can anyone tell how to enable usb debugging mode when phone is bricked.....
    2
    my phone too .. I forgot to switch my USB debugging... :(
    1
    if you want to install a stock rom via odin, you dont need usb debugging to be on, just boot into odin/download mode (google to see how) and flash a stock rom, then do whatever you need.
    1
    Hi! hello every one.......I'm new to XDA .... and may be I'm posting my problem in wrong discussion ...... any how I having a problem with my mt6589 Clone S4......
    Yesterday I was using my phone and it's working fine but when I restart my phone I gets stuck on adroid logo..... I tried wiping cache / factory rest....but no luck...
    I'm googling my problem for last 14 to 15 hours but I don't find any help full information......
    I tried Installing custom rom by going to recovery mode .....but it gets unknown error....
    I tried spflash tool ..... but it asks for enabling usb debugging mode but my stucks on android logo..... now basically my question is that how to turn debugging mode on when my phone get stucks on android logo.....
    I also can't install cwm recovery because it's also ask for enabling a debugging mode.......

    Now listen to me very carefully! Don't even try to flash a new firmware to your mobile which is not for your mobile and face the same fate as did! Your place is needrom.com. just contact the site administrator for your device model and he will help you... Believe me!