How to enable VoLTE // VoWiFi Switch (without Root)

devsx

Senior Member
Sep 5, 2016
76
44
0
1: Go to the dialer and enter: *#800#
2: Select Enter
3: Go to Logkit
4: Swipe down to function switch
5: Tick VoLTE, VoWiFi switch
6: Reboot

That's a way if you don't want to root and install the voenabler magisk module.

Keep in mind, that will not enable VoLTE if you don't have the right NV-Settings, IMS apn configured, your carrier doesn't support VoLTE or your subscription is not provisioned for VoLTE.
 

FireMAN999

Senior Member
Sep 6, 2006
140
39
0
1: Go to the dialer and enter: *#800#
2: Select Enter
3: Go to Logkit
4: Swipe down to function switch
5: Tick VoLTE, VoWiFi switch
6: Reboot

That's a way if you don't want to root and install the voenabler magisk module.

Keep in mind, that will not enable VoLTE if you don't have the right NV-Settings, IMS apn configured, your carrier doesn't support VoLTE or your subscription is not provisioned for VoLTE.
THANKS MATE YOU ARE A LIFE SAVER.
I am on 3 UK and have had VoLTE and VoWiFi working on my previous phones but the switches were not available to turn on with the OP6.
No matter what I tried I was unable to view these settings to turn them on.
Phoning 3 UK for help was a waste of a call.
Now both are working again.
THANKS.
 

js931

Senior Member
Jul 14, 2010
448
128
43
For me *#800# doesn't work. "unknow application"
You probably don't have the stock ROM. In some custom ROMs this app has been removed...

---------- Post added at 02:14 PM ---------- Previous post was at 02:11 PM ----------

1: Go to the dialer and enter: *#800#
2: Select Enter
3: Go to Logkit
4: Swipe down to function switch
5: Tick VoLTE, VoWiFi switch
6: Reboot

That's a way if you don't want to root and install the voenabler magisk module.

Keep in mind, that will not enable VoLTE if you don't have the right NV-Settings, IMS apn configured, your carrier doesn't support VoLTE or your subscription is not provisioned for VoLTE.
I think that is only the first step in the process to enable it. This activates the buttons, but not the underlying function. You have to complete the whole process, including editing your EFS with some Qualcomm service technician tool.
There are instructions around from the developer Jamal on another forum.
 

white43

Senior Member
Jan 26, 2008
652
143
73
Dorset, UK
1: Go to the dialer and enter: *#800#
2: Select Enter
3: Go to Logkit
4: Swipe down to function switch
5: Tick VoLTE, VoWiFi switch
6: Reboot

That's a way if you don't want to root and install the voenabler magisk module.

Keep in mind, that will not enable VoLTE if you don't have the right NV-Settings, IMS apn configured, your carrier doesn't support VoLTE or your subscription is not provisioned for VoLTE.
You probably don't have the stock ROM. In some custom ROMs this app has been removed...

---------- Post added at 02:14 PM ---------- Previous post was at 02:11 PM ----------



I think that is only the first step in the process to enable it. This activates the buttons, but not the underlying function. You have to complete the whole process, including editing your EFS with some Qualcomm service technician tool.
There are instructions around from the developer Jamal on another forum.

WORKS!!!! Dude you are a lifesaver!

This was so annoying as I'm on Three UK and due to some sort of *something* between Three and OP, you can't have the Wifi calling options. Even though Three support Wifi Calling.

So your procedure made the buttons 'appear'.

So I tested it - turned on Wifi Calling, put the phone into Airplane mode and turned on Wifi. Was successfully able to make a call!!!! :D:highfive:
 
  • Like
Reactions: goRt

brmbjn

Senior Member
Mar 17, 2015
774
83
53
Bojonegoro
1: Go to the dialer and enter: *#800#
2: Select Enter
3: Go to Logkit
4: Swipe down to function switch
5: Tick VoLTE, VoWiFi switch
6: Reboot

That's a way if you don't want to root and install the voenabler magisk module.

Keep in mind, that will not enable VoLTE if you don't have the right NV-Settings, IMS apn configured, your carrier doesn't support VoLTE or your subscription is not provisioned for VoLTE.
thank work fine
 

humzaahmed155

Senior Member
Dec 30, 2011
1,331
295
113
London
WORKS!!!! Dude you are a lifesaver!

This was so annoying as I'm on Three UK and due to some sort of *something* between Three and OP, you can't have the Wifi calling options. Even though Three support Wifi Calling.

So your procedure made the buttons 'appear'.

So I tested it - turned on Wifi Calling, put the phone into Airplane mode and turned on Wifi. Was successfully able to make a call!!!! :D:highfive:
See I've done the exact same thing as you, on the exact same network, but for some reason, now that I've enabled this my caller ID just stopped working
 

cheetah2k

Senior Member
May 27, 2008
1,470
194
83
Brisbane
Awesome!! worked for me on Vodafone Australia!:good::good::good::good::good::good:




1: Go to the dialer and enter: *#800#
2: Select Enter
3: Go to Logkit
4: Swipe down to function switch
5: Tick VoLTE, VoWiFi switch
6: Reboot

That's a way if you don't want to root and install the voenabler magisk module.

Keep in mind, that will not enable VoLTE if you don't have the right NV-Settings, IMS apn configured, your carrier doesn't support VoLTE or your subscription is not provisioned for VoLTE.
 

aoprea

Senior Member
Nov 20, 2007
411
225
63
Iasi
why is so hard to understand ???
only this procedure with open the dialer: *#800# --> oneplus Logkit --> Function Switch --> enable VoLTE + VoWifi switch
it's not enough in some providers ... this only enable switch's without root

please continue with this steps described here: https://forum.xda-developers.com/oneplus-5t/how-to/guide-volte-vowifi-german-carriers-t3817542

It does say VoLTE provisioned in *#*#4636#*#* after this procedure . My SIM card is VoLTE activated in a supported phone by DigiMobil Romania . But seems there's no luck for me.
I have OP6 with volte and wowifi enabled and working with this procedure on DigiMobil Romania


.
 
Last edited:
  • Like
Reactions: MetalSir

matze19999

Senior Member
Dec 23, 2013
795
335
93
21
Near Donauwörth
1: Go to the dialer and enter: *#800#
2: Select Enter
3: Go to Logkit
4: Swipe down to function switch
5: Tick VoLTE, VoWiFi switch
6: Reboot

That's a way if you don't want to root and install the voenabler magisk module.

Keep in mind, that will not enable VoLTE if you don't have the right NV-Settings, IMS apn configured, your carrier doesn't support VoLTE or your subscription is not provisioned for VoLTE.
this doenst work for german users, u have to modify a bit more to make it worked for them ^^