• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

How to fix crashing Google Play services

Search This thread

dape16

Senior Member
Jun 20, 2006
502
118
A recent update to the Google Play services makes it crash, regardless of Android version. This is how i fixed it:

Requirements:
Root
A root file explorer
Google Play services APK (make sure to select right Android version and use arm + nodpi): http://www.apkmirror.com/apk/google-inc/google-play-services/google-play-services-10-0-84-release/
System app remover: https://play.google.com/store/apps/details?id=com.jumobile.manager.systemapp

Instructions:
Disable WiFi.
Use System app remover to uninstall Google Play services, this will make it revert to the factory supplied version.
Install the Google Play services apk. The 10.0.84 is the latest working version accordning to my tests.
Create two folders in \data\app and name them com.google.android.gms-1.apk and com.google.android.gms-2.apk. This will stop Google Play services from auto updating. You should be able to create at least one. Do not overwrite any existing file.
Restart and enable WiFi.

Credits:
ConnCarl: https://forum.xda-developers.com/android/help/delete-disable-downgrade-prevent-update-t3091832
 

growf

Member
Feb 11, 2017
14
14
Some additional steps to the above.

If Google Play is broken, like it was on mine, you can't download the System app remover. I got it from http://www.apkmirror.com/apk/jumobi...-root-3-6-2019-android-apk-download/download/
(I do not know if that site is safe.)
Download APK to PC, transfer it over USB, and install it with Terminal Emulator.

Also, if you cannot download a File Explorer since Google Play is broken, try some APK like http://www.apkmirror.com/apk/es-glo...-manager-4-1-6-android-apk-download/download/
(again, no idea if that site is safe.)
and install it via Terminal...

Then finally you can click the Google Play services APK. (Or just install it via terminal since by now you know how to...)

NOTE: if you have TF101 with KatKiss 4.4.4 you can't use the one marked Android 4.4W+, it fails and you will wasting hours of your time like I did - use the Android 2.3 version.

---------- Post added at 02:53 AM ---------- Previous post was at 01:53 AM ----------

After spending 3 hours of figuring out all the above details, I still got the "has stopped" popups, because I had created the file names in terminal as gsm instead of gms. Details are important...
 
Last edited:

ignasigh

Member
Jan 17, 2009
47
2
Barcelona
My problem is that while trying to flash KK6.0 again it gets stuck on the "Checking connection" step and it continuously prompts the famous "Unfortunately, Google Play services has stopped". I have flashed old gapps (1st Feb) but problem persists.

I know there is a general issue about a gplay/gservices version but I am not sure how to proceed now....:confused:
 
Dec 20, 2014
17
10
This is my solution for Transformer TF101 on firmware KatKiss 4.4.4:
  1. Install Lucky Patcher from here: dl1.revdownload.com/dl1/1701/Lucky_Patcher_v6.4.5__5557_Revdl.com.apk
  2. Open Lucky Patcher, select "Search", type "Google"
  3. Uninstall "Google Play", "Google Play Services" (I also uninstalled "Google App" forever cause I needn't it)
  4. Download open gapps on 2017-07-31 from here: github.com/opengapps/arm/releases/download/20160731/open_gapps-arm-4.4-pico-20160731.zip
  5. Disable Wi-fi
  6. Reboot to TWRP recovery
  7. Flash gapps, wipe cache/dalvik.
  8. Now boot and create 2 folders in /data/app - com.google.android.gms-1.apk and com.google.android.gms-2.apk
  9. Now you can turn on your Wi-fi

Here's my solution about installing right version of Youtube for this gapps and prevent Youtube app from updating. There's ZipSigner app which changes a certificate and "detaches" the app from Google Play. For Youtube app this method causes failure on startup with a security exception. Luckily, I've found another solution:
  1. The latest working version is 11.41.56 on October 28, 2016. Download Youtube app from here: apkmirror.com/apk/google-inc/youtube/youtube-11-41-56-release/youtube-11-41-56-21-android-apk-download/download
  2. Disable Wi-fi
  3. Uninstall current Youtube using Lucky Patcher
  4. Now install downloaded version of Youtube
  5. Create a folder com.google.android.youtube-2.apk in /data/app. There should be 1 file com.google.android.youtube-1.apk and 1 folder com.google.android.youtube-2.apk.
    This solution should prevent a Youtube app from being updated by Google Play: it begins to update but at the end dialog shown which says there's insufficient storage space.
    By the way, you can prevent auto-update for another Google app like Google Drive. Open Lucky Patcher, click on the app and select "App Info" and you'll see a detailed info. All you need to do is to create a folder with name like apk but "-1.apk" has to be replaced with "-2.apk"
  6. Turn on Wi-fi
 
  • Like
Reactions: Peter_

timppu

New member
Feb 18, 2017
1
0
Phew, good to know it wasn't only me. I've been having this Services issue for some time now on the old 4.4.4 KatKiss, googling for it, updated to 6.0.1 but the problem starts as soon as I even try to install Google Play Services in any way (either flashing GAPPS or installing afterwards with an apk). The device works fine without the Services, but then I can't use Google Play...

So is it yet known who are affected? Is this only a TF101 problem, or are other devices (also non-ASUS ones) also affected? Or is this a KatKiss issue? Or what?

I don't feel like blocking Google from updating the services, that sounds like a stopgap solution that probably makes Services unusable in the long run. Hoping that e.g. Google fixes this problem with a new update...
 
Last edited:
Dec 20, 2014
17
10
So is it yet known who are affected? Is this only a TF101 problem, or are other devices (also non-ASUS ones) also affected? Or is this a KatKiss issue? Or what?

I don't feel like blocking Google from updating the services, that sounds like a stopgap solution that probably makes Services unusable in the long run. Hoping that e.g. Google fixes this problem with a new update...
Yes, there are a lot of devices which faced with this issue. The reason why Google Services stopped working is so-called NEON instruction set for ARM chips. Our tablet has Nvidia Tegra 2 chip which does not support such command set! And no, that will not be fixed!
Here's a quote from the forum (bit.ly/2luHVwu):
If this started on or about the 9th it is due to Google putting ARM neon code into the last update. Older ARM chips do not have neon code functionality and are therefore screwed.
My 6 year old Asus TF101 with a Tegra 2 processor was still running like a champ with android 6.0.1 until last week.
 

kenpoh

Member
Feb 19, 2017
6
0
My problem is that while trying to flash KK6.0 again it gets stuck on the "Checking connection" step and it continuously prompts the famous "Unfortunately, Google Play services has stopped". I have flashed old gapps (1st Feb) but problem persists.

I know there is a general issue about a gplay/gservices version but I am not sure how to proceed now....:confused:

I was having it stop at the "Checking Connection" step too, realized I was using the 2017 gapps package instead of the 2016 one. Check to see if you're using the correct one. However, I'm still having the "Google Services" issue.
 

kenpoh

Member
Feb 19, 2017
6
0
A recent update to the Google Play services makes it crash, regardless of Android version. This is how i fixed it:

Requirements:
Root
A root file explorer
Google Play services APK (make sure to select right Android version and use arm + nodpi): http://www.apkmirror.com/apk/google-inc/google-play-services/google-play-services-10-0-84-release/
System app remover: https://play.google.com/store/apps/details?id=com.jumobile.manager.systemapp

Instructions:
Disable WiFi.
Use System app remover to uninstall Google Play services, this will make it revert to the factory supplied version.
Install the Google Play services apk. The 10.0.84 is the latest working version accordning to my tests.
Create two folders in \data\app and name them com.google.android.gms-1.apk and com.google.android.gms-2.apk. This will stop Google Play services from auto updating. You should be able to create at least one. Do not overwrite any existing file.
Restart and enable WiFi.

Credits:
ConnCarl: https://forum.xda-developers.com/android/help/delete-disable-downgrade-prevent-update-t3091832

I was finally able to get it to work but had to omit the .apk part of the two folder names. UPDATE: sorry, that actually didn't work, in fact, at the moment, no matter what I try, I cannot stop it from updating at some point and having to start all over again...
 
Last edited:

lrmotta

New member
Oct 21, 2015
1
0
I rolled back to ASUS 4.0.3 original firmware.

It is working fine for the last 5 days, as long you do not update any of Google apps. The original firmware still has Google Talk pre-installed. :eek:

The original firmware is so so slow, when compared with KatKiss 6.0.1 or KatKiss 4.4.4, but at least it is working fine. No FCs at all.

Please note that there are some recent apps that do not work with Ice Cream Sandwich (Android 4.0.3).

[]'s
 

Apaco

Member
Jul 18, 2011
19
4
Version Matters

I was finally able to get it to work but had to omit the .apk part of the two folder names.

Kenpoh, what version of KatKiss?

I found the format of the info in the /data/apps folder different from 4.4.4 to 5.1 to 6.0. I was unable to get things to work with fresh 5.1 ROM flashes so went to 4.4.4 and creating the folder with the "-2.apk" worked in 4.4.4. I think the bottom line is you have to create a folder name that is the same name as the .apk file (with a -2) to "confuse" the auto-update.

Now that I know I can get 4.4.4 to work, I'll see if I can get 5.1 and/or 6.0 to work and share my findings.

UPDATE
OK - I gave up :) 6.0 required setup a WiFi connection before fully booting. 5.1 wouldn't let me load ES File Explorer from the terminal (failure uri something or other).

For 4.4.4, I:
- Downloaded ROM, SU, GAPPS, Google Play Services 10.0.84 from apkmirror.com
- Did a clean flash
- booted up installed ES File Explorer from terminal
- installed GPS 10.0.84
- reboot
- create folder using the "-2"
- reboot

All is well. I let everything update (including Google Play Games) and everything is running just fine.
 
Last edited:
Dec 4, 2011
5
0
caracas
This is my solution for Transformer TF101 on firmware KatKiss 4.4.4:
  1. Install Lucky Patcher from here: dl1.revdownload.com/dl1/1701/Lucky_Patcher_v6.4.5__5557_Revdl.com.apk
  2. Open Lucky Patcher, select "Search", type "Google"
  3. Uninstall "Google Play", "Google Play Services" (I also uninstalled "Google App" forever cause I needn't it)
  4. Download open gapps on 2017-07-31 from here: github.com/opengapps/arm/releases/download/20160731/open_gapps-arm-4.4-pico-20160731.zip
  5. Disable Wi-fi
  6. Reboot to TWRP recovery
  7. Flash gapps, wipe cache/dalvik.
  8. Now boot and create 2 folders in /data/app - com.google.android.gms-1.apk and com.google.android.gms-2.apk
  9. Now you can turn on your Wi-fi

Here's my solution about installing right version of Youtube for this gapps and prevent Youtube app from updating. There's ZipSigner app which changes a certificate and "detaches" the app from Google Play. For Youtube app this method causes failure on startup with a security exception. Luckily, I've found another solution:
  1. The latest working version is 11.41.56 on October 28, 2016. Download Youtube app from here: apkmirror.com/apk/google-inc/youtube/youtube-11-41-56-release/youtube-11-41-56-21-android-apk-download/download
  2. Disable Wi-fi
  3. Uninstall current Youtube using Lucky Patcher
  4. Now install downloaded version of Youtube
  5. Create a folder com.google.android.youtube-2.apk in /data/app. There should be 1 file com.google.android.youtube-1.apk and 1 folder com.google.android.youtube-2.apk.
    This solution should prevent a Youtube app from being updated by Google Play: it begins to update but at the end dialog shown which says there's insufficient storage space.
    By the way, you can prevent auto-update for another Google app like Google Drive. Open Lucky Patcher, click on the app and select "App Info" and you'll see a detailed info. All you need to do is to create a folder with name like apk but "-1.apk" has to be replaced with "-2.apk"
  6. Turn on Wi-fi

Thank you very much for your post. It worked flawlessly!!!
 

slow1234

Senior Member
May 2, 2011
102
33
I have a Moto Xoom which is also a Tegra 2 Non-Neon device that is experiencing this Google Play Services issue -

I just had a one-on-one chat with Google support. Since I am running a rooted Moto Xoom (Omni 4.4.4), the only advice Google one-on-one support could provide was to unroot and revert back to Stock (which is 4.1.2. on the Xoom) and/or contact Motorola for support. Google seems to be unwilling to investigate fixes unless folks that are running UNROOTED Tegra2 Non-Neon devices are also experiencing the same issue.

So, if you are running a non-rooted Tegra2 device (like your ASUS TF101's) and are having this issue, please contact Google one-on-one support and let them know via https://support.google.com/googlepla...l=en#contact=1
 

V.I.P.

New member
Aug 11, 2008
2
1
UPDATE
OK - I gave up :) 6.0 required setup a WiFi connection before fully booting. 5.1 wouldn't let me load ES File Explorer from the terminal (failure uri something or other).

For 6.0, I rebooted after first boot, then the "Skip >" option showed up during the wifi connection setup screen.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 20
    A recent update to the Google Play services makes it crash, regardless of Android version. This is how i fixed it:

    Requirements:
    Root
    A root file explorer
    Google Play services APK (make sure to select right Android version and use arm + nodpi): http://www.apkmirror.com/apk/google-inc/google-play-services/google-play-services-10-0-84-release/
    System app remover: https://play.google.com/store/apps/details?id=com.jumobile.manager.systemapp

    Instructions:
    Disable WiFi.
    Use System app remover to uninstall Google Play services, this will make it revert to the factory supplied version.
    Install the Google Play services apk. The 10.0.84 is the latest working version accordning to my tests.
    Create two folders in \data\app and name them com.google.android.gms-1.apk and com.google.android.gms-2.apk. This will stop Google Play services from auto updating. You should be able to create at least one. Do not overwrite any existing file.
    Restart and enable WiFi.

    Credits:
    ConnCarl: https://forum.xda-developers.com/android/help/delete-disable-downgrade-prevent-update-t3091832
    10
    Somebody named Just_Golem posted in one of the Google Support forums and indicated the following potentially good news:

    Apparently today's beta version of Google Play Services (version 10.5.42) may have resolved the Google Play Services issues for non-Neon compatible devices.

    Hopefully it's true and the apk gets pushed to all devices soon.
    9
    Some additional steps to the above.

    If Google Play is broken, like it was on mine, you can't download the System app remover. I got it from http://www.apkmirror.com/apk/jumobi...-root-3-6-2019-android-apk-download/download/
    (I do not know if that site is safe.)
    Download APK to PC, transfer it over USB, and install it with Terminal Emulator.

    Also, if you cannot download a File Explorer since Google Play is broken, try some APK like http://www.apkmirror.com/apk/es-glo...-manager-4-1-6-android-apk-download/download/
    (again, no idea if that site is safe.)
    and install it via Terminal...

    Then finally you can click the Google Play services APK. (Or just install it via terminal since by now you know how to...)

    NOTE: if you have TF101 with KatKiss 4.4.4 you can't use the one marked Android 4.4W+, it fails and you will wasting hours of your time like I did - use the Android 2.3 version.

    ---------- Post added at 02:53 AM ---------- Previous post was at 01:53 AM ----------

    After spending 3 hours of figuring out all the above details, I still got the "has stopped" popups, because I had created the file names in terminal as gsm instead of gms. Details are important...
    7
    Somebody named Just_Golem posted in one of the Google Support forums and indicated the following potentially good news:

    Apparently today's beta version of Google Play Services (version 10.5.42) may have resolved the Google Play Services issues for non-Neon compatible devices.

    Hopefully it's true and the apk gets pushed to all devices soon.

    Installed yesterday night, for the moment no play services FC.

    thanks
    2
    I'm running KatKiss ROM - Asus TF101 Lollipop 5.1.1 Release 24: https://forum.xda-developers.com/eee-pad-transformer/development/rom-t2942560

    I tried the posted fix but google play services was still being auto-updated to the latest unusable version despite creating com.google.android.gms-1.apk and com.google.android.gms-2.apk folders under /data/app. What finally prevented google play services from being auto-updated was by executing the following in a terminal:

    1. The com.google.android.gms-[1-2].apk folders were owned by root after I created them. I changed ownership to system and group system to match the ownership of the other folders under /data/app:

    chown system:system /data/app/com.google.android.gms-1.apk
    chown system:system /data/app/com.google.android.gms-2.apk

    2. The com.google.android.gms-[1-2].apk folders' permission were 700 (rwx------) after I created them. I changed the permissions of com.google.android.gms-[1-2].apk folders to 755 (rwxr-xr-x) to match the permissions of the other folders under /data/apk:

    chmod 755 /data/app/com.google.android.gms-1.apk
    chmod 755 /data/app/com.google.android.gms-2.apk