[how to] Fix the google contacts sync issue on CN ROM

Search This thread

kezzuki

Senior Member
Mar 9, 2013
282
59
Toronto
This guide is to meant to attempt to save valuable time and frustration from anyone who needs google's contact sync.
Please keep all discussions polite.

So I need google apps on a daily basis and i tried to set up google on the chinese ROM .
And of course there is no Google contacts app so you need to put it in yourself.
I have looked at several guides and threads from XDA and MIUI Forum but they didn't seem to touch the critical steps for getting the contacts to sync with google.
After 2 days of trying...literally.., i figured out how to set the contact sync up reliably, not "reboot it and it will work after the reboot" sorta result.
If the following steps don't work for you, please let me know...I have tried this on 2 MIX 3's and they all worked after first attempt.

1, Enable google play services in Settings app -> system apps -> google play services
2, Download the Google play store from Apk Mirror:
https://www.apkmirror.com/apk/googl...8-23-all-0-pr-224256688-android-apk-download/
and the google contacts sync adapter:
https://www.apkmirror.com/apk/googl.../google-contacts-sync-9-android-apk-download/
And install them.
3, Open google play store, log in, and install Google contacts from the play store.
4, Give permissions to google contacts and contact sync adapter
*** Above steps are common to the threads i have read, and below are the key points ***
5, Enable on developer options by goto Settings->my phone(or something like that) -> full specs and tap MIUI version 7 times.
6, Go to settings -> additional settings -> developer options , scroll to the very bottom (last item) and disable "MIUI optimizations". Will explain why in later steps.
7, Download an "app permission setting" app such as (but not limited to) this one:
https://play.google.com/store/apps/details?id=com.fdd2hdd.AppPermissionInfo
8, Open the permission settings app and find Google contacts and Google contact sync adapter apps and grant all their required permission.
Once you are here you should notice that, the permission GUI opened from this permission app is different. The GUI here is more AOSP style, or vanilla android style, and this is what we need. The permission GUI from MIUI layer doesn't allow you to set this up.
******* End of the key steps************
9, Now if you go to settings->accounts->Google, you should see "contacts" in the sync options and it should work. If not, well, reboot lol, i think it should appear.



If this works for you, a "Thanks" button press is very much appreciated.
 
Last edited:

Mackay53

Senior Member
Apr 1, 2011
2,113
769
Edinburgh
OPPO Find X5 Pro
This guide is to meant to attempt to save valuable time and frustration from anyone who needs google's contact sync.
Please keep all discussions polite.

So I need google apps on a daily basis and i tried to set up google on the chinese ROM .
And of course there is no Google contacts app so you need to put it in yourself.
I have looked at several guides and threads from XDA and MIUI Forum but they didn't seem to touch the critical steps for getting the contacts to sync with google.
After 2 days of trying...literally.., i figured out how to set the contact sync up reliably, not "reboot it and it will work after the reboot" sorta result.
If the following steps don't work for you, please let me know...I have tried this on 2 MIX 3's and they all worked after first attempt.

1, Enable google play services in Settings app -> system apps -> google play services
2, Download the Google play store from Apk Mirror:
https://www.apkmirror.com/apk/googl...8-23-all-0-pr-224256688-android-apk-download/
and the google contacts sync adapter:
https://www.apkmirror.com/apk/googl.../google-contacts-sync-9-android-apk-download/
And install them.
3, Open google play store, log in, and install Google contacts from the play store.
4, Give permissions to google contacts and contact sync adapter
*** Above steps are common to the threads i have read, and below are the key points ***
5, Enable on developer options by goto Settings->my phone(or something like that) -> full specs and tap MIUI version 7 times.
6, Go to settings -> additional settings -> developer options , scroll to the very bottom (last item) and disable "MIUI optimizations". Will explain why in later steps.
7, Download an "app permission setting" app such as (but not limited to) this one:
https://play.google.com/store/apps/details?id=com.fdd2hdd.AppPermissionInfo
8, Open the permission settings app and find Google contacts and Google contact sync adapter apps and grant all their required permission.
Once you are here you should notice that, the permission GUI opened from this permission app is different. The GUI here is more AOSP style, or vanilla android style, and this is what we need. The permission GUI from MIUI layer doesn't allow you to set this up.
******* End of the key steps************
9, Now if you go to settings->accounts->Google, you should see "contacts" in the sync options and it should work. If not, well, reboot lol, i think it should appear.



If this works for you, a "Thanks" button press is very much appreciated.

Could just install Google installer v3 APK, let it install and go to contacts permission in settings and tick them all, job done
 
  • Like
Reactions: kezzuki

souless poet

Senior Member
Nov 9, 2009
434
59
Chinese ROM doesn't have it installed so no need to uninstall it. Just run Google installer v3, set contacts permission and it works fine.

If I remember it does. That however may be the dev rom as I only set up the stock room once while I set up the dev rom multiple times. Dev rom install of contacts sync will fail.
 
  • Like
Reactions: kezzuki

Shilis

Member
Nov 12, 2018
8
2
Install Google installer v3 APK, let it install and go to contacts permission in settings and tick them all, job done - this has helped. Thank you!
 
  • Like
Reactions: Mackay53

knives of ice

Senior Member
Jul 12, 2007
1,611
261
Xiaomi Mix Fold 2
not sure what the problem is, followed this guide to a T and still can't get contacts to show up in my google account to sync it. everything else like Gmail works no problem. i have every permission checked. i've uninstalled and reinstalled. i have the AOSP like sliders to turn things on after going to developer settings.

for some reason instead of contacts i get a people details sync but nothing for contacts will show up. so frustrating.

ok i wiped data and started from scratch and unfortunately same results. ****ing hell this never happened with original mi mix. i guess i'm stuck waiting for the 72 hours to be able to unlock unless anyone has other ideas.


EDIT - ------ FINALLY I got this working. the key is you have to downgrade the calendar sync app to 8.1 - it would not work with 9.0 for me for some reason. once i did this and followed the rest of your instructions it finally worked for me
 
Last edited:

clue2001

New member
Jan 8, 2022
1
0
Worked excellent in Mi 11 Pro! at 2022, I only wonder about what I'm losing by disbling the optimizations, but at the beginning it seems not a big deal... thanks!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    This guide is to meant to attempt to save valuable time and frustration from anyone who needs google's contact sync.
    Please keep all discussions polite.

    So I need google apps on a daily basis and i tried to set up google on the chinese ROM .
    And of course there is no Google contacts app so you need to put it in yourself.
    I have looked at several guides and threads from XDA and MIUI Forum but they didn't seem to touch the critical steps for getting the contacts to sync with google.
    After 2 days of trying...literally.., i figured out how to set the contact sync up reliably, not "reboot it and it will work after the reboot" sorta result.
    If the following steps don't work for you, please let me know...I have tried this on 2 MIX 3's and they all worked after first attempt.

    1, Enable google play services in Settings app -> system apps -> google play services
    2, Download the Google play store from Apk Mirror:
    https://www.apkmirror.com/apk/googl...8-23-all-0-pr-224256688-android-apk-download/
    and the google contacts sync adapter:
    https://www.apkmirror.com/apk/googl.../google-contacts-sync-9-android-apk-download/
    And install them.
    3, Open google play store, log in, and install Google contacts from the play store.
    4, Give permissions to google contacts and contact sync adapter
    *** Above steps are common to the threads i have read, and below are the key points ***
    5, Enable on developer options by goto Settings->my phone(or something like that) -> full specs and tap MIUI version 7 times.
    6, Go to settings -> additional settings -> developer options , scroll to the very bottom (last item) and disable "MIUI optimizations". Will explain why in later steps.
    7, Download an "app permission setting" app such as (but not limited to) this one:
    https://play.google.com/store/apps/details?id=com.fdd2hdd.AppPermissionInfo
    8, Open the permission settings app and find Google contacts and Google contact sync adapter apps and grant all their required permission.
    Once you are here you should notice that, the permission GUI opened from this permission app is different. The GUI here is more AOSP style, or vanilla android style, and this is what we need. The permission GUI from MIUI layer doesn't allow you to set this up.
    ******* End of the key steps************
    9, Now if you go to settings->accounts->Google, you should see "contacts" in the sync options and it should work. If not, well, reboot lol, i think it should appear.



    If this works for you, a "Thanks" button press is very much appreciated.
    2
    not sure what the problem is, followed this guide to a T and still can't get contacts to show up in my google account to sync it. everything else like Gmail works no problem. i have every permission checked. i've uninstalled and reinstalled. i have the AOSP like sliders to turn things on after going to developer settings.

    for some reason instead of contacts i get a people details sync but nothing for contacts will show up. so frustrating.

    ok i wiped data and started from scratch and unfortunately same results. ****ing hell this never happened with original mi mix. i guess i'm stuck waiting for the 72 hours to be able to unlock unless anyone has other ideas.


    EDIT - ------ FINALLY I got this working. the key is you have to downgrade the calendar sync app to 8.1 - it would not work with 9.0 for me for some reason. once i did this and followed the rest of your instructions it finally worked for me
    1
    This guide is to meant to attempt to save valuable time and frustration from anyone who needs google's contact sync.
    Please keep all discussions polite.

    So I need google apps on a daily basis and i tried to set up google on the chinese ROM .
    And of course there is no Google contacts app so you need to put it in yourself.
    I have looked at several guides and threads from XDA and MIUI Forum but they didn't seem to touch the critical steps for getting the contacts to sync with google.
    After 2 days of trying...literally.., i figured out how to set the contact sync up reliably, not "reboot it and it will work after the reboot" sorta result.
    If the following steps don't work for you, please let me know...I have tried this on 2 MIX 3's and they all worked after first attempt.

    1, Enable google play services in Settings app -> system apps -> google play services
    2, Download the Google play store from Apk Mirror:
    https://www.apkmirror.com/apk/googl...8-23-all-0-pr-224256688-android-apk-download/
    and the google contacts sync adapter:
    https://www.apkmirror.com/apk/googl.../google-contacts-sync-9-android-apk-download/
    And install them.
    3, Open google play store, log in, and install Google contacts from the play store.
    4, Give permissions to google contacts and contact sync adapter
    *** Above steps are common to the threads i have read, and below are the key points ***
    5, Enable on developer options by goto Settings->my phone(or something like that) -> full specs and tap MIUI version 7 times.
    6, Go to settings -> additional settings -> developer options , scroll to the very bottom (last item) and disable "MIUI optimizations". Will explain why in later steps.
    7, Download an "app permission setting" app such as (but not limited to) this one:
    https://play.google.com/store/apps/details?id=com.fdd2hdd.AppPermissionInfo
    8, Open the permission settings app and find Google contacts and Google contact sync adapter apps and grant all their required permission.
    Once you are here you should notice that, the permission GUI opened from this permission app is different. The GUI here is more AOSP style, or vanilla android style, and this is what we need. The permission GUI from MIUI layer doesn't allow you to set this up.
    ******* End of the key steps************
    9, Now if you go to settings->accounts->Google, you should see "contacts" in the sync options and it should work. If not, well, reboot lol, i think it should appear.



    If this works for you, a "Thanks" button press is very much appreciated.

    Could just install Google installer v3 APK, let it install and go to contacts permission in settings and tick them all, job done
    1
    Chinese ROM doesn't have it installed so no need to uninstall it. Just run Google installer v3, set contacts permission and it works fine.

    If I remember it does. That however may be the dev rom as I only set up the stock room once while I set up the dev rom multiple times. Dev rom install of contacts sync will fail.
    1
    Install Google installer v3 APK, let it install and go to contacts permission in settings and tick them all, job done - this has helped. Thank you!