how to install GSI on Pixel 3a

Search This thread


Senior Member
Aug 8, 2012
i couldn't install phh-treble 10 AOSP on my Pixel 3a runing android 10 through the bootloader or fastbootd ,

on the bootloader it says it should be done through fastbootd and on fastbootd it says it can't resize the partition ,

is there a third way i don't know about ??


New member
Aug 22, 2013
I never tried this myself but you just reminded me of this from Googles page:

On Android 10 devices that have smaller system partitions, the following error message might appear when flashing the GSI:

Resizing 'system_a' FAILED (remote: 'Not enough space to resize partition')
fastboot: error: Command failed

Use the following command to delete the product partition and free up space for the system partition. This provides extra space to flash the GSI:

$ fastboot delete-logical-partition product_a

The postfix _a should match the slot id of the system partition, such as system_a in this example.

I never tried it but I am probably going to now. I didn't know you had to flash in fastbootd, i was flashing in bootloader and the rom had no data connection so now I'm excited to try in in fastbootd :)