• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

How to install on linux, protips for noobs with outdated fastboot/adb

Search This thread

Dratini

Senior Member
Jul 21, 2010
180
16
I spent a day with issues on linux, mainly fastboot not being recent enough (grapheneOS) and adb not working properly installing on linux (did not detect my devices when not booted to system) adb kept not detecting my deviecs was most of my problems, I kept trying to install TWRP (don't bother as of June 2021). Here are my tips:

Download this for latest adb and fastboot
Open it and get adb and fastboot executables
Use "which fastboot" and "which adb" to find where they are located in, mine were in /usr/bin

Move both into /usr/bin (root on linux required, I used su on a file brower, I used PCManFM but you can use something else, now they will be in path and not outdated executables from debian)

I installed magisk root (canary to modify boot.img) on GrapheneOS with https://www.droidwin.com/root-andro...STEP_1_Get_Stock_Boot_img_File_from_Stock_ROM The security is nice but I wanted to stop it from charging after 80% with a magisk module I did not get webUSB to work.
Main part is
"fastboot flash boot magisk_patched.img

fastboot flash boot_b magisk_patched.img just did the boot_b patch "
You can use the commands as they suggested but I saw boot did boot_a so I jusd did the 2nd one atfer.

This works too.

Also udev is a problem on linux, I did not have success reaching my phone sometimes and I was running the grapheneOS installer while I tried to install ubuntu touch, the UBports installer fixed my udev when I ran it.
I had problems flashing with adb when I didn't do it in root/sudo
 
Last edited: