Question How to lock bootloader?

Search This thread
I unlocked the bootloader using a quick way, which is by pressing the volume buttons up and down and running the script. After that, I had an inscription at startup, in order to start the phone, I had to press the power button again. To get rid of this inscription, I downloaded platform tools and threw into the platform tools folder a file with the name vbmeta.img, which I took from the firmware that I currently have and entered the command when the phone was in fastboot "fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img". The inscriptions did not disappear, then on one forum I was advised to enter the command "fastboot oem cdms", I entered this command and the phone started without inscriptions. After that, I patched boot.img from my firmware using magisc and threw the file into the platform tools folder, renaming it magisc_boot.img and entered the command "fastboot flash boot magisk_boot.img". Root rights worked, but I realized that I didn't need root and deleted it using the update item and download the full firmware. Now the bootloader is unlocked on my phone and there is no root. How do I lock the bootloader safely. Current Firmware Indonesia


Recognized Contributor
Will there be any problems due to the fact that I unlocked the bootloader in an unofficial way and flashed vbmeta.img from my firmware?
Miflash will erase your data.
Normally not but tried to do a test without locking the bootloader.
Or you can use the Bat files included in the extracted folder of the TGZ file, without Miflash.