• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

How to manually upgrade to FROYO?

Search This thread

rackspace

Senior Member
May 17, 2010
97
1
Unfortunately I am stuck with very slow GPRS (not even EDGE).
Many people have shared the update on zipped files.
I wanted to know, if I download the update in zip file and transfer it to my mobile, how can i manually install the update myself?


I have found the steps to update the froyo:


1. Download the Android 2.2 firmware for the Desire – here is the link to download
2. Rename the file update.zip and copy it to your microSD card via USB. [Note: make sure the file is named update.zip and not update.zip.zip.]
3. Power down your Desire
4. Hold down the “Volume Down” button as you power the phone back on.
5. A screen should appear showing your phone’s system searching for various files. Scroll down to “recovery” and press the “Power” button.
6. When you see the triangle with an exclamation point symbol, press the “Power” and “Volume Up” buttons at the same time.
7. From the menu that appears, select “Apply sdcard:update.zip.”
8. When the screen displays “Install from sdcard complete” select “reboot system now” and wait for the phone to power back up.
 
Last edited:

rackspace

Senior Member
May 17, 2010
97
1
Actually, my question is aimed at those, who have the debranded phones and who are getting the update, but are unable to download it because of in accessibility of wifi and slow data connection of operator.
 

Palidhje

Member
Jul 16, 2010
29
0
Prishtina
I have the same prob. Already downloaded the zip and gonna try a methot found in another website.

Since I'm a new user and not allowed to insert links here it is:

.androidpolice.com/2010/07/30/breaking-htc-releases-android-2-2-froyo-ota-for-evo4g-download/ add www in front

Or google:
[Updated, New Instructions, Mirror] BREAKING: HTC Releases Android 2.2 FroYo OTA For EVO4G [Download]

I know this is really newbish but I guess it should work. Will post the results laterz.
 

rackspace

Senior Member
May 17, 2010
97
1

I am not sure what is problem :(
I have tried the above method my self. And every thing ended out great.

The only problem I faced was failure to upgrade due to low disk space. I deleted some apps and tried to install it again. It worked with out any further issue.

You can make sure that you DONOT touch the zip file. DONOT even open or extract it, just download it and transfer to SD Card.
 

Palidhje

Member
Jul 16, 2010
29
0
Prishtina
I am not sure what is problem :(
I have tried the above method my self. And every thing ended out great.

The only problem I faced was failure to upgrade due to low disk space. I deleted some apps and tried to install it again. It worked with out any further issue.

You can make sure that you DONOT touch the zip file. DONOT even open or extract it, just download it and transfer to SD Card.

That's what I did. Just downloaded, changed name and copied it to sd. :S

I'll try deleting some apps.
 

sebaztian

Senior Member
Jan 8, 2008
58
7
Have you tried this method?


To manually update the phone

1. Download the official firmware update.
2. Copy the file to your microSD card and name it update.zip (newb warning: not update.zip.zip)
3. Power off your phone.
4. Hold down the VOLUME DOWN button and power it back on.
5. The phone will now search for files like PB00IMG.zip, etc. This is normal. Scroll down to recovery and press the POWER button.
6. When you see the /!\ symbol, press the POWER button and the Volume Up button at the same time. You should be presented with a menu and one of the options should be "Apply sdcard:update.zip".
7. Use the trackball to navigate to "apply sdcard:update.zip" and select it.
8. When you see "Install from sdcard complete", select "reboot system now".

Via Nickedynick over at Vodafone forums.
 

gnolihp

Senior Member
Jan 24, 2008
80
0
I got the same error message. Could it be that my Build Number is 1.19.707.7?

I believe the Zip file, before being renamed to update.zip, contains a different Build.

It is 1.21...

I am using a Desire in Singapore. Any idea why the OTA is only available in European countries?

Me too bro, I am from Singapore also. trying to do it manual got error status 7 also.