[HOW TO] [NO JTAG] unbrick / debrick hardbricked Samsung Galaxy S3

still having trouble? New guide by request

  • Total voters
Search This thread

Top Liked Posts

  • There are no posts matching your filters.
  • 46
    This should work on all Qualcomm Snapdragon based Samsung galaxy SIII's, if it doesn't, PM me the model and I'll try and find a solution.


    Disclaimer out of the way, let us begin.

    Needed Materials and Files:

    EDIT: if you have another phone or know someone else with the same phone have them run this and the output will be a debrick image you can use: busybox dd if=/dev/block/mmcblk0 of=/sdcard/backup.bin bs=1M count=200 if it does not work then change the last number (count=) to something larger and try it. If you create an image please upload it so I can put it into a repository I'm creating

    16GB or 32GB class10 microSD card
    A hard bricked Samsung galaxy S3 US Cellular
    The debrick image for your device:

    [[Here is the drive image for a folder containing all the debrick images that I currently have uploaded, more will be coming: https://drive.google.com/folderview?id=0B612qYHFMILfWUlMTTEwdUstcXM&usp=sharing ]]
    If you have any images that I missed, please send me a link or, better yet, upload them to drive, make them publicly shared, and share them with me at [email protected], I will put them in this folder for all to use

    US Cellular R530: ftp://sdbruington.us/d2usc/SCH-R530_ALIVE_MJA_200MB_16GB.bin
    Sprint L710: http://www.mediafire.com/download/23...ph_l710.img.xz
    AT&T I747: http://d-h.st/iEy
    T-mobile T999: http://www.mediafire.com/download/gr...k_SGH-T999.img

    ---I did not upload these images, I have simply collected the links over time, please thank Cnexus for his help in finding these and
    ---helping me to originally unbrick my S3

    Your computer
    A card reader that will accept the card (another phone will not work as this is an image, and it needs to repartition the SD card)
    Either a partition editor (I've heard that you can use dd or something on linux, but I haven't tried) or this: View attachment win32diskimager-v0.9-binary.zip
    A wall charger (computer charging isn't as reliable)


    1. Take the sdcard and insert it into your computer
    2. Download the mentioned image and the software to put it onto the sdcard
    3. Use your computer to pull the data already on the card onto your computer hard drive, as the sdcard will be wiped when the image is put onto it
    4. use the software that you downloaded earlier to burn the image to the sdcard
    5. Remove the battery from the SGS3
    6. insert the sdcard into the S3
    7. Put the battery into the S3
    8. The S3 may boot automatically, or you may have to manually boot it by holding down the power button for 5< seconds
    9. If the update that bricked your phone also messed up /system, then you'll have to coerce Odin mode to shove a stock firmware image to your phone, though I've had more than just SOME trouble with that in the past (in other words I haven't been able to get back to stock yet...), if you simply had a radio update or something go wrong, then proceed to the next step.
    10. Do a victory dance with your phone in your pocket not the repair bench, or on second thought, make sure you don't drop it, don't create another problem. :p
    11. After that, you can just use your device normally with the sdcard in it without worry of bricking it, though it will not be able to boot if you remove the sdcard;
    the only known method of getting it to boot without the sdcard is reflashing stock firmware, which completely wipes the phone and resets everything back to complete stock. Also, Odin mode has, at least for me, objected when I've tried to flash the stock image back onto it, and even if Odin mode was sure of working, backing up ~16GB of data isn't a fast process, especially with the most reliable means being ADB. If you try to flash a stock image and it fails, your device will almost definitely come up with a version of dmode when you try to turn it on with the sdcard (still bricked otherwise) that says something about Kies update failure, the only way of correcting this that I've had success with is flashing an image that won't do much, such as the same recovery that you already had, over odin mode from that special dmode, as while that won't correct the actual brick, it will at least make you able to boot from the sdcard again. I will provide links to the stock images in a little while, once someone gets that far, as I will have to find all but the one from the US Cellular version.
    I am currently looking for firmware images that will only flash the bootloader/modem, if anyone knows of an odin file that could do that, please let me know as soon as possible, in the meantime, I will try and create an update.zip that will flash the necessary files; as most bricks are likely cause by an update.zip that was meant for a different device, I am very confident that it can be fixed with another .zip file.---Stay tuned!

    ---Don't forget, that thanks button won't bite your finger off if you push it:fingers-crossed:

    If any of the links are not fully functional, PM me to let me know, and if you have the link to another debrick image for another device, send me the link so I can include it here!:D

    Please note: While there is a similar procedure for Xynos based S3's, they apparently require a physical modification that requires an amount of soldering, so it is most likely best for them to simply take them in for Jtagging and then just not brick them after that. :(

    EDIT: here is the link to a full youtube tutorial that I made, just for those of you who like watching a video instead of getting lost in a written guide:) https://www.youtube.com/watch?v=-RTAbLBVfMI

    EDIT AGAIN: I'm sorry about both of the mediafire links being down, I will try and find some more and upload them to my google drive, along with the others just to make sure they exist somewhere safe.I'm downloading the images now and uploading some that I already have, they will be available in this folder (https://drive.google.com/folderview?id=0B612qYHFMILfWUlMTTEwdUstcXM&usp=sharing) on google drive and will be available by email upon request
    here is a sprint image that should work, sorry I haven't tested it http://www.mediafire.com/download/231uhy6l80jx74n/debrick_sph_l710.img.xz
    for the t999 4.1: https://www.copy.com/s/xSAswQZbhQX8/t999_debrick.zip for the t999 4.3: https://www.copy.com/s/7ICfKXMC3ccr/T999_4.3_debrick.zip
    I know this is becoming a mess of links :p but here is a link to an xda post that has t999 variant images http://forum.xda-developers.com/showthread.php?t=2439367
    here is a sprint 4.4 debrick image: http://www.androidfilehost.com/?fid=23329332407591176

    If you want to get your phone to operate without an sd card in there for every boot, stay tuned, I'll have a guide to return to stock soon, though a quick google search shouldn't be that hard if you're desperate

    I will clean up this guide in a little bit but currently I have school and such to attend to so it may not be immediate

    I know this is getting unwieldy but (big thanks to youdoofus) I have a way to completely debrick and fix it so it doesn't require even the sd to boot.

    "Restoring stock bootloader
    1) You were able to boot into the ROM
    2) Plug your phone into a computer and use MTP mode
    3) Move the debrick file onto your internal sdcard (/sdcard/debrick.bin)
    4) Disconnect your phone
    5) Open up a Terminal Emulator on your phone and input this code

    dd if=/sdcard/debrick.bin of=/dev/block/mmcblk0

    6) Reboot"
    Of course this should be modified for the different versions and types of debrick image as some are img, some are bin, I think there might even be an ISO hanging around somewhere

    EDIT: As of October 10th I'm working on a tool that will get an image directly from a stock rom/tar and put it on the SDcard. This is pretty complex so it will probably take a little while, but it should make it easier to get images if all that's required is a stock tar.
    I've followed all these guides and haven't had any luck. I did use a CM 4.4 rom and some people are saying i need a debrick.img of a 4.4 to get it working again. i'm on an i-747. can you help?
    You don't need a debrick.img of a 4.4 to get it working, you need a debrick.img of the correct bootloader. If you bricked your phone by flashing an older bootloader after upgrading to the 4.3 bootloader, then you need a debrick.img with the 4.3 bootloader.
    Like i said, it was totally random. My phone froze and rebooted yesterday. It got to the Samsung logo so i thought everything was okay. I fell asleep and woke up to a bricked phone. After all of my attempts, I got one debrick.img to show something on my screen and it shows "BOOT RECOVERY MODE". Odin sees my phone and tries to fix the PIT and the Bootloader but it always fails. From what i gather, it seems to be a hardware issue.

    Whoa whoa there, if your phone still boots in either recovery or download mode, then you don't need to use a debrick.img.

    If you have a custom recovery, you can flash your custom rom. If you don't, you can flash a stock ROM using ODIN in download mode.
    NE6 Debrick Images

    On a OTA stock upgraded i747M 4.4.2 NE6,

    Root (TowelRoot + SuperSU + busybox),

    Here are the OTA NE6 i747M Bell phone 3 debrick images...

    Created from Terminal Emulator APK:

    su (enter)
    busybox dd if=/dev/block/mmcblk0 of=/sdcard/debrick.img bs=1M count=128 (enter)

    I747M_NE6_128.img http://d-h.st/Pl4

    su (enter)
    busybox dd if=/dev/block/mmcblk0 of=/sdcard/debrick.img bs=1M count=256 (enter)

    I747M_NE6_256.img http://d-h.st/WoZ

    su (enter)
    busybox dd if=/dev/block/mmcblk0 of=/sdcard/debrick.img bs=1M count=512 (enter)

    I747M_NE6_512.rar http://d-h.st/w7g

    I haven't try yet.

    Thank u all
    Need help

    Hi, i really need help, i have been trying to unbrick my galaxy s3, its a sgh-i747m model from from a mexican carrier, the latest official firmware that was installed on my phone was "I747MUMUEND3_I747MTCEEND3_I747MUMUEND3_HOME.tar" and i had a custom rom CM12, but i had a problem with the gps and try to update the bootloader or something like that and flashed with the file "d2att_I747UCUEMJB_bootloader_modem_4.3" so after flashed it wouldnt turn on anymore, only the red light when its connected without the battery, i have try different unbrick images but im not able to unbrick, if anyone could help me i would really appreciate.

    Thanks in advance!
    ps. sorry for my english