• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

How to restore and fix "Cust Fail"

Search This thread

lynxdog

Senior Member
Jun 29, 2010
145
67
New Zealand
Many people are having problems with this when you do a Factory Wipe or flash a new rom, after you flash or wipe it will come up with "fail" or "cust fail".

It all comes down to a partition called "/cust"

this dictates what software to install and what theme to use for the "ZONE" of your phone.
I.E my phone is/was a Vodafone AU phone (sim unlocked now).

Now, when you do a recovery/wipe data it looks for information in the /cust partition regarding your phone.
If it's not there then "Cust fail" will appear when you do a wipe.
This has been happening to me for quite some time now, I've tried all types of roms...... but failed every time until now.

This is what I did. (This may only work with my phone but it will give many many many people that information to rectify this problem)

1, unlock your bootloader (you should know how to do this already)
2, flash custom recovery in fastboot mode (again, know how to do this)
3, reboot into recovery and install SuperSU
4, Reboot, and install RootExplorer
5, in RootExplorer mount as R/W then head over to /cust using RootExplorer
6, make a directory in /cust as /cust/vha <----- This was important as vha is Vodafone Hutchinson Australia on my phone
7, copy /cust/hw/au to /cust/vha this will give me /cust/vha/au
8, reboot back into fastboot mode and flash original recovery
9, reboot into recovery and do a wipe...... NO MORE CUST FAIL!!!!!!
10, reboot!!!!! all done..... my god it's taken me weeks to figure this out.

Hope this help.

:cool::laugh::good:
 

Killerdog

Senior Member
Aug 15, 2009
266
94
Cannes
Many people are having problems with this when you do a Factory Wipe or flash a new rom, after you flash or wipe it will come up with "fail" or "cust fail".

It all comes down to a partition called "/cust"

this dictates what software to install and what theme to use for the "ZONE" of your phone.
I.E my phone is/was a Vodafone AU phone (sim unlocked now).

Now, when you do a recovery/wipe data it looks for information in the /cust partition regarding your phone.
If it's not there then "Cust fail" will appear when you do a wipe.
This has been happening to me for quite some time now, I've tried all types of roms...... but failed every time until now.

This is what I did. (This may only work with my phone but it will give many many many people that information to rectify this problem)

1, unlock your bootloader (you should know how to do this already)
2, flash custom recovery in fastboot mode (again, know how to do this)
3, reboot into recovery and install SuperSU
4, Reboot, and install RootExplorer
5, in RootExplorer mount as R/W then head over to /cust using RootExplorer
6, make a directory in /cust as /cust/vha <----- This was important as vha is Vodafone Hutchinson Australia on my phone
7, copy /cust/hw/au to /cust/vha this will give me /cust/vha/au
8, reboot back into fastboot mode and flash original recovery
9, reboot into recovery and do a wipe...... NO MORE CUST FAIL!!!!!!
10, reboot!!!!! all done..... my god it's taken me weeks to figure this out.

Hope this help.

:cool::laugh::good:

Hi Lynxdog, i follow your guide to correct my "cust fail" problem.

I found the correct ID for My phone (apparently a bouygues telecom one), i copy the eu directory to the new one, restart to recovery and make a full wipe, no error so it's Good.

I go to settings, about, but don't seen a Cust version into the info.

Copy B137 dload/update.app and install it, everything is good but if i go to /cust my ne directory is deleted, and if i do a wipe or a new firmware install with dload/update.app i got "cust fail" again.

did you face the same problem ?
 

lynxdog

Senior Member
Jun 29, 2010
145
67
New Zealand
Hi Lynxdog, i follow your guide to correct my "cust fail" problem.

I found the correct ID for My phone (apparently a bouygues telecom one), i copy the eu directory to the new one, restart to recovery and make a full wipe, no error so it's Good.

I go to settings, about, but don't seen a Cust version into the info.

Copy B137 dload/update.app and install it, everything is good but if i go to /cust my ne directory is deleted, and if i do a wipe or a new firmware install with dload/update.app i got "cust fail" again.

did you face the same problem ?

Yip, i get that as well, it seems to be for some phones that with every rom it wipes all customization and installs a generic one which doesn't work.

I gave up and i'm on an iphone 6 for now...... until 5.1 comes out.
 

pascalbriand

Member
Jan 21, 2008
40
6
Paris
Hi Lynxdog, i follow your guide to correct my "cust fail" problem.

I found the correct ID for My phone (apparently a bouygues telecom one), i copy the eu directory to the new one, restart to recovery and make a full wipe, no error so it's Good.

I go to settings, about, but don't seen a Cust version into the info.

Copy B137 dload/update.app and install it, everything is good but if i go to /cust my ne directory is deleted, and if i do a wipe or a new firmware install with dload/update.app i got "cust fail" again.

did you face the same problem ?

Killerdog, can you contact me; thanks
 

Killerdog

Senior Member
Aug 15, 2009
266
94
Cannes
A spanish user (Suros) of HTC-Mania have the CUST.APP for Huawei Mate 7 MT-L09, (he has send his phone to repair, and apparently some tech forgot to remove his sdcard with the B137SP03+Cust update).

You can find the download link in MEGA.

I can't test it right now, because my phone is actually in a repair center, but some user report working good.
 

pascalbriand

Member
Jan 21, 2008
40
6
Paris
A spanish user (Suros) of HTC-Mania have the CUST.APP for Huawei Mate 7 MT-L09, (he has send his phone to repair, and apparently some tech forgot to remove his sdcard with the B137SP03+Cust update).

You can find the download link in MEGA.

I can't test it right now, because my phone is actually in a repair center, but some user report working good.

Hello,

I read you on HTC mania; i have use this firmware (with the update_cust.app) and no more cust fail.

Very Good
 

Killerdog

Senior Member
Aug 15, 2009
266
94
Cannes
just download the zip, extract it and copy to your sd card (you need to have /dload/update.app and /dload/update_cust.app to the root of your sdcard)
shut down your phone.

start it with the 3 buttons (vol + / vol - / power) to start the update process.

You need to be on a 4.4 firmware and to have a MT-L09 model, if you are in 5.1 you need to do a "clean downgrade" before flash it.
 

isaekrem

Senior Member
Mar 23, 2010
223
45
Konya
Hello,

I read you on HTC mania; i have use this firmware (with the update_cust.app) and no more cust fail.

Very Good

just download the zip, extract it and copy to your sd card (you need to have /dload/update.app and /dload/update_cust.app to the root of your sdcard)
shut down your phone.

start it with the 3 buttons (vol + / vol - / power) to start the update process.

You need to be on a 4.4 firmware and to have a MT-L09 model, if you are in 5.1 you need to do a "clean downgrade" before flash it.

Thanks. I wil try.
 

traiangm

Senior Member
Jun 7, 2008
67
23
Cust fail fix

I managed to avoid cust fail by following the tutorial from this link:
http://forum.xda-developers.com/ascend-p7/general/ascend-p7-b602-emui-3-0-international-t2972854

It is for P7, so use steps 3 - up:
3- you must be ROOT
4- have a Root Explorer app
5-go to the folder "data" and see the contents of custom.bin
6. You must remember the contents of this file.
7-Depending on the file custom.bin say, is as it should rename folders CUST.
8-For example if it says "hw/naf", that means that inside the folder "CUST" the folder must exist "hw" and within it another folder "naf".
9. Go to the root folder, using the Root Explorer
10. Go to the folder Cust
11. Rename *the folders according to the content of step 5
12. ( optional ) Perform Factory Reset
 

Sw33t_Lov3r

Senior Member
Dec 8, 2012
135
17
Lima
Hello guys. I followed the process (update.app + update_cust.app) to solve cust fail in my L09 while downgrading from B317 to B137, it succeeded,
though I flashed it through the Updater option because it didn't run the update with the 3 button combination.

Anyway, I got to be on B137 from B317. (Thank you all!) But, my Mate is with NO SIGNAL (Says Emergency Only), I have no telephony :(

What is most weird is that Baseband is now the same as originaly, the same number which worked fine! But I have no telephony.

One thing I saw as I was checking in the Hiden Menu (*#*#2846579159#*#* Please try it) the details of the software of my unit, in the option 7 (Net config) and then 3 (Operator and Country Info), there's:
Operator Name: hw
Country name: eu

This detail seems to point me to this tutorial traiangm has posted in this thread:

Cust fail fix
I managed to avoid cust fail by following the tutorial from this link:
http://forum.xda-developers.com/asce...ional-t2972854

It is for P7, so use steps 3 - up:
3- you must be ROOT
4- have a Root Explorer app
5-go to the folder "data" and see the contents of custom.bin
6. You must remember the contents of this file.
7-Depending on the file custom.bin say, is as it should rename folders CUST.
8-For example if it says "hw/naf", that means that inside the folder "CUST" the folder must exist "hw" and within it another folder "naf".
9. Go to the root folder, using the Root Explorer
10. Go to the folder Cust
11. Rename *the folders according to the content of step 5
12. ( optional ) Perform Factory Reset

What do you think?

What is weird, also, is that after I managed to get on B137 I had no telephony, then I thought flashing the firmware from Huawe's site for my very country of Peru would fix this.
So I downloaded the firmware from Huawei's site for my country and flashed it. It's the B120SP04.
I thought now I would have telephony ok, but no, still no telephony. The baseband is the same as when it was working.
I didn't know what else to do so I checked the Hiden Menu and found that.

What do you think?

I really wish you can send me what information says your unit in the option 7 and 3 of the Hiden Menu, and that you could help me figure out what else to do :(

Thank you in advance!

- L.
 
Last edited:

demirozu69

Senior Member
Aug 6, 2015
159
9
Hello,

I read you on HTC mania; i have use this firmware (with the update_cust.app) and no more cust fail.

Very Good
I tried it too but it did not work,my updater gave software install failed how did you do?I never rescue cust fail error help please,by the way can I load that rom by adb commands maybe it will be a solution,thanks

Sent from my HUAWEI MT7-L09 using Tapatalk
 
Oct 2, 2015
19
1
Many people are having problems with this when you do a Factory Wipe or flash a new rom, after you flash or wipe it will come up with "fail" or "cust fail".

It all comes down to a partition called "/cust"

this dictates what software to install and what theme to use for the "ZONE" of your phone.
I.E my phone is/was a Vodafone AU phone (sim unlocked now).

Now, when you do a recovery/wipe data it looks for information in the /cust partition regarding your phone.
If it's not there then "Cust fail" will appear when you do a wipe.
This has been happening to me for quite some time now, I've tried all types of roms...... but failed every time until now.

This is what I did. (This may only work with my phone but it will give many many many people that information to rectify this problem)

1, unlock your bootloader (you should know how to do this already)
2, flash custom recovery in fastboot mode (again, know how to do this)
3, reboot into recovery and install SuperSU
4, Reboot, and install RootExplorer
5, in RootExplorer mount as R/W then head over to /cust using RootExplorer
6, make a directory in /cust as /cust/vha <----- This was important as vha is Vodafone Hutchinson Australia on my phone
7, copy /cust/hw/au to /cust/vha this will give me /cust/vha/au
8, reboot back into fastboot mode and flash original recovery
9, reboot into recovery and do a wipe...... NO MORE CUST FAIL!!!!!!
10, reboot!!!!! all done..... my god it's taken me weeks to figure this out.

Hope this help.

:cool::laugh::good:


Currently I have cust problem with my Voda AU TL09, I am running B324
Seems like can be fix by ur way only as I failed at 19% when rollback with B300 rollback package.
Copy /cust/hw/au to /cust/vha means copy the content under /cust/hw/au to /cust/vha ? another words....change the name of folder?
or copy the /cust/hw/au under /cust/vha and make it become sub folder under /cust/vha?

Also, where can I get original recovery of B324?

Thanks lot

---------- Post added at 01:25 AM ---------- Previous post was at 01:12 AM ----------

Many people are having problems with this when you do a Factory Wipe or flash a new rom, after you flash or wipe it will come up with "fail" or "cust fail".

It all comes down to a partition called "/cust"

this dictates what software to install and what theme to use for the "ZONE" of your phone.
I.E my phone is/was a Vodafone AU phone (sim unlocked now).

Now, when you do a recovery/wipe data it looks for information in the /cust partition regarding your phone.
If it's not there then "Cust fail" will appear when you do a wipe.
This has been happening to me for quite some time now, I've tried all types of roms...... but failed every time until now.

This is what I did. (This may only work with my phone but it will give many many many people that information to rectify this problem)

1, unlock your bootloader (you should know how to do this already)
2, flash custom recovery in fastboot mode (again, know how to do this)
3, reboot into recovery and install SuperSU
4, Reboot, and install RootExplorer
5, in RootExplorer mount as R/W then head over to /cust using RootExplorer
6, make a directory in /cust as /cust/vha <----- This was important as vha is Vodafone Hutchinson Australia on my phone
7, copy /cust/hw/au to /cust/vha this will give me /cust/vha/au
8, reboot back into fastboot mode and flash original recovery
9, reboot into recovery and do a wipe...... NO MORE CUST FAIL!!!!!!
10, reboot!!!!! all done..... my god it's taken me weeks to figure this out.

Hope this help.

:cool::laugh::good:

another question is how to get unlock code? i checked several post, seems need to send email to Huawei. But I couldn't find way to get my product ID
 

demirozu69

Senior Member
Aug 6, 2015
159
9
use honortuner program with root privalleges, I have cust fail error too but not in au,I am from Turkey and operator is avea, by the way on which rom you tried this way? I am using b133 and folder concepts different how can I solve this problem? on the other hand my device give software fail error,even original b133 rom too,is my sdcard failed?I did not solve these two problem can any one help,thanks

Sent from my HUAWEI MT7-L09 using Tapatalk
 
Oct 2, 2015
19
1
Many people are having problems with this when you do a Factory Wipe or flash a new rom, after you flash or wipe it will come up with "fail" or "cust fail".

It all comes down to a partition called "/cust"

this dictates what software to install and what theme to use for the "ZONE" of your phone.
I.E my phone is/was a Vodafone AU phone (sim unlocked now).

Now, when you do a recovery/wipe data it looks for information in the /cust partition regarding your phone.
If it's not there then "Cust fail" will appear when you do a wipe.
This has been happening to me for quite some time now, I've tried all types of roms...... but failed every time until now.

This is what I did. (This may only work with my phone but it will give many many many people that information to rectify this problem)

1, unlock your bootloader (you should know how to do this already)
2, flash custom recovery in fastboot mode (again, know how to do this)
3, reboot into recovery and install SuperSU
4, Reboot, and install RootExplorer
5, in RootExplorer mount as R/W then head over to /cust using RootExplorer
6, make a directory in /cust as /cust/vha <----- This was important as vha is Vodafone Hutchinson Australia on my phone
7, copy /cust/hw/au to /cust/vha this will give me /cust/vha/au
8, reboot back into fastboot mode and flash original recovery
9, reboot into recovery and do a wipe...... NO MORE CUST FAIL!!!!!!
10, reboot!!!!! all done..... my god it's taken me weeks to figure this out.

Hope this help.

:cool::laugh::good:

I am the AU user with Vodafail as well......I couldn't find /cust/hw/au......only eu or ru.......

Would you please update your au folder ? Thanks lot !!!
 

papoose515

Senior Member
Nov 16, 2013
180
20
OnePlus 7 Pro
Many people are having problems with this when you do a Factory Wipe or flash a new rom, after you flash or wipe it will come up with "fail" or "cust fail".

It all comes down to a partition called "/cust"

this dictates what software to install and what theme to use for the "ZONE" of your phone.
I.E my phone is/was a Vodafone AU phone (sim unlocked now).

Now, when you do a recovery/wipe data it looks for information in the /cust partition regarding your phone.
If it's not there then "Cust fail" will appear when you do a wipe.
This has been happening to me for quite some time now, I've tried all types of roms...... but failed every time until now.

This is what I did. (This may only work with my phone but it will give many many many people that information to rectify this problem)

1, unlock your bootloader (you should know how to do this already)
2, flash custom recovery in fastboot mode (again, know how to do this)
3, reboot into recovery and install SuperSU
4, Reboot, and install RootExplorer
5, in RootExplorer mount as R/W then head over to /cust using RootExplorer
6, make a directory in /cust as /cust/vha <----- This was important as vha is Vodafone Hutchinson Australia on my phone
7, copy /cust/hw/au to /cust/vha this will give me /cust/vha/au
8, reboot back into fastboot mode and flash original recovery
9, reboot into recovery and do a wipe...... NO MORE CUST FAIL!!!!!!
10, reboot!!!!! all done..... my god it's taken me weeks to figure this out.

Hope this help.

:cool::laugh::good:
help me please
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Many people are having problems with this when you do a Factory Wipe or flash a new rom, after you flash or wipe it will come up with "fail" or "cust fail".

    It all comes down to a partition called "/cust"

    this dictates what software to install and what theme to use for the "ZONE" of your phone.
    I.E my phone is/was a Vodafone AU phone (sim unlocked now).

    Now, when you do a recovery/wipe data it looks for information in the /cust partition regarding your phone.
    If it's not there then "Cust fail" will appear when you do a wipe.
    This has been happening to me for quite some time now, I've tried all types of roms...... but failed every time until now.

    This is what I did. (This may only work with my phone but it will give many many many people that information to rectify this problem)

    1, unlock your bootloader (you should know how to do this already)
    2, flash custom recovery in fastboot mode (again, know how to do this)
    3, reboot into recovery and install SuperSU
    4, Reboot, and install RootExplorer
    5, in RootExplorer mount as R/W then head over to /cust using RootExplorer
    6, make a directory in /cust as /cust/vha <----- This was important as vha is Vodafone Hutchinson Australia on my phone
    7, copy /cust/hw/au to /cust/vha this will give me /cust/vha/au
    8, reboot back into fastboot mode and flash original recovery
    9, reboot into recovery and do a wipe...... NO MORE CUST FAIL!!!!!!
    10, reboot!!!!! all done..... my god it's taken me weeks to figure this out.

    Hope this help.

    :cool::laugh::good:
    2
    Cust fail fix

    I managed to avoid cust fail by following the tutorial from this link:
    http://forum.xda-developers.com/ascend-p7/general/ascend-p7-b602-emui-3-0-international-t2972854

    It is for P7, so use steps 3 - up:
    3- you must be ROOT
    4- have a Root Explorer app
    5-go to the folder "data" and see the contents of custom.bin
    6. You must remember the contents of this file.
    7-Depending on the file custom.bin say, is as it should rename folders CUST.
    8-For example if it says "hw/naf", that means that inside the folder "CUST" the folder must exist "hw" and within it another folder "naf".
    9. Go to the root folder, using the Root Explorer
    10. Go to the folder Cust
    11. Rename *the folders according to the content of step 5
    12. ( optional ) Perform Factory Reset