How to Root a Galaxy core LTE G386W?

Search This thread

spinach183

Member
May 13, 2015
12
0
Today I installed the latest TWRP recovery and also rooted using Odin.

Twrp for the Avant variant will work for the sm-g386w I am using it now on mine and worked without any problems.

Also to root you can use Odin With the Avant md5.

Worked well on my sm-g386w

Have fun!
 

J.Tichi

Member
Jul 1, 2008
43
5
Hey, Folks, can you please check what recovery you end up with after rooting?

When you boot into recovery (by holding Volume-Up/Home/Power buttons)
on top of the page there is the version info .. mine ends with ..ANG6.

I wonder if it is right, and the rooting went as intended?

Thank you in advance...
 

the wiz

New member
Jun 15, 2015
3
0
Finally did it !

Hi there,
I Finally rooted succesfully my SM-G386W the proper way, i used iRoot, a small chinese one-click soft that has been translated in english, and checked in odin mode and it didn't trip my knox counter it is still at 0x0, :good:

it says samsung official release in odin mode

the whole process last about 20 min



Have a good day

if you want the link , search google: how to root android phone in 2015 and choose the iRoot method result in the first videos
 

Shibayev2002

New member
Aug 15, 2015
1
0
Same Problem

Having the same problem. I tryed towelroot kingoroot root master mobilego and even chimera tool. I think it's some sort of root protected phone. Lucky Lenovo users, they get root on start up.
 

tonydd

Senior Member
Jul 15, 2007
507
45
Now that I'm rooted and twrp, any custom rom yet?
 
Last edited:

hitibiti

Senior Member
Sep 1, 2007
73
4
42
Canada Montreal
succed with g386W using G386T
<ID:0/004> Added!!
<OSM> Enter CS for MD5..
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> CF-Auto-Root-afyonltetmo-afyonltetmo-smg386t.tar.md5 is valid.
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/004> Odin v.3 engine (ID:4)..
<ID:0/004> File analysis..
<ID:0/004> SetupConnection..
<ID:0/004> Initialzation..
<ID:0/004> Get PIT for mapping..
<ID:0/004> Firmware update start..
<ID:0/004> recovery.img
<ID:0/004> NAND Write Start!!
<ID:0/004> cache.img.ext4
<ID:0/004> RQT_CLOSE !!
<ID:0/004> RES OK !!
<ID:0/004> Removed!!
 

The Wire Guy

Member
Mar 21, 2013
5
0
rooted smg386w

hello, so i have the sm-g386w and i know for sure i have rooted it verified with superSU and im able to install and use root only apps. but i want to install what i have found for a custom rom and need to access the recovery but funny thing is no matter how many times i flash successfully with odin and then try rebooting into recovery either with key presses or chosen to reboot to recovery thru superSU, twrp. no matter what it always goes to download mode for odin and in order to turn my phone on i must also flash cwm or twrp and it boots up and i can use it as if nothing is wrong until i turn it off or try to get to recovery, always always download mode. any help?
 

ethanl8089

New member
Mar 10, 2017
2
0
drayton valley
cm 11

if ths is still active i have made a custom rom its not android 5-6 or 7 its a cm11 rom u need a custom rec to install any custom rec 4 the avant will work
i cant post any links 4 now u can download if frum android file host by serching galaxy avant and going to my user ethanl8089 and into the cm 11 roms folder
 

Josh-Reimer

New member
May 26, 2022
2
2
Galaxy Core LTE is basically the Galaxy Avant (tmobile) with different branding. The Galaxy Avant has a chainfire root. Submit the recovery image for your firmware to the main chainfire thread (search for it) and chainfire should be able to provide a odin flashable file. Keep in mind your bootloader must be unlocked.
I have a galaxy g386w as well that I am want to root. However, I cannot seem to unlock the bootloader. I have searched online for instructions, but all of them require either that there is an oem unlock toggle in the developer settings(there isn't one) or that you put the device into fastboot mode, which I can't do either. I have only managed to get it into download mode. The device is running android 4.4.2.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I've just got myself a new phone, the Samsung GALAXY core LTE a few weeks ago and now I'm wanting to root it so I can customize it even more than it already is and while it runs android 4.4.2 and it's an awesome phone, Kingo Root doesn't seem to be able to connect with it.

    The model number is SM-G386W

    Any suggestions?
    1
    Galaxy Core LTE is basically the Galaxy Avant (tmobile) with different branding. The Galaxy Avant has a chainfire root. Submit the recovery image for your firmware to the main chainfire thread (search for it) and chainfire should be able to provide a odin flashable file. Keep in mind your bootloader must be unlocked.
    1
    Can root SM-G386W same way as SM-G386T

    I took the plunge and tried the Chainfire Autoroot method provided for the SM-G386T on my Canadian SM-G386W (Koodo variant) and it rooted fine. I have verified root and removed system apps with 3C Toolbox via the Xposed framework. Thus, it is clearly good to go root-wise. The instructions are here:
    http://forum.xda-developers.com/showpost.php?p=54768458&postcount=1

    Warning: this method will trip your Knox counter to 0x1 as Chainfire warns. So, if that concerns you do not use this method.
    1
    Download the Odin tar.md5 from sammobile and extract. I would do it myself but I don't have > 10 posts and can't post on the request thread...

    Sent from my SM-G386W using XDA Free mobile app
    1
    Do you know guys if this SRSroot is a reliable root provider?

    I tried SRSroot. pretty sure there just garbage. reboots the phone a couple times, claims to succeed. then Root checker says "not rooted" and when you try to undo root with SRSroot it also says device is not rooted unroot failed

    we just really need someone to convert the G386 stuff over for the G386W. there the same damn phone. it just seems no one wants to touch the G386W because its only carried by Wind Mobile Canada. no love for the Canadians i see. :p

    heres what happens.

    SRS does this:

    ---= SRS One-Click-Root v4.7 =---

    6:57:57 PM - Starting ADB Server..
    6:58:02 PM - Manufacturer: samsung
    6:58:02 PM - Model: SM-G386W
    6:58:02 PM - Android Version: 4.4.2
    6:58:02 PM - Build ID: KOT49H.G386WVLU1ANH7
    6:58:02 PM - Board ID: MSM8226
    6:58:03 PM - Chipset Platform: msm8226
    6:58:03 PM - Getting OffSets.. : 0x8003 0x8005 (False)
    6:58:03 PM - Query Server for Best Method.. Found Rootkit: 4

    ----= Start Rooting Process.. Please Wait =----

    6:58:06 PM [+] Testing exploit: root4 (please wait..)
    6:58:09 PM [+] Device Reboot #1 (Wait till it's started)
    6:59:34 PM [+] Device Reboot #2 (Wait till it's started)
    7:00:48 PM [+] Remounting /system Filesystem as R/W..
    7:00:49 PM [+] Installing SU Binary...
    7:00:49 PM [+] Installing SuperUser APK...
    7:00:49 PM [+] Remounting /system Filesystem as R/O..

    7:00:55 PM [+] Rooting Complete !

    Then Rootcheck does as shown in the attachment.

    then unrooting says:

    ---= SRS One-Click-Root v4.7 =---

    7:11:01 PM - Starting ADB Server..
    7:11:06 PM - Manufacturer: samsung
    7:11:06 PM - Model: SM-G386W
    7:11:06 PM - Android Version: 4.4.2
    7:11:07 PM - Build ID: KOT49H.G386WVLU1ANH7
    7:11:07 PM - Board ID: MSM8226
    7:11:07 PM - Chipset Platform: msm8226
    7:11:07 PM - Getting OffSets.. : 0x8003 0x8005 (False)

    [x] Device is not rooted, UnRooting not needed.