How to root the Amazon FireTV

Search This thread

roligov

Senior Member
Dec 29, 2012
284
98
London
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Update 02/03/2015

This guide I posted is well out of date, there are other methods to follow now days.
Please use http://www.aftvnews.com/tag/guide/ as it is up to date and current.


-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Thanks to Geohot, we now have root access :D

1. A) Go to: http://towelroot.com/ and click the red button to download the APK:



or

1. B) Download from this MediaFire mirror I made: http://goo.gl/DQ6xXF

2. Download the Chainfire SU APK from the Playstore: http://apps.evozi.com/apk-downloader/?id=eu.chainfire.supersu

3. Sideload both APKs.

4. Run Towelroot, hit "Make it Ra1n" and then your FTV will reboot.

5. After reboot install SU and set default access to "Grant" in it's settings.


Setup SSH after SU install:

1. Download Busybox APK: http://apps.evozi.com/apk-downloader/?id=stericson.busybox

2. Download SSH Daemon APK: http://apps.evozi.com/apk-downloader/?id=web.oss.sshsftpDaemon

3. Sideload both APKs.

4. Configure SSH Daemon to your liking and to start on boot

5. SSH with username root and password abc123 (configurable in SSH Daemon)

How to disable the FireTV Updater :

1. Connect via ADB and type "su" (without quotes)

2. pm disable com.amazon.dcp

3. If done correctly it should say "Package com.amazon.dcp new state: disabled".

OR

1. Just disable the OTA portion (Thanks JPDeckers)
Code:
pm disable "com.amazon.dcp/.ota.OTAUpdateMessageHandler"
pm disable "com.amazon.dcp/.ota.OTAService"
pm disable "com.amazon.dcp/.ota.CheckForOTAUpdatesService"
pm disable "com.amazon.dcp/.ota.OTAStatusActivity"
pm disable "com.amazon.dcp/.ota.ResetOTAMessageHandler"
pm disable "com.amazon.dcp/.ota.OTAService$OTAWakeupReceiver"
pm disable "com.amazon.dcp/.ota.OTAService$OTADedupeReceiver"
pm disable "com.amazon.dcp/.ota.OTAService$OTAInstallNowReceiver"

2. If done correctly it should say "Package xxx.xxxxxx.xxx new state: disabled".

How to Enable installations from "Unknown Sources":
http://forum.xda-developers.com/showthread.php?t=2784173



Here are some guides with pictures and step by step instructions:

How to root the Amazon FireTV:
http://www.aftvnews.com/how-to-root-the-amazon-fire-tv/

How to block OTA updates to keep root:
http://www.aftvnews.com/how-to-block-ota-update-for-amazon-fire-tv-and-keep-root-access/

How to install the Google Play Store on the Amazon FireTV:
http://www.aftvnews.com/how-to-install-the-google-play-store-on-the-amazon-fire-tv/

How to mount external usb storage devices:
http://www.aftvnews.com/how-to-play-media-files-from-external-usb-storage-on-amazon-fire-tv/

How to run FireTV apps from an External USB Drive:
http://www.aftvnews.com/how-to-move-and-run-amazon-fire-tv-apps-from-an-external-usb-storage-drive/

How to manually upgrade/downgrade your Amazon FireTV:
http://forum.xda-developers.com/showthread.php?t=2796067

How to install ClockworkMod Custom Recovery on the Amazon Fire TV
http://www.aftvnews.com/how-to-insta...mazon-fire-tv/

How to install a Custom ROM Image on the Amazon Fire TV
http://www.aftvnews.com/how-to-insta...mazon-fire-tv/

How to update a Rooted Amazon Fire TV to the Latest Version Without Losing Root
http://www.aftvnews.com/how-to-updat...t-losing-root/

How to boot into recovery mode and fix a softbricked FireTV:
http://www.aftvnews.com/how-to-unbr...ry-mode-and-factory-reset-the-amazon-fire-tv/

Fix PS4 DualShock 4 button mapping on the Fire TV:
http://www.aftvnews.com/fix-ps4-dualshock-4-button-mapping-on-the-fire-tv/

How to trick Google Play Store into allowing All Apps
http://www.aftvnews.com/how-to-trick-google-play-store-into-allowing-all-apps/

How to connect a Wii Remote (Wiimote) to the Fire TV:
http://www.aftvnews.com/how-to-connect-a-wii-remote-wiimote-to-the-fire-tv/

How to setup a new Fire TV without blocking Root:
http://www.aftvnews.com/how-to-setup-a-new-fire-tv-without-blocking-root/

How to remove unwanted Home Screen Menu Items:
http://www.aftvnews.com/how-to-remove-unwanted-home-screen-menu-items/

How to setup Plex (and XBMC) for Surround Sound Audio:
http://www.aftvnews.com/how-to-setup-plex-and-xbmc-for-surround-sound-audio/


More to come....

Changelog:
21-09-2014 - Added more links to guides including how to flash custom recovery and pre-rooted images
13-09-2014 - Added more links to guides added Towelroot v3 to mirror.
28-07-2014 - Added more links to guides.
23-07-2014 - Updated links to new http://www.aftvnews.com/ site.
30-06-2014 - Added link to guide on booting to recovery mode and fixing a softbrick
26-06-2014 - Added link to guide on manually upgrade/downgrade to different firmware versions
24-06-2014 - Added mediafire mirror for towelroot apks
24-06-2014 - Added link to guide for running apps from external drive
22-06-2014 - Added link to guide for installing playstore on the FireTV
 
Last edited:

wavrunrx

Senior Member
Jul 14, 2011
955
398
Yep.

FYI, you should probably link to the main site instead of deeplinking the APK, same goes for SuperSU, the official download can be found here: http://download.chainfire.eu/supersu

People can just pull the superuser.apk from the zip file.

holy crap amazing !
i was thinking root wait waiting till amazon releases the new update to thwart any last minute attempt for amazon to 'fix' it...
 

Nierana

New member
May 20, 2014
4
1
The towel root link does not allow hotlinking,so you should just change it to the DOT com webpage.
Also,click the red-ish symbol on their page to download the tr apk.

Hi! I'm still a beginer, so .. can you explain how to change it to the DOT com webpage?
Thanks ;)
 
Last edited:

retroben

Senior Member
May 19, 2014
510
60
Fultondale
Ninja'd!

Was DP for more attention.

How do we add the OTA links to Fire TV's HOSTS file for blocking the update?

Also,how do I ensure that root is working without having to install another app?

Edit:

I was talking about the OP with towelroot.

*Piccard facepalm*
By DOT com,I meant just the website by itself,and not linking to the apk directly.

I also now know root is working because seeder was granted lag reduction access.
 
Last edited:
  • Like
Reactions: Nierana

ahoslc

Senior Member
Mar 30, 2010
1,482
236
salt lake city
can edit that host file with your instructions

---------- Post added at 02:09 PM ---------- Previous post was at 02:01 PM ----------

USB Storage working download [root] StickMount 3.01 ;)
 

jamesrascal

Member
Jan 11, 2011
42
4
Idyllwild
Rooted and took some pictures as proof installed Root Browser and made a change to hosts file.

IMG_20140615_125746.jpg

IMG_20140615_125754.jpg

IMG_20140615_130000.jpg

IMG_20140615_130319.jpg
 
  • Like
Reactions: stanggman75

danknee

Senior Member
Oct 22, 2009
903
21
Las Vegas
SSH to your device then run the following:
Code:
su
mount -o rw,remount /dev/block/platform/msm_sdcc.1/by-name/system /system
chmod +w /etc/hosts
vi /etc/hosts
127.0.0.1    firs-ta-g7g.amazon.com
127.0.0.1    amzdigitaldownloads.edgesuite.net
:wq!
mount -o ro,remount /dev/block/platform/msm_sdcc.1/by-name/system /system
reboot

This step can also be done through a gui, root browser lite or other such.[/QUOTE]

Editing hosts for me failed at chmod. Instead I side loaded root browser and modified the hosts file directly on the Fire TV.
 

retroben

Senior Member
May 19, 2014
510
60
Fultondale
I checked the amz site after undoing OpenDNS and setting my two router DNS' to Google's two servers.
After two attempts of loading my google bookmark,it errored on one and worked on two,so internet is fine.

I tried loading the amz page and it gave me an error instead of file not found,which must mean it worked from the hosts file!
I also did that adb shell function through terminal app directly on Fire TV as an extra measure.
 

deanemj

Senior Member
May 2, 2014
79
12
FYI, to install APKs directly from your Fire TV without the sideloading nonsense, grab a SQLite editor and meander your way through Settings Storage/Settings/Global to change the value of "install_non_market_apps" from 0 to 1.
 
  • Like
Reactions: MadJoe

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone