How to turn off WiFi calling notification

Search This thread


Senior Member
Feb 4, 2009
Does*anyone know how to get rid of the Vodafone WiFi calling notification? It appears at the top of notification bar and also on my lock screen, when I have poor signal and it connects to WiFi calling mode. I can only mute it for 2 hours at a time. In the notification settings it comes under "IMS service" which is a system app that it is*greyed out so can't be switched off. I never had any notifications when WiFi*calling*was connected with O2 but I do since changing to the N20 and my new carrier Vodafone. I find this irritating.


Senior Member
Jun 3, 2014
Did you ever find any joy with this problem?

I'm having the same issue on my Z Fold 2, I've just switched provider to Vodafone from Three and the IMS Service/WiFi calling notification is unable to be disabled.

It must be Vodafone related as I used WiFi calling on three and never had this issue!


New member
Apr 11, 2021
I'm having the same problem too. As far as I can tell this seems to be an issue unique to Vodafone users - indeed in the Vodafone's network options menu, the ability to turn off these notifications is greyed out. Same sim card into a friend's phone = same problem. My friend's O2 sim card or another friend's EE sim in my phone = no problem. I've raised this with Vodafone repeatedly and the consistent response from their technical support team has been that a) this isn't a problem that has been raised before; b) that it's something that needs to be fixed across the whole network's standard SIM functionality and they can only do that for widespread issues. Both of these answers are entirely untrue. I keep raising it and I've now formally complained about it.

In the meantime, I use an app called BuzzKill, which although isn't free and for me isn't always 100% effective at muting the Vodafone WiFi Calling notifications, it certainly catches most of them so the £2ish was well worth it. Easy set up too (and no, I don't work for them 😂).
Last edited: