how to unbrick my sony xperia c5 ultra

Search This thread

sharif3g

New member
Oct 11, 2015
2
0
pls help someone to unbrick my xperia c5 ultra. now phone detect as a unknown device . I cannot turn into my phone in flash mood. how to flash pls give some solution .I stuck at dead phone . pls do something for me .................
 

Geeks Empire

Senior Member
Aug 29, 2014
1,211
1,253
Nashville
GeeksEmpire.co

spiramedia

Senior Member
May 4, 2011
166
33
Moscow
If i can't acces not fastboot mode or flash mode? i just stuck with red light when i connect the phone to usb. volume up + cable or volume down + cable don't work.
 

un.Known

Senior Member
Sep 12, 2011
231
128
Damascus
Same here, I guess the boot is damaged.
Last night i suspected that the battery is dead, so I opened the device and disconnected the battery then tested it with MultiMeter, but the battery was doing fine.
anyway, I tried MTK Droid Tools, SP Flash Tool, SP Multi Port Download, Androxyde Flashtool, Sony PC Companion, All seems not able to detect the device.
in windows Device Manager when i connect the device it's shown as COM port.
When I plug the phone into charger or pc the notification light turns RED.
When I press the power button a faint red light appears in proximity sensor.
That's it.
I'm searching currently for TEST Points for the C5 Ultra Dual, I'm willing to try the "Emergency Flashmode", So, PLZ HELP
 

spiramedia

Senior Member
May 4, 2011
166
33
Moscow
Same here, I guess the boot is damaged.
Last night i suspected that the battery is dead, so I opened the device and disconnected the battery then tested it with MultiMeter, but the battery was doing fine.
anyway, I tried MTK Droid Tools, SP Flash Tool, SP Multi Port Download, Androxyde Flashtool, Sony PC Companion, All seems not able to detect the device.
in windows Device Manager when i connect the device it's shown as COM port.
When I plug the phone into charger or pc the notification light turns RED.
When I press the power button a faint red light appears in proximity sensor.
That's it.
I'm searching currently for TEST Points for the C5 Ultra Dual, I'm willing to try the "Emergency Flashmode", So, PLZ HELP
I see I'm not the only one here, it's realy gives me hope to repair it. I will try with RIFF box to repair the boot, but as you said there are no test point on the main board

UPD:
No test point on the main board, i have removed the main board from the phone and tried all points on it, no changes, still the COM port.
 
Last edited:
Oct 16, 2014
18
8
Perth
I see I'm not the only one here, it's realy gives me hope to repair it. I will try with RIFF box to repair the boot, but as you said there are no test point on the main board

UPD:
No test point on the main board, i have removed the main board from the phone and tried all points on it, no changes, still the COM port.

Anyone have any updates on this? I've managed to brick mine as well, exactly the same symptoms....and I only bought my phone a few days ago :(
 

-kOS-

Account currently disabled
Feb 10, 2007
174
22
Sweden
in windows Device Manager when i connect the device it's shown as COM port.
When I plug the phone into charger or pc the notification light turns RED.
When I press the power button a faint red light appears in proximity sensor.

I got a C5 yesterday and when i try to flash it stuck in boot flashing, so right now i have this behavior, i read someting about and emercency mode on xperia smartphones based on snapdragon soc's i don't know if this apply with this mtk based model.

Please keep updated.

Thanks
 

un.Known

Senior Member
Sep 12, 2011
231
128
Damascus
I got a C5 yesterday and when i try to flash it stuck in boot flashing, so right now i have this behavior, i read someting about and emercency mode on xperia smartphones based on snapdragon soc's i don't know if this apply with this mtk based model.

Please keep updated.

Thanks

I'm fixing the device for a friend of mine, anyway, I have xperia mini pro that I unlocked via testpoint method a long time ago
I searched the internet to look for more info about Testpoints, Is it related to chipset or is it a special mode related to sony devices
anyway I'm willing to figure out the testpoint on E5533 by using the multimeter and see if the test point have some sort of different voltage on the mini pro, then I'll do the same with C5U to locate the test point (If exist at all)
I'll update as soon as i have results
regards
 

Danilosc

Member
Jun 5, 2013
11
1
I'm fixing the device for a friend of mine, anyway, I have xperia mini pro that I unlocked via testpoint method a long time ago
I searched the internet to look for more info about Testpoints, Is it related to chipset or is it a special mode related to sony devices
anyway I'm willing to figure out the testpoint on E5533 by using the multimeter and see if the test point have some sort of different voltage on the mini pro, then I'll do the same with C5U to locate the test point (If exist at all)
I'll update as soon as i have results
regards

Waiting... :( :(
 

gsser

Senior Member
i dont have my phone right now, i gave it to service cause i didnt know where the test point is. just download s1 tools and try to connect your phone with opening test point. there is a russian guy who changed lcd screen. it shows backside of the mainboard. tere are 4 pins near the usb port. you should watch it
 
  • Like
Reactions: joel-0602

fetzkochl

New member
Feb 10, 2011
4
2
Can someone link me S1Tools and the drivers?
I am lost, only found very old versions of S1Tools and I have no idea what drivers are needed and where to find them.
At least my c5 lies open infront of me :)
 
  • Like
Reactions: joel-0602

fetzkochl

New member
Feb 10, 2011
4
2
I tested a little with my open phone, shortcutted Mass with either 1 2 3 and 4

testpoint.png


and connected the USB Plug again. But nothing happened, I constantly got the same device reconized, also it reconnects atfer about 45sec again.
S1Tools gave me failures at my "Patch SECMBoot" attempts when the device reconnects automatically.

device.png


On other tutorials they stated that you should have some SEMC device connected.

Can somebody check aswell?
 
  • Like
Reactions: joel-0602

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Same here, I guess the boot is damaged.
    Last night i suspected that the battery is dead, so I opened the device and disconnected the battery then tested it with MultiMeter, but the battery was doing fine.
    anyway, I tried MTK Droid Tools, SP Flash Tool, SP Multi Port Download, Androxyde Flashtool, Sony PC Companion, All seems not able to detect the device.
    in windows Device Manager when i connect the device it's shown as COM port.
    When I plug the phone into charger or pc the notification light turns RED.
    When I press the power button a faint red light appears in proximity sensor.
    That's it.
    I'm searching currently for TEST Points for the C5 Ultra Dual, I'm willing to try the "Emergency Flashmode", So, PLZ HELP
    2
    Same here, I guess the boot is damaged.
    Last night i suspected that the battery is dead, so I opened the device and disconnected the battery then tested it with MultiMeter, but the battery was doing fine.
    anyway, I tried MTK Droid Tools, SP Flash Tool, SP Multi Port Download, Androxyde Flashtool, Sony PC Companion, All seems not able to detect the device.
    in windows Device Manager when i connect the device it's shown as COM port.
    When I plug the phone into charger or pc the notification light turns RED.
    When I press the power button a faint red light appears in proximity sensor.
    That's it.
    I'm searching currently for TEST Points for the C5 Ultra Dual, I'm willing to try the "Emergency Flashmode", So, PLZ HELP
    I see I'm not the only one here, it's realy gives me hope to repair it. I will try with RIFF box to repair the boot, but as you said there are no test point on the main board

    UPD:
    No test point on the main board, i have removed the main board from the phone and tried all points on it, no changes, still the COM port.
    2
    This is what happens when a OEM(Sony) thinks they know better than the SoC manufacturer (Mediatek) FlashTool vs SPFlashtool then SPFlashtool wins easy
    I did manage to get SPFlashtool to talk with the phone but it said baseband was secure and "add file???" What ever that file is I have no idea.
    1
    it has to EXIST. i tried s1tools amd device successfuly detected and it wanted and said open test point. that means it has a test point
    Please, can you post some screenshots? thx man!!
    1
    2 days ago i installed 6.0 on my e5553 got the same problem today.the computer was seeing the phone as COM when i use the sony data cable...i just used original samsung cable i dont know why but it worked.flashed stock rom after that and it didnt fix the problem.still wasnt able to boot the phone.i just connected the computer with samsung cable and left it like that for few hours.when i came back i saw the sony logo on the screen and opened succesfully 5min later with 6.0(last rom i installed was stock turkey and its 5.1)i dont know what happened but its fully working with no problem.
    maybe changing usb ports or cable can help you guys.