• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

How to upgrade from Magisk stable to Magisk canary?

Search This thread

AnonVendetta

Senior Member
Apr 29, 2016
982
367
Portland, OR
OK, so I'm running Resurrection Remix 5.8.5 (Nougat 7.1.2) on a Galaxy Note 4. Magisk stable works fine on this ROM.

But when I download the canary installer zip from GitHub (has "debug" in zip name), it flashes fine, but when I boot into Android, manager says Magisk isn't installed (i.e. not in ramdisk/sbin mode, no config options available, apps say I'm not rooted).

I recently flashed canary on another device, and I think the UI is a massive improvement over the stable UI. And also because Substratum can theme canary but not stable (I use Swift Black, Flux black edition, and Pitch Black).

Canary used to work on my Note 4, but that was several months ago, with an older version.

Since a direct install of canary renders it essentially not working, how can I upgrade from stable to canary?

Thanks!
 

AnonVendetta

Senior Member
Apr 29, 2016
982
367
Portland, OR
@black_file: What makes you think I didn't already google it? That's the first thing I did before making this thread. And if you google "magisk canary XDA", you will see that the canary support thread is locked...which means I can't post for help there. So I decided it would be better to create a thread.

People like you are exactly the reason why I have 2 infractions. You ****post and insult, then expect the other person to just lay down and take it. But I won't.
 
  • Like
Reactions: MML.Pro

hairycheez

Senior Member
Aug 2, 2011
103
39
Google Pixel 5
@black_file: What makes you think I didn't already google it? That's the first thing I did before making this thread. And if you google "magisk canary XDA", you will see that the canary support thread is locked...which means I can't post for help there. So I decided it would be better to create a thread.

People like you are exactly the reason why I have 2 infractions. You ****post and insult, then expect the other person to just lay down and take it. But I won't.

Ha he didn't mean post your question there. He meant actually read it.

Canary is only debug now so need to use Magisk Manager (Debug). You should restore your current Magisk Manager before updating the app. Then follow the instructions on the page you already searched for.

Edit: Actually just use this link for the custom update url. https://github.com/topjohnwu/magisk_files/raw/canary/debug.json
 
Last edited:

tyler19820201

Senior Member
Jun 19, 2011
375
62
London
I have an old Samsung Galaxy J7 Max Indian version G615F phone with Android 7.1 and was intending to upgrade my Magisk on it. I was succesfully upgrade to verison 21 the latest stable. However it looks like canary does not support Android Nougat? Magisk Manager succesfully installed as canary version however if i update Magisk on canary channel (Direct Install (Recommended) )after reboot will be just simply uninstalled. Strange.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    @black_file: What makes you think I didn't already google it? That's the first thing I did before making this thread. And if you google "magisk canary XDA", you will see that the canary support thread is locked...which means I can't post for help there. So I decided it would be better to create a thread.

    People like you are exactly the reason why I have 2 infractions. You ****post and insult, then expect the other person to just lay down and take it. But I won't.

    Ha he didn't mean post your question there. He meant actually read it.

    Canary is only debug now so need to use Magisk Manager (Debug). You should restore your current Magisk Manager before updating the app. Then follow the instructions on the page you already searched for.

    Edit: Actually just use this link for the custom update url. https://github.com/topjohnwu/magisk_files/raw/canary/debug.json
    1
    @black_file: What makes you think I didn't already google it? That's the first thing I did before making this thread. And if you google "magisk canary XDA", you will see that the canary support thread is locked...which means I can't post for help there. So I decided it would be better to create a thread.

    People like you are exactly the reason why I have 2 infractions. You ****post and insult, then expect the other person to just lay down and take it. But I won't.