• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

How to use Google pay in rooted max pro m2

Search This thread

kickyvivi

Senior Member
Jul 14, 2016
716
479
Trivandrum
Clear GPay app data and force stop it. Go to settings -> apps and notifications and choose google play services and from permissions, disable the telephone permission.
Now open gpay app and set up upi. After finishing it, go back and enable the telephone permission for Google Play services
 
  • Like
Reactions: Arown orton

Arown orton

Senior Member
Jan 10, 2019
128
47
Clear GPay app data and force stop it. Go to settings -> apps and notifications and choose google play services and from permissions, disable the telephone permission.
Now open gpay app and set up upi. After finishing it, go back and enable the telephone permission for Google Play services

Thanks man so cool but what if i dont give the phone permission to google play services ?
If i give the permission will it detect root again?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Clear GPay app data and force stop it. Go to settings -> apps and notifications and choose google play services and from permissions, disable the telephone permission.
    Now open gpay app and set up upi. After finishing it, go back and enable the telephone permission for Google Play services
    1
    Thanks man so cool but what if i dont give the phone permission to google play services ?
    If i give the permission will it detect root again?
    If you keep it disabled i think the contacts will stop syncing.
    No problem in re-enabling it after setting up upi
    1
    It didn't actually ! That's what i was confused about when i did it. Had to revert to stock rom coz i do payments on regular basis. Maybe i should check it out again? Or wait pie gonna come soon ?
    First use magisk hide, then disable the telephone permission and setup GPay, then re enable the permission and everything should work.