[HOW-TO] Workaround for Google Play Services that won't install on some ROMs

Search This thread
Hi guys, after I had surfing internet for a while, I had found a workaround and successfully installed Google Play Services on my device (GT-S5300) with custom rom.

Credit:
http://androidforums.com/marquee-all-things-root/660913-google-play-services-wont-install.html


Steps:
1. Download Gapps for your ROM here.
2. Turn off your phone.
3. Enter recovery mode and do Wipe data/factory reset. (Make sure that you have backed up everything.)
4. Flash the Gapps.
5. Wipe Dalvik cache and cache partition then reboot.
6. Get the lastest version of Google Play Store and install it.
7. Update all the Gapps via Play Store.
8. Then install Google Play Services and done!

Or open the Market (Play Store) and tap agree. Then press home and leave it awhile. After the Play Store is updated, open it and tap agree again. The new Play Store should download Google Play Services and install it for you.

NOTE: It may NOT working with some ROMs. Don't blame me!

Sent from my GT-S5300 using xda app-developers app
 
Last edited:

renson62

New member
Jul 10, 2013
1
0
Ayuda

Hola, me gustaria recibir ayuda, tengo un galaxy ace M, con rom evo x4, instale los gabs 2,3,6 y segui todo el procedimiento cuando reinicio el equipo me sale el icono de bienvenido, registro mi cuenta gmail y me sale un error que dice "La aplicación asistente de configuracion, android setupwizard se ha detenido de forma imprevista. forzar cierre" despues la pantalla queda negra, solo aparece la hora, la bateria y se desplega la barra de notificaciones. Como podre solucionarlo?
 
Hola, me gustaria recibir ayuda, tengo un galaxy ace M, con rom evo x4, instale los gabs 2,3,6 y segui todo el procedimiento cuando reinicio el equipo me sale el icono de bienvenido, registro mi cuenta gmail y me sale un error que dice "La aplicación asistente de configuracion, android setupwizard se ha detenido de forma imprevista. forzar cierre" despues la pantalla queda negra, solo aparece la hora, la bateria y se desplega la barra de notificaciones. Como podre solucionarlo?

This is not portugese (or what?) forum. USE ENGLISH only.

Sent from my GT-S5300 using Tapatalk 2
 

spekasam

New member
Sep 30, 2013
1
0
Need further explanation

Steps:
1. Download Gapps for your ROM
2. Turn off your phone.
3. Enter recovery mode and do Wipe data/factory reset. (Make sure that you have backed up everything.)
4. Flash the Gapps.
5. Wipe Dalvik cache and cache partition then reboot.
6. Get the lastest version of Google Play Store and install it.
7. Update all the Gapps via Play Store.
8. Then install Google Play Services and done!

Or open the Market (Play Store) and tap agree. Then press home and leave it awhile. After the Play Store is updated, open it and tap agree again. The new Play Store should download Google Play Services and install it for you.

NOTE: It may NOT working with some ROMs. Don't blame me!

Sent from my GT-S5300 using xda app-developers app[/QUOTE]

------------------
I am new in this, sorry to ask a very basic question.
- I have a clone S4 with Android 4.2.2, I downloaded gapps-jb-20130301-signed.zip and gapps-jb-20130812-signed.zip
- On step 2 and 3, I am using Root Manager (ClockworkMod), I manage to enter recovery mode and wipe data/factory reset
- But then, when i want to install from SDCARD the gapps, both version got error invalid OTA. Flash mean install under recovery mode right?

Could you please reword, use layman term, suggest the apps to be used for this work. Thanks a lot for your help
 
I am new in this, sorry to ask a very basic question.
- I have a clone S4 with Android 4.2.2, I downloaded gapps-jb-20130301-signed.zip and gapps-jb-20130812-signed.zip
- On step 2 and 3, I am using Root Manager (ClockworkMod), I manage to enter recovery mode and wipe data/factory reset
- But then, when i want to install from SDCARD the gapps, both version got error invalid OTA. Flash mean install under recovery mode right?

Could you please reword, use layman term, suggest the apps to be used for this work. Thanks a lot for your help

Yes, under recovery mode.
AFAIK, you just need to update your Play Store and Google Play services (Shown on app drawer as Google Settings) after flashing the Gapps (Google Apps).

Sent from my GT-S5300 using Tapatalk 2
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    Hi guys, after I had surfing internet for a while, I had found a workaround and successfully installed Google Play Services on my device (GT-S5300) with custom rom.

    Credit:
    http://androidforums.com/marquee-all-things-root/660913-google-play-services-wont-install.html


    Steps:
    1. Download Gapps for your ROM here.
    2. Turn off your phone.
    3. Enter recovery mode and do Wipe data/factory reset. (Make sure that you have backed up everything.)
    4. Flash the Gapps.
    5. Wipe Dalvik cache and cache partition then reboot.
    6. Get the lastest version of Google Play Store and install it.
    7. Update all the Gapps via Play Store.
    8. Then install Google Play Services and done!

    Or open the Market (Play Store) and tap agree. Then press home and leave it awhile. After the Play Store is updated, open it and tap agree again. The new Play Store should download Google Play Services and install it for you.

    NOTE: It may NOT working with some ROMs. Don't blame me!

    Sent from my GT-S5300 using xda app-developers app
    1
    not working , please help :crying::crying::crying::crying: i'm using Hyperion 8 ROM on galaxy y

    Plz mention details of ur prob

    Sent from my room using sgy evo-x4//
    I m always there to help. :D
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone