[HOWTO] Chromecast/Netflix outside USA without VPN

Search This thread


Aug 31, 2009
Well I didn't go through the whole thread, but I want to add this post for any openwrt users out there.
If you are using free service such dnsflix, there is a chance that you will have to change your US dns ip address. In that situation you will need to prepare configuration as simple as possible to change only dns server for specific host (netflix in this case). Please add lines in files listed below.
iptables -t nat -A PREROUTING -d -j DNAT --to-destination x.x.x.x
iptables -t nat -A PREROUTING -d -j DNAT --to-destination x.x.x.x

config dnsmasq
        list server '/netflix.com/y.y.y.y'

x.x.x.x - enter your gateway (not US dns ip!). That redirects you on your ISP dns servers and you don't have to change it every time dns service will change.
y.y.y.y - enter your US dns ip. This is the only place to change US dns in your configuration.

Above Configuration works perfectly for all devices in your LAN.
Last edited:

Deleted member 5545167

Can anyone help me???!! Totally lost!! I just want to use my chromecast but it doesn't work. Did some research turns out that it doesn't work in my region because google blocked our IPs so I'll have to use a VPN. But my modem doesn't support vpns. Till about a week ago I shared my computer's VPN connection and it worked! But now that vpns are blocked it doesn't. So right now VPN doesn't work in my country on PC but on android, it does surprisingly. Anyways, I was wondering if Chromecast update could be done in another way... I mean I enabled the colored search results of google which is available only in the U.S. via Market Unlocker, VPN and gps location faker but this, is a pickle...

Any Suggestions?


Senior Member
Oct 10, 2013
You'll have to be much clearer if you want meaningful help.

What exactly isn't working? What are you attempting to cast to the Chromecast and from what device?

You say Google blocked your IPs? That doesn't seem likely. Do you mean that you are encountering geo-blocking of all IPs from your country with certain apps? Which apps in particular?

You say that you were sharing your computer's VPN connection? How? By bridging a secondary wireless network on one computer? But now it stopped working because "vpns are blocked"? What makes you think that your VPN is being blocked? Did you try a different VPN gateway, or a different VPN? Have you tried using a DNS unblocking service instead?

What is your problem with Chromecast updates? Do you mean that Google is not providing Chromecast updates for your country? They didn't block any countries in the past, but it's always possible they might have started now that the Chromecast is available with different firmware versions in different countries. Did you try with a VPN?


New member
Sep 17, 2015
I have set up my dd-wrt router with the following commands
iptables -t nat -I PREROUTING -p udp -d --dport 53 -j DNAT --to
iptables -t nat -I PREROUTING -p udp -d --dport 53 -j DNAT --to
iptables -t nat -I PREROUTING -p tcp -d --dport 53 -j DNAT --to
iptables -t nat -I PREROUTING -p tcp -d --dport 53 -j DNAT --to

It is working for netflix but, I want to restrict the usage of unlocator to netflix alone. The rest of the traffic should go to Google dns.

Please guide with regards to iptables commands to achieve this configuration.


Sep 24, 2011
Is it possible to setup in my tp-link dd-wrt router so your chromecast gets your normal dns from your provider by dhcp so i get the normal EU content from my chromecast, but also to hockup a Roku device by wifi to my router and block google dns only to that device on my network so only the Roku device gets US netflix.
Possible to config something like this with dd-wrt?
  • Like
Reactions: diando


New member
Mar 19, 2017
My question might not be completely on topic but I thought, you guys might be able to help me.
I've been using unblock-us for a few years. I mostly watch netflix on my Samsung Smart-TV. Everything used to work fine until Netflix started to block Smart-DNS providers. After a while I got it to work again but only on my computer with a browser.
I tried the stuff mentioned in this post. When I start the netflix app now on my TV, the US Neflix library is loading. I can see all the content that is available in the US. But when I try to stream a show, it loads until 25% and then tells me that there is a problem with my internet. Content that is available in my homecountry (Switzerland) works.

Did anybody encountered something similar and has a solution for it? Would unlocator work better (I haven't tried it)


P.S. Sorry for any bad english

Top Liked Posts

  • There are no posts matching your filters.
  • 29
    Using the already available information on the internet and a few threads of this XDA forum, I figured out how to get Netflix working in Switzerland, without having to use a VPN service.

    DISCLAIMER: This is not a replacement for a VPN service and its functionality, but an alternative way to use geoblocked websites outside their origin countries. This workaround needs you to have either a DD-WRT router or atleast a router on which you can configure iptables via CLI.

    • Sign up for the free beta at Unlocator
    • You will need admin access to your home router. Connect to this router via web interface or command line whichever is applicable.
    • Follow Setup Guides for Multiple Devices and setup your home router with the Unlocator DNS IPs
    • Follow How to Setup DD-WRT to Work With Chromecast
    • I didn't have a DD-WRT router but with admin access I could use the commands in the previous step on the command line of my TP-Link W8960N router.
    • You can replace the DNS IPs in these commands with any other service that you are using for eg. Unblock-US
      iptables -t nat -A PREROUTING -d -j DNAT --to-destination
      iptables -t nat -A PREROUTING -d -j DNAT --to-destination
    • Edit: Due to some problems with newer Netflix app versions on the Chromecast build 19084 these iptables rules seem to be a better option. They redirect only DNS requests made to Google servers to the server of your choice
      iptables -t nat -A PREROUTING -i br0 -p tcp --dport 53 -j DNAT --to
      iptables -t nat -A PREROUTING -i br0 -p udp --dport 53 -j DNAT --to
    • Try playing any Netflix content in the Chrome browser, and use the Netflix player's Chromecast button to cast your content. It will work without any issues as your Chromecast will be able to bypass having to query Google's DNS and query Unlocator's DNS.
    • You can now try the same from any Android or iOS device using the appropriate Netflix app. (You can find the Netflix apk here)
    • Happy Netflixing! :highfive:

    Here are detailed and confirmed working steps to:
    I have found a solution that works for me, and I think it would do for everyone who uses private DNS servers as Unblock-Us or Unlocator. The only thing you need is a router capable of filtering outgoing connections, and every router I have seen can do this as part of the built-in firewall without need of flashing an alternate firmware that supports iptables (such as openwrt).

    You only need to put two rules on your router firewall to block outgoing packets to Google DNS Servers ( and for TCP/UDP and port 53 (DNS). This way, Chromecast will get a timeout trying to reach Google DNS Servers and will fallback to your router defined DNS servers and your Netflix or Hulu will work again!
    Let me know if you get it working. I'll have an fritz 7390 with the same problems.

    I have an FB 7320 and it is working with routing the google IPs to some unused IP...

    But you have to be careful how you enter the the google IPs (it should not be and,
    but should be and - because FB does not allow to enter netmask

    So it should look like:
    Gateway: (per default you have the FB configured as GW,
    so it must be in this network - and in this example .222 is an IP which is not used by any host).

    And same for IP
    This looks interesting mate.

    Do you have any idea if its possible on DDWRT / tomato?

    Is it a firewall script like this one (that i have been using but no longer works. Presumably because of the return.

    iptables -I PREROUTING -t nat -p udp -d --dport 53 -j DNAT --to-destination

    I saw a script on reddit that is currently working just fine in my tomato-based router. You can use it to redirect all traffic going out on TCP/UDP port 53 to a specific IP address:

    iptables -t nat -A PREROUTING -i br0 -p udp --dport 53 -j DNAT --to
    iptables -t nat -A PREROUTING -i br0 -p tcp --dport 53 -j DNAT --to

    (assumes router IP is - change accordingly or reroute to your smart DNS server of choice directly)
    (assumes interface is br0 - change accordingly)
    I re-direct the Google DNS requests in the Router, using Static Routes, which works quite well.

    The static route method redirects Google DNS lookups to a black hole, so that no response is returned. That's equivalent to blocking Google DNS. That won't work with the new Android Netflix app 3.7.2. The iptables method might work because the app will get a valid response to its domain lookup.